Update to release 8.1.1.

- Drop the backported dyninst-test2_4-kill-init.patch.
- Drop the now-upstreamed dyninst-unused_vars.patch.
- Update other patches for context.
- Patch the installed symlinks to be relative, not $(DEST) filled.
This commit is contained in:
Josh Stone 2013-03-15 14:36:26 -07:00
parent 7c432c4f48
commit ddf1ba5375
8 changed files with 63 additions and 356 deletions

2
.gitignore vendored
View File

@ -1,2 +1,4 @@
/dyninst-8.0.tar.gz /dyninst-8.0.tar.gz
/dyninst-docs-8.0.tar.gz /dyninst-docs-8.0.tar.gz
/dyninst-8.1.1.tar.gz
/dyninst-docs-8.1.1.tar.gz

View File

@ -1,51 +1,20 @@
commit d16d2ecb99b3b32f8d7319fec02754a2b9fc4a5b commit 701eb936767886bfd7b8858e8e2151173f9dc6bd
Author: Josh Stone <jistone@redhat.com> Author: Josh Stone <jistone@redhat.com>
Date: Tue Feb 26 09:34:52 2013 -0800 Date: Tue Feb 26 09:34:52 2013 -0800
Hack the testsuite into shape for installation Hack the testsuite into shape for installation
* make.components: Fix a findstring call which block parseThat.
* parseThat/Makefile.in: Respect DESTDIR.
* testsuite/make.module.tmpl: Forgo rpath, and install all targets. * testsuite/make.module.tmpl: Forgo rpath, and install all targets.
* testsuite/src/runTests-utils.C (setupVars): Don't complain about the * testsuite/src/runTests-utils.C (setupVars): Don't complain about the
scripts dir, as it's not actually needed anyway. scripts dir, as it's not actually needed anyway.
* testsuite/src/test_driver.C(updateSearchPaths): fix a strcat->strcpy. * testsuite/src/test_driver.C (getRTLibDir): Hack out the builddir path,
(getRTLibDir): Hack out the builddir path, and just use ../ and just use ../ (aka %{libdir}/dyninst/testsuite/../)
* testsuite/src/dyninst/test1_18F_fortran.F: Backport a fix from master.
diff --git a/make.components b/make.components
index 159a44a..17f41c5 100644
--- a/make.components
+++ b/make.components
@@ -86,7 +86,7 @@ endif # StackwalkerAPI
endif # SymtabAPI
endif # default
-ifeq (findstring(dyninstAPI,$(fullSystem)),dyninstAPI)
+ifeq ($(findstring dyninstAPI,$(fullSystem)),dyninstAPI)
BUILD_PARSETHAT ?= true
endif
diff --git a/parseThat/Makefile.in b/parseThat/Makefile.in
index 6226a35..1dd1e08 100644
--- a/parseThat/Makefile.in
+++ b/parseThat/Makefile.in
@@ -23,6 +23,10 @@ vpath % @srcdir@/src
# -------------------------------------------
.PHONY: clean ready
+ifdef DESTDIR
+prefix := $(DESTDIR)$(prefix)
+endif
+
SRCS = parseThat.C \
config.C \
ipc.C \
diff --git a/testsuite/make.module.tmpl b/testsuite/make.module.tmpl diff --git a/testsuite/make.module.tmpl b/testsuite/make.module.tmpl
index fc03503..38393e0 100644 index 1d3ce2c..1c76d8f 100644
--- a/testsuite/make.module.tmpl --- a/testsuite/make.module.tmpl
+++ b/testsuite/make.module.tmpl +++ b/testsuite/make.module.tmpl
@@ -225,7 +225,7 @@ proccontrol_COMPONENT_LIB = $(LIBPROCCONTROLCOMP) @@ -227,7 +227,7 @@ proccontrol_COMPONENT_LIB = $(LIBPROCCONTROLCOMP)
SPACE := SPACE :=
SPACE += SPACE +=
#COMPONENT_LDFLAGS += $(subst $(SPACE),,-Wl,--enable-new-dtags$(ALL_COMP_DIRS:%=,-rpath,%)) #COMPONENT_LDFLAGS += $(subst $(SPACE),,-Wl,--enable-new-dtags$(ALL_COMP_DIRS:%=,-rpath,%))
@ -54,7 +23,7 @@ index fc03503..38393e0 100644
all: default all: default
@@ -244,8 +244,19 @@ full: test-full @@ -246,8 +246,19 @@ full: test-full
### A list of all the targets we're building, for install purposes ### A list of all the targets we're building, for install purposes
####################################################################### #######################################################################
@ -76,7 +45,7 @@ index fc03503..38393e0 100644
####################################################################### #######################################################################
### Some pattern rules ### Some pattern rules
@@ -272,13 +283,11 @@ include make.mutators.gen @@ -274,13 +285,11 @@ include make.mutators.gen
include make.solo_mutatee.gen include make.solo_mutatee.gen
@ -95,7 +64,7 @@ index fc03503..38393e0 100644
####################################################################### #######################################################################
### Filter results, if needed ### Filter results, if needed
@@ -294,13 +303,13 @@ include $(TO_CORE)/make.components @@ -296,13 +305,13 @@ include $(TO_CORE)/make.components
ifneq ($(wildcard ../src/dyninst), ) ifneq ($(wildcard ../src/dyninst), )
ifneq ($(findstring dyninstAPI,$(fullSystem)),) ifneq ($(findstring dyninstAPI,$(fullSystem)),)
@ -115,7 +84,7 @@ index fc03503..38393e0 100644
dyninst_targs = $(DYNINST_TESTLIBS_ABI) $(DYNINST_STATIC_TESTLIBS_ABI) dyninst_targs = $(DYNINST_TESTLIBS_ABI) $(DYNINST_STATIC_TESTLIBS_ABI)
endif endif
dyninst_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(dyninst_SOLO_MUTATEES))) dyninst_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(dyninst_SOLO_MUTATEES)))
@@ -310,11 +319,11 @@ endif @@ -312,11 +321,11 @@ endif
ifneq ($(wildcard ../src/symtab), ) ifneq ($(wildcard ../src/symtab), )
ifneq ($(findstring symtabAPI,$(fullSystem)),) ifneq ($(findstring symtabAPI,$(fullSystem)),)
@ -132,7 +101,7 @@ index fc03503..38393e0 100644
symtab_targs = $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(symtab_SOLO_MUTATEES))) symtab_targs = $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(symtab_SOLO_MUTATEES)))
symtab_targs = $(symtab_MUTATORS_SO) $(LIBSYMTABCOMP) symtab_targs = $(symtab_MUTATORS_SO) $(LIBSYMTABCOMP)
endif endif
@@ -322,12 +331,12 @@ endif @@ -324,12 +333,12 @@ endif
ifneq ($(wildcard ../src/instruction), ) ifneq ($(wildcard ../src/instruction), )
ifneq ($(findstring instructionAPI,$(fullSystem)),) ifneq ($(findstring instructionAPI,$(fullSystem)),)
@ -150,7 +119,7 @@ index fc03503..38393e0 100644
instruction_targs = $(LIBINSTRUCTIONCOMP) instruction_targs = $(LIBINSTRUCTIONCOMP)
endif endif
instruction_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(instruction_SOLO_MUTATEES))) instruction_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(instruction_SOLO_MUTATEES)))
@@ -337,12 +346,12 @@ endif @@ -339,12 +348,12 @@ endif
ifneq ($(wildcard ../src/proccontrol), ) ifneq ($(wildcard ../src/proccontrol), )
ifneq ($(findstring proccontrol,$(fullSystem)),) ifneq ($(findstring proccontrol,$(fullSystem)),)
@ -168,7 +137,7 @@ index fc03503..38393e0 100644
proccontrol_targs = $(LIBPROCCONTROLCOMP) $(PROCCONTROL_TESTLIBS) $(PROCCONTROL_TESTLIBS_ABI) $(DYNINST_TESTLIBS) $(DYNINST_TESTLIBS_ABI) proccontrol_targs = $(LIBPROCCONTROLCOMP) $(PROCCONTROL_TESTLIBS) $(PROCCONTROL_TESTLIBS_ABI) $(DYNINST_TESTLIBS) $(DYNINST_TESTLIBS_ABI)
endif endif
proccontrol_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(proccontrol_SOLO_MUTATEES))) proccontrol_targs += $(filter-out $(BUILD_FILTER), $(filter-out $(MINIMUM_BUILD_FILTER), $(proccontrol_SOLO_MUTATEES)))
@@ -350,6 +359,16 @@ proccontrol_targs += $(proccontrol_MUTATORS_SO) @@ -352,6 +361,16 @@ proccontrol_targs += $(proccontrol_MUTATORS_SO)
endif endif
endif endif
@ -185,7 +154,7 @@ index fc03503..38393e0 100644
common_infra: drivers output_drivers common_infra: drivers output_drivers
dyninstAPI: common_infra $(dyninst_targs) $(symtab_targs) $(instruction_targs) $(proccontrol_targs) dyninstAPI: common_infra $(dyninst_targs) $(symtab_targs) $(instruction_targs) $(proccontrol_targs)
@@ -360,7 +379,13 @@ instructionAPI: common_infra $(instruction_targs) @@ -362,7 +381,13 @@ instructionAPI: common_infra $(instruction_targs)
proccontrol: common_infra $(proccontrol_targs) proccontrol: common_infra $(proccontrol_targs)
@ -200,7 +169,7 @@ index fc03503..38393e0 100644
symlink: all symlink: all
@@ -409,7 +434,8 @@ endif @@ -412,7 +437,8 @@ endif
testlibs: $(LIBTESTSUITE) testlibs: $(LIBTESTSUITE)
@ -210,7 +179,7 @@ index fc03503..38393e0 100644
.PHONY: clean install distclean mutators mutatees testlibs gnu_mutatees native_mutatees echo all .PHONY: clean install distclean mutators mutatees testlibs gnu_mutatees native_mutatees echo all
@@ -563,7 +589,8 @@ endif @@ -566,7 +592,8 @@ endif
# Install directory # Install directory
$(TEST_DEST): $(TEST_DEST):
@ -220,26 +189,13 @@ index fc03503..38393e0 100644
####################################################################### #######################################################################
### Generic Mutator build rule: ### Generic Mutator build rule:
@@ -841,3 +868,6 @@ endif @@ -857,3 +884,6 @@ endif
endif endif
endif endif
endif endif
+ +
+install: $(ALL_TARGETS_DEST) +install: $(ALL_TARGETS_DEST)
+install-full: $(FULL_TARGETS_DEST) +install-full: $(FULL_TARGETS_DEST)
diff --git a/testsuite/src/dyninst/test1_18F_fortran.F b/testsuite/src/dyninst/test1_18F_fortran.F
index a33241b..9863fef 100644
--- a/testsuite/src/dyninst/test1_18F_fortran.F
+++ b/testsuite/src/dyninst/test1_18F_fortran.F
@@ -47,8 +47,6 @@
#define AND and
#define OR or
#endif
- DATA test1_18_globalVariable1/42/
- END
!------------------------------------------------------------------------------
SUBROUTINE test1_18f_init_globals
diff --git a/testsuite/src/runTests-utils.C b/testsuite/src/runTests-utils.C diff --git a/testsuite/src/runTests-utils.C b/testsuite/src/runTests-utils.C
index 0f54874..02bd505 100644 index 0f54874..02bd505 100644
--- a/testsuite/src/runTests-utils.C --- a/testsuite/src/runTests-utils.C
@ -260,18 +216,9 @@ index 0f54874..02bd505 100644
// Determine Test log dir // Determine Test log dir
char *pdtst = getenv("PDTST"); char *pdtst = getenv("PDTST");
diff --git a/testsuite/src/test_driver.C b/testsuite/src/test_driver.C diff --git a/testsuite/src/test_driver.C b/testsuite/src/test_driver.C
index 02eec1a..31def33 100644 index 0fc3117..31def33 100644
--- a/testsuite/src/test_driver.C --- a/testsuite/src/test_driver.C
+++ b/testsuite/src/test_driver.C +++ b/testsuite/src/test_driver.C
@@ -755,7 +755,7 @@ void updateSearchPaths(const char *filename) {
// Add current directory to the search path
const char *pathenv = getenv("PATH");
char *newpath = (char *) malloc (strlen(pathenv)+3);
- strcat(newpath, pathenv);
+ strcpy(newpath, pathenv);
strcat(newpath, ":.");
execpath = searchPath(newpath, filename);
if(execpath == NULL) {
@@ -805,6 +805,8 @@ void updateSearchPaths(const char *filename) { @@ -805,6 +805,8 @@ void updateSearchPaths(const char *filename) {
} }

View File

@ -0,0 +1,23 @@
commit 6401cf3b040bee82a3d1146519aaaf3123b169bb
Author: Andrew Bernat <bernat@cs.wisc.edu>
Date: Thu Mar 14 19:30:52 2013 -0500
Symlink path fix as suggested by Josh Stone
diff --git a/make.library.tmpl b/make.library.tmpl
index fb2dce4..61f7651 100644
--- a/make.library.tmpl
+++ b/make.library.tmpl
@@ -153,10 +153,10 @@ $(DEST)/$(TARGET).$(RELEASE_NUM): $(TARGET).$(RELEASE_NUM) $(TARGET)
ifndef STATIC_LIBRARY
$(DEST)/$(TARGET).$(SONAME_NUM): $(DEST)/$(TARGET).$(RELEASE_NUM)
@echo Making symlink $(TARGET).$(RELEASE_NUM) to $(DEST)/$(TARGET).$(SONAME_NUM)
- $(HIDE_COMP)-$(LN) -f $(DEST)/$(TARGET).$(RELEASE_NUM) $(DEST)/$(TARGET).$(SONAME_NUM)
+ $(HIDE_COMP)-$(LN) -f $(TARGET).$(RELEASE_NUM) $(DEST)/$(TARGET).$(SONAME_NUM)
$(DEST)/$(TARGET): $(DEST)/$(TARGET).$(SONAME_NUM)
@echo Making symlink $(TARGET).$(SONAME_NUM) to $(DEST)/$(TARGET)
- $(HIDE_COMP)-$(LN) -f $(DEST)/$(TARGET).$(SONAME_NUM) $(DEST)/$(TARGET)
+ $(HIDE_COMP)-$(LN) -f $(TARGET).$(SONAME_NUM) $(DEST)/$(TARGET)
else
$(DEST)/$(TARGET): $(TARGET)
@echo Installing $(TARGET) to $(DEST)/$(TARGET)

View File

@ -5,10 +5,9 @@
# flags for normal (non-kludge) files, with common warnings # flags for normal (non-kludge) files, with common warnings
-CFLAGS = $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(ARCH_FLAGS) -CFLAGS = $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(ARCH_FLAGS)
-CXXFLAGS = $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(STDINT_MACROS) $(ARCH_FLAGS)
-LDFLAGS = $(ARCH_FLAGS)
+CFLAGS += $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(ARCH_FLAGS) +CFLAGS += $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(ARCH_FLAGS)
+CXXFLAGS += $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(STDINT_MACROS) $(ARCH_FLAGS) CXXFLAGS += $(IFLAGS) $(UNIFIED_DEF) $(OPT_FLAG) $(COMMON_WARNINGS) $(STDINT_MACROS) $(ARCH_FLAGS)
-LDFLAGS = $(ARCH_FLAGS)
+LDFLAGS += $(ARCH_FLAGS) +LDFLAGS += $(ARCH_FLAGS)
# flags for kludge files, won't have warnings generated # flags for kludge files, won't have warnings generated

View File

@ -1,25 +0,0 @@
commit 3a6a6d980d345552ebb6c2dd27b874dbb9794e7d
Author: Andrew Bernat <bernat@cs.wisc.edu>
Date: Thu Feb 21 13:14:29 2013 -0600
Fix a system crash when running the test suite as root
diff --git a/testsuite/src/dyninst/test2_4.C b/testsuite/src/dyninst/test2_4.C
index 2920149..1cbb6a6 100644
--- a/testsuite/src/dyninst/test2_4.C
+++ b/testsuite/src/dyninst/test2_4.C
@@ -68,6 +68,14 @@ extern "C" DLLEXPORT TestMutator *test2_4_factory() {
// static int mutatorTest(BPatch *bpatch, bool useAttach)
test_results_t test2_4_Mutator::executeTest() {
// attach to an a protected pid
+
+#if !defined(os_windows_test)
+ if (getuid() == 0 || geteuid() == 0) {
+ // We're root, there _are_ no protected PIDs
+ return SKIPPED;
+ }
+#endif
+
clearError();
BPatch_process *ret = bpatch->processAttach(NULL, 1);
int gotError = getError();

View File

@ -1,244 +0,0 @@
commit 59803a8928076463096fbaa8834ee15cd63852f9
Author: William Cohen <wcohen@redhat.com>
Date: Mon Jul 9 15:25:42 2012 -0400
Remove the unused variable assignments for getenv() calls
There were a number of places in the code that assigned the return value
of getenv to a variable. However, the variable was never used in most cases.
This patch cleans up those unneeded assignments.
diff --git a/common/src/Annotatable.C b/common/src/Annotatable.C
index bdc67a0..2b9f875 100644
--- a/common/src/Annotatable.C
+++ b/common/src/Annotatable.C
@@ -75,16 +75,15 @@ void annotations_debug_init()
{
if (dyn_debug_annotations) return;
- char *p;
- if ( (p=getenv("DYNINST_DEBUG_ANNOTATIONS"))) {
+ if (getenv("DYNINST_DEBUG_ANNOTATIONS")) {
fprintf(stderr, "Enabling DyninstAPI annotations debug\n");
dyn_debug_annotations = true;
}
- else if ( (p=getenv("DYNINST_DEBUG_ANNOTATION"))) {
+ else if (getenv("DYNINST_DEBUG_ANNOTATION")) {
fprintf(stderr, "Enabling DyninstAPI annotations debug\n");
dyn_debug_annotations = true;
}
- else if ( (p=getenv("DYNINST_DEBUG_ANNOTATABLE"))) {
+ else if (getenv("DYNINST_DEBUG_ANNOTATABLE")) {
fprintf(stderr, "Enabling DyninstAPI annotations debug\n");
dyn_debug_annotations = true;
}
diff --git a/dataflowAPI/src/debug_dataflow.C b/dataflowAPI/src/debug_dataflow.C
index d1adf11..6499375 100644
--- a/dataflowAPI/src/debug_dataflow.C
+++ b/dataflowAPI/src/debug_dataflow.C
@@ -54,34 +54,32 @@ bool df_init_debug() {
if (init) return true;
init = true;
- char *p;
-
#if defined(_MSC_VER)
#pragma warning(push)
#pragma warning(disable:4996)
#endif
- if ((p=getenv("DATAFLOW_DEBUG_STACKANALYSIS"))) {
+ if ((getenv("DATAFLOW_DEBUG_STACKANALYSIS"))) {
fprintf(stderr, "Enabling DataflowAPI stack analysis debugging\n");
df_debug_stackanalysis = 1;
}
- if ((p=getenv("DATAFLOW_DEBUG_SLICING"))) {
+ if ((getenv("DATAFLOW_DEBUG_SLICING"))) {
fprintf(stderr, "Enabling DataflowAPI slicing debugging\n");
df_debug_slicing = 1;
}
- if ((p=getenv("DATAFLOW_DEBUG_CONVERT"))) {
+ if ((getenv("DATAFLOW_DEBUG_CONVERT"))) {
fprintf(stderr, "Enabling DataflowAPI->ROSE conversion debugging\n");
df_debug_convert = 1;
}
- if ((p=getenv("DATAFLOW_DEBUG_EXPAND"))) {
+ if ((getenv("DATAFLOW_DEBUG_EXPAND"))) {
fprintf(stderr, "Enabling DataflowAPI symbolic expansion debugging\n");
df_debug_expand = 1;
}
- if ((p=getenv("DATAFLOW_DEBUG_LIVENESS"))) {
+ if ((getenv("DATAFLOW_DEBUG_LIVENESS"))) {
fprintf(stderr, "Enabling DataflowAPI liveness debugging\n");
df_debug_liveness = 1;
}
diff --git a/dyninstAPI/src/Relocation/patchapi_debug.C b/dyninstAPI/src/Relocation/patchapi_debug.C
index 474ba0f..14fa96a 100644
--- a/dyninstAPI/src/Relocation/patchapi_debug.C
+++ b/dyninstAPI/src/Relocation/patchapi_debug.C
@@ -45,15 +45,14 @@ bool init_debug_patchapi() {
if (init) return true;
init = true;
- char *p;
- if ( (p=getenv("DYNINST_DEBUG_RELOCATION")) ||
- (p=getenv("PATCHAPI_DEBUG_RELOCATION"))) {
+ if ( getenv("DYNINST_DEBUG_RELOCATION") ||
+ getenv("PATCHAPI_DEBUG_RELOCATION")) {
fprintf(stderr, "Enabling DyninstAPI relocation debug\n");
patch_debug_relocation = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_SPRINGBOARD")) ||
- (p=getenv("PATCHAPI_DEBUG_SPRINGBOARD"))) {
+ if ( getenv("DYNINST_DEBUG_SPRINGBOARD") ||
+ getenv("PATCHAPI_DEBUG_SPRINGBOARD")) {
fprintf(stderr, "Enabling DyninstAPI springboard debug\n");
patch_debug_relocation = 1;
}
diff --git a/dyninstAPI/src/debug.C b/dyninstAPI/src/debug.C
index 8bb677b..a6ecc86 100644
--- a/dyninstAPI/src/debug.C
+++ b/dyninstAPI/src/debug.C
@@ -243,19 +243,19 @@ bool init_debug() {
init = true;
char *p;
- if ( (p=getenv("DYNINST_DEBUG_MALWARE"))) {
+ if (getenv("DYNINST_DEBUG_MALWARE")) {
fprintf(stderr, "Enabling DyninstAPI malware debug\n");
dyn_debug_malware = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_TRAP"))) {
+ if (getenv("DYNINST_DEBUG_TRAP")) {
fprintf(stderr, "Enabling DyninstAPI debugging using traps\n");
dyn_debug_trap = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_SPRINGBOARD"))) {
+ if (getenv("DYNINST_DEBUG_SPRINGBOARD")) {
fprintf(stderr, "Enabling DyninstAPI springboard debug\n");
dyn_debug_springboard = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_STARTUP"))) {
+ if (getenv("DYNINST_DEBUG_STARTUP")) {
fprintf(stderr, "Enabling DyninstAPI startup debug\n");
dyn_debug_startup = 1;
}
@@ -271,68 +271,68 @@ bool init_debug() {
dyn_debug_parsing = 1;
}
}
- if ( (p=getenv("DYNINST_DEBUG_DYNPC"))
- || (p=getenv("DYNINST_DEBUG_FORKEXEC"))
- || (p=getenv("DYNINST_DEBUG_INFRPC"))
- || (p=getenv("DYNINST_DEBUG_SIGNAL"))
- || (p=getenv("DYNINST_DEBUG_INFERIORRPC"))
- || (p=getenv("DYNINST_DEBUG_THREAD"))
- || (p=getenv("DYNINST_DEBUG_MAILBOX"))
- || (p=getenv("DYNINST_DEBUG_DBI"))
+ if ( getenv("DYNINST_DEBUG_DYNPC")
+ || getenv("DYNINST_DEBUG_FORKEXEC")
+ || getenv("DYNINST_DEBUG_INFRPC")
+ || getenv("DYNINST_DEBUG_SIGNAL")
+ || getenv("DYNINST_DEBUG_INFERIORRPC")
+ || getenv("DYNINST_DEBUG_THREAD")
+ || getenv("DYNINST_DEBUG_MAILBOX")
+ || getenv("DYNINST_DEBUG_DBI")
)
{
fprintf(stderr, "Enabling DyninstAPI process control debug\n");
dyn_debug_proccontrol = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_STACKWALK"))) {
+ if (getenv("DYNINST_DEBUG_STACKWALK")) {
fprintf(stderr, "Enabling DyninstAPI stack walking debug\n");
dyn_debug_stackwalk = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_INST"))) {
+ if (getenv("DYNINST_DEBUG_INST")) {
fprintf(stderr, "Enabling DyninstAPI inst debug\n");
dyn_debug_inst = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_RELOC"))) {
+ if (getenv("DYNINST_DEBUG_RELOC")) {
fprintf(stderr, "Enabling DyninstAPI relocation debug\n");
dyn_debug_reloc = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_RELOCATION"))) {
+ if (getenv("DYNINST_DEBUG_RELOCATION")) {
fprintf(stderr, "Enabling DyninstAPI relocation debug\n");
dyn_debug_reloc = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_SENSITIVITY"))) {
+ if (getenv("DYNINST_DEBUG_SENSITIVITY")) {
fprintf(stderr, "Enabling DyninstAPI sensitivity debug\n");
dyn_debug_sensitivity = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_DYN_UNW"))) {
+ if (getenv("DYNINST_DEBUG_DYN_UNW")) {
fprintf(stderr, "Enabling DyninstAPI dynamic unwind debug\n");
dyn_debug_dyn_unw = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_MUTEX"))) {
+ if (getenv("DYNINST_DEBUG_MUTEX")) {
fprintf(stderr, "Enabling DyninstAPI mutex debug\n");
dyn_debug_mutex = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_DWARF"))) {
+ if (getenv("DYNINST_DEBUG_DWARF")) {
fprintf(stderr, "Enabling DyninstAPI dwarf debug\n");
dyn_debug_dwarf= 1;
}
- if ( (p=getenv("DYNINST_DEBUG_RTLIB"))) {
+ if (getenv("DYNINST_DEBUG_RTLIB")) {
fprintf(stderr, "Enabling DyninstAPI RTlib debug\n");
dyn_debug_rtlib = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_CATCHUP"))) {
+ if (getenv("DYNINST_DEBUG_CATCHUP")) {
fprintf(stderr, "Enabling DyninstAPI catchup debug\n");
dyn_debug_catchup = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_BPATCH"))) {
+ if (getenv("DYNINST_DEBUG_BPATCH")) {
fprintf(stderr, "Enabling DyninstAPI bpatch debug\n");
dyn_debug_bpatch = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_REGALLOC"))) {
+ if (getenv("DYNINST_DEBUG_REGALLOC")) {
fprintf(stderr, "Enabling DyninstAPI register allocation debug\n");
dyn_debug_regalloc = 1;
}
- if ( (p=getenv("DYNINST_DEBUG_AST"))) {
+ if (getenv("DYNINST_DEBUG_AST")) {
fprintf(stderr, "Enabling DyninstAPI ast debug\n");
dyn_debug_ast = 1;
}
@@ -351,7 +351,7 @@ bool init_debug() {
dyn_debug_crash = 1;
dyn_debug_crash_debugger = p;
}
- if ((p=getenv("DYNINST_DEBUG_DISASS"))) {
+ if (getenv("DYNINST_DEBUG_DISASS")) {
fprintf(stderr, "Enabling DyninstAPI instrumentation disassembly debugging\n");
dyn_debug_disassemble = 1;
}
diff --git a/parseAPI/src/SymtabCodeSource.C b/parseAPI/src/SymtabCodeSource.C
index 660fa9d..72b0fcd 100644
--- a/parseAPI/src/SymtabCodeSource.C
+++ b/parseAPI/src/SymtabCodeSource.C
@@ -273,9 +273,7 @@ SymtabCodeSource::SymtabCodeSource(char * file) :
bool
SymtabCodeSource::init_stats() {
- char *p;
-
- if ((p = getenv("DYNINST_STATS_PARSING"))) {
+ if ((getenv("DYNINST_STATS_PARSING"))) {
parsing_printf("[%s] Enabling ParseAPI parsing statistics\n", FILE__);
// General counts
stats_parse->add(PARSE_BLOCK_COUNT, CountStat);

View File

@ -2,9 +2,9 @@ Summary: An API for Run-time Code Generation
License: LGPLv2+ License: LGPLv2+
Name: dyninst Name: dyninst
Group: Development/Libraries Group: Development/Libraries
Release: 7%{?dist} Release: 1%{?dist}
URL: http://www.dyninst.org URL: http://www.dyninst.org
Version: 8.0 Version: 8.1.1
Exclusiveos: linux Exclusiveos: linux
#Right now dyninst does not know about the following architectures #Right now dyninst does not know about the following architectures
ExcludeArch: s390 s390x %{arm} ExcludeArch: s390 s390x %{arm}
@ -12,18 +12,17 @@ ExcludeArch: s390 s390x %{arm}
# The source for this package was pulled from upstream's vcs. Use the # The source for this package was pulled from upstream's vcs. Use the
# following commands to generate the tarball: # following commands to generate the tarball:
# git clone http://git.dyninst.org/dyninst.git; cd dyninst # git clone http://git.dyninst.org/dyninst.git; cd dyninst
# git archive --format=tar.gz --prefix=dyninst/ v8.0 > dyninst-8.0.tar.gz # git archive --format=tar.gz --prefix=dyninst/ v8.1.1 > dyninst-8.1.1.tar.gz
# git clone http://git.dyninst.org/docs.git; cd docs # git clone http://git.dyninst.org/docs.git; cd docs
# git archive --format=tar.gz v8.0 > dyninst-docs-8.0.tar.gz # git archive --format=tar.gz v8.1.1 > dyninst-docs-8.1.1.tar.gz
# Verify the commit ids with: # Verify the commit ids with:
# gunzip -c dyninst-8.0.tar.gz | git get-tar-commit-id # gunzip -c dyninst-8.1.1.tar.gz | git get-tar-commit-id
# gunzip -c dyninst-docs-8.0.tar.gz | git get-tar-commit-id # gunzip -c dyninst-docs-8.1.1.tar.gz | git get-tar-commit-id
Source0: %{name}-%{version}.tar.gz Source0: %{name}-%{version}.tar.gz
Source1: %{name}-docs-%{version}.tar.gz Source1: %{name}-docs-%{version}.tar.gz
Patch1: dyninst-rpm-build-flags.patch Patch1: dyninst-rpm-build-flags.patch
Patch2: dyninst-install-testsuite.patch Patch2: dyninst-install-testsuite.patch
Patch3: dyninst-test2_4-kill-init.patch Patch3: dyninst-relative-symlinks.patch
Patch5: dyninst-unused_vars.patch
BuildRequires: libdwarf-devel >= 20111030 BuildRequires: libdwarf-devel >= 20111030
BuildRequires: elfutils-libelf-devel BuildRequires: elfutils-libelf-devel
BuildRequires: boost-devel BuildRequires: boost-devel
@ -87,8 +86,7 @@ making sure that dyninst works properly.
pushd dyninst pushd dyninst
%patch1 -p1 -b .buildflags %patch1 -p1 -b .buildflags
%patch2 -p1 -b .testsuite %patch2 -p1 -b .testsuite
%patch3 -p1 -b .kill-init %patch3 -p1 -b .symlinks
%patch5 -p1 -b .unused
popd popd
%build %build
@ -138,7 +136,7 @@ chmod 644 %{buildroot}%{_libdir}/dyninst/testsuite/*
%doc ParseAPI.pdf %doc ParseAPI.pdf
%doc PatchAPI.pdf %doc PatchAPI.pdf
%doc ProcControlAPI.pdf %doc ProcControlAPI.pdf
%doc stackwalk/stackwalker.pdf %doc StackwalkerAPI.pdf
%doc SymtabAPI.pdf %doc SymtabAPI.pdf
%files devel %files devel
@ -155,9 +153,16 @@ chmod 644 %{buildroot}%{_libdir}/dyninst/testsuite/*
%{_bindir}/parseThat %{_bindir}/parseThat
%dir %{_libdir}/dyninst/testsuite/ %dir %{_libdir}/dyninst/testsuite/
# Restore the permissions that were hacked out above, during install. # Restore the permissions that were hacked out above, during install.
%attr(755,-,-) %{_libdir}/dyninst/testsuite/* %attr(755,root,root) %{_libdir}/dyninst/testsuite/*
%changelog %changelog
* Fri Mar 15 2013 Josh Stone <jistone@redhat.com> 8.1.1-1
- Update to release 8.1.1.
- Drop the backported dyninst-test2_4-kill-init.patch.
- Drop the now-upstreamed dyninst-unused_vars.patch.
- Update other patches for context.
- Patch the installed symlinks to be relative, not $(DEST) filled.
* Tue Feb 26 2013 Josh Stone <jistone@redhat.com> 8.0-7 * Tue Feb 26 2013 Josh Stone <jistone@redhat.com> 8.0-7
- testsuite: Require dyninst-devel for the libdyninstAPI_RT.so symlink - testsuite: Require dyninst-devel for the libdyninstAPI_RT.so symlink

View File

@ -1,2 +1,2 @@
579ea746504c07f6d330d017f3aae82c dyninst-8.0.tar.gz b917441a9f0c121377ddc82b5d817ba1 dyninst-8.1.1.tar.gz
22b13ded5c341c647051093b983fb67f dyninst-docs-8.0.tar.gz 73d258f60bf773ceb7d7f8d272446e95 dyninst-docs-8.1.1.tar.gz