Update to 10.2.0

This commit is contained in:
Stan Cox 2020-09-02 13:54:44 -04:00
parent 23090e1213
commit d51e94a73e
14 changed files with 32 additions and 330 deletions

1
.gitignore vendored
View File

@ -21,3 +21,4 @@
/testsuite-9.4.0.tar.gz /testsuite-9.4.0.tar.gz
/testsuite-10.1.0.tar.gz /testsuite-10.1.0.tar.gz
/dyninst-10.1.0.tar.gz /dyninst-10.1.0.tar.gz
/dyninst-10.2.0.tar.gz

View File

@ -1,29 +0,0 @@
# workaround for https://github.com/dyninst/dyninst/issues/396
--- ./dyninst-9.3.2/symtabAPI/src/Object-elf.C.sv 2017-09-27 21:43:18.399429243 -0400
+++ ./dyninst-9.3.2/symtabAPI/src/Object-elf.C 2017-09-27 21:56:14.485125928 -0400
@@ -1445,6 +1445,24 @@
if (fbt_iter == -1) { // Create new relocation entry.
relocationEntry re( next_plt_entry_addr, offset, targ_name,
NULL, type );
+ if (type == R_X86_64_IRELATIVE) {
+ vector<Symbol *> funcs;
+ dyn_hash_map<std::string, std::vector<Symbol *> >::iterator iter;
+ // find the resolver function and use that as the
+ // caller function symbol. The resolver has not run
+ // so we don't know the ultimate destination.
+ // Since the funcsByOffset map hasn't been setup yet
+ // we cannot call associated_symtab->findFuncByEntryOffset
+ for (iter = symbols_.begin(); iter != symbols_.end(); ++iter) {
+ std::string name = iter->first;
+ Symbol *sym = iter->second[0];
+ if (sym->getOffset() == (Offset)addend) {
+ // Use dynsym_list.push_back(sym) instead?
+ re.addDynSym(sym);
+ break;
+ }
+ }
+ }
re.setAddend(addend);
re.setRegionType(rtype);
if (dynsym_list.size() > 0)

View File

@ -1,12 +0,0 @@
# workaround for https://github.com/dyninst/dyninst/issues/406
--- dyninst-9.3.2/common/src/addrtranslate-sysv.C.sv 2017-10-03 21:32:23.608614189 -0400
+++ dyninst-9.3.2/common/src/addrtranslate-sysv.C 2017-10-03 21:33:36.538642148 -0400
@@ -800,6 +800,7 @@
continue;
}
if (obj_name == "linux-vdso.so.1" ||
+ obj_name == "linux-vdso64.so.1" ||
obj_name == "linux-gate.so.1")
{
continue;

View File

@ -1,12 +0,0 @@
--- ./dyninst-10.0.0/CMakeLists.txt.sv 2018-11-09 11:48:08.000000000 -0500
+++ ./dyninst-10.0.0/CMakeLists.txt 2018-11-13 11:35:20.109650373 -0500
@@ -149,7 +149,7 @@ if(BUILD_DOCS)
foreach(COMPONENT ${WORD_DOCS})
add_dependencies(doc ${COMPONENT}-doc)
set_target_properties(${COMPONENT}-doc PROPERTIES EXCLUDE_FROM_DEFAULT_BUILD 1)
- install(FILES ${CMAKE_SOURCE_DIR}/${COMPONENT}/doc/${COMPONENT}.pdf
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${COMPONENT}/doc/${COMPONENT}.pdf
DESTINATION ${INSTALL_DOC_DIR}
RENAME ${COMPONENT}-${VERSION_STRING}.pdf
OPTIONAL

View File

@ -1,42 +0,0 @@
# workaround for https://github.com/dyninst/dyninst/issues/396
--- ./dyninst-10.0.0/examples/CMakeLists.txt.sv 2018-11-09 11:48:08.000000000 -0500
+++ ./dyninst-10.0.0/examples/CMakeLists.txt 2018-11-13 11:35:20.109650373 -0500
@@ -1,19 +1,19 @@
-add_executable(unstrip unstrip/unstrip.C
- unstrip/util.C
- unstrip/types.C
- unstrip/semanticDescriptor.C
- unstrip/database.C
- unstrip/fingerprint.C
- unstrip/callback.C)
+add_executable(unstrip unstrip.dir/unstrip.C
+ unstrip.dir/util.C
+ unstrip.dir/types.C
+ unstrip.dir/semanticDescriptor.C
+ unstrip.dir/database.C
+ unstrip.dir/fingerprint.C
+ unstrip.dir/callback.C)
add_dependencies(unstrip parseAPI symtabAPI instructionAPI common)
target_link_libraries(unstrip parseAPI symtabAPI instructionAPI common dynDwarf dynElf ${Boost_LIBRARIES})
-add_executable(codeCoverage codeCoverage/codeCoverage.C)
+add_executable(codeCoverage codeCoverage.dir/codeCoverage.C)
add_dependencies(codeCoverage dyninstAPI patchAPI parseAPI symtabAPI instructionAPI pcontrol common stackwalk dynDwarf dynElf)
target_link_libraries(codeCoverage dyninstAPI patchAPI parseAPI symtabAPI instructionAPI pcontrol common stackwalk dynDwarf dynElf ${Boost_LIBRARIES})
-add_library(Inst SHARED codeCoverage/libInst.C)
+add_library(Inst SHARED codeCoverage.dir/libInst.C)
add_executable(cfg_to_dot ../parseAPI/doc/example.cc)
@@ -29,5 +29,5 @@
)
-install (
- FILES unstrip/ddb.db unstrip/params.db unstrip/unistd.db DESTINATION ${INSTALL_BIN_DIR}
-)
+# install (
+# FILES unstrip.dir/ddb.db unstrip.dir/params.db unstrip.dir/unistd.db DESTINATION ${INSTALL_BIN_DIR}
+# )

View File

@ -1,28 +0,0 @@
--- ./dyninst-10.0.0/instructionAPI/h/Result.h.sv 2018-11-09 11:48:08.000000000 -0500
+++ ./dyninst-10.0.0/instructionAPI/h/Result.h 2018-12-04 22:12:47.369579566 -0500
@@ -449,10 +449,10 @@
snprintf(hex, 20, "%x", val.s32val);
break;
case u64:
- snprintf(hex, 20, "%lx", val.u64val);
+ snprintf(hex, 20, "%" PRIx64, val.u64val);
break;
case s64:
- snprintf(hex, 20, "%lx", val.s64val);
+ snprintf(hex, 20, "%" PRIx64, val.s64val);
break;
case sp_float:
snprintf(hex, 20, "%f", val.floatval);
@@ -464,10 +464,10 @@
snprintf(hex, 20, "%x", val.bitval);
break;
case u48:
- snprintf(hex, 20, "%lx", val.s48val);
+ snprintf(hex, 20, "%" PRIx64, val.s48val);
break;
case s48:
- snprintf(hex, 20, "%lx", val.s48val);
+ snprintf(hex, 20, "%" PRIx64, val.s48val);
break;
case m512:
snprintf(hex, 20, "%p", val.m512val);

View File

@ -1,35 +0,0 @@
commit 54a2debd94c3e8df3b6f1e579f1db02dae61cbb7
Author: Mark W. Krentel <krentel@rice.edu>
Date: Fri Feb 1 13:14:11 2019 -0600
Add some explicit casts from boost::tribool to bool for some code in (#541)
Add some explicit casts from boost::tribool to bool for some code in dataflowAPI/rose/util/Message.[Ch]. This was breaking the build when using boost >= 1.69.
diff --git a/dataflowAPI/rose/util/Message.C b/dataflowAPI/rose/util/Message.C
index a8a66ad4c..5e276f97d 100644
--- ./dyninst-10.0.0/dataflowAPI/rose/util/Message.C
+++ ./dyninst-10.0.0/dataflowAPI/rose/util/Message.C
@@ -1123,7 +1123,7 @@ StreamBuf::bake() {
destination_->bakeDestinations(message_.properties(), baked_/*out*/);
anyUnbuffered_ = false;
for (BakedDestinations::const_iterator bi=baked_.begin(); bi!=baked_.end() && !anyUnbuffered_; ++bi)
- anyUnbuffered_ = !bi->second.isBuffered;
+ anyUnbuffered_ = static_cast<bool>(!bi->second.isBuffered);
isBaked_ = true;
}
}
diff --git a/dataflowAPI/rose/util/Message.h b/dataflowAPI/rose/util/Message.h
index 816f68d2e..03592cb97 100644
--- ./dyninst-10.0.0/dataflowAPI/rose/util/Message.h
+++ ./dyninst-10.0.0/dataflowAPI/rose/util/Message.h
@@ -386,7 +386,8 @@ struct SAWYER_EXPORT ColorSpec {
ColorSpec(AnsiColor fg, AnsiColor bg, bool bold): foreground(fg), background(bg), bold(bold) {}
/** Returns true if this object is in its default-constructed state. */
- bool isDefault() const { return COLOR_DEFAULT==foreground && COLOR_DEFAULT==background && !bold; }
+ bool isDefault() const { return COLOR_DEFAULT==foreground && COLOR_DEFAULT==background
+ && static_cast<bool>(!bold); }
};
/** Colors to use for each message importance.

View File

@ -1,108 +0,0 @@
--- dyninst-9.3.1/common/src/Types.h.sv 2017-03-07 22:05:52.187479600 -0500
+++ dyninst-9.3.1/common/src/Types.h 2017-03-07 22:06:57.509944790 -0500
@@ -170,7 +170,7 @@
static const Address ADDR_NULL = (Address)(0);
#else
#define ADDR_NULL (0)
-typedef uintptr_t Address;
+typedef unsigned long Address;
#endif
/* Note the inherent assumption that the size of a "long" integer matches
that of an address (void*) on every supported Paradyn/Dyninst system!
--- dyninst-9.3.1/common/h/dyntypes.h.sv 2017-03-08 10:16:18.657768231 -0500
+++ dyninst-9.3.1/common/h/dyntypes.h 2017-03-08 10:37:07.992634513 -0500
@@ -124,8 +124,8 @@
namespace Dyninst
{
- typedef uintptr_t Address;
- typedef uintptr_t Offset;
+ typedef unsigned long Address;
+ typedef unsigned long Offset;
#if defined(_MSC_VER)
typedef int PID;
--- dyninst-9.3.1/dyninstAPI/src/BPatch_memoryAccess.C.sv 2017-03-07 23:07:29.371789000 -0500
+++ dyninst-9.3.1/dyninstAPI/src/BPatch_memoryAccess.C 2017-03-07 23:07:48.928927991 -0500
@@ -33,10 +33,10 @@
#include <stdlib.h>
#include <string.h>
+#include "../../common/src/Types.h"
#include "BPatch_memoryAccess_NP.h"
#include "BPatch_Vector.h"
#include "BPatch_point.h"
-#include "../../common/src/Types.h"
BPatch_addrSpec_NP::BPatch_addrSpec_NP(long _imm, int _ra, int _rb, int _scale) :
imm(_imm),
--- dyninst-9.3.1/dyninstAPI/h/BPatch_instruction.h.sv 2017-03-08 09:06:46.638171175 -0500
+++ dyninst-9.3.1/dyninstAPI/h/BPatch_instruction.h 2017-03-08 09:00:39.455564403 -0500
@@ -69,7 +69,7 @@
public:
BPatch_instruction(internal_instruction *insn,
- uintptr_t _addr);
+ Dyninst::Address _addr);
virtual ~BPatch_instruction();
void getInstruction(const unsigned char *&_buffer, unsigned char &_length);
--- dyninst-9.3.1/dyninstAPI/h/BPatch_memoryAccess_NP.h.sv 2017-03-07 22:43:56.645745821 -0500
+++ dyninst-9.3.1/dyninstAPI/h/BPatch_memoryAccess_NP.h 2017-03-08 10:39:30.122643332 -0500
@@ -121,27 +121,27 @@
static BPatch_memoryAccess* init_tables();
// initializes only the first access; #bytes is a constant
- BPatch_memoryAccess(internal_instruction *, uintptr_t _addr,
+ BPatch_memoryAccess(internal_instruction *, Dyninst::Address _addr,
bool _isLoad, bool _isStore, unsigned int _bytes,
long _imm, int _ra, int _rb, unsigned int _scale = 0,
int _cond = -1, bool _nt = false);
// initializes only the first access; #bytes is an expression w/scale
- BPatch_memoryAccess(internal_instruction *insn, uintptr_t _addr,
+ BPatch_memoryAccess(internal_instruction *insn, Dyninst::Address _addr,
bool _isinternal_Load, bool _isStore,
long _imm_s, int _ra_s, int _rb_s, unsigned int _scale_s,
long _imm_c, int _ra_c, int _rb_c, unsigned int _scale_c,
int _cond, bool _nt, int _preFcn = -1);
// initializes only the first access; #bytes is an expression
- BPatch_memoryAccess(internal_instruction *insn, uintptr_t _addr,
+ BPatch_memoryAccess(internal_instruction *insn, Dyninst::Address _addr,
bool _isLoad, bool _isStore, bool _isPrefetch,
long _imm_s, int _ra_s, int _rb_s,
long _imm_c, int _ra_c, int _rb_c,
unsigned short _preFcn);
// initializes only the first access; #bytes is an expression & not a prefetch
- BPatch_memoryAccess(internal_instruction *insn, uintptr_t _addr,
+ BPatch_memoryAccess(internal_instruction *insn, Dyninst::Address _addr,
bool _isLoad, bool _isStore, long _imm_s, int _ra_s, int _rb_s,
long _imm_c, int _ra_c, int _rb_c);
@@ -156,14 +156,14 @@
int _cond, bool _nt);
// initializes both accesses; #bytes is a constant
- BPatch_memoryAccess(internal_instruction *insn, uintptr_t _addr,
+ BPatch_memoryAccess(internal_instruction *insn, Dyninst::Address _addr,
bool _isLoad, bool _isStore, unsigned int _bytes,
long _imm, int _ra, int _rb, unsigned int _scale,
bool _isLoad2, bool _isStore2, unsigned int _bytes2,
long _imm2, int _ra2, int _rb2, unsigned int _scale2);
// initializes both accesses; #bytes is an expression & not a prefetch
- BPatch_memoryAccess(internal_instruction *insn, uintptr_t _addr, bool _isLoad, bool _isStore,
+ BPatch_memoryAccess(internal_instruction *insn, Dyninst::Address _addr, bool _isLoad, bool _isStore,
long _imm_s, int _ra_s, int _rb_s, unsigned int _scale_s,
long _imm_c, int _ra_c, int _rb_c, unsigned int _scale_c,
bool _isLoad2, bool _isStore2, long _imm2_s, int _ra2_s,

View File

@ -1,14 +0,0 @@
diff -up dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C.me dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C
--- dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C.me 2018-02-07 15:50:36.706363500 +0100
+++ dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C 2018-02-07 16:30:28.173906877 +0100
@@ -2512,8 +2512,8 @@ void emitElf<ElfTypes>::createDynamicSec
if (!object->hasReldyn() && !object->hasReladyn()) {
if (object->getRelType() == Region::RT_REL) {
- new_dynamic_entries.push_back(make_pair(DT_REL, 0));
- new_dynamic_entries.push_back(make_pair(DT_RELSZ, 0));
+ new_dynamic_entries.push_back(std::pair<long, long>(DT_REL, 0));
+ new_dynamic_entries.push_back(std::pair<long, long>(DT_RELSZ, 0));
dynamicSecData[DT_REL].push_back(dynsecData + curpos);
dynsecData[curpos].d_tag = DT_NULL;

View File

@ -1,23 +0,0 @@
diff -up dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt.me dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt
--- dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt.me 2018-02-07 15:25:38.925763122 +0100
+++ dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt 2018-02-07 15:30:42.242099198 +0100
@@ -19,6 +19,7 @@ include (${DYNINST_ROOT}/cmake/shared.cm
configure_file(cmake/version.h.in common/h/version.h)
include_directories(${PROJECT_BINARY_DIR})
include_directories(${PROJECT_BINARY_DIR}/common/h)
+include_directories("/usr/include/tirpc/")
set (HEADER_DIRS common
dataflowAPI
dyninstAPI
diff -up dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h.me dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h
--- dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h.me 2018-02-07 15:06:45.961780668 +0100
+++ dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h 2018-02-07 15:38:56.832278338 +0100
@@ -281,7 +281,7 @@ inline bool_t P_xdr_string(XDR *x, char
inline void P_xdrrec_create(XDR *x, const u_int send_sz, const u_int rec_sz,
const caddr_t handle,
xdr_rd_func read_r, xdr_wr_func write_f) {
- xdrrec_create(x, send_sz, rec_sz, handle, (int(*)(char*, char*, int))read_r, (int(*)(char*, char*, int))write_f);}
+ xdrrec_create(x, send_sz, rec_sz, handle, (int(*)(void*, void*, int))read_r, (int(*)(void*, void*, int))write_f);}
inline bool_t P_xdrrec_endofrecord(XDR *x, int now) {
return (xdrrec_endofrecord(x, now));}
inline bool_t P_xdrrec_skiprecord(XDR *x) { return (xdrrec_skiprecord(x));}

View File

@ -1,21 +1,21 @@
Summary: An API for Run-time Code Generation Summary: An API for Run-time Code Generation
License: LGPLv2+ License: LGPLv2+
Name: dyninst Name: dyninst
Release: 10%{?dist} Release: 1%{?dist}
URL: http://www.dyninst.org URL: http://www.dyninst.org
Version: 10.1.0 Version: 10.2.0
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64 ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
%define __testsuite_version 10.1.0
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
Source1: https://github.com/dyninst/testsuite/archive/v%{version}/testsuite-%{version}.tar.gz Source1: https://github.com/dyninst/testsuite/archive/v10.1.0/testsuite-%{__testsuite_version}.tar.gz
Patch1: dyninst-10.1.0-result.patch Patch1: dyninst-10.2.0-pie.patch
Patch2: testsuite-10.1.0-gettid.patch Patch2: testsuite-10.1.0-gettid.patch
Patch3: testsuite-10.1.0-386.patch Patch3: testsuite-10.1.0-386.patch
Patch4: dyninst-10.1.0-aarch-regs.patch
%global dyninst_base dyninst-%{version} %global dyninst_base dyninst-%{version}
%global testsuite_base testsuite-%{version} %global testsuite_base testsuite-%{__testsuite_version}
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: elfutils-devel BuildRequires: elfutils-devel
@ -28,7 +28,7 @@ BuildRequires: tbb tbb-devel
BuildRequires: tex-latex BuildRequires: tex-latex
# Extra requires just for the testsuite # Extra requires just for the testsuite
BuildRequires: gcc-gfortran nasm libxml2-devel BuildRequires: gcc-gfortran libxml2-devel
# Testsuite files should not provide/require anything # Testsuite files should not provide/require anything
%{?filter_setup: %{?filter_setup:
@ -75,10 +75,9 @@ making sure that dyninst works properly.
%setup -q -n %{name}-%{version} -c %setup -q -n %{name}-%{version} -c
%setup -q -T -D -a 1 %setup -q -T -D -a 1
%patch1 -p1 -b.result %patch1 -p1 -b.pie
%patch2 -p1 -b.gettid %patch2 -p1 -b.gettid
%patch3 -p1 -b.386 %patch3 -p1 -b.386
%patch4 -p1 -b.aarch
# cotire seems to cause non-deterministic gcc errors # cotire seems to cause non-deterministic gcc errors
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551 # https://bugzilla.redhat.com/show_bug.cgi?id=1420551
@ -91,6 +90,10 @@ cd %{dyninst_base}
CFLAGS="$CFLAGS $RPM_OPT_FLAGS" CFLAGS="$CFLAGS $RPM_OPT_FLAGS"
LDFLAGS="$LDFLAGS $RPM_LD_FLAGS" LDFLAGS="$LDFLAGS $RPM_LD_FLAGS"
%ifarch %{ix86}
CFLAGS="$CFLAGS -fno-lto"
LDFLAGS="$LDFLAGS -fno-lto"
%endif
CXXFLAGS="$CFLAGS" CXXFLAGS="$CFLAGS"
export CFLAGS CXXFLAGS LDFLAGS export CFLAGS CXXFLAGS LDFLAGS
@ -165,17 +168,14 @@ echo "%{_libdir}/dyninst" > %{buildroot}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
%files testsuite %files testsuite
%{_bindir}/parseThat %{_bindir}/parseThat
%exclude %{_bindir}/cfg_to_dot
%exclude /usr/bin/codeCoverage
%exclude /usr/bin/unstrip
%exclude /usr/bin/ddb.db
%exclude /usr/bin/params.db
%exclude /usr/bin/unistd.db
%dir %{_libdir}/dyninst/testsuite/ %dir %{_libdir}/dyninst/testsuite/
%attr(755,root,root) %{_libdir}/dyninst/testsuite/*[!a] %attr(755,root,root) %{_libdir}/dyninst/testsuite/*[!a]
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a %attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
%changelog %changelog
* Tue Sep 01 2020 Stan Cox <scox@redhat.com> - 10.2.0-1
- Update to 10.2.0
* Mon Aug 10 2020 Orion Poplawski <orion@nwra.com> - 10.1.0-10 * Mon Aug 10 2020 Orion Poplawski <orion@nwra.com> - 10.1.0-10
- Use new cmake macros (FTBFS bz#1863463) - Use new cmake macros (FTBFS bz#1863463)
- Add BR tex-latex for doc build - Add BR tex-latex for doc build

View File

@ -1,2 +1,2 @@
SHA512 (testsuite-10.1.0.tar.gz) = 47b91ebc0623f672378086a5f8d84e3934bd6b22d8932b12aaad257ccf7eb109505edb63dfbc3eb15aa099fc488a517835412099a77e3e0dd1275b3e3f672b3b SHA512 (testsuite-10.1.0.tar.gz) = 47b91ebc0623f672378086a5f8d84e3934bd6b22d8932b12aaad257ccf7eb109505edb63dfbc3eb15aa099fc488a517835412099a77e3e0dd1275b3e3f672b3b
SHA512 (dyninst-10.1.0.tar.gz) = 41d7b6f0fce56be84091cc9796b7fa3295a652f80203b6e246df3a28a7bdc02a11996a38c9ccfb2ea7c18ee937a93020ff31d5d4652fd8082f99167e94b16df6 SHA512 (dyninst-10.2.0.tar.gz) = 32ddf871a8b486bb38530a264b140f504bfd5fb9401c940c6e36540f932ad8dd87375a517324416035ba6eeb05107cf03acebc88bdaad4b5d4c3643afaa5ac5c

View File

@ -1,3 +1,18 @@
--- dyninst-10.1.0/testsuite-10.1.0/CMakeLists.txt
+++ dyninst-10.1.0/testsuite-10.1.0/CMakeLists.txt
@@ -111,7 +111,8 @@
if(UNIX)
enable_language(ASM-ATT)
- if("${DYNINST_PLATFORM}" MATCHES "i386")
- enable_language(ASM_NASM)
- endif()
+# nasm/yasm are deprecated
+# if("${DYNINST_PLATFORM}" MATCHES "i386")
+# enable_language(ASM_NASM)
+# endif()
elseif(WIN32)
enable_language(ASM_MASM)
--- dyninst-10.1.0/testsuite-10.1.0/src/instruction/test_instruction_farcall.C --- dyninst-10.1.0/testsuite-10.1.0/src/instruction/test_instruction_farcall.C
+++ dyninst-10.1.0/testsuite-10.1.0/src/instruction/test_instruction_farcall.C +++ dyninst-10.1.0/testsuite-10.1.0/src/instruction/test_instruction_farcall.C
@@ -96,21 +96,21 @@ test_results_t test_instruction_farcall_Mutator::executeTest() @@ -96,21 +96,21 @@ test_results_t test_instruction_farcall_Mutator::executeTest()

View File

@ -1,11 +0,0 @@
--- testsuite-9.3.0/src/JUnitOutputDriver.cpp.nullptr 2016-12-19 14:55:38.000000000 -0800
+++ testsuite-9.3.0/src/JUnitOutputDriver.cpp 2017-02-15 11:19:22.628056889 -0800
@@ -35,7 +35,7 @@ void JUnitOutputDriver::startNewTest(std
{
std::stringstream suitename;
suitename << last_group->modname;
- if(last_group->mutatee != '\0') suitename << "." << last_group->mutatee;
+ if(last_group->mutatee != nullptr) suitename << "." << last_group->mutatee;
log(HUMAN, "<testsuite name=\"%s\" errors=\"%d\" skipped=\"%d\" tests=\"%d\" failures=\"%d\">\n",
suitename.str().c_str(), group_errors, group_skips, group_tests, group_failures);
log(HUMAN, group_output.str().c_str());