Update to 12.1.0
This commit is contained in:
parent
c2951e4bc5
commit
c7e910447c
2
.gitignore
vendored
2
.gitignore
vendored
@ -29,3 +29,5 @@
|
|||||||
/testsuite-11.0.1.tar.gz
|
/testsuite-11.0.1.tar.gz
|
||||||
/dyninst-12.0.1.tar.gz
|
/dyninst-12.0.1.tar.gz
|
||||||
/testsuite-12.0.0.tar.gz
|
/testsuite-12.0.0.tar.gz
|
||||||
|
/dyninst-12.1.0.tar.gz
|
||||||
|
/testsuite-12.1.0.tar.gz
|
||||||
|
11
dyninst.spec
11
dyninst.spec
@ -2,16 +2,15 @@ Summary: An API for Run-time Code Generation
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Name: dyninst
|
Name: dyninst
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 12.0.1
|
Version: 12.1.0
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
||||||
|
|
||||||
%define __testsuite_version 12.0.0
|
%define __testsuite_version 12.1.0
|
||||||
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
|
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
|
||||||
Source1: https://github.com/dyninst/testsuite/archive/%{__testsuite_version}/testsuite-%{__testsuite_version}.tar.gz
|
Source1: https://github.com/dyninst/testsuite/archive/%{__testsuite_version}/testsuite-%{__testsuite_version}.tar.gz
|
||||||
|
|
||||||
Patch1: rhbz2034662.patch
|
|
||||||
Patch2: dwarf-error.patch
|
Patch2: dwarf-error.patch
|
||||||
|
|
||||||
%global dyninst_base dyninst-%{version}
|
%global dyninst_base dyninst-%{version}
|
||||||
@ -81,7 +80,6 @@ making sure that dyninst works properly.
|
|||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
|
|
||||||
pushd %{dyninst_base}
|
pushd %{dyninst_base}
|
||||||
%patch1 -p1 -b .2034662
|
|
||||||
%patch2 -p1 -b .dwerr
|
%patch2 -p1 -b .dwerr
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -192,6 +190,9 @@ find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
|||||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 10 2022 William Cohen <wcohen@redhat.com> - 12.1.0-1
|
||||||
|
- Update to 12.1.0
|
||||||
|
|
||||||
* Sat Mar 05 2022 Orion Poplawski <orion@nwra.com> - 12.0.1-4
|
* Sat Mar 05 2022 Orion Poplawski <orion@nwra.com> - 12.0.1-4
|
||||||
- Fix cmake build dir
|
- Fix cmake build dir
|
||||||
|
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
Remove interposed definition of _r_debug
|
|
||||||
|
|
||||||
Previously there was a dynamic relocation against _r_debug in the loader which picked up the interposed definition,
|
|
||||||
but glibc now uses a direct internal hidden symbol reference and thus no longer updates the interposed object.
|
|
||||||
|
|
||||||
--- dyninst-12.0.1/dyninstAPI_RT/src/RTlinux.c
|
|
||||||
+++ dyninst-12.0.1/dyninstAPI_RT/src/RTlinux.c
|
|
||||||
@@ -404,7 +404,6 @@ void dyninstTrapHandler(int sig, siginfo_t *sg, ucontext_t *context)
|
|
||||||
#if defined(cap_binary_rewriter)
|
|
||||||
|
|
||||||
extern struct r_debug _r_debug;
|
|
||||||
-DLLEXPORT struct r_debug _r_debug __attribute__ ((weak));
|
|
||||||
|
|
||||||
/* Verify that the r_debug variable is visible */
|
|
||||||
void r_debugCheck() { assert(_r_debug.r_map); }
|
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (dyninst-12.0.1.tar.gz) = 7827d4fa84ed15773e191b36612a3eab4e4b5451b1c645d0899056b831d7fdaa5b2ee439287ef0755d68f7d3a7882139f7d79b4a318700a676c3f0fc687482ad
|
SHA512 (dyninst-12.1.0.tar.gz) = ec09b83f288afefd6a30a3253c91554d421305a43c2f2384435207dcabf523d5498d64873f876817c3108c3fc0a43fd4c48ce2c1ca873c73fb98a2d823446549
|
||||||
SHA512 (testsuite-12.0.0.tar.gz) = 7e39b0e1f1a7687abebcf44c59124855d4128ce8820b6a31efa987441c1d94b19a315b208a7ef56c57e5ca91e12d5388f2cd8298791500a98ffa4d3790507f27
|
SHA512 (testsuite-12.1.0.tar.gz) = 884a33c5b912249166acc0c52bd0ab02b578dcea2a24fbfa2abc7887b6a9c4f3a113934b96079653d60d9dba34c8870eff7d08388c906111a024ec92e629798a
|
||||||
|
Loading…
Reference in New Issue
Block a user