import dyninst-9.3.2-12.el8
This commit is contained in:
commit
a7dfbd857d
2
.dyninst.metadata
Normal file
2
.dyninst.metadata
Normal file
@ -0,0 +1,2 @@
|
||||
dbaf68ab57ab99d878cd87da3b5c7295e54d4c3f SOURCES/dyninst-9.3.2.tar.gz
|
||||
5463fcfe1a374b41c5b829d9eefbf0c050fdb63d SOURCES/testsuite-9.3.0.tar.gz
|
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
SOURCES/dyninst-9.3.2.tar.gz
|
||||
SOURCES/testsuite-9.3.0.tar.gz
|
29
SOURCES/Object-elf.patch
Normal file
29
SOURCES/Object-elf.patch
Normal file
@ -0,0 +1,29 @@
|
||||
# workaround for https://github.com/dyninst/dyninst/issues/396
|
||||
|
||||
--- ./dyninst-9.3.2/symtabAPI/src/Object-elf.C.sv 2017-09-27 21:43:18.399429243 -0400
|
||||
+++ ./dyninst-9.3.2/symtabAPI/src/Object-elf.C 2017-09-27 21:56:14.485125928 -0400
|
||||
@@ -1445,6 +1445,24 @@
|
||||
if (fbt_iter == -1) { // Create new relocation entry.
|
||||
relocationEntry re( next_plt_entry_addr, offset, targ_name,
|
||||
NULL, type );
|
||||
+ if (type == R_X86_64_IRELATIVE) {
|
||||
+ vector<Symbol *> funcs;
|
||||
+ dyn_hash_map<std::string, std::vector<Symbol *> >::iterator iter;
|
||||
+ // find the resolver function and use that as the
|
||||
+ // caller function symbol. The resolver has not run
|
||||
+ // so we don't know the ultimate destination.
|
||||
+ // Since the funcsByOffset map hasn't been setup yet
|
||||
+ // we cannot call associated_symtab->findFuncByEntryOffset
|
||||
+ for (iter = symbols_.begin(); iter != symbols_.end(); ++iter) {
|
||||
+ std::string name = iter->first;
|
||||
+ Symbol *sym = iter->second[0];
|
||||
+ if (sym->getOffset() == (Offset)addend) {
|
||||
+ // Use dynsym_list.push_back(sym) instead?
|
||||
+ re.addDynSym(sym);
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
re.setAddend(addend);
|
||||
re.setRegionType(rtype);
|
||||
if (dynsym_list.size() > 0)
|
12
SOURCES/addrtranslate-sysv.patch
Normal file
12
SOURCES/addrtranslate-sysv.patch
Normal file
@ -0,0 +1,12 @@
|
||||
# workaround for https://github.com/dyninst/dyninst/issues/406
|
||||
|
||||
--- dyninst-9.3.2/common/src/addrtranslate-sysv.C.sv 2017-10-03 21:32:23.608614189 -0400
|
||||
+++ dyninst-9.3.2/common/src/addrtranslate-sysv.C 2017-10-03 21:33:36.538642148 -0400
|
||||
@@ -800,6 +800,7 @@
|
||||
continue;
|
||||
}
|
||||
if (obj_name == "linux-vdso.so.1" ||
|
||||
+ obj_name == "linux-vdso64.so.1" ||
|
||||
obj_name == "linux-gate.so.1")
|
||||
{
|
||||
continue;
|
14
SOURCES/dyninst-9.3.2-gcc8.patch
Normal file
14
SOURCES/dyninst-9.3.2-gcc8.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C.me dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C
|
||||
--- dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C.me 2018-02-07 15:50:36.706363500 +0100
|
||||
+++ dyninst-9.3.2/dyninst-9.3.2/symtabAPI/src/emitElf.C 2018-02-07 16:30:28.173906877 +0100
|
||||
@@ -2512,8 +2512,8 @@ void emitElf<ElfTypes>::createDynamicSec
|
||||
|
||||
if (!object->hasReldyn() && !object->hasReladyn()) {
|
||||
if (object->getRelType() == Region::RT_REL) {
|
||||
- new_dynamic_entries.push_back(make_pair(DT_REL, 0));
|
||||
- new_dynamic_entries.push_back(make_pair(DT_RELSZ, 0));
|
||||
+ new_dynamic_entries.push_back(std::pair<long, long>(DT_REL, 0));
|
||||
+ new_dynamic_entries.push_back(std::pair<long, long>(DT_RELSZ, 0));
|
||||
|
||||
dynamicSecData[DT_REL].push_back(dynsecData + curpos);
|
||||
dynsecData[curpos].d_tag = DT_NULL;
|
23
SOURCES/dyninst-9.3.2-glibc-rpc.patch
Normal file
23
SOURCES/dyninst-9.3.2-glibc-rpc.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt.me dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt
|
||||
--- dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt.me 2018-02-07 15:25:38.925763122 +0100
|
||||
+++ dyninst-9.3.2/dyninst-9.3.2/CMakeLists.txt 2018-02-07 15:30:42.242099198 +0100
|
||||
@@ -19,6 +19,7 @@ include (${DYNINST_ROOT}/cmake/shared.cm
|
||||
configure_file(cmake/version.h.in common/h/version.h)
|
||||
include_directories(${PROJECT_BINARY_DIR})
|
||||
include_directories(${PROJECT_BINARY_DIR}/common/h)
|
||||
+include_directories("/usr/include/tirpc/")
|
||||
set (HEADER_DIRS common
|
||||
dataflowAPI
|
||||
dyninstAPI
|
||||
diff -up dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h.me dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h
|
||||
--- dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h.me 2018-02-07 15:06:45.961780668 +0100
|
||||
+++ dyninst-9.3.2/dyninst-9.3.2/common/src/linuxHeaders.h 2018-02-07 15:38:56.832278338 +0100
|
||||
@@ -281,7 +281,7 @@ inline bool_t P_xdr_string(XDR *x, char
|
||||
inline void P_xdrrec_create(XDR *x, const u_int send_sz, const u_int rec_sz,
|
||||
const caddr_t handle,
|
||||
xdr_rd_func read_r, xdr_wr_func write_f) {
|
||||
- xdrrec_create(x, send_sz, rec_sz, handle, (int(*)(char*, char*, int))read_r, (int(*)(char*, char*, int))write_f);}
|
||||
+ xdrrec_create(x, send_sz, rec_sz, handle, (int(*)(void*, void*, int))read_r, (int(*)(void*, void*, int))write_f);}
|
||||
inline bool_t P_xdrrec_endofrecord(XDR *x, int now) {
|
||||
return (xdrrec_endofrecord(x, now));}
|
||||
inline bool_t P_xdrrec_skiprecord(XDR *x) { return (xdrrec_skiprecord(x));}
|
11
SOURCES/testsuite-9.3.0-junit-nullptr.patch
Normal file
11
SOURCES/testsuite-9.3.0-junit-nullptr.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- testsuite-9.3.0/src/JUnitOutputDriver.cpp.nullptr 2016-12-19 14:55:38.000000000 -0800
|
||||
+++ testsuite-9.3.0/src/JUnitOutputDriver.cpp 2017-02-15 11:19:22.628056889 -0800
|
||||
@@ -35,7 +35,7 @@ void JUnitOutputDriver::startNewTest(std
|
||||
{
|
||||
std::stringstream suitename;
|
||||
suitename << last_group->modname;
|
||||
- if(last_group->mutatee != '\0') suitename << "." << last_group->mutatee;
|
||||
+ if(last_group->mutatee != nullptr) suitename << "." << last_group->mutatee;
|
||||
log(HUMAN, "<testsuite name=\"%s\" errors=\"%d\" skipped=\"%d\" tests=\"%d\" failures=\"%d\">\n",
|
||||
suitename.str().c_str(), group_errors, group_skips, group_tests, group_failures);
|
||||
log(HUMAN, group_output.str().c_str());
|
458
SPECS/dyninst.spec
Normal file
458
SPECS/dyninst.spec
Normal file
@ -0,0 +1,458 @@
|
||||
Summary: An API for Run-time Code Generation
|
||||
License: LGPLv2+
|
||||
Name: dyninst
|
||||
Group: Development/Libraries
|
||||
Release: 12%{?dist}
|
||||
URL: http://www.dyninst.org
|
||||
Version: 9.3.2
|
||||
# Dyninst only has full support for a few architectures.
|
||||
# It has some preliminary support for aarch64 and ppc64le,
|
||||
# but we're waiting for those to be feature-complete.
|
||||
ExclusiveArch: %{ix86} x86_64 ppc ppc64
|
||||
|
||||
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
|
||||
# Explicit version since it does not match the source version
|
||||
Source1: https://github.com/dyninst/testsuite/archive/v9.3.0/testsuite-9.3.0.tar.gz
|
||||
|
||||
Patch1: testsuite-9.3.0-junit-nullptr.patch
|
||||
Patch2: addrtranslate-sysv.patch
|
||||
Patch3: Object-elf.patch
|
||||
Patch4: dyninst-9.3.2-gcc8.patch
|
||||
Patch5: dyninst-9.3.2-glibc-rpc.patch
|
||||
|
||||
%global dyninst_base dyninst-%{version}
|
||||
# Explicit version since it does not match the source version
|
||||
%global testsuite_base testsuite-9.3.0
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: libdwarf-devel >= 20111030
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
BuildRequires: boost-devel
|
||||
BuildRequires: binutils-devel
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libtirpc-devel
|
||||
|
||||
# Extra requires just for the testsuite
|
||||
BuildRequires: gcc-gfortran glibc-static libstdc++-static nasm
|
||||
|
||||
# Testsuite files should not provide/require anything
|
||||
%{?filter_setup:
|
||||
%filter_provides_in %{_libdir}/dyninst/testsuite/
|
||||
%filter_requires_in %{_libdir}/dyninst/testsuite/
|
||||
%filter_setup
|
||||
}
|
||||
|
||||
%description
|
||||
|
||||
Dyninst is an Application Program Interface (API) to permit the insertion of
|
||||
code into a running program. The API also permits changing or removing
|
||||
subroutine calls from the application program. Run-time code changes are
|
||||
useful to support a variety of applications including debugging, performance
|
||||
monitoring, and to support composing applications out of existing packages.
|
||||
The goal of this API is to provide a machine independent interface to permit
|
||||
the creation of tools and applications that use run-time code patching.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for using the Dyninst API
|
||||
Group: Documentation
|
||||
%description doc
|
||||
dyninst-doc contains API documentation for the Dyninst libraries.
|
||||
|
||||
%package devel
|
||||
Summary: Header files for the compiling programs with Dyninst
|
||||
Group: Development/System
|
||||
Requires: dyninst = %{version}-%{release}
|
||||
Requires: boost-devel
|
||||
|
||||
%description devel
|
||||
dyninst-devel includes the C header files that specify the Dyninst user-space
|
||||
libraries and interfaces. This is required for rebuilding any program
|
||||
that uses Dyninst.
|
||||
|
||||
%package static
|
||||
Summary: Static libraries for the compiling programs with Dyninst
|
||||
Group: Development/System
|
||||
Requires: dyninst-devel = %{version}-%{release}
|
||||
%description static
|
||||
dyninst-static includes the static versions of the library files for
|
||||
the dyninst user-space libraries and interfaces.
|
||||
|
||||
%package testsuite
|
||||
Summary: Programs for testing Dyninst
|
||||
Group: Development/System
|
||||
Requires: dyninst = %{version}-%{release}
|
||||
Requires: dyninst-devel = %{version}-%{release}
|
||||
Requires: dyninst-static = %{version}-%{release}
|
||||
Requires: glibc-static
|
||||
%description testsuite
|
||||
dyninst-testsuite includes the test harness and target programs for
|
||||
making sure that dyninst works properly.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version} -c
|
||||
%setup -q -T -D -a 1
|
||||
|
||||
%patch1 -p0 -b.nullptr
|
||||
%patch2 -p0 -b.addrtrans
|
||||
%patch3 -p0 -b.objelf
|
||||
%patch4 -p1 -b.gcc8
|
||||
%patch5 -p1 -b.glibc-rpc
|
||||
|
||||
# cotire seems to cause non-deterministic gcc errors
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
||||
sed -i.cotire -e 's/USE_COTIRE true/USE_COTIRE false/' \
|
||||
%{dyninst_base}/cmake/shared.cmake
|
||||
|
||||
%build
|
||||
|
||||
cd %{dyninst_base}
|
||||
|
||||
%cmake \
|
||||
-DENABLE_STATIC_LIBS=1 \
|
||||
-DINSTALL_LIB_DIR:PATH=%{_libdir}/dyninst \
|
||||
-DINSTALL_INCLUDE_DIR:PATH=%{_includedir}/dyninst \
|
||||
-DINSTALL_CMAKE_DIR:PATH=%{_libdir}/cmake/Dyninst \
|
||||
-DCMAKE_BUILD_TYPE=None \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=YES
|
||||
%make_build
|
||||
|
||||
# Hack to install dyninst nearby, so the testsuite can use it
|
||||
make DESTDIR=../install install
|
||||
find ../install -name '*.cmake' -execdir \
|
||||
sed -i -e 's!%{_prefix}!../install&!' '{}' '+'
|
||||
|
||||
cd ../%{testsuite_base}
|
||||
%cmake \
|
||||
-DDyninst_DIR:PATH=$PWD/../install%{_libdir}/cmake/Dyninst \
|
||||
-DINSTALL_DIR:PATH=%{_libdir}/dyninst/testsuite \
|
||||
-DCMAKE_BUILD_TYPE:STRING=Debug \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=YES
|
||||
%make_build
|
||||
|
||||
%install
|
||||
|
||||
cd %{dyninst_base}
|
||||
%make_install
|
||||
|
||||
# It doesn't install docs the way we want, so remove them.
|
||||
# We'll just grab the pdfs later, directly from the build dir.
|
||||
rm -v %{buildroot}%{_docdir}/*-%{version}.pdf
|
||||
|
||||
cd ../%{testsuite_base}
|
||||
%make_install
|
||||
|
||||
mkdir -p %{buildroot}/etc/ld.so.conf.d
|
||||
echo "%{_libdir}/dyninst" > %{buildroot}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
||||
|
||||
# Ugly hack to mask testsuite files from debuginfo extraction. Running the
|
||||
# testsuite requires debuginfo, so extraction is useless. However, debuginfo
|
||||
# extraction is still nice for the main libraries, so we don't want to disable
|
||||
# it package-wide. The permissions are restored by attr(755,-,-) in files.
|
||||
find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
||||
-type f '!' -name '*.a' -execdir chmod 644 '{}' '+'
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%dir %{_libdir}/dyninst
|
||||
%{_libdir}/dyninst/*.so.*
|
||||
|
||||
%doc %{dyninst_base}/COPYRIGHT
|
||||
%doc %{dyninst_base}/LGPL
|
||||
|
||||
%config(noreplace) /etc/ld.so.conf.d/*
|
||||
|
||||
%files doc
|
||||
%doc %{dyninst_base}/dataflowAPI/doc/dataflowAPI.pdf
|
||||
%doc %{dyninst_base}/dynC_API/doc/dynC_API.pdf
|
||||
%doc %{dyninst_base}/dyninstAPI/doc/dyninstAPI.pdf
|
||||
%doc %{dyninst_base}/instructionAPI/doc/instructionAPI.pdf
|
||||
%doc %{dyninst_base}/parseAPI/doc/parseAPI.pdf
|
||||
%doc %{dyninst_base}/patchAPI/doc/patchAPI.pdf
|
||||
%doc %{dyninst_base}/proccontrol/doc/proccontrol.pdf
|
||||
%doc %{dyninst_base}/stackwalk/doc/stackwalk.pdf
|
||||
%doc %{dyninst_base}/symtabAPI/doc/symtabAPI.pdf
|
||||
|
||||
%files devel
|
||||
%{_includedir}/dyninst
|
||||
%{_libdir}/dyninst/*.so
|
||||
%{_libdir}/cmake/Dyninst
|
||||
|
||||
%files static
|
||||
%{_libdir}/dyninst/*.a
|
||||
|
||||
%files testsuite
|
||||
%{_bindir}/parseThat
|
||||
%dir %{_libdir}/dyninst/testsuite/
|
||||
# Restore the permissions that were hacked out above, during install.
|
||||
%attr(755,root,root) %{_libdir}/dyninst/testsuite/*[!a]
|
||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||
|
||||
%changelog
|
||||
* Wed May 16 2018 Frank Ch. Eigler <fche@redhat.com> - 9.3.2-12
|
||||
- Rebuild with newer boost.
|
||||
|
||||
* Wed Mar 07 2018 Adam Williamson <awilliam@redhat.com> - 9.3.2-11
|
||||
- Rebuild to fix GCC 8 mis-compilation
|
||||
See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
|
||||
|
||||
* Wed Feb 07 2018 Than Ngo <than@redhat.com> - - 9.3.2-10
|
||||
- fix FTBS with gcc8
|
||||
- fix for using libtirpc, Sun RPC Interfaces is removed in latest glibc
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 9.3.2-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Feb 05 2018 Stan Cox <scox@redhat.com> - 9.3.2-8
|
||||
- Rebuild for Boost 1.64
|
||||
|
||||
* Wed Oct 04 2017 Stan Cox <scox@redhat.com> - 9.3.2-7
|
||||
- Fix swbz22248, handle R_*_IRELATIV, swbz22004, ignore linux-vdso64.so.1
|
||||
|
||||
* Sun Aug 06 2017 Björn Esser <besser82@fedoraproject.org> - 9.3.2-6
|
||||
- Rebuilt for AutoReq cmake-filesystem
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 9.3.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 9.3.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Jul 20 2017 Kalev Lember <klember@redhat.com> - 9.3.2-3
|
||||
- Rebuilt for Boost 1.64
|
||||
|
||||
* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 9.3.2-2
|
||||
- Rebuild due to bug in RPM (RHBZ #1468476)
|
||||
|
||||
* Wed Jul 05 2017 Stan Cox <scox@redhat.com> - 9.3.2-1
|
||||
- Update to 9.3.2
|
||||
|
||||
* Mon Mar 06 2017 Stan Cox <scox@redhat.com> - 9.3.1-1
|
||||
- Update to 9.3.1
|
||||
|
||||
* Wed Feb 8 2017 William Cohen <wcohen@redhat.com> - 9.3.0-2
|
||||
- Rebuild for boost 1.63
|
||||
|
||||
* Mon Jan 09 2017 Josh Stone <jistone@redhat.com> - 9.3.0-1
|
||||
- Update to 9.3.0
|
||||
|
||||
* Tue Nov 22 2016 Josh Stone <jistone@redhat.com> - 9.2.0-5
|
||||
- Backport fixes for rhbz1373197, attach thread races.
|
||||
|
||||
* Wed Sep 14 2016 Josh Stone <jistone@redhat.com> - 9.2.0-4
|
||||
- Fix rhbz1373239, process attach without exe specified.
|
||||
|
||||
* Mon Aug 15 2016 Josh Stone <jistone@redhat.com> - 9.2.0-3
|
||||
- Revert aarch64 and ppc64le support until they're more complete.
|
||||
|
||||
* Fri Aug 12 2016 Peter Robinson <pbrobinson@fedoraproject.org> 9.2.0-2
|
||||
- aarch64 and ppc64le are now supported
|
||||
|
||||
* Thu Jun 30 2016 Josh Stone <jistone@redhat.com> - 9.2.0-1
|
||||
- Update to 9.2.0
|
||||
|
||||
* Tue Jun 21 2016 Josh Stone <jistone@redhat.com> - 9.1.0-5
|
||||
- Use static TLS for libdyninstAPI_RT.so
|
||||
|
||||
* Thu Mar 10 2016 William Cohen <wcohen@redhat.com> - 9.1.0-4
|
||||
- Export libdyninstAPI_RT_init_maxthreads (ref rhbz1315841)
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 9.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Sat Jan 23 2016 Orion Poplawski <orion@cora.nwra.com> - 9.1.0-2
|
||||
- Rebuild for boost 1.60
|
||||
|
||||
* Fri Dec 18 2015 Josh Stone <jistone@redhat.com> - 9.1.0-1
|
||||
- Update to 9.1.0
|
||||
|
||||
* Fri Sep 04 2015 Josh Stone <jistone@redhat.com> - 9.0.3-1
|
||||
- Update to 9.0.3
|
||||
|
||||
* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 8.2.1-9
|
||||
- Rebuilt for Boost 1.59
|
||||
|
||||
* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
|
||||
|
||||
* Thu Jul 23 2015 Josh Stone <jistone@redhat.com> - 8.2.1-7
|
||||
- Patch use of boost::bind for boost 1.58.
|
||||
|
||||
* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 8.2.1-6
|
||||
- rebuild for Boost 1.58
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Apr 17 2015 Frank Ch. Eigler <fche@redhat.com> - 8.2.1-4
|
||||
- Rebuild with gcc 5.0.1 for abitag-equipped cxx11 symbols.
|
||||
|
||||
* Sat Feb 14 2015 Frank Ch. Eigler <fche@redhat.com> - 8.2.1-3
|
||||
- Rebuild with gcc 5 for std::__cxx11::basic_string etc. ABI
|
||||
|
||||
* Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 8.2.1-2
|
||||
- Rebuild for boost 1.57.0
|
||||
|
||||
* Fri Oct 31 2014 Josh Stone <jistone@redhat.com> - 8.2.1-1
|
||||
- Update to point release 8.2.1.
|
||||
|
||||
* Wed Aug 20 2014 Josh Stone <jistone@redhat.com> - 8.2.0-1
|
||||
- rebase to 8.2.0, using upstream tag "v8.2.0.1"
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.2-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Mon Jul 07 2014 Josh Stone <jistone@redhat.com> - 8.1.2-10
|
||||
- Flip from ExcludeArch to ExclusiveArch (ref rhbz1113991)
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.2-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 8.1.2-8
|
||||
- Rebuild for boost 1.55.0
|
||||
|
||||
* Thu May 22 2014 Josh Stone <jistone@redhat.com> - 8.1.2-7
|
||||
- Rebuild for libdwarf.so.1
|
||||
|
||||
* Wed Dec 11 2013 Josh Stone <jistone@redhat.com> 8.1.2-6
|
||||
- Fix rhbz1040715 (testsuite g++ optimization)
|
||||
|
||||
* Tue Dec 03 2013 Josh Stone <jistone@redhat.com> 8.1.2-5
|
||||
- Fix rhbz1037048 (-Werror=format-security FTBFS)
|
||||
|
||||
* Mon Aug 05 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.2-4
|
||||
- Fix rhbz991889 (FTBFS).
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.1.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 8.1.2-2
|
||||
- Rebuild for boost 1.54.0
|
||||
|
||||
* Tue Jun 18 2013 Josh Stone <jistone@redhat.com> 8.1.2-1
|
||||
- Update to release 8.1.2.
|
||||
|
||||
* Fri Mar 15 2013 Josh Stone <jistone@redhat.com> 8.1.1-1
|
||||
- Update to release 8.1.1.
|
||||
- Drop the backported dyninst-test2_4-kill-init.patch.
|
||||
- Drop the now-upstreamed dyninst-unused_vars.patch.
|
||||
- Update other patches for context.
|
||||
- Patch the installed symlinks to be relative, not $(DEST) filled.
|
||||
|
||||
* Tue Feb 26 2013 Josh Stone <jistone@redhat.com> 8.0-7
|
||||
- testsuite: Require dyninst-devel for the libdyninstAPI_RT.so symlink
|
||||
|
||||
* Tue Feb 26 2013 Josh Stone <jistone@redhat.com> 8.0-6
|
||||
- Fix the testsuite path to include libtestlaunch.so
|
||||
|
||||
* Mon Feb 25 2013 Josh Stone <jistone@redhat.com> 8.0-5
|
||||
- Add a dyninst-testsuite package.
|
||||
- Patch test2_4 to protect against running as root.
|
||||
- Make dyninst-static require dyninst-devel.
|
||||
|
||||
* Thu Feb 14 2013 Josh Stone <jistone@redhat.com> 8.0-4
|
||||
- Patch make.config to ensure rpm build flags are not discarded.
|
||||
|
||||
* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 8.0-3
|
||||
- Rebuild for Boost-1.53.0
|
||||
|
||||
* Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 8.0-2
|
||||
- Rebuild for Boost-1.53.0
|
||||
|
||||
* Tue Nov 20 2012 Josh Stone <jistone@redhat.com>
|
||||
- Tweak the configure/make commands
|
||||
- Disable the testsuite via configure.
|
||||
- Set the private includedir and libdir via configure.
|
||||
- Set VERBOSE_COMPILATION for make.
|
||||
- Use DESTDIR for make install.
|
||||
|
||||
* Mon Nov 19 2012 Josh Stone <jistone@redhat.com> 8.0-1
|
||||
- Update to release 8.0.
|
||||
- Updated "files doc" to reflect renames.
|
||||
- Drop the unused BuildRequires libxml2-devel.
|
||||
- Drop the 7.99.x version-munging patch.
|
||||
|
||||
* Fri Nov 09 2012 Josh Stone <jistone@redhat.com> 7.99.2-0.29
|
||||
- Rebase to git e99d7070bbc39c76d6d528db530046c22681c17e
|
||||
|
||||
* Mon Oct 29 2012 Josh Stone <jistone@redhat.com> 7.99.2-0.28
|
||||
- Bump to 7.99.2 per abi-compliance-checker results
|
||||
|
||||
* Fri Oct 26 2012 Josh Stone <jistone@redhat.com> 7.99.1-0.27
|
||||
- Rebase to git dd8f40b7b4742ad97098613876efeef46d3d9e65
|
||||
- Use _smp_mflags to enable building in parallel.
|
||||
|
||||
* Wed Oct 03 2012 Josh Stone <jistone@redhat.com> 7.99.1-0.26
|
||||
- Rebase to git 557599ad7417610f179720ad88366c32a0557127
|
||||
|
||||
* Thu Sep 20 2012 Josh Stone <jistone@redhat.com> 7.99.1-0.25
|
||||
- Rebase on newer git tree.
|
||||
- Bump the fake version to 7.99.1 to account for ABI differences.
|
||||
- Enforce the minimum libdwarf version.
|
||||
- Drop the upstreamed R_PPC_NUM patch.
|
||||
|
||||
* Wed Aug 15 2012 Karsten Hopp <karsten@redhat.com> 7.99-0.24
|
||||
- check if R_PPC_NUM is defined before using it, similar to R_PPC64_NUM
|
||||
|
||||
* Mon Jul 30 2012 Josh Stone <jistone@redhat.com> 7.99-0.23
|
||||
- Rebase on newer git tree.
|
||||
- Update license files with upstream additions.
|
||||
- Split documentation into -doc subpackage.
|
||||
- Claim ownership of {_libdir}/dyninst.
|
||||
|
||||
* Fri Jul 27 2012 William Cohen <wcohen@redhat.com> - 7.99-0.22
|
||||
- Correct requires for dyninst-devel.
|
||||
|
||||
* Wed Jul 25 2012 Josh Stone <jistone@redhat.com> - 7.99-0.21
|
||||
- Rebase on newer git tree
|
||||
- Update context in dyninst-git.patch
|
||||
- Drop dyninst-delete_array.patch
|
||||
- Drop dyninst-common-makefile.patch
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.99-0.20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jul 16 2012 William Cohen <wcohen@redhat.com> - 7.99-0.19
|
||||
- Patch common/i386-unknown-linux2.4/Makefile to build.
|
||||
|
||||
* Fri Jul 13 2012 William Cohen <wcohen@redhat.com> - 7.99-0.18
|
||||
- Rebase on newer git tree the has a number of merges into it.
|
||||
- Adjust spec file to allow direct use of git patches
|
||||
- Fix to eliminate unused varables.
|
||||
- Proper delete for array.
|
||||
|
||||
* Thu Jun 28 2012 William Cohen <wcohen@redhat.com> - 7.99-0.17
|
||||
- Rebase on newer git repo.
|
||||
|
||||
* Thu Jun 28 2012 William Cohen <wcohen@redhat.com> - 7.99-0.16
|
||||
- Eliminate dynptr.h file use with rebase on newer git repo.
|
||||
|
||||
* Mon Jun 25 2012 William Cohen <wcohen@redhat.com> - 7.99-0.14
|
||||
- Rebase on newer git repo.
|
||||
|
||||
* Tue Jun 19 2012 William Cohen <wcohen@redhat.com> - 7.99-0.12
|
||||
- Fix static library and header file permissions.
|
||||
- Use sources from the dyninst git repositories.
|
||||
- Fix 32-bit library versioning for libdyninstAPI_RT_m32.so.
|
||||
|
||||
* Wed Jun 13 2012 William Cohen <wcohen@redhat.com> - 7.99-0.11
|
||||
- Fix library versioning.
|
||||
- Move .so links to dyninst-devel.
|
||||
- Remove unneded clean section.
|
||||
|
||||
* Fri May 11 2012 William Cohen <wcohen@redhat.com> - 7.0.1-0.9
|
||||
- Clean up Makefile rules.
|
||||
|
||||
* Sat May 5 2012 William Cohen <wcohen@redhat.com> - 7.0.1-0.8
|
||||
- Clean up spec file.
|
||||
|
||||
* Wed May 2 2012 William Cohen <wcohen@redhat.com> - 7.0.1-0.7
|
||||
- Use "make install" and do staged build.
|
||||
- Use rpm configure macro.
|
||||
|
||||
* Thu Mar 15 2012 William Cohen <wcohen@redhat.com> - 7.0.1-0.5
|
||||
- Nuke the bundled boost files and use the boost-devel rpm instead.
|
||||
|
||||
* Mon Mar 12 2012 William Cohen <wcohen@redhat.com> - 7.0.1-0.4
|
||||
- Initial submission of dyninst spec file.
|
Loading…
Reference in New Issue
Block a user