Rebase on newer git tree
- Update context in dyninst-git.patch - Drop dyninst-delete_array.patch - Drop dyninst-common-makefile.patch
This commit is contained in:
parent
c2c6c859ed
commit
92922641a6
@ -1,57 +0,0 @@
|
||||
diff --git a/common/i386-unknown-linux2.4/Makefile b/common/i386-unknown-linux2.4/Makefile
|
||||
index d92aedc..9663864 100644
|
||||
--- a/common/i386-unknown-linux2.4/Makefile
|
||||
+++ b/common/i386-unknown-linux2.4/Makefile
|
||||
@@ -4,14 +4,8 @@
|
||||
|
||||
# Define any symbols needed to invoke configuration changes in make.config
|
||||
|
||||
-#USES_SHM_SAMPLING = true
|
||||
-#USES_PAPI = true
|
||||
-DEBUG_FLAG = -g
|
||||
NO_IMPLICIT_TEMPLATES = true
|
||||
|
||||
-# For debugging.
|
||||
-#NO_OPT_FLAG = true
|
||||
-
|
||||
# Include standard make configuration stuff that applies to everything
|
||||
# in the paradyn tree.
|
||||
|
||||
@@ -24,35 +18,18 @@ SRCS = ../../common/src/linuxKludges.C \
|
||||
../../common/src/parseauxv.C \
|
||||
../../common/src/addrtranslate-sysv.C \
|
||||
../../common/src/addrtranslate-auxv.C \
|
||||
- ../../common/src/addrtranslate-linux.C \
|
||||
- ../../common/src/dwarfExpr.C
|
||||
-
|
||||
-#MYFLAGS += -DNO_MDL_PRINT
|
||||
-#MYFLAGS += -DLD_DEBUG
|
||||
-#MYFLAGS += -DATTACH_DETACH_DEBUG
|
||||
-#MYFLAGS += -DPTRACEDEBUG
|
||||
-#MYFLAGS += -DPTRACEDEBUG_EXCESSIVE
|
||||
-#MYFLAGS += -DPTRACEDEBUG_ALWAYS
|
||||
-#MYFLAGS += -DINST_TRAP_DEBUG
|
||||
-#MYFLAGS += -DSIGNAL_DEBUG
|
||||
-#MYFLAGS += -DASTDEBUG
|
||||
-#MYFLAGS += -DINFERIOR_RPC_DEBUG
|
||||
+ ../../common/src/addrtranslate-linux.C
|
||||
|
||||
CXXFLAGS += $(MYFLAGS)
|
||||
CFLAGS += $(MYFLAGS)
|
||||
TFLAGS += $(MYFLAGS)
|
||||
|
||||
-# Tradeoff: adding -g to TFLAGS aids gdb but uses gobs of disk space
|
||||
-#TFLAGS += -g
|
||||
-
|
||||
LIBS += -ldl
|
||||
|
||||
AS = /usr/bin/as
|
||||
|
||||
-
|
||||
# Add preprocessor and special link information for G++
|
||||
-G_PTHREAD = -pthread
|
||||
-G_PTHREAD_LD = -pthread
|
||||
+G_PTHREAD = -pthread
|
||||
|
||||
# Include the module-specific Makefile, which defines everything about
|
||||
# the module that is common across architectures.
|
@ -1,19 +0,0 @@
|
||||
commit d4d422b792f5621e5b08e4025bd3f2d447857c0a
|
||||
Author: William Cohen <wcohen@redhat.com>
|
||||
Date: Tue Jul 10 09:46:31 2012 -0400
|
||||
|
||||
Use proper kind of delete for array object.
|
||||
|
||||
diff --git a/dyninstAPI/src/BPatch_flowGraph.C b/dyninstAPI/src/BPatch_flowGraph.C
|
||||
index ea85413..638cfab 100644
|
||||
--- a/dyninstAPI/src/BPatch_flowGraph.C
|
||||
+++ b/dyninstAPI/src/BPatch_flowGraph.C
|
||||
@@ -369,7 +369,7 @@ BPatch_basicBlock* BPatch_flowGraph::findBlockByAddr(Address where)
|
||||
if (first <= last) {
|
||||
ret = blocks[idx];
|
||||
}
|
||||
- delete blocks;
|
||||
+ delete[] blocks;
|
||||
return ret;
|
||||
}
|
||||
|
@ -8,5 +8,5 @@ diff -up dyninst-7.99/dyninst/make.config.git dyninst-7.99/dyninst/make.config
|
||||
-RELEASE_NUM = 8.0
|
||||
+RELEASE_NUM = 7.99
|
||||
|
||||
# ***** EXTERNAL SOFTWARE CONFIGURATION *****
|
||||
|
||||
ifndef TO_CORE
|
||||
TO_CORE = ../..
|
||||
|
14
dyninst.spec
14
dyninst.spec
@ -4,7 +4,7 @@ Summary: An API for Run-time Code Generation
|
||||
License: LGPLv2+
|
||||
Name: dyninst
|
||||
Group: Development/Libraries
|
||||
Release: 0.20%{?dist}
|
||||
Release: 0.21%{?dist}
|
||||
URL: http://www.dyninst.org
|
||||
Version: %version
|
||||
Exclusiveos: linux
|
||||
@ -14,7 +14,7 @@ ExcludeArch: s390 s390x %{arm}
|
||||
# The source for this package was pulled from upstream's vcs. Use the
|
||||
# following commands to generate the tarball:
|
||||
# git clone http://git.dyninst.org/dyninst.git; cd dyninst
|
||||
# git archive --format=tar.gz --prefix=dyninst/ 96826d0b7cbec7deb1398019ecadea5cf756c9c7 > dyninst-7.99.tar.gz
|
||||
# git archive --format=tar.gz --prefix=dyninst/ 1d17e0266d82c53f6e80f5bc658d93803aedbc8c > dyninst-7.99.tar.gz
|
||||
# git clone http://git.dyninst.org/docs.git; cd docs
|
||||
# git archive --format=tar.gz fe92e5b28804791ecadc893e469bc2215dbc3066 > dyninst-docs-7.99.tar.gz
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
@ -22,8 +22,6 @@ Source1: %{name}-docs-%{version}.tar.gz
|
||||
# Change version number so official dyninst 8.0 will replace it
|
||||
Patch3: dyninst-git.patch
|
||||
Patch5: dyninst-unused_vars.patch
|
||||
Patch6: dyninst-delete_array.patch
|
||||
Patch7: dyninst-common-makefile.patch
|
||||
BuildRequires: libxml2-devel >= 2.7.8
|
||||
BuildRequires: libdwarf-devel
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
@ -64,8 +62,6 @@ the dyninst user-space libraries and interfaces.
|
||||
|
||||
pushd dyninst
|
||||
%patch5 -p1 -b .unused
|
||||
%patch6 -p1 -b .delete
|
||||
%patch7 -p1 -b .common
|
||||
popd
|
||||
|
||||
%build
|
||||
@ -130,6 +126,12 @@ chmod 644 %{buildroot}%{_libdir}/dyninst/*.a
|
||||
%{_libdir}/dyninst/*.a
|
||||
|
||||
%changelog
|
||||
* Wed Jul 25 2012 Josh Stone <jistone@redhat.com> - 7.99-0.21
|
||||
- Rebase on newer git tree
|
||||
- Update context in dyninst-git.patch
|
||||
- Drop dyninst-delete_array.patch
|
||||
- Drop dyninst-common-makefile.patch
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.99-0.20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user