Resolves: #1973038
This commit is contained in:
parent
9799cdda08
commit
7ee8500bd1
@ -3,8 +3,8 @@ Remove extraneous error messages of the form:
|
|||||||
err message: invalid DWARF
|
err message: invalid DWARF
|
||||||
which are repeated in some circumstances without adding useful context
|
which are repeated in some circumstances without adding useful context
|
||||||
|
|
||||||
--- dyninst-11.0.0/dyninst-11.0.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-11.0.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/dyninst-11.0.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
+++ dyninst-11.0.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
||||||
@@ -1858,1 +1858,1 @@
|
@@ -1858,1 +1858,1 @@
|
||||||
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
||||||
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
||||||
|
11
dyninst-11.0.0-rosebc.patch
Normal file
11
dyninst-11.0.0-rosebc.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
rhbz1973038
|
||||||
|
|
||||||
|
--- dyninst-11.0.0/dataflowAPI/src/RoseInsnFactory.C.orig 2021-06-09 15:54:21.753883619 -0400
|
||||||
|
+++ dyninst-11.0.0/dataflowAPI/src/RoseInsnFactory.C 2021-06-23 14:17:37.854933719 -0400
|
||||||
|
@@ -317,5 +317,5 @@
|
||||||
|
// It looks like the ROSE semantics code will infer the target from
|
||||||
|
// the bo field. So, what is passed in as the third operands does not matter
|
||||||
|
- if(branch_target) {
|
||||||
|
+ if(branch_target || iapi_opcode == power_op_bc) {
|
||||||
|
rose_operands->append_operand(new SgAsmDoubleWordValueExpression(branch_target));
|
||||||
|
} else if(power_op_bcctr == iapi_opcode) {
|
14
dyninst.spec
14
dyninst.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: An API for Run-time Code Generation
|
Summary: An API for Run-time Code Generation
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Name: dyninst
|
Name: dyninst
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 11.0.0
|
Version: 11.0.0
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
||||||
@ -12,6 +12,7 @@ Source1: https://github.com/dyninst/testsuite/archive/%{version}/testsuite-%{ver
|
|||||||
Patch1: testsuite-11.0.0-test12.patch
|
Patch1: testsuite-11.0.0-test12.patch
|
||||||
Patch2: testsuite-11.0.0-386.patch
|
Patch2: testsuite-11.0.0-386.patch
|
||||||
Patch3: dyninst-11.0.0-dwarf.patch
|
Patch3: dyninst-11.0.0-dwarf.patch
|
||||||
|
Patch4: dyninst-11.0.0-rosebc.patch
|
||||||
|
|
||||||
%global dyninst_base dyninst-%{version}
|
%global dyninst_base dyninst-%{version}
|
||||||
%global testsuite_base testsuite-%{version}
|
%global testsuite_base testsuite-%{version}
|
||||||
@ -76,9 +77,15 @@ making sure that dyninst works properly.
|
|||||||
%setup -q -n %{name}-%{version} -c
|
%setup -q -n %{name}-%{version} -c
|
||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
|
|
||||||
|
pushd %{testsuite_base}
|
||||||
%patch1 -p1 -b .test12
|
%patch1 -p1 -b .test12
|
||||||
%patch2 -p1 -b .386
|
%patch2 -p1 -b .386
|
||||||
|
popd
|
||||||
|
|
||||||
|
pushd %{dyninst_base}
|
||||||
%patch3 -p1 -b .dwarf
|
%patch3 -p1 -b .dwarf
|
||||||
|
%patch4 -p1 -b .rosebc
|
||||||
|
popd
|
||||||
|
|
||||||
# cotire seems to cause non-deterministic gcc errors
|
# cotire seems to cause non-deterministic gcc errors
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
||||||
@ -182,7 +189,10 @@ find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
|||||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Apr 30 2021 Stan Cox <scox@redhat.com> - 11.0.0
|
* Wed Jun 30 2021 Stan Cox <scox@redhat.com> - 11.0.1-2
|
||||||
|
- Related: rhbz1973038
|
||||||
|
|
||||||
|
* Fri Apr 30 2021 Stan Cox <scox@redhat.com> - 11.0.0-1
|
||||||
- Update to 11.0.0
|
- Update to 11.0.0
|
||||||
|
|
||||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 10.2.1-7
|
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 10.2.1-7
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
--- testsuite-11.0.0/CMakeLists.txt
|
||||||
+++ dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
+++ testsuite-11.0.0/CMakeLists.txt
|
||||||
@@ -111,7 +111,8 @@
|
@@ -111,7 +111,8 @@
|
||||||
if(UNIX)
|
if(UNIX)
|
||||||
enable_language(ASM-ATT)
|
enable_language(ASM-ATT)
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
--- testsuite-11.0.0/CMakeLists.txt
|
||||||
+++ dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
+++ testsuite-11.0.0/CMakeLists.txt
|
||||||
@@ -341,5 +341,10 @@
|
@@ -341,5 +341,10 @@
|
||||||
add_library(Test12 SHARED src/dyninst/libTest12.c)
|
add_library(Test12 SHARED src/dyninst/libTest12.c)
|
||||||
add_library(dyninstAPI_RT SHARED IMPORTED)
|
add_library(dyninstAPI_RT SHARED IMPORTED)
|
||||||
|
Loading…
Reference in New Issue
Block a user