rhbz2173030
This commit is contained in:
parent
511a74a18b
commit
765f434830
10
dyninst.spec
10
dyninst.spec
@ -2,7 +2,7 @@ Summary: An API for Run-time Code Generation
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Name: dyninst
|
Name: dyninst
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 12.2.0
|
Version: 12.2.0
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
||||||
@ -13,6 +13,7 @@ Source1: https://github.com/dyninst/testsuite/archive/%{__testsuite_version}/tes
|
|||||||
|
|
||||||
Patch1: dwarf-error.patch
|
Patch1: dwarf-error.patch
|
||||||
Patch2: cmdline.patch
|
Patch2: cmdline.patch
|
||||||
|
Patch3: rhbz2173030.patch
|
||||||
|
|
||||||
%global dyninst_base dyninst-%{version}
|
%global dyninst_base dyninst-%{version}
|
||||||
%global testsuite_base testsuite-%{__testsuite_version}
|
%global testsuite_base testsuite-%{__testsuite_version}
|
||||||
@ -88,6 +89,10 @@ pushd %{testsuite_base}
|
|||||||
%patch2 -p1 -b .cmdline
|
%patch2 -p1 -b .cmdline
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
pushd %{dyninst_base}
|
||||||
|
%patch3 -p1
|
||||||
|
popd
|
||||||
|
|
||||||
# cotire seems to cause non-deterministic gcc errors
|
# cotire seems to cause non-deterministic gcc errors
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
||||||
sed -i.cotire -e 's/USE_COTIRE true/USE_COTIRE false/' \
|
sed -i.cotire -e 's/USE_COTIRE true/USE_COTIRE false/' \
|
||||||
@ -188,6 +193,9 @@ find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
|||||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 23 2023 Frank Ch. Eigler <fche@redhat.com> - 12.2.0-4
|
||||||
|
- rhbz2173030: ftbfs with gcc 13
|
||||||
|
|
||||||
* Mon Feb 20 2023 Jonathan Wakely <jwakely@redhat.com> - 12.2.0-3
|
* Mon Feb 20 2023 Jonathan Wakely <jwakely@redhat.com> - 12.2.0-3
|
||||||
- Rebuilt for Boost 1.81
|
- Rebuilt for Boost 1.81
|
||||||
|
|
||||||
|
62
rhbz2173030.patch
Normal file
62
rhbz2173030.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
commit 358db4610e4919690d928797713bef3cf67ef61d
|
||||||
|
gpg: Signature made Wed 22 Feb 2023 10:51:01 AM EST
|
||||||
|
gpg: using RSA key 4AEE18F83AFDEB23
|
||||||
|
gpg: Good signature from "GitHub (web-flow commit signing) <noreply@github.com>" [full]
|
||||||
|
Author: kupsch <kupsch@cs.wisc.edu>
|
||||||
|
Date: Wed Feb 22 09:51:01 2023 -0600
|
||||||
|
|
||||||
|
explicitly include <array> (#1384)
|
||||||
|
|
||||||
|
- std::array is used in this file, but not included explicitly as
|
||||||
|
on many systems this header is implicitly included recursively
|
||||||
|
via another included file. On new versions of headers this may
|
||||||
|
no longer be the case, so explicitly include it.
|
||||||
|
|
||||||
|
diff --git a/instructionAPI/src/InstructionDecoder-aarch64.h b/instructionAPI/src/InstructionDecoder-aarch64.h
|
||||||
|
index 7994d0b1cc81..ae516232a68b 100644
|
||||||
|
--- a/instructionAPI/src/InstructionDecoder-aarch64.h
|
||||||
|
+++ b/instructionAPI/src/InstructionDecoder-aarch64.h
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
* Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <array>
|
||||||
|
#include "InstructionDecoderImpl.h"
|
||||||
|
#include <iostream>
|
||||||
|
#include "Immediate.h"
|
||||||
|
|
||||||
|
commit 0cd2b8b7858f48cd60e070010bb6600a1f44180e
|
||||||
|
gpg: Signature made Wed 22 Feb 2023 04:03:20 PM EST
|
||||||
|
gpg: using RSA key 4AEE18F83AFDEB23
|
||||||
|
gpg: Good signature from "GitHub (web-flow commit signing) <noreply@github.com>" [full]
|
||||||
|
Author: Tim Haines <thaines.astro@gmail.com>
|
||||||
|
Date: Wed Feb 22 15:03:20 2023 -0600
|
||||||
|
|
||||||
|
Add missing <array> includes (#1385)
|
||||||
|
|
||||||
|
These were showing up on ufront@rice.
|
||||||
|
|
||||||
|
diff --git a/instructionAPI/src/AMDGPU/cdna2/InstructionDecoder-amdgpu-cdna2.C b/instructionAPI/src/AMDGPU/cdna2/InstructionDecoder-amdgpu-cdna2.C
|
||||||
|
index e852f47437a1..f62b1f5463e8 100644
|
||||||
|
--- a/instructionAPI/src/AMDGPU/cdna2/InstructionDecoder-amdgpu-cdna2.C
|
||||||
|
+++ b/instructionAPI/src/AMDGPU/cdna2/InstructionDecoder-amdgpu-cdna2.C
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
|
||||||
|
#include "Ternary.h"
|
||||||
|
#include "InstructionDecoder-amdgpu-cdna2.h"
|
||||||
|
+#include <array>
|
||||||
|
|
||||||
|
namespace Dyninst {
|
||||||
|
namespace InstructionAPI {
|
||||||
|
diff --git a/instructionAPI/src/AMDGPU/vega/InstructionDecoder-amdgpu-vega.C b/instructionAPI/src/AMDGPU/vega/InstructionDecoder-amdgpu-vega.C
|
||||||
|
index 449255ae00b4..3093ece41002 100644
|
||||||
|
--- a/instructionAPI/src/AMDGPU/vega/InstructionDecoder-amdgpu-vega.C
|
||||||
|
+++ b/instructionAPI/src/AMDGPU/vega/InstructionDecoder-amdgpu-vega.C
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
|
||||||
|
#include "Ternary.h"
|
||||||
|
#include "InstructionDecoder-amdgpu-vega.h"
|
||||||
|
+#include <array>
|
||||||
|
|
||||||
|
namespace Dyninst {
|
||||||
|
namespace InstructionAPI {
|
Loading…
Reference in New Issue
Block a user