import dyninst-12.1.0-1.el8
This commit is contained in:
parent
6c3eb85a04
commit
68a1d9066a
@ -1,2 +1,2 @@
|
|||||||
f1e6143469813ef6ef96fddeee10fff8caa01c7d SOURCES/dyninst-11.0.0.tar.gz
|
cdbbb6ded567874409f9a6903f4a794e827c7436 SOURCES/dyninst-12.1.0.tar.gz
|
||||||
a8289d9f3106f6f069ae62ba0f601b4a58bf3c7e SOURCES/testsuite-11.0.0.tar.gz
|
16dd6c1cdb105dac43aaa78315b23b59c6f30d2f SOURCES/testsuite-12.1.0.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/dyninst-11.0.0.tar.gz
|
SOURCES/dyninst-12.1.0.tar.gz
|
||||||
SOURCES/testsuite-11.0.0.tar.gz
|
SOURCES/testsuite-12.1.0.tar.gz
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
rhbz1965455
|
|
||||||
|
|
||||||
commit 212576147 (refs/bisect/new)
|
|
||||||
Author: Xiaozhu Meng <mxz297@gmail.com>
|
|
||||||
Date: Wed May 26 11:26:28 2021 -0500
|
|
||||||
|
|
||||||
Skip parsing of blocks whose code buffer is null (#1033)
|
|
||||||
|
|
||||||
--- dyninst-11.0.0/parseAPI/src/Parser.C.orig
|
|
||||||
+++ dyninst-11.0.0/parseAPI/src/Parser.C
|
|
||||||
@@ -1703,6 +1703,14 @@ Parser::parse_frame_one_iteration(ParseFrame &frame, bool recursive) {
|
|
||||||
cur->region()->offset() + cur->region()->length() - curAddr;
|
|
||||||
const unsigned char* bufferBegin =
|
|
||||||
(const unsigned char *)(func->region()->getPtrToInstruction(curAddr));
|
|
||||||
+ if (bufferBegin == nullptr) {
|
|
||||||
+ // This can happen if jump table is over-approxiated.
|
|
||||||
+ // We ignore this block for now, and later the over-approximated block
|
|
||||||
+ // will be removed.
|
|
||||||
+ parsing_printf("\taddress %lx in a different region from the funcion entry at %lx, skip parsing\n", curAddr, func->addr());
|
|
||||||
+ continue;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
InstructionDecoder dec(bufferBegin,size,frame.codereg->getArch());
|
|
||||||
|
|
||||||
if (!ahPtr)
|
|
@ -3,8 +3,8 @@ Remove extraneous error messages of the form:
|
|||||||
err message: invalid DWARF
|
err message: invalid DWARF
|
||||||
which are repeated in some circumstances without adding useful context
|
which are repeated in some circumstances without adding useful context
|
||||||
|
|
||||||
--- dyninst-11.0.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-12.1.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
+++ dyninst-12.1.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
||||||
@@ -1858,1 +1858,1 @@
|
@@ -1858,1 +1858,1 @@
|
||||||
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
||||||
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
@ -1,12 +1,12 @@
|
|||||||
--- dyninst-11.0.0/cmake/Boost.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-12.1.0/cmake/Boost.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/cmake/Boost.cmake 2021-05-07 12:35:53.124203324 -0400
|
+++ dyninst-12.1.0/cmake/Boost.cmake 2021-05-07 12:35:53.124203324 -0400
|
||||||
@@ -53,3 +53,3 @@
|
@@ -53,3 +53,3 @@
|
||||||
# Need at least Boost-1.67 because of deprecated headers
|
# Need at least Boost-1.67 because of deprecated headers
|
||||||
-set(_boost_min_version 1.67.0)
|
-set(_boost_min_version 1.70.0)
|
||||||
+set(_boost_min_version 1.66.0)
|
+set(_boost_min_version 1.66.0)
|
||||||
|
|
||||||
--- dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-12.1.0/cmake/ThreadingBuildingBlocks.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake 2021-05-07 12:40:13.092183538 -0400
|
+++ dyninst-12.1.0/cmake/ThreadingBuildingBlocks.cmake 2021-05-07 12:40:13.092183538 -0400
|
||||||
@@ -52,3 +52,3 @@
|
@@ -52,3 +52,3 @@
|
||||||
else()
|
else()
|
||||||
- set(_tbb_min_version 2018.6)
|
- set(_tbb_min_version 2018.6)
|
@ -1,15 +0,0 @@
|
|||||||
--- testsuite-11.0.0/CMakeLists.txt
|
|
||||||
+++ testsuite-11.0.0/CMakeLists.txt
|
|
||||||
@@ -111,7 +111,8 @@
|
|
||||||
if(UNIX)
|
|
||||||
enable_language(ASM-ATT)
|
|
||||||
- if("${DYNINST_PLATFORM}" MATCHES "i386")
|
|
||||||
- enable_language(ASM_NASM)
|
|
||||||
- endif()
|
|
||||||
+# nasm/yasm are deprecated
|
|
||||||
+# if("${DYNINST_PLATFORM}" MATCHES "i386")
|
|
||||||
+# enable_language(ASM_NASM)
|
|
||||||
+# endif()
|
|
||||||
elseif(WIN32)
|
|
||||||
enable_language(ASM_MASM)
|
|
||||||
|
|
@ -1,14 +0,0 @@
|
|||||||
--- testsuite-11.0.0/CMakeLists.txt
|
|
||||||
+++ testsuite-11.0.0/CMakeLists.txt
|
|
||||||
@@ -341,5 +341,10 @@
|
|
||||||
add_library(Test12 SHARED src/dyninst/libTest12.c)
|
|
||||||
add_library(dyninstAPI_RT SHARED IMPORTED)
|
|
||||||
- set_target_properties(dyninstAPI_RT PROPERTIES IMPORTED_LOCATION "${Dyninst_DIR}/../../libdyninstAPI_RT.so")
|
|
||||||
+ set(_path_suffixes dyninst)
|
|
||||||
+ find_library(dyninstAPI_RT_LIBRARY
|
|
||||||
+ NAMES libdyninstAPI_RT.so
|
|
||||||
+ PATHS ${Dyninst_DIR}/../..
|
|
||||||
+ PATH_SUFFIXES ${_path_suffixes})
|
|
||||||
+ set_target_properties(dyninstAPI_RT PROPERTIES IMPORTED_LOCATION ${dyninstAPI_RT_LIBRARY})
|
|
||||||
target_link_libraries(Test12 dyninstAPI_RT)
|
|
||||||
install(TARGETS Test12
|
|
@ -2,22 +2,20 @@ Summary: An API for Run-time Code Generation
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Name: dyninst
|
Name: dyninst
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 11.0.0
|
Version: 12.1.0
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
||||||
|
|
||||||
|
%define __testsuite_version 12.1.0
|
||||||
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
|
Source0: https://github.com/dyninst/dyninst/archive/v%{version}/dyninst-%{version}.tar.gz
|
||||||
Source1: https://github.com/dyninst/testsuite/archive/%{version}/testsuite-%{version}.tar.gz
|
Source1: https://github.com/dyninst/testsuite/archive/%{__testsuite_version}/testsuite-%{__testsuite_version}.tar.gz
|
||||||
|
|
||||||
Patch1: testsuite-11.0.0-test12.patch
|
Patch1: dyninst-12.1.0-dwarf.patch
|
||||||
Patch2: testsuite-11.0.0-386.patch
|
Patch2: dyninst-12.1.0-tbb.patch
|
||||||
Patch3: dyninst-11.0.0-dwarf.patch
|
|
||||||
Patch4: dyninst-11.0.0-tbb.patch
|
|
||||||
Patch5: dyninst-11.0.0-nullbuf.patch
|
|
||||||
|
|
||||||
%global dyninst_base dyninst-%{version}
|
%global dyninst_base dyninst-%{version}
|
||||||
%global testsuite_base testsuite-%{version}
|
%global testsuite_base testsuite-%{__testsuite_version}
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: elfutils-devel
|
BuildRequires: elfutils-devel
|
||||||
@ -28,6 +26,8 @@ BuildRequires: binutils-devel
|
|||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: libtirpc-devel
|
BuildRequires: libtirpc-devel
|
||||||
BuildRequires: tbb tbb-devel
|
BuildRequires: tbb tbb-devel
|
||||||
|
BuildRequires: tex-latex
|
||||||
|
BuildRequires: make
|
||||||
|
|
||||||
# Extra requires just for the testsuite
|
# Extra requires just for the testsuite
|
||||||
BuildRequires: gcc-gfortran glibc-static libstdc++-static libxml2-devel
|
BuildRequires: gcc-gfortran glibc-static libstdc++-static libxml2-devel
|
||||||
@ -90,14 +90,11 @@ making sure that dyninst works properly.
|
|||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
|
|
||||||
pushd %{testsuite_base}
|
pushd %{testsuite_base}
|
||||||
%patch1 -p1 -b .test12
|
|
||||||
%patch2 -p1 -b .386
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd %{dyninst_base}
|
pushd %{dyninst_base}
|
||||||
%patch3 -p1 -b .dwarf
|
%patch1 -p1 -b .dwarf
|
||||||
%patch4 -p1 -b .tbb
|
%patch2 -p1 -b .tbb
|
||||||
%patch5 -p1 -b .nullbuf
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# cotire seems to cause non-deterministic gcc errors
|
# cotire seems to cause non-deterministic gcc errors
|
||||||
@ -127,35 +124,37 @@ export CFLAGS CXXFLAGS LDFLAGS
|
|||||||
-DCMAKE_BUILD_TYPE=None \
|
-DCMAKE_BUILD_TYPE=None \
|
||||||
-DCMAKE_SKIP_RPATH:BOOL=YES \
|
-DCMAKE_SKIP_RPATH:BOOL=YES \
|
||||||
.
|
.
|
||||||
%make_build
|
%cmake_build
|
||||||
|
|
||||||
# Hack to install dyninst nearby, so the testsuite can use it
|
# Hack to install dyninst nearby, so the testsuite can use it
|
||||||
make DESTDIR=../install install
|
DESTDIR="../install" %__cmake --install "%{__cmake_builddir}"
|
||||||
find ../install -name '*.cmake' -execdir \
|
find ../install -name '*.cmake' -execdir \
|
||||||
sed -i -e 's!%{_prefix}!../install&!' '{}' '+'
|
sed -i -e "s!%{_prefix}!$PWD/../install&!" '{}' '+'
|
||||||
# cmake mistakenly looks for libtbb.so in the dyninst install dir
|
# cmake mistakenly looks for libtbb.so in the dyninst install dir
|
||||||
sed -i '/libtbb.so/ s/".*usr/"\/usr/' $PWD/../install%{_libdir}/cmake/Dyninst/commonTargets.cmake
|
sed -i '/libtbb.so/ s/".*usr/"\/usr/' $PWD/../install%{_libdir}/cmake/Dyninst/commonTargets.cmake
|
||||||
|
|
||||||
cd ../%{testsuite_base}
|
cd ../%{testsuite_base}
|
||||||
|
# testsuite build sometimes encounters dependency issues with -jN
|
||||||
|
%define _smp_mflags -j1
|
||||||
%cmake \
|
%cmake \
|
||||||
-DDyninst_DIR:PATH=$PWD/../install%{_libdir}/cmake/Dyninst \
|
-DDyninst_DIR:PATH=$PWD/../install%{_libdir}/cmake/Dyninst \
|
||||||
-DINSTALL_DIR:PATH=%{_libdir}/dyninst/testsuite \
|
-DINSTALL_DIR:PATH=%{_libdir}/dyninst/testsuite \
|
||||||
-DCMAKE_BUILD_TYPE:STRING=Debug \
|
-DCMAKE_BUILD_TYPE:STRING=Debug \
|
||||||
-DCMAKE_SKIP_RPATH:BOOL=YES \
|
-DCMAKE_SKIP_RPATH:BOOL=YES \
|
||||||
.
|
.
|
||||||
%make_build
|
%cmake_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
|
||||||
cd %{dyninst_base}
|
cd %{dyninst_base}
|
||||||
%make_install
|
%cmake_install
|
||||||
|
|
||||||
# It doesn't install docs the way we want, so remove them.
|
# It doesn't install docs the way we want, so remove them.
|
||||||
# We'll just grab the pdfs later, directly from the build dir.
|
# We'll just grab the pdfs later, directly from the build dir.
|
||||||
rm -v %{buildroot}%{_docdir}/*-%{version}.pdf
|
rm -v %{buildroot}%{_docdir}/*-%{version}.pdf
|
||||||
|
|
||||||
cd ../%{testsuite_base}
|
cd ../%{testsuite_base}
|
||||||
%make_install
|
%cmake_install
|
||||||
|
|
||||||
mkdir -p %{buildroot}/etc/ld.so.conf.d
|
mkdir -p %{buildroot}/etc/ld.so.conf.d
|
||||||
echo "%{_libdir}/dyninst" > %{buildroot}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
echo "%{_libdir}/dyninst" > %{buildroot}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
|
||||||
@ -207,6 +206,9 @@ find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
|||||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 21 2022 Stan Cox <scox@redhat.com> - 12.1.0-1
|
||||||
|
- Update to 12.1.0
|
||||||
|
|
||||||
* Wed Jun 30 2021 Stan Cox <scox@redhat.com> - 11.0.0-3
|
* Wed Jun 30 2021 Stan Cox <scox@redhat.com> - 11.0.0-3
|
||||||
- Related: rhbz1965455
|
- Related: rhbz1965455
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user