Update to release 8.1.2.
This commit is contained in:
parent
5c60460cc0
commit
55f25f6c6e
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/dyninst-docs-8.0.tar.gz
|
/dyninst-docs-8.0.tar.gz
|
||||||
/dyninst-8.1.1.tar.gz
|
/dyninst-8.1.1.tar.gz
|
||||||
/dyninst-docs-8.1.1.tar.gz
|
/dyninst-docs-8.1.1.tar.gz
|
||||||
|
/dyninst-8.1.2.tar.gz
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
commit 6401cf3b040bee82a3d1146519aaaf3123b169bb
|
|
||||||
Author: Andrew Bernat <bernat@cs.wisc.edu>
|
|
||||||
Date: Thu Mar 14 19:30:52 2013 -0500
|
|
||||||
|
|
||||||
Symlink path fix as suggested by Josh Stone
|
|
||||||
|
|
||||||
diff --git a/make.library.tmpl b/make.library.tmpl
|
|
||||||
index fb2dce4..61f7651 100644
|
|
||||||
--- a/make.library.tmpl
|
|
||||||
+++ b/make.library.tmpl
|
|
||||||
@@ -153,10 +153,10 @@ $(DEST)/$(TARGET).$(RELEASE_NUM): $(TARGET).$(RELEASE_NUM) $(TARGET)
|
|
||||||
ifndef STATIC_LIBRARY
|
|
||||||
$(DEST)/$(TARGET).$(SONAME_NUM): $(DEST)/$(TARGET).$(RELEASE_NUM)
|
|
||||||
@echo Making symlink $(TARGET).$(RELEASE_NUM) to $(DEST)/$(TARGET).$(SONAME_NUM)
|
|
||||||
- $(HIDE_COMP)-$(LN) -f $(DEST)/$(TARGET).$(RELEASE_NUM) $(DEST)/$(TARGET).$(SONAME_NUM)
|
|
||||||
+ $(HIDE_COMP)-$(LN) -f $(TARGET).$(RELEASE_NUM) $(DEST)/$(TARGET).$(SONAME_NUM)
|
|
||||||
$(DEST)/$(TARGET): $(DEST)/$(TARGET).$(SONAME_NUM)
|
|
||||||
@echo Making symlink $(TARGET).$(SONAME_NUM) to $(DEST)/$(TARGET)
|
|
||||||
- $(HIDE_COMP)-$(LN) -f $(DEST)/$(TARGET).$(SONAME_NUM) $(DEST)/$(TARGET)
|
|
||||||
+ $(HIDE_COMP)-$(LN) -f $(TARGET).$(SONAME_NUM) $(DEST)/$(TARGET)
|
|
||||||
else
|
|
||||||
$(DEST)/$(TARGET): $(TARGET)
|
|
||||||
@echo Installing $(TARGET) to $(DEST)/$(TARGET)
|
|
13
dyninst.spec
13
dyninst.spec
@ -4,7 +4,7 @@ Name: dyninst
|
|||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 8.1.1
|
Version: 8.1.2
|
||||||
Exclusiveos: linux
|
Exclusiveos: linux
|
||||||
#Right now dyninst does not know about the following architectures
|
#Right now dyninst does not know about the following architectures
|
||||||
ExcludeArch: s390 s390x %{arm}
|
ExcludeArch: s390 s390x %{arm}
|
||||||
@ -12,17 +12,16 @@ ExcludeArch: s390 s390x %{arm}
|
|||||||
# The source for this package was pulled from upstream's vcs. Use the
|
# The source for this package was pulled from upstream's vcs. Use the
|
||||||
# following commands to generate the tarball:
|
# following commands to generate the tarball:
|
||||||
# git clone http://git.dyninst.org/dyninst.git; cd dyninst
|
# git clone http://git.dyninst.org/dyninst.git; cd dyninst
|
||||||
# git archive --format=tar.gz --prefix=dyninst/ v8.1.1 > dyninst-8.1.1.tar.gz
|
# git archive --format=tar.gz --prefix=dyninst/ v8.1.2 > dyninst-8.1.2.tar.gz
|
||||||
# git clone http://git.dyninst.org/docs.git; cd docs
|
# git clone http://git.dyninst.org/docs.git; cd docs
|
||||||
# git archive --format=tar.gz v8.1.1 > dyninst-docs-8.1.1.tar.gz
|
# git archive --format=tar.gz v8.1.1 > dyninst-docs-8.1.1.tar.gz
|
||||||
# Verify the commit ids with:
|
# Verify the commit ids with:
|
||||||
# gunzip -c dyninst-8.1.1.tar.gz | git get-tar-commit-id
|
# gunzip -c dyninst-8.1.2.tar.gz | git get-tar-commit-id
|
||||||
# gunzip -c dyninst-docs-8.1.1.tar.gz | git get-tar-commit-id
|
# gunzip -c dyninst-docs-8.1.1.tar.gz | git get-tar-commit-id
|
||||||
Source0: %{name}-%{version}.tar.gz
|
Source0: %{name}-%{version}.tar.gz
|
||||||
Source1: %{name}-docs-%{version}.tar.gz
|
Source1: %{name}-docs-8.1.1.tar.gz
|
||||||
Patch1: dyninst-rpm-build-flags.patch
|
Patch1: dyninst-rpm-build-flags.patch
|
||||||
Patch2: dyninst-install-testsuite.patch
|
Patch2: dyninst-install-testsuite.patch
|
||||||
Patch3: dyninst-relative-symlinks.patch
|
|
||||||
BuildRequires: libdwarf-devel >= 20111030
|
BuildRequires: libdwarf-devel >= 20111030
|
||||||
BuildRequires: elfutils-libelf-devel
|
BuildRequires: elfutils-libelf-devel
|
||||||
BuildRequires: boost-devel
|
BuildRequires: boost-devel
|
||||||
@ -86,7 +85,6 @@ making sure that dyninst works properly.
|
|||||||
pushd dyninst
|
pushd dyninst
|
||||||
%patch1 -p1 -b .buildflags
|
%patch1 -p1 -b .buildflags
|
||||||
%patch2 -p1 -b .testsuite
|
%patch2 -p1 -b .testsuite
|
||||||
%patch3 -p1 -b .symlinks
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -156,6 +154,9 @@ chmod 644 %{buildroot}%{_libdir}/dyninst/testsuite/*
|
|||||||
%attr(755,root,root) %{_libdir}/dyninst/testsuite/*
|
%attr(755,root,root) %{_libdir}/dyninst/testsuite/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 18 2013 Josh Stone <jistone@redhat.com> 8.1.2-1
|
||||||
|
- Update to release 8.1.2.
|
||||||
|
|
||||||
* Fri Mar 15 2013 Josh Stone <jistone@redhat.com> 8.1.1-1
|
* Fri Mar 15 2013 Josh Stone <jistone@redhat.com> 8.1.1-1
|
||||||
- Update to release 8.1.1.
|
- Update to release 8.1.1.
|
||||||
- Drop the backported dyninst-test2_4-kill-init.patch.
|
- Drop the backported dyninst-test2_4-kill-init.patch.
|
||||||
|
Loading…
Reference in New Issue
Block a user