import dyninst-11.0.0-3.el8
This commit is contained in:
parent
dd82038851
commit
1d1e216f70
@ -3,8 +3,8 @@ Remove extraneous error messages of the form:
|
|||||||
err message: invalid DWARF
|
err message: invalid DWARF
|
||||||
which are repeated in some circumstances without adding useful context
|
which are repeated in some circumstances without adding useful context
|
||||||
|
|
||||||
--- dyninst-11.0.0/dyninst-11.0.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-11.0.0/symtabAPI/src/dwarfWalker.C.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/dyninst-11.0.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
+++ dyninst-11.0.0/symtabAPI/src/dwarfWalker.C 2021-04-27 12:48:55.643978425 -0400
|
||||||
@@ -1858,1 +1858,1 @@
|
@@ -1858,1 +1858,1 @@
|
||||||
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
- cerr << "err message: " << dwarf_errmsg(dwarf_errno()) << endl;
|
||||||
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
+ dwarf_printf("(0x%lx) Error while decoding location: %s\n", id(), dwarf_errmsg(dwarf_errno()));
|
||||||
|
25
SOURCES/dyninst-11.0.0-nullbuf.patch
Normal file
25
SOURCES/dyninst-11.0.0-nullbuf.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
rhbz1965455
|
||||||
|
|
||||||
|
commit 212576147 (refs/bisect/new)
|
||||||
|
Author: Xiaozhu Meng <mxz297@gmail.com>
|
||||||
|
Date: Wed May 26 11:26:28 2021 -0500
|
||||||
|
|
||||||
|
Skip parsing of blocks whose code buffer is null (#1033)
|
||||||
|
|
||||||
|
--- dyninst-11.0.0/parseAPI/src/Parser.C.orig
|
||||||
|
+++ dyninst-11.0.0/parseAPI/src/Parser.C
|
||||||
|
@@ -1703,6 +1703,14 @@ Parser::parse_frame_one_iteration(ParseFrame &frame, bool recursive) {
|
||||||
|
cur->region()->offset() + cur->region()->length() - curAddr;
|
||||||
|
const unsigned char* bufferBegin =
|
||||||
|
(const unsigned char *)(func->region()->getPtrToInstruction(curAddr));
|
||||||
|
+ if (bufferBegin == nullptr) {
|
||||||
|
+ // This can happen if jump table is over-approxiated.
|
||||||
|
+ // We ignore this block for now, and later the over-approximated block
|
||||||
|
+ // will be removed.
|
||||||
|
+ parsing_printf("\taddress %lx in a different region from the funcion entry at %lx, skip parsing\n", curAddr, func->addr());
|
||||||
|
+ continue;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
InstructionDecoder dec(bufferBegin,size,frame.codereg->getArch());
|
||||||
|
|
||||||
|
if (!ahPtr)
|
@ -1,12 +1,12 @@
|
|||||||
--- dyninst-11.0.0/dyninst-11.0.0/cmake/Boost.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-11.0.0/cmake/Boost.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/dyninst-11.0.0/cmake/Boost.cmake 2021-05-07 12:35:53.124203324 -0400
|
+++ dyninst-11.0.0/cmake/Boost.cmake 2021-05-07 12:35:53.124203324 -0400
|
||||||
@@ -53,3 +53,3 @@
|
@@ -53,3 +53,3 @@
|
||||||
# Need at least Boost-1.67 because of deprecated headers
|
# Need at least Boost-1.67 because of deprecated headers
|
||||||
-set(_boost_min_version 1.67.0)
|
-set(_boost_min_version 1.67.0)
|
||||||
+set(_boost_min_version 1.66.0)
|
+set(_boost_min_version 1.66.0)
|
||||||
|
|
||||||
--- dyninst-11.0.0/dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
--- dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake.orig 2021-04-08 16:48:12.000000000 -0400
|
||||||
+++ dyninst-11.0.0/dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake 2021-05-07 12:40:13.092183538 -0400
|
+++ dyninst-11.0.0/cmake/ThreadingBuildingBlocks.cmake 2021-05-07 12:40:13.092183538 -0400
|
||||||
@@ -52,3 +52,3 @@
|
@@ -52,3 +52,3 @@
|
||||||
else()
|
else()
|
||||||
- set(_tbb_min_version 2018.6)
|
- set(_tbb_min_version 2018.6)
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
--- testsuite-11.0.0/CMakeLists.txt
|
||||||
+++ dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
+++ testsuite-11.0.0/CMakeLists.txt
|
||||||
@@ -111,7 +111,8 @@
|
@@ -111,7 +111,8 @@
|
||||||
if(UNIX)
|
if(UNIX)
|
||||||
enable_language(ASM-ATT)
|
enable_language(ASM-ATT)
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
--- testsuite-11.0.0/CMakeLists.txt
|
||||||
+++ dyninst-11.0.0/testsuite-11.0.0/CMakeLists.txt
|
+++ testsuite-11.0.0/CMakeLists.txt
|
||||||
@@ -341,5 +341,10 @@
|
@@ -341,5 +341,10 @@
|
||||||
add_library(Test12 SHARED src/dyninst/libTest12.c)
|
add_library(Test12 SHARED src/dyninst/libTest12.c)
|
||||||
add_library(dyninstAPI_RT SHARED IMPORTED)
|
add_library(dyninstAPI_RT SHARED IMPORTED)
|
||||||
|
@ -2,7 +2,7 @@ Summary: An API for Run-time Code Generation
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Name: dyninst
|
Name: dyninst
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Release: 1%{?dist}
|
Release: 3%{?dist}
|
||||||
URL: http://www.dyninst.org
|
URL: http://www.dyninst.org
|
||||||
Version: 11.0.0
|
Version: 11.0.0
|
||||||
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
ExclusiveArch: %{ix86} x86_64 ppc64le aarch64
|
||||||
@ -14,6 +14,7 @@ Patch1: testsuite-11.0.0-test12.patch
|
|||||||
Patch2: testsuite-11.0.0-386.patch
|
Patch2: testsuite-11.0.0-386.patch
|
||||||
Patch3: dyninst-11.0.0-dwarf.patch
|
Patch3: dyninst-11.0.0-dwarf.patch
|
||||||
Patch4: dyninst-11.0.0-tbb.patch
|
Patch4: dyninst-11.0.0-tbb.patch
|
||||||
|
Patch5: dyninst-11.0.0-nullbuf.patch
|
||||||
|
|
||||||
%global dyninst_base dyninst-%{version}
|
%global dyninst_base dyninst-%{version}
|
||||||
%global testsuite_base testsuite-%{version}
|
%global testsuite_base testsuite-%{version}
|
||||||
@ -88,10 +89,16 @@ making sure that dyninst works properly.
|
|||||||
%setup -q -n %{name}-%{version} -c
|
%setup -q -n %{name}-%{version} -c
|
||||||
%setup -q -T -D -a 1
|
%setup -q -T -D -a 1
|
||||||
|
|
||||||
|
pushd %{testsuite_base}
|
||||||
%patch1 -p1 -b .test12
|
%patch1 -p1 -b .test12
|
||||||
%patch2 -p1 -b .386
|
%patch2 -p1 -b .386
|
||||||
|
popd
|
||||||
|
|
||||||
|
pushd %{dyninst_base}
|
||||||
%patch3 -p1 -b .dwarf
|
%patch3 -p1 -b .dwarf
|
||||||
%patch4 -p1 -b .tbb
|
%patch4 -p1 -b .tbb
|
||||||
|
%patch5 -p1 -b .nullbuf
|
||||||
|
popd
|
||||||
|
|
||||||
# cotire seems to cause non-deterministic gcc errors
|
# cotire seems to cause non-deterministic gcc errors
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1420551
|
||||||
@ -200,7 +207,13 @@ find %{buildroot}%{_libdir}/dyninst/testsuite/ \
|
|||||||
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
%attr(644,root,root) %{_libdir}/dyninst/testsuite/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Apr 30 2021 Stan Cox <scox@redhat.com> - 11.0.0
|
* Wed Jun 30 2021 Stan Cox <scox@redhat.com> - 11.0.0-3
|
||||||
|
- Related: rhbz1965455
|
||||||
|
|
||||||
|
* Mon Jun 28 2021 Stan Cox <scox@redhat.com> - 11.0.0-2
|
||||||
|
- Related: rhbz1965455, rhbz1965501
|
||||||
|
|
||||||
|
* Fri Apr 30 2021 Stan Cox <scox@redhat.com> - 11.0.0-1
|
||||||
- Update to 11.0.0
|
- Update to 11.0.0
|
||||||
|
|
||||||
* Fri Nov 06 2020 Stan Cox <scox@redhat.com> - 10.2.1-2
|
* Fri Nov 06 2020 Stan Cox <scox@redhat.com> - 10.2.1-2
|
||||||
|
Loading…
Reference in New Issue
Block a user