Patch common/i386-unknown-linux2.4/Makefile so dyninst builds on i386.
This commit is contained in:
parent
221ead6cbd
commit
09d6a6d42b
57
dyninst-common-makefile.patch
Normal file
57
dyninst-common-makefile.patch
Normal file
@ -0,0 +1,57 @@
|
||||
diff --git a/common/i386-unknown-linux2.4/Makefile b/common/i386-unknown-linux2.4/Makefile
|
||||
index d92aedc..9663864 100644
|
||||
--- a/common/i386-unknown-linux2.4/Makefile
|
||||
+++ b/common/i386-unknown-linux2.4/Makefile
|
||||
@@ -4,14 +4,8 @@
|
||||
|
||||
# Define any symbols needed to invoke configuration changes in make.config
|
||||
|
||||
-#USES_SHM_SAMPLING = true
|
||||
-#USES_PAPI = true
|
||||
-DEBUG_FLAG = -g
|
||||
NO_IMPLICIT_TEMPLATES = true
|
||||
|
||||
-# For debugging.
|
||||
-#NO_OPT_FLAG = true
|
||||
-
|
||||
# Include standard make configuration stuff that applies to everything
|
||||
# in the paradyn tree.
|
||||
|
||||
@@ -24,35 +18,18 @@ SRCS = ../../common/src/linuxKludges.C \
|
||||
../../common/src/parseauxv.C \
|
||||
../../common/src/addrtranslate-sysv.C \
|
||||
../../common/src/addrtranslate-auxv.C \
|
||||
- ../../common/src/addrtranslate-linux.C \
|
||||
- ../../common/src/dwarfExpr.C
|
||||
-
|
||||
-#MYFLAGS += -DNO_MDL_PRINT
|
||||
-#MYFLAGS += -DLD_DEBUG
|
||||
-#MYFLAGS += -DATTACH_DETACH_DEBUG
|
||||
-#MYFLAGS += -DPTRACEDEBUG
|
||||
-#MYFLAGS += -DPTRACEDEBUG_EXCESSIVE
|
||||
-#MYFLAGS += -DPTRACEDEBUG_ALWAYS
|
||||
-#MYFLAGS += -DINST_TRAP_DEBUG
|
||||
-#MYFLAGS += -DSIGNAL_DEBUG
|
||||
-#MYFLAGS += -DASTDEBUG
|
||||
-#MYFLAGS += -DINFERIOR_RPC_DEBUG
|
||||
+ ../../common/src/addrtranslate-linux.C
|
||||
|
||||
CXXFLAGS += $(MYFLAGS)
|
||||
CFLAGS += $(MYFLAGS)
|
||||
TFLAGS += $(MYFLAGS)
|
||||
|
||||
-# Tradeoff: adding -g to TFLAGS aids gdb but uses gobs of disk space
|
||||
-#TFLAGS += -g
|
||||
-
|
||||
LIBS += -ldl
|
||||
|
||||
AS = /usr/bin/as
|
||||
|
||||
-
|
||||
# Add preprocessor and special link information for G++
|
||||
-G_PTHREAD = -pthread
|
||||
-G_PTHREAD_LD = -pthread
|
||||
+G_PTHREAD = -pthread
|
||||
|
||||
# Include the module-specific Makefile, which defines everything about
|
||||
# the module that is common across architectures.
|
@ -4,7 +4,7 @@ Summary: An API for Run-time Code Generation
|
||||
License: LGPLv2+
|
||||
Name: dyninst
|
||||
Group: Development/Libraries
|
||||
Release: 0.18%{?dist}
|
||||
Release: 0.19%{?dist}
|
||||
URL: http://www.dyninst.org
|
||||
Version: %version
|
||||
Exclusiveos: linux
|
||||
@ -23,6 +23,7 @@ Source1: %{name}-docs-%{version}.tar.gz
|
||||
Patch3: dyninst-git.patch
|
||||
Patch5: dyninst-unused_vars.patch
|
||||
Patch6: dyninst-delete_array.patch
|
||||
Patch7: dyninst-common-makefile.patch
|
||||
BuildRequires: libxml2-devel >= 2.7.8
|
||||
BuildRequires: libdwarf-devel
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
@ -64,6 +65,7 @@ the dyninst user-space libraries and interfaces.
|
||||
pushd dyninst
|
||||
%patch5 -p1 -b .unused
|
||||
%patch6 -p1 -b .delete
|
||||
%patch7 -p1 -b .common
|
||||
popd
|
||||
|
||||
%build
|
||||
@ -128,6 +130,9 @@ chmod 644 %{buildroot}%{_libdir}/dyninst/*.a
|
||||
%{_libdir}/dyninst/*.a
|
||||
|
||||
%changelog
|
||||
* Mon Jul 16 2012 William Cohen <wcohen@redhat.com> - 7.99-0.19
|
||||
- Patch common/i386-unknown-linux2.4/Makefile to build.
|
||||
|
||||
* Fri Jul 13 2012 William Cohen <wcohen@redhat.com> - 7.99-0.18
|
||||
- Rebase on newer git tree the has a number of merges into it.
|
||||
- Adjust spec file to allow direct use of git patches
|
||||
|
Loading…
Reference in New Issue
Block a user