0.14-6 - Add dwz-0.14-gdb-add-index.patch
This commit is contained in:
parent
422692be8a
commit
7572832259
26
dwz-0.14-gdb-add-index.patch
Normal file
26
dwz-0.14-gdb-add-index.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
commit 5cb60631fad2827d5d337fce0c1cd03c894d6f8c
|
||||||
|
Author: Mark Wielaard <mark@klomp.org>
|
||||||
|
Date: Sat Jul 2 00:57:38 2022 +0200
|
||||||
|
|
||||||
|
Redirect stder in gdb-add-index.sh test
|
||||||
|
|
||||||
|
gdb-add-index might produce an error message on stderr when trying to
|
||||||
|
disable debuginfod support. Any message to stderr makes the testcase
|
||||||
|
fail. This looks like a gdb bug:
|
||||||
|
https://sourceware.org/bugzilla/show_bug.cgi?id=29316
|
||||||
|
But it is easy to workaround by redirecting stderr to stdout.
|
||||||
|
|
||||||
|
diff --git a/testsuite/dwz.tests/gdb-add-index.sh b/testsuite/dwz.tests/gdb-add-index.sh
|
||||||
|
index 5a91b23..3095efb 100644
|
||||||
|
--- a/testsuite/dwz.tests/gdb-add-index.sh
|
||||||
|
+++ b/testsuite/dwz.tests/gdb-add-index.sh
|
||||||
|
@@ -1,6 +1,8 @@
|
||||||
|
cp $execs/hello 1
|
||||||
|
|
||||||
|
-gdb-add-index 1
|
||||||
|
+# Redirect gdb-add-index stderr to stdout.
|
||||||
|
+# https://sourceware.org/bugzilla/show_bug.cgi?id=29316
|
||||||
|
+gdb-add-index 1 2>&1
|
||||||
|
|
||||||
|
readelf -S 1 | grep -q '\.gdb_index'
|
||||||
|
|
6
dwz.spec
6
dwz.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: DWARF optimization and duplicate removal tool
|
Summary: DWARF optimization and duplicate removal tool
|
||||||
Name: dwz
|
Name: dwz
|
||||||
Version: 0.14
|
Version: 0.14
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: GPLv2+ and GPLv3+
|
License: GPLv2+ and GPLv3+
|
||||||
Source: %{name}-0.14.tar.xz
|
Source: %{name}-0.14.tar.xz
|
||||||
BuildRequires: gcc, gcc-c++, gdb, elfutils-libelf-devel, dejagnu
|
BuildRequires: gcc, gcc-c++, gdb, elfutils-libelf-devel, dejagnu
|
||||||
@ -10,6 +10,7 @@ BuildRequires: make elfutils
|
|||||||
# Patches
|
# Patches
|
||||||
Patch1: dwz-0.14-binutils-Wn.patch
|
Patch1: dwz-0.14-binutils-Wn.patch
|
||||||
Patch2: dwz-0.14-binutils-readelf-alt.patch
|
Patch2: dwz-0.14-binutils-readelf-alt.patch
|
||||||
|
Patch3: dwz-0.14-gdb-add-index.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The dwz package contains a program that attempts to optimize DWARF
|
The dwz package contains a program that attempts to optimize DWARF
|
||||||
@ -40,6 +41,9 @@ make check
|
|||||||
%{_mandir}/man1/dwz.1*
|
%{_mandir}/man1/dwz.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 1 2022 Mark Wielaard <mjw@fedoraproject.org> 0.14-6
|
||||||
|
- Add dwz-0.14-gdb-add-index.patch
|
||||||
|
|
||||||
* Wed Jun 29 2022 Mark Wielaard <mjw@fedoraproject.org> 0.14-5
|
* Wed Jun 29 2022 Mark Wielaard <mjw@fedoraproject.org> 0.14-5
|
||||||
- Add dwz-0.14-binutils-readelf-alt.patch
|
- Add dwz-0.14-binutils-readelf-alt.patch
|
||||||
- BuildRequires elfutils (for tests)
|
- BuildRequires elfutils (for tests)
|
||||||
|
Loading…
Reference in New Issue
Block a user