0.14-9 - Add dwz-0.14-grep-E.patch
This commit is contained in:
parent
99656c6dcd
commit
2536f753c8
34
dwz-0.14-grep-E.patch
Normal file
34
dwz-0.14-grep-E.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
commit a57177980a05f0f84bf290ab7b68f73c0f78053f
|
||||||
|
Author: Martin Liška <mliska@suse.cz>
|
||||||
|
Date: Wed Sep 7 21:55:03 2022 +0200
|
||||||
|
|
||||||
|
Use grep -E instead of egrep.
|
||||||
|
|
||||||
|
egrep is obsoleted starting with GNU Grep 3.8.
|
||||||
|
|
||||||
|
diff --git a/contrib/bytes-per-die.sh b/contrib/bytes-per-die.sh
|
||||||
|
index 969f733..fda8998 100755
|
||||||
|
--- a/contrib/bytes-per-die.sh
|
||||||
|
+++ b/contrib/bytes-per-die.sh
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
f="$1"
|
||||||
|
|
||||||
|
size=$(readelf -WS "$f" \
|
||||||
|
- | egrep "[ \t]\.debug_info" \
|
||||||
|
+ | grep -E "[ \t]\.debug_info" \
|
||||||
|
| sed 's/.*\.debug_info//' \
|
||||||
|
| awk '{print $4}')
|
||||||
|
size=$((16#$size))
|
||||||
|
diff --git a/testsuite/dwz.tests/two-files-low-mem-die-limit-0.sh b/testsuite/dwz.tests/two-files-low-mem-die-limit-0.sh
|
||||||
|
index a3395a7..ee31359 100644
|
||||||
|
--- a/testsuite/dwz.tests/two-files-low-mem-die-limit-0.sh
|
||||||
|
+++ b/testsuite/dwz.tests/two-files-low-mem-die-limit-0.sh
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
1 2 \
|
||||||
|
2> dwz.err
|
||||||
|
|
||||||
|
-if egrep -q "Compressing (1|2)$" dwz.err; then
|
||||||
|
+if grep -Eq "Compressing (1|2)$" dwz.err; then
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
6
dwz.spec
6
dwz.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: DWARF optimization and duplicate removal tool
|
Summary: DWARF optimization and duplicate removal tool
|
||||||
Name: dwz
|
Name: dwz
|
||||||
Version: 0.14
|
Version: 0.14
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
License: GPLv2+ and GPLv3+
|
License: GPLv2+ and GPLv3+
|
||||||
URL: https://sourceware.org/dwz/
|
URL: https://sourceware.org/dwz/
|
||||||
Source: https://sourceware.org/ftp/dwz/releases/%{name}-%{version}.tar.xz
|
Source: https://sourceware.org/ftp/dwz/releases/%{name}-%{version}.tar.xz
|
||||||
@ -12,6 +12,7 @@ BuildRequires: make elfutils
|
|||||||
Patch1: dwz-0.14-binutils-Wn.patch
|
Patch1: dwz-0.14-binutils-Wn.patch
|
||||||
Patch2: dwz-0.14-binutils-readelf-alt.patch
|
Patch2: dwz-0.14-binutils-readelf-alt.patch
|
||||||
Patch3: dwz-0.14-gdb-add-index.patch
|
Patch3: dwz-0.14-gdb-add-index.patch
|
||||||
|
Patch4: dwz-0.14-grep-E.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The dwz package contains a program that attempts to optimize DWARF
|
The dwz package contains a program that attempts to optimize DWARF
|
||||||
@ -42,6 +43,9 @@ make check
|
|||||||
%{_mandir}/man1/dwz.1*
|
%{_mandir}/man1/dwz.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 25 2022 Mark Wielaard <mjw@fedoraproject.org> 0.14-9
|
||||||
|
- Add dwz-0.14-grep-E.patch
|
||||||
|
|
||||||
* Tue Oct 25 2022 William Cohen <wcohen@redhat.com> 0.14-8
|
* Tue Oct 25 2022 William Cohen <wcohen@redhat.com> 0.14-8
|
||||||
- Added URL and complete path to source tarball to dwz.spec.
|
- Added URL and complete path to source tarball to dwz.spec.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user