Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/dwz.git#ab23aeae881a90a7704201096f0f1f3e82743232
This commit is contained in:
DistroBaker 2021-01-21 15:38:17 +00:00
parent d9f6777d52
commit 1a09a6dd4e
4 changed files with 62 additions and 4 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/dwz-0.12.tar.bz2 /dwz-0.12.tar.bz2
/dwz-0.13.tar.xz /dwz-0.13.tar.xz
/dwz-20210118.tar.xz /dwz-20210118.tar.xz
/dwz-20210121.tar.xz

50
dwz.patch Normal file
View File

@ -0,0 +1,50 @@
diff --git a/Makefile b/Makefile
index 340569a..236a3dc 100644
--- a/Makefile
+++ b/Makefile
@@ -99,37 +99,37 @@ $(TEST_EXECS_DWARF_ASM): %: %-dw.S
$(CC) $(TEST_SRC)/main.c $< -o $@
odr-struct:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=struct
odr-class:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=class
odr-union:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=union
odr-struct-ns:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=struct -DNAMESPACE=1
odr-class-ns:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=class -DNAMESPACE=1
odr-union-ns:
- $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -g \
+ $(CXX) $(TEST_SRC)/odr.cc $(TEST_SRC)/odr-2.cc -I$(TEST_SRC) -o $@ -gdwarf-4 \
-DKIND=union -DNAMESPACE=1
odr-loc:
$(CXX) $(TEST_SRC)/odr-loc.cc $(TEST_SRC)/odr-loc-2.cc -I$(TEST_SRC) \
- -o $@ -g
+ -o $@ -gdwarf-4
def-decl:
$(CXX) $(TEST_SRC)/decl.c $(TEST_SRC)/def.c $(TEST_SRC)/def2.c -I$(TEST_SRC) \
- -o $@ -g
+ -o $@ -gdwarf-4
# On some systems we need to set and export DEJAGNU to suppress
# WARNING: Couldn't find the global config file.

View File

@ -1,11 +1,12 @@
Summary: DWARF optimization and duplicate removal tool Summary: DWARF optimization and duplicate removal tool
Name: dwz Name: dwz
Version: 0.13 Version: 0.13
Release: 5%{?dist} Release: 6%{?dist}
License: GPLv2+ and GPLv3+ License: GPLv2+ and GPLv3+
#Source: https://sourceware.org/ftp/dwz/releases/%{name}-%{version}.tar.xz #Source: https://sourceware.org/ftp/dwz/releases/%{name}-%{version}.tar.xz
#git clone git://sourceware.org/git/dwz; cd dwz; git archive --format=tar --prefix=dwz/ 40d5efd4edc52a7d2ed02f8400a9beb129053271 | xz -9e > ../dwz-20210118.tar.xz #git clone git://sourceware.org/git/dwz; cd dwz; git archive --format=tar --prefix=dwz/ 47af8da7c8533924e96d1dbd97625b6a4dc35855 | xz -9e > ../dwz-20210121.tar.xz
Source: %{name}-20210118.tar.xz Source: %{name}-20210121.tar.xz
Patch: %{name}.patch
BuildRequires: gcc, gcc-c++, gdb, elfutils-libelf-devel, dejagnu BuildRequires: gcc, gcc-c++, gdb, elfutils-libelf-devel, dejagnu
BuildRequires: make BuildRequires: make
@ -20,6 +21,7 @@ and using DW_TAG_imported_unit to import it into each CU that needs it.
%prep %prep
%setup -q -n dwz %setup -q -n dwz
%patch -p1
%build %build
%make_build CFLAGS='%{optflags}' LDFLAGS='%{build_ldflags}' \ %make_build CFLAGS='%{optflags}' LDFLAGS='%{build_ldflags}' \
@ -38,6 +40,11 @@ make check
%{_mandir}/man1/dwz.1* %{_mandir}/man1/dwz.1*
%changelog %changelog
* Thu Jan 21 2021 Jakub Jelinek <jakub@redhat.com> 0.13-6
- DW_FORM_implicit_const handling fixes (sw#27212, sw#27213)
- temporarily build odr tests with -gdwarf-4 as they are incompatible with
DWARF 5
* Mon Jan 18 2021 Jakub Jelinek <jakub@redhat.com> 0.13-5 * Mon Jan 18 2021 Jakub Jelinek <jakub@redhat.com> 0.13-5
- update to latest git snapshot - update to latest git snapshot
- DWARF5 support - DWARF5 support

View File

@ -1 +1 @@
SHA512 (dwz-20210118.tar.xz) = 093cf08413e88def02bd55adf8a2aa515ae79f6cb21bbab7b943785437fd333b72175ad4284acfd2cd878e7527018c9be86ed8e26a9a5b97dfff0004cc93189a SHA512 (dwz-20210121.tar.xz) = f35855856e1ed6b64f726382b2d63ee1de5b16e06ef83a115563e9f4b2d661419a5c82f5e0da219e98f8f67d6af8bc2a5122ce14bba6a70aa00d7bd14fff3d98