dwarves: New upstream release: 1.13
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
This commit is contained in:
parent
0f8b793d3e
commit
56f69ef7a5
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ dwarves-1.8.tar.bz2
|
||||
/dwarves-1.9.tar.bz2
|
||||
/dwarves-1.10.tar.bz2
|
||||
/dwarves-1.12.tar.bz2
|
||||
/dwarves-1.13.tar.xz
|
||||
|
118
dwarves-1.13-spec-fixes.patch
Normal file
118
dwarves-1.13-spec-fixes.patch
Normal file
@ -0,0 +1,118 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e2c0ee107940..88a364febaf2 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -143,6 +143,8 @@ install(TARGETS dwarves LIBRARY DESTINATION ${LIB_INSTALL_DIR})
|
||||
install(TARGETS dwarves dwarves_emit dwarves_reorganize LIBRARY DESTINATION ${LIB_INSTALL_DIR})
|
||||
install(FILES dwarves.h dwarves_emit.h dwarves_reorganize.h
|
||||
dutil.h gobuffer.h list.h rbtree.h strings.h
|
||||
+ btf_encoder.h config.h ctf_encoder.h ctf.h
|
||||
+ elfcreator.h elf_symtab.h hash.h libbtf.h libctf.h
|
||||
DESTINATION ${CMAKE_INSTALL_PREFIX}/include/dwarves/)
|
||||
install(FILES man-pages/pahole.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1/)
|
||||
install(PROGRAMS ostra/ostra-cg DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
diff --git a/rpm/SPECS/dwarves.spec b/rpm/SPECS/dwarves.spec
|
||||
index 5d8f60879afa..be2c29f3792c 100644
|
||||
--- a/rpm/SPECS/dwarves.spec
|
||||
+++ b/rpm/SPECS/dwarves.spec
|
||||
@@ -5,14 +5,13 @@ Name: dwarves
|
||||
Version: 1.13
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
-Summary: Debugging Information Manipulation Tools
|
||||
-Group: Development/Tools
|
||||
+Summary: Debugging Information Manipulation Tools (pahole & friends)
|
||||
URL: http://acmel.wordpress.com
|
||||
-Source: http://fedorapeople.org/~acme/dwarves/%{name}-%{version}.tar.bz2
|
||||
+Source: http://fedorapeople.org/~acme/dwarves/%{name}-%{version}.tar.xz
|
||||
+BuildRequires: gcc
|
||||
BuildRequires: cmake
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: elfutils-devel >= 0.130
|
||||
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
%description
|
||||
dwarves is a set of tools that use the debugging information inserted in
|
||||
@@ -37,14 +36,12 @@ functions, inlines, decisions made by the compiler about inlining, etc.
|
||||
|
||||
%package -n %{libname}%{libver}
|
||||
Summary: Debugging information processing library
|
||||
-Group: Development/Libraries
|
||||
|
||||
%description -n %{libname}%{libver}
|
||||
Debugging information processing library.
|
||||
|
||||
%package -n %{libname}%{libver}-devel
|
||||
Summary: Debugging information library development files
|
||||
-Group: Development/Libraries
|
||||
Requires: %{libname}%{libver} = %{version}-%{release}
|
||||
|
||||
%description -n %{libname}%{libver}-devel
|
||||
@@ -61,19 +58,12 @@ make VERBOSE=1 %{?_smp_mflags}
|
||||
rm -Rf %{buildroot}
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
-%post -n %{libname}%{libver} -p /sbin/ldconfig
|
||||
-
|
||||
-%postun -n %{libname}%{libver} -p /sbin/ldconfig
|
||||
-
|
||||
-%clean
|
||||
-rm -rf %{buildroot}
|
||||
+%ldconfig_scriptlets -n %{libname}%{libver}
|
||||
|
||||
%files
|
||||
-%defattr(0644,root,root,0755)
|
||||
%doc README.ctracer
|
||||
%doc README.btf
|
||||
%doc NEWS
|
||||
-%defattr(0755,root,root,0755)
|
||||
%{_bindir}/btfdiff
|
||||
%{_bindir}/codiff
|
||||
%{_bindir}/ctracer
|
||||
@@ -99,19 +89,26 @@ rm -rf %{buildroot}
|
||||
%attr(0755,root,root) %{_datadir}/dwarves/runtime/python/ostra.py*
|
||||
|
||||
%files -n %{libname}%{libver}
|
||||
-%defattr(0644,root,root,0755)
|
||||
%{_libdir}/%{libname}.so.*
|
||||
%{_libdir}/%{libname}_emit.so.*
|
||||
%{_libdir}/%{libname}_reorganize.so.*
|
||||
|
||||
%files -n %{libname}%{libver}-devel
|
||||
-%defattr(0644,root,root,0755)
|
||||
%doc MANIFEST README
|
||||
+%{_includedir}/dwarves/btf_encoder.h
|
||||
+%{_includedir}/dwarves/config.h
|
||||
+%{_includedir}/dwarves/ctf_encoder.h
|
||||
+%{_includedir}/dwarves/ctf.h
|
||||
+%{_includedir}/dwarves/dutil.h
|
||||
%{_includedir}/dwarves/dwarves.h
|
||||
%{_includedir}/dwarves/dwarves_emit.h
|
||||
%{_includedir}/dwarves/dwarves_reorganize.h
|
||||
-%{_includedir}/dwarves/dutil.h
|
||||
+%{_includedir}/dwarves/elfcreator.h
|
||||
+%{_includedir}/dwarves/elf_symtab.h
|
||||
%{_includedir}/dwarves/gobuffer.h
|
||||
+%{_includedir}/dwarves/hash.h
|
||||
+%{_includedir}/dwarves/libbtf.h
|
||||
+%{_includedir}/dwarves/libctf.h
|
||||
%{_includedir}/dwarves/list.h
|
||||
%{_includedir}/dwarves/rbtree.h
|
||||
%{_includedir}/dwarves/strings.h
|
||||
@@ -120,6 +117,16 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/%{libname}_reorganize.so
|
||||
|
||||
%changelog
|
||||
+* Tue Apr 23 2019 Arnaldo Carvalho de Melo <acme@redhat.com> - 1.13-1
|
||||
+- New release: 1.13
|
||||
+- Infer __packed__ attributes, i.e. __attribute__((__packed__))
|
||||
+- Support DW_AT_alignment, i.e. __attribute__((__aligned__(N)))
|
||||
+- Decode BTF type format and pretty print it
|
||||
+- BTF encoding fixes
|
||||
+- Use libbpf's BTF deduplication
|
||||
+- Support unions as arguments to -C/--class
|
||||
+- New 'pfunct --compile' generates compilable output with type definitions
|
||||
+
|
||||
* Thu Aug 16 2018 Arnaldo Carvalho de Melo <acme@kernel.org> - 1.12-1
|
||||
- New release:
|
||||
- union member cacheline boundaries for all inner structs
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dwarves-1.12.tar.bz2) = 20644344e694253b79ede65e489696a319f10eaf424af81882414ae6efeaf34a82132321430d647916b78f97ef504907b3bd32919420f2cd14384910e283ff27
|
||||
SHA512 (dwarves-1.13.tar.xz) = 26485b183b4c7b608dd0392f9155dd570a14c86fdeafee232e44ad30f14a1357b408b61b0e8a31ea4bf976ed7fc44e7d5a4a3ccede9713c47265ad52c13dadf0
|
||||
|
Loading…
Reference in New Issue
Block a user