import dvd+rw-tools-7.1-27.el8

This commit is contained in:
CentOS Sources 2019-05-07 08:08:03 -04:00 committed by Andrew Lukoshko
commit 64ed45fb07
16 changed files with 1992 additions and 0 deletions

1
.dvd+rw-tools.metadata Normal file
View File

@ -0,0 +1 @@
6400e013934ff589b4b224eced03fd9f42ed719b SOURCES/dvd+rw-tools-7.1.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/dvd+rw-tools-7.1.tar.gz

View File

@ -0,0 +1,13 @@
--- ./growisofs_mmc.cpp.joe 2006-04-27 20:45:00.788446635 +0200
+++ ./growisofs_mmc.cpp 2006-04-27 20:46:01.666824300 +0200
@@ -1412,9 +1412,7 @@
blocks += 15, blocks &= ~15;
if (blocks <= split)
- fprintf (stderr,":-( more than 50%% of space will be *wasted*!\n"
- " use single layer media for this recording\n"),
- exit (FATAL_START(EMEDIUMTYPE));
+ fprintf (stderr,":-? more than 50%% of space will be *wasted*!\n");
blocks /= 16;
blocks += 1;

View File

@ -0,0 +1,11 @@
diff -up dvd+rw-tools-7.0/transport.hxx.glibc2.6.90 dvd+rw-tools-7.0/transport.hxx
--- dvd+rw-tools-7.0/transport.hxx.glibc2.6.90 2007-08-15 12:56:17.000000000 +0200
+++ dvd+rw-tools-7.0/transport.hxx 2007-08-15 12:56:42.000000000 +0200
@@ -11,6 +11,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <limits.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>

View File

@ -0,0 +1,12 @@
diff -Nrup dvd+rw-tools-7.0/growisofs_mmc.cpp dvd+rw-tools-7.0_mod/growisofs_mmc.cpp
--- dvd+rw-tools-7.0/growisofs_mmc.cpp 2006-09-23 20:45:49.000000000 +0800
+++ dvd+rw-tools-7.0_mod/growisofs_mmc.cpp 2007-11-19 18:20:46.000000000 +0800
@@ -138,7 +138,7 @@ int media_reload (char *name=NULL,struct
cmd[0] = 0x1B; // START/STOP UNIT
cmd[4] = 0x2; // "Eject"
cmd[5] = 0;
- if (cmd.transport()) return 1;
+ cmd.transport();
}
#if defined(__sun) || defined(sun)
else if (volmgt_running())

View File

@ -0,0 +1,11 @@
--- transport.hxx~ 2008-03-25 21:24:47.000000000 -0400
+++ transport.hxx 2008-03-25 21:25:36.000000000 -0400
@@ -116,7 +116,7 @@
extern "C" char *plusminus_locale()
{ static class __plusminus {
private:
- char str[4];
+ char str[MB_LEN_MAX];
public:
__plusminus() { setlocale(LC_CTYPE,ENV_LOCALE);
int l = wctomb(str,(wchar_t)(unsigned char)'±');

View File

@ -0,0 +1,11 @@
--- dvd+rw-tools-7.0/dvd+rw-format.cpp.wexit 2007-06-21 12:42:30.000000000 +0200
+++ dvd+rw-tools-7.0/dvd+rw-format.cpp 2007-06-21 12:44:13.000000000 +0200
@@ -245,7 +245,7 @@ int main (int argc, char *argv[])
alarm(1);
while ((waitpid(pid,&i,0) != pid) && !WIFEXITED(i)) ;
if (WEXITSTATUS(i) == 0) fprintf (stderr,"\n");
- exit (0);
+ exit (WEXITSTATUS(i));
}
#endif

View File

@ -0,0 +1,27 @@
diff -ur dvd+rw-tools-7.0/Makefile.m4 dvd+rw-tools-7.0-manpatch/Makefile.m4
--- dvd+rw-tools-7.0/Makefile.m4 2006-09-24 19:55:19.000000000 +0200
+++ dvd+rw-tools-7.0-manpatch/Makefile.m4 2006-10-09 10:44:31.000000000 +0200
@@ -191,7 +191,7 @@
LINK.o =$(LINK.cc)
prefix?=/usr/local
-manprefix?=$(shell case $(prefix) in (*/usr/?*) echo $(prefix)/man ;; (*) echo $(prefix)/share/man ;; esac)
+mandir?=$(shell case $(prefix) in (*/usr/?*) echo $(prefix)/man ;; (*) echo $(prefix)/share/man ;; esac)
bin_mode?=0755 # yes, default is *no* set-uid
minus_o:=$(shell [[ `id -u` == 0 ]] && echo "-o root")
@@ -199,10 +199,10 @@
install: dvd+rw-tools
[[ -d $(prefix)/bin ]] || mkdir -p $(prefix)/bin
install $(minus_o) -m $(bin_mode) $(CHAIN) $(prefix)/bin
- [[ -d $(manprefix)/man1 ]] || mkdir -p $(manprefix)/man1
- install $(minus_o) -m 0644 growisofs.1 $(manprefix)/man1
- -[[ -f rpl8 ]] && install $(minus_o) -m $(bin_mode) rpl8 $(prefix)/bin; :
- -[[ -f btcflash ]] && install $(minus_o) -m $(bin_mode) btcflash $(prefix)/bin; :
+ [[ -d $(mandir)/man1 ]] || mkdir -p $(mandir)/man1
+ install $(minus_o) -m 0644 growisofs.1 $(mandir)/man1
+ -[[ -f rpl8 ]] && install $(minus_o) -m $(bin_mode) rpl8 $(prefix)/bin || :
+ -[[ -f btcflash ]] && install $(minus_o) -m $(bin_mode) btcflash $(prefix)/bin || :
])
# common section

View File

@ -0,0 +1,14 @@
diff -up wrk/growisofs_mmc.cpp.wrk wrk/growisofs_mmc.cpp
--- wrk/growisofs_mmc.cpp.wrk 2014-11-14 13:22:49.579552118 +0100
+++ wrk/growisofs_mmc.cpp 2014-11-14 13:35:36.779730963 +0100
@@ -410,7 +410,9 @@ static unsigned int get_2k_capacity (Scs
}
nwa = 0;
- if (buf[7]&1 && !bdr_plus_pow) // NWA_V
+ //if (buf[7]&1 && !bdr_plus_pow) // NWA_V
+ //!bdr_plus_pow patched out for Fedora
+ if (buf[7]&1) // NWA_V
{ nwa = buf[12]<<24;
nwa |= buf[13]<<16;
nwa |= buf[14]<<8;

View File

@ -0,0 +1,12 @@
diff -up dvd+rw-tools-7.1/growisofs_mmc.cpp.wrk dvd+rw-tools-7.1/growisofs_mmc.cpp
--- dvd+rw-tools-7.1/growisofs_mmc.cpp.wrk 2013-06-24 14:18:38.898344970 +0200
+++ dvd+rw-tools-7.1/growisofs_mmc.cpp 2013-06-24 14:20:00.428025541 +0200
@@ -756,6 +756,8 @@ static void bd_r_format (Scsi_Command &c
wait_for_unit (cmd);
+ bdr_plus_pow = 1;
+
cmd[0] = 0x35; // FLUSH CACHE
cmd[9] = 0;
cmd.transport();

View File

@ -0,0 +1,251 @@
diff -up dvd+rw-tools-7.1/dvd+rw-format.1.format dvd+rw-tools-7.1/dvd+rw-format.1
--- dvd+rw-tools-7.1/dvd+rw-format.1.format 2012-08-23 17:30:20.001822268 +0200
+++ dvd+rw-tools-7.1/dvd+rw-format.1 2012-08-24 09:37:14.549094680 +0200
@@ -0,0 +1,132 @@
+.TH DVD+RW\-FORMAT 1 "24 Aug 2012" "dvd+rw\-tools 7.1"
+.SH NAME
+dvd+rw\-format \- formatting and blanking DVD and BD media program.
+.SH SYNOPSIS
+.B dvd+rw\-format
+[\fB\-force\fP[\fB\=full\fP]]
+[\fB\-lead\-out|\-blank\fP[\fB\=full\fP]]
+[\fB\-ssa\fP[\fB\=none|default|max|XXXm\fP]]
+.I /dev/dvd
+
+.SH DESCRIPTION
+\fBdvd+rw\-format\fP is a part of \fBdvd+rw\-tools\fP suite and allows to
+format virgin DVD+RW or BD\-RE media for the first use or blank already
+written DVD\-RW.
+Typical use cases of using \fBdvd+rw\-format\fP is formatting DVD\-RW to
+make them over\-writable, blanking used DVD\-RW to make them sequentially
+writable from scratch, formatting BD\-RE and DVD\-RAM with custom
+spare area sizes or re\-formatting BD\-RE and DVD\-RAM to change their spare
+size.
+It is not possible to format CD\-RW by \fBdvd+rw\-format\fP,
+you can use \fBcdrskin\fP, \fBxorriso\fP or \fBwodim\fP utilities to blank
+them or cdrwtool to format them instead, see section \fBEXAMPLES\fP.
+
+A DVD\-RW accepts two disc modes: the \fISequential Recording\fP
+and the \fIRestricted Overwrite\fP. If a DVD\-RW medium is in the latter one,
+it will behave much like DVD+RW.
+By default DVD\-RW discs are in Sequential Recording mode, but
+can be put into Restricted Overwrite mode using \fBdvd+rw\-format\fP
+when no options given.
+Be aware, that only \-blank=full, which lasts as long as full writing,
+makes a used sequential DVD\-RW capable of performing multi\-session,
+while fast blanked DVD\-RW can only do Disk\-At\-Once.
+
+Virgin DVD\-RW can be directly written without
+the need of a formatting operation, however a non\-virgin DVD\-RW in
+Sequential Recording mode needs to be blanked before writing a new
+initial session. Since a DVD\-RW medium in the Restricted Overwrite
+mode behaves much like DVD+RW, it can be written again without prior
+formatting the media.
+
+Virgin BD\-RE and DVD+RW media may be initially formatted prior
+usage. Any\-time later, \fBgrowisofs\fP program will take care of formatting
+it automatically whenever appropriate, while further formatting is not
+recommended, however it is possible.
+
+.SH OPTIONS
+.TP
+.BI \-force[\=full]
+Perform formatting even if the medium is formatted already. This is not
+recommended for BD\-RE and DVD+RW media, since they need to be
+formatted only once. Use \fB\-format=full\fP to perform full (lengthy)
+reformat in case of DVD\-RAM or (lengthy) Full Certification in case of
+BD\-RE.
+.TP
+.BI \-lead\-out
+Relocates the lead\-out next to outermost written sector as well as makes
+sure there is no virgin surface before it. This can make the medium more
+compatible with some DVD players. Previously written data is not
+affected by this operation.
+.TP
+.BI \-blank[\=full]
+Wipe data from DVD\-RW media. Data on BD\-RE and DVD+RW will we overwritten
+automatically, so there is no need to blank them explicitly.
+Use \fB\-blank\=full\fP to change DVD\-RW back to Sequential Recording mode.
+.TP
+.BI \-ssa[\=none|default|max|XXXm]
+Grow, eliminate, reset to default or maximize \fISupplementary Spare Area\fP.
+
+.SH EXAMPLES
+Actual device names vary from one operating system to another. We use
+\fI/dev/dvd\fP as a collective name or as symbolic link to the actual
+device if you wish. Under Linux it will most likely be a
+device such as "/dev/sr0" or "/dev/hda" for older Linux 2.6.
+
+To blank a CD\-RW, you have to use another utility, e.g. wodim:
+
+ \fBwodim\fP \fBblank=fast\fP \-immed dev=\fI/dev/cdrom\fP
+ \fBcdrskin\fP \fBblank=all|fast|as_needed\fP \-immed dev=\fI/dev/cdrom\fP
+ \fBxorriso\fP \fB\-outdev\fP \fI/dev/cdrom\fP \fB\-blank all|fast|as_needed\fP
+
+To format CD\-RW, you can use cdrwtool:
+
+ \fBcdrwtool\fP \fB\-d\fP \fI/dev/cdrom\fP \fB\-q\fP
+
+To blank a DVD\-RW and put in the incremental sequential mode, run:
+
+ \fBdvd+rw\-format\fP \fB\-blank=full\fP \fI/dev/dvd\fP
+
+To blank a DVD\-RW and put in the Restricted Overwrite mode, run:
+
+ \fBdvd+rw\-format\fP \fB\-force\fP \fI/dev/dvd\fP
+
+To overwrite data of BD\-RE, DVD+RW, DVD\-RW or DVD\-RAM run:
+
+ \fBgrowisofs\fP \fB\-Z\fP \fI/dev/dvd\fP\=\fI/dev/zero\fP
+
+To blank a DVD\-RAM, you can use:
+
+ \fBdd\fP if\=\fI/dev/zero\fP of\=\fI/dev/dvd\fP
+
+To relocate lead\-out sector, run:
+
+ \fBdvd+rw\-format\fP \fB\-lead\-out\fP \fI/dev/dvd\fP
+
+.SH NOTES
+Note that DVD+RW re\-formatting procedure does not substitute for
+blanking. If you want to nullify the media, e.g. for privacy reasons,
+do it explicitly with 'growisofs \-Z \fI/dev/dvd\fP\=\fB/dev/zero\fP'.
+
+When growisofs "runs into" blank Blu\-ray Disc media or BD\-RE,
+it gets pre\-formatted with minimal spare area size of 256MB.
+
+.SH SEE ALSO
+Most up\-to\-date information on dvd+rw\-tools is available at
+http://fy.chalmers.se/~appro/linux/DVD+RW/.
+.PP
+.BR growisofs (1),
+.BR cdrskin (1),
+.BR xorriso (1),
+.BR wodim (1),
+.BR cdrwtool (1)
+
+.SH AUTHORS
+Andy Polyakov <appro@fy.chalmers.se> stands for programming and on\-line
+information.
+
+This manpage was created by Honza Horak <hhorak@redhat.com> and consulted by
+Thomas Schmitt <scdbackup@gmx.net>.
+
+.SH LICENSE
+\fBdvd+rw\-format\fP is distributed under GNU GPL.
+
diff -up dvd+rw-tools-7.1/growisofs.1.format dvd+rw-tools-7.1/growisofs.1
--- dvd+rw-tools-7.1/growisofs.1.format 2008-03-01 11:40:06.000000000 +0100
+++ dvd+rw-tools-7.1/growisofs.1 2012-08-24 09:35:55.550780073 +0200
@@ -113,7 +113,7 @@ recordings.
Actual device names vary from one operating system to another. We use
\fI/dev/dvd\fP as a collective name or as symbolic link to the actual
device if you wish. Under Linux it will most likely be an ide\-scsi
-device such as "/dev/scd0." Under NetBSD/OpenBSD it has to be a
+device such as "/dev/sr0." Under NetBSD/OpenBSD it has to be a
\fIcharacter\fP SCSI CD\-ROM device such as "/dev/rcd0c." Under Solaris
it also has to be a \fIcharacter\fP SCSI/ATAPI CD\-ROM device, e.g.
"/dev/rdsk/c0t1d0s2" or "/vol/dev/aliases/cdrom0." And likewise in
@@ -210,11 +210,19 @@ DVD\-RAM or Blu\-ray Disc, as volumes ar
When growisofs "runs into" blank Blu\-ray Disc media, BD\-RE or BD\-R,
it gets pre-formatted with minimal spare area size of 256MB.
+A DVD\-RW accepts two disc modes: the \fISequential Recording\fP
+and the \fIRestricted Overwrite\fP. If a DVD\-RW medium is in the later one,
+it will behave much like DVD+RW.
+By default DVD\-RW discs are in Sequential Recording mode, but
+can be put into Restricted Overwrite mode using \fBdvd+rw\-format\fP.
+See \fBdvd+rw\-format (1)\fP for more info.
+
.SH SEE ALSO
Most up-to-date information on dvd+rw\-tools is available at
http://fy.chalmers.se/~appro/linux/DVD+RW/.
.PP
-The manpage for \fBmkisofs\fP.
+.BR mkisofs (1),
+.BR dvd+rw\-format (1)
.SH AUTHORS
Andy Polyakov <appro@fy.chalmers.se> stands for programming and on-line
diff -up dvd+rw-tools-7.1/growisofs.c.format dvd+rw-tools-7.1/growisofs.c
--- dvd+rw-tools-7.1/growisofs.c.format 2008-03-04 10:15:03.000000000 +0100
+++ dvd+rw-tools-7.1/growisofs.c 2012-08-23 17:30:20.028822506 +0200
@@ -3433,8 +3433,15 @@ int main (int argc, char *argv[])
else if (isatty (0)) warn_for_isofs |= 2;
if (no_tty_check || (warn_for_isofs&2))
- fprintf (stderr,"WARNING: %s already carries isofs!\n",in_device),
+ {
+ fprintf (stderr,"WARNING: %s already carries isofs!\n",in_device);
+ /* we cannot re-write a DVD-RW media in Sequential mode */
+ if ((int)(mmc_profile&0xFFFF) == 0x14)
+ fprintf (stderr,"FATAL: DVD-RW medium is in Sequential mode, you "
+ "need to blank it before writing again.\n"),
+ exit(FATAL_START(EBUSY));
printf ("About to execute '");
+ }
else
fprintf (stderr,"FATAL: %s already carries isofs!\n",in_device),
exit(FATAL_START(EBUSY));
diff -up dvd+rw-tools-7.1/Makefile.format dvd+rw-tools-7.1/Makefile
--- dvd+rw-tools-7.1/Makefile.format 2008-02-27 14:11:27.000000000 +0100
+++ dvd+rw-tools-7.1/Makefile 2012-08-23 17:30:20.037822589 +0200
@@ -22,6 +22,7 @@ pkg:
$(DIST)/Makefile.m4 \
$(DIST)/dvd+rw-tools.spec \
$(DIST)/growisofs.1 \
+ $(DIST)/dvd+rw-format.1 \
$(DIST)/transport.hxx \
$(DIST)/mp.h \
$(DIST)/win32err.h \
diff -up dvd+rw-tools-7.1/Makefile.m4.format dvd+rw-tools-7.1/Makefile.m4
--- dvd+rw-tools-7.1/Makefile.m4.format 2012-08-23 17:30:19.971822000 +0200
+++ dvd+rw-tools-7.1/Makefile.m4 2012-08-23 17:30:20.038822597 +0200
@@ -32,6 +32,7 @@ BIN_MODE?=0755
install: dvd+rw-tools
install -o root -m $(BIN_MODE) $(CHAIN) /usr/bin
install -o root -m 0644 growisofs.1 /usr/share/man/man1
+ install -o root -m 0644 dvd+rw-format.1 /usr/share/man/man1
])
ifelse(OS,MINGW32,[
@@ -68,6 +69,7 @@ BIN_MODE?=04755
install: dvd+rw-tools
install -o root -m $(BIN_MODE) $(CHAIN) /usr/local/bin
install -o root -m 0644 growisofs.1 /usr/local/man/man1
+ install -o root -m 0644 dvd+rw-format.1 /usr/local/man/man1
])
ifelse(OS,SunOS,[
@@ -103,6 +105,7 @@ LDLIBS=-lvolmgt -lrt -lpthread -ldl
install: dvd+rw-tools
/usr/ucb/install -o root -m 04755 $(CHAIN) /usr/local/bin
/usr/ucb/install -o root -m 0644 growisofs.1 /usr/local/man/man1
+ /usr/ucb/install -o root -m 0644 dvd+rw-format.1 /usr/local/man/man1
])
ifelse(OS,HP-UX,[
@@ -141,6 +144,7 @@ LDLIBS=-lrt -lpthread
install: dvd+rw-tools
/usr/sbin/install -o -f /usr/local/bin $(CHAIN)
/usr/sbin/install -o -f /usr/local/man/man1 growisofs.1
+ /usr/sbin/install -o -f /usr/local/man/man1 dvd+rw-format.1
])
ifelse(OS,IRIX,[
@@ -178,6 +182,7 @@ BIN_MODE=04755 # set-root-uid
install: dvd+rw-tools
/sbin/install -u root -m $(BIN_MODE) $(CHAIN) /usr/local/bin
/sbin/install -u root -m 0644 growisofs.1 /usr/local/man/man1
+ /sbin/install -u root -m 0644 dvd+rw-format.1 /usr/local/man/man1
])
ifelse(OS,Linux,[
@@ -202,6 +207,7 @@ install: dvd+rw-tools
install $(minus_o) -m $(bin_mode) $(CHAIN) $(prefix)/bin
[[ -d $(mandir)/man1 ]] || mkdir -p $(mandir)/man1
install $(minus_o) -m 0644 growisofs.1 $(mandir)/man1
+ install $(minus_o) -m 0644 dvd+rw-format.1 $(mandir)/man1
-[[ -f rpl8 ]] && install $(minus_o) -m $(bin_mode) rpl8 $(prefix)/bin || :
-[[ -f btcflash ]] && install $(minus_o) -m $(bin_mode) btcflash $(prefix)/bin || :
])

View File

@ -0,0 +1,12 @@
diff -up dvd+rw-tools-7.1/growisofs_mmc.cpp.lastshort dvd+rw-tools-7.1/growisofs_mmc.cpp
--- dvd+rw-tools-7.1/growisofs_mmc.cpp.lastshort 2012-04-13 18:09:31.047641524 +0200
+++ dvd+rw-tools-7.1/growisofs_mmc.cpp 2012-04-13 18:09:34.451763587 +0200
@@ -540,7 +540,7 @@ ssize_t poor_mans_pwrite64 (int fd,const
// own higher HZ value and disrespects the user-land one.
// Sending them down as milliseconds is just safer...
//
- if (!(errcode=cmd.transport (WRITE,(void *)buff,size)))
+ if (!(errcode=cmd.transport (WRITE,(void *)buff,nbl*2048)))
break;
//--- WRITE failed ---//

View File

@ -0,0 +1,19 @@
diff -up dvd+rw-tools-7.1/transport.hxx.debug dvd+rw-tools-7.1/transport.hxx
--- dvd+rw-tools-7.1/transport.hxx.debug 2012-03-07 10:55:07.167322839 +0100
+++ dvd+rw-tools-7.1/transport.hxx 2012-03-07 15:44:34.384202747 +0100
@@ -1795,9 +1795,12 @@ static int handle_events (Scsi_Command &
break;
case 5: ret |= 1<<5; break; // Multiple Initiators
case 6: // Device Busy
- if ((event[4]&0xF)==1 && // Timeout occured
- (event[5]&0x3)!=0)
- { poll(NULL,0,(descr&0xFFFF)*100+100);
+ if ((event[4]&0xF)==1) // Timeout occured
+ {
+ if ((event[5]&0x3)==0) // No Event
+ return 0; // Ready to accept any command
+
+ poll(NULL,0,(descr&0xFFFF)*100+100);
cmd[0] = 0; // TEST UNIT READY
cmd[5] = 0;
if ((err=cmd.transport()))

View File

@ -0,0 +1,24 @@
From 02d3c9a60421741c0cdd2808d5fa18a1b53f32e1 Mon Sep 17 00:00:00 2001
From: Jakub Martisko <jamartis@redhat.com>
Date: Mon, 6 Aug 2018 10:07:07 +0200
Subject: [PATCH] include sysmacros header
---
growisofs.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/growisofs.c b/growisofs.c
index 8b71935..a5cde82 100644
--- a/growisofs.c
+++ b/growisofs.c
@@ -440,6 +440,7 @@
#include <string.h>
#include <fcntl.h>
#include <sys/types.h>
+#include <sys/sysmacros.h>
#include <sys/stat.h>
#include <assert.h>
#include "mp.h"
--
2.14.4

1295
SOURCES/index.html Normal file

File diff suppressed because it is too large Load Diff

278
SPECS/dvd+rw-tools.spec Normal file
View File

@ -0,0 +1,278 @@
Summary: Toolchain to master DVD+RW/+R media
Name: dvd+rw-tools
Version: 7.1
Release: 27%{?dist}
License: GPLv2
Group: Applications/Multimedia
Source: http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-%{version}.tar.gz
Source1: index.html
Patch1: dvd+rw-tools-7.0.manpatch
Patch2: dvd+rw-tools-7.0-wexit.patch
Patch3: dvd+rw-tools-7.0-glibc2.6.90.patch
Patch4: dvd+rw-tools-7.0-reload.patch
Patch5: dvd+rw-tools-7.0-wctomb.patch
Patch6: dvd+rw-tools-7.0-dvddl.patch
Patch7: dvd+rw-tools-7.1-noevent.patch
Patch8: dvd+rw-tools-7.1-lastshort.patch
Patch9: dvd+rw-tools-7.1-format.patch
Patch10: dvd+rw-tools-7.1-bluray_srm+pow.patch
Patch11: dvd+rw-tools-7.1-bluray_pow_freespace.patch
Patch12: dvd+rw-tools-7.1-sysmacros.patch
URL: http://fy.chalmers.se/~appro/linux/DVD+RW/
Requires: mkisofs >= 2.0
BuildRequires: kernel-headers m4
%description
Collection of tools to master DVD+RW/+R media. For further
information see http://fy.chalmers.se/~appro/linux/DVD+RW/.
%prep
%setup -q
%patch1 -p1 -b .manpatch
%patch2 -p1 -b .wexit
%patch3 -p1 -b .glibc2.6.90
%patch4 -p1 -b .reload
%patch5 -p0 -b .wctomb
%patch6 -p0 -b .dvddl
%patch7 -p1 -b .noevent
%patch8 -p1 -b .lastshort
%patch9 -p1 -b .format
%patch10 -p1 -b .pow
%patch11 -p1 -b .freespace
%patch12 -p1 -b .sysmacros
install -m 644 %{SOURCE1} index.html
%build
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
export LDFLAGS="$RPM_LD_FLAGS"
make WARN="-DDEFAULT_BUF_SIZE_MB=16 -DRLIMIT_MEMLOCK" %{?_smp_mflags}
%install
# make install DESTDIR= does not work here
%makeinstall
%files
%doc index.html LICENSE
%{_bindir}/*
%{_mandir}/man1/*.1*
%changelog
* Mon Aug 06 2018 Jakub Martisko <jamartis@redhat.com> - 7.1-27
- Include sys/sysmacros header in the growisofs.c file
- Some macros have been moved from sys/types to sys/sysmacros which lead to FTBFS
- Resolves: 1611716
* Fri Feb 23 2018 Florian Weimer <fweimer@redhat.com> - 7.1-26
- Use LDFLAGS from redhat-rpm-config
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 7.1-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.1-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.1-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.1-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.1-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Oct 09 2015 Frantisek Kluknavsky <fkluknav@redhat.com> - 7.1-20
- serious typo in spec file - patch10 applied twice, patch11 not at all
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 7.1-18
- Rebuilt for GCC 5 C++11 ABI change
* Fri Nov 14 2014 Frantisek Kluknavsky <fkluknav@redhat.com> - 7.1-17
- added dvd+rw-tools-7.1-bluray_pow_freespace.patch,
based on https://bugzilla.redhat.com/show_bug.cgi?id=1082360
count nwa (next writeable address) even in pow (pseudo overwrite) mode
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Jun 24 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 7.1-13
- when formating blu-ray as srm+pow, handle it later correctly as srm+pow, not srm
(credits Thomas Schmitt)
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Aug 27 2012 Honza Horak <hhorak@redhat.com> - 7.1-11
- Spec file cleanup
- Print error in case we want to write already written DVD-RW in Sequential
Recording mode (bug #810838)
- Add man page for dvd+rw-format
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Mon Apr 16 2012 Honza Horak <hhorak@redhat.com> - 7.1-9
- Allow buffer length of the block to be shorter than multiple of 16,
even in case of DAO writing (replaces the previous fix)
Resolves: #810483
* Fri Apr 06 2012 Honza Horak <hhorak@redhat.com> - 7.1-8
- Align blocks count to multiple of 16 also in case of DAO writing
Resolves: #810483
* Wed Mar 07 2012 Honza Horak <hhorak@redhat.com> - 7.1-7
- applied patch from Petr Sumbera to handle Teac DVD drive timeout issue
Resolves: #799299
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Jun 23 2010 Roman Rakus <rrakus@redhat.com> - 7.1-5
- Compile with -fno-strict-aliasing CFLAG
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Wed Dec 17 2008 Roman Rakus <rrakus@redhat.com> - 7.1-2
- Allow burn small images on dvd-dl
Resolves: #476154
* Fri Aug 15 2008 Roman Rakus <rrakus@redhat.com> - 7.1-1
- new version 7.1
* Wed Mar 26 2008 Harald Hoyer <harald@redhat.com> 7.0-11
- fixed widechar overflow (bug #426068) (patch from Jonathan Kamens)
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.0-9
- Autorebuild for GCC 4.3
* Tue Nov 20 2007 Harald Hoyer <harald@redhat.com> - 7.0-8
- added a patch to fix a reload problem on some drives,
after a successful burn
* Fri Aug 31 2007 Matthias Saou <http://freshrpms.net/> 7.0-7
- Minor spec file cleanups (tabs vs. spaces, etc.).
- Use install instead of cp for the html file to avoid umask differences.
* Fri Aug 17 2007 Harald Hoyer <harald@rawhide.home> - 7.0-6
- changed license to GPLv2
* Wed Aug 15 2007 Harald Hoyer <harald@redhat.com> - 7.0-5
- added limits.h to transport.hxx
* Thu Jun 21 2007 Harald Hoyer <harald@redhat.com> - 7.0-4
- fixed exit status (#243036)
- Allow session to cross 4GB boundary regardless of medium type.
Add a -F option (used instead of -M or -Z), which displays
next_session offset and capacity. (#237967)
* Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 7.0-3
- fixed specfile issues (#209985)
* Thu Dec 14 2006 Harald Hoyer <harald@redhat.com> - 7.0-0.4
- set pthread stack size according to limit (#215818)
* Wed Dec 13 2006 Harald Hoyer <harald@redhat.com> - 7.0-0.3
- use _SC_PHYS_PAGES instead of _SC_AVPHYS_PAGES to determine available memory
- Resolves: rhbz#216794
* Fri Nov 03 2006 Harald Hoyer <harald@redhat.com> - 7.0-0.2
- define RLIMIT_MEMLOCK, which should resolve the memlock problems
* Thu Oct 26 2006 Harald Hoyer <harald@redhat.com> - 7.0-0.1
- new version 7.0
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 6.1-4.1
- rebuild
* Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 6.1-4
- more build requirements
* Tue Apr 18 2006 Harald Hoyer <harald@redhat.com> - 6.1-2
- compile with smaller buffer size
- removed O_EXCL patch
* Fri Mar 24 2006 Harald Hoyer <harald@redhat.com> - 6.1-1
- version 6.1
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 5.21.4.10.8-6.2.1
- bump again for double-long bug on ppc(64)
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 5.21.4.10.8-6.2
- rebuilt for new gcc4.1 snapshot and glibc changes
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
- rebuilt
* Wed Feb 16 2005 Harald Hoyer <harald@redhat.com> - 5.21.4.10.8-5
- built with RPM_OPT_FLAGS
* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
- rebuilt
* Thu Nov 18 2004 Harald Hoyer <harald@redhat.com> - 5.21.4.10.8-4
- removed wget dependency
* Wed Sep 01 2004 Harald Hoyer <harald@redhat.com> - 5.21.4.10.8-2
- added dvd+rw-tools-5.21.4.10.8-excl.patch to open O_EXCL
* Wed Sep 01 2004 Harald Hoyer <harald@redhat.com> - 5.21.4.10.8-1
- version 5.21.4.10.8
* Mon Jul 26 2004 Harald Hoyer <harald@redhat.com> - 5.20.4.10.8-1
- version 5.20.4.10.8
* Wed Jun 16 2004 Harald Hoyer <harald@redhat.com> - 5.19.1.4.9.7-1
- version 5.19.1.4.9.7
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Thu Jan 29 2004 Harald Hoyer <harald@redhat.com> - 5.17.4.8.6-1
- version 5.17.4.8.6
- fixes 110740 110700
* Wed Oct 8 2003 Harald Hoyer <harald@redhat.de> 5.13.4.7.4-1
- version 5.13.4.7.4
* Mon Sep 08 2003 Harald Hoyer <harald@redhat.de> 5.12.4.7.4-1
* updated to version 5.12.4.7.4
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Tue Apr 15 2003 Harald Hoyer <harald@redhat.de> 5.3.4.2.4-1
- updated to version 5.3.4.2.4
* Mon Feb 3 2003 Chris Kloiber <ckloiber@redhat.com>
- Updated version to 5.1.4.0.4
- Requires mkisofs 2.0
* Thu Nov 4 2002 Andy Polyakov <appro@fy.chalmers.se>
- Minor growisofs update. Uninitialized errno at exit when
-Z /dev/scd0=image.iso is used.
* Thu Nov 3 2002 Andy Polyakov <appro@fy.chalmers.se>
- Initial packaging. Package version is derived from growisofs,
dvd+rw-format and dvd+rw-booktype version. 4.0.3.0.3 means
growisofs 4.0, dvd+rw-format 3.0 dvd+rw-booktype 3.