1.5.1
This commit is contained in:
parent
ecabd9ca60
commit
709e9ae20e
12
dtc.spec
12
dtc.spec
@ -1,16 +1,14 @@
|
|||||||
Name: dtc
|
Name: dtc
|
||||||
Version: 1.5.0
|
Version: 1.5.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Device Tree Compiler
|
Summary: Device Tree Compiler
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://devicetree.org/
|
URL: https://devicetree.org/
|
||||||
|
|
||||||
Source0: https://www.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
|
Source0: https://www.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
|
||||||
#Patch1: use-tx-as-the-type-specifier-instead-of-zx.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc make
|
BuildRequires: gcc make
|
||||||
BuildRequires: flex bison swig
|
BuildRequires: flex bison swig
|
||||||
#BuildRequires: python2-devel python2-setuptools
|
|
||||||
BuildRequires: python3-devel python3-setuptools
|
BuildRequires: python3-devel python3-setuptools
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -53,7 +51,6 @@ This package provides python2 bindings for libfdt
|
|||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
sed -i 's/python2/python3/' pylibfdt/setup.py
|
sed -i 's/python2/python3/' pylibfdt/setup.py
|
||||||
#sed -i 's/PREFIX/SETUP_PREFIX/' pylibfdt/Makefile.pylibfdt
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} V=1 CC="gcc $RPM_OPT_FLAGS $RPM_LD_FLAGS"
|
make %{?_smp_mflags} V=1 CC="gcc $RPM_OPT_FLAGS $RPM_LD_FLAGS"
|
||||||
@ -76,7 +73,7 @@ rm -f $RPM_BUILD_ROOT/%{_bindir}/ftdump
|
|||||||
|
|
||||||
%files -n libfdt
|
%files -n libfdt
|
||||||
%license GPL
|
%license GPL
|
||||||
%{_libdir}/libfdt-%{version}.so
|
%{_libdir}/libfdt-1.5.0.so
|
||||||
%{_libdir}/libfdt.so.*
|
%{_libdir}/libfdt.so.*
|
||||||
|
|
||||||
%files -n libfdt-static
|
%files -n libfdt-static
|
||||||
@ -90,6 +87,9 @@ rm -f $RPM_BUILD_ROOT/%{_bindir}/ftdump
|
|||||||
%{python3_sitearch}/*
|
%{python3_sitearch}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 11 2019 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.1-1
|
||||||
|
- New dtc 1.5.1 release
|
||||||
|
|
||||||
* Tue Sep 10 2019 Miro Hrončok <mhroncok@redhat.com> - 1.5.0-3
|
* Tue Sep 10 2019 Miro Hrončok <mhroncok@redhat.com> - 1.5.0-3
|
||||||
- Rebuilt for Python 3.8
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (dtc-1.5.0.tar.xz) = fd1e692a1b7bf7987f921ad17d9be6719f7b3aa7915873b45fa86f4ecb1398a0a62cdf53c1fddf98a0f7fed9bf34a79f684018bd01a2b5e88746b50879bf7102
|
SHA512 (dtc-1.5.1.tar.xz) = 9e17103d791c71f1ad5d86ab6ac629d523d9add684c9cccb1624214d6c65e5c29776c23a2ad70597420b043bb5dfd412bf4beafd74729f02309d399d9639da83
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
--- dtc-1.4.7/fdtdump.c.orig 2018-07-23 04:00:50.000000000 +0100
|
|
||||||
+++ dtc-1.4.7/fdtdump.c 2018-08-18 22:04:23.059267042 +0100
|
|
||||||
@@ -100,7 +100,7 @@
|
|
||||||
p = p_struct;
|
|
||||||
while ((tag = fdt32_to_cpu(GET_CELL(p))) != FDT_END) {
|
|
||||||
|
|
||||||
- dumpf("%04zx: tag: 0x%08"PRIx32" (%s)\n",
|
|
||||||
+ dumpf("%04tx: tag: 0x%08"PRIx32" (%s)\n",
|
|
||||||
(uintptr_t)p - blob_off - 4, tag, tagname(tag));
|
|
||||||
|
|
||||||
if (tag == FDT_BEGIN_NODE) {
|
|
||||||
@@ -140,8 +140,8 @@
|
|
||||||
|
|
||||||
p = PALIGN(p + sz, 4);
|
|
||||||
|
|
||||||
- dumpf("%04zx: string: %s\n", (uintptr_t)s - blob_off, s);
|
|
||||||
- dumpf("%04zx: value\n", (uintptr_t)t - blob_off);
|
|
||||||
+ dumpf("%04tx: string: %s\n", (uintptr_t)s - blob_off, s);
|
|
||||||
+ dumpf("%04tx: value\n", (uintptr_t)t - blob_off);
|
|
||||||
printf("%*s%s", depth * shift, "", s);
|
|
||||||
utilfdt_print_data(t, sz);
|
|
||||||
printf(";\n");
|
|
||||||
@@ -229,14 +229,14 @@
|
|
||||||
if (valid_header(p, this_len))
|
|
||||||
break;
|
|
||||||
if (debug)
|
|
||||||
- printf("%s: skipping fdt magic at offset %#zx\n",
|
|
||||||
+ printf("%s: skipping fdt magic at offset %#tx\n",
|
|
||||||
file, p - buf);
|
|
||||||
}
|
|
||||||
++p;
|
|
||||||
}
|
|
||||||
if (!p || endp - p < sizeof(struct fdt_header))
|
|
||||||
die("%s: could not locate fdt magic\n", file);
|
|
||||||
- printf("%s: found fdt at offset %#zx\n", file, p - buf);
|
|
||||||
+ printf("%s: found fdt at offset %#tx\n", file, p - buf);
|
|
||||||
buf = p;
|
|
||||||
} else if (!valid_header(buf, len))
|
|
||||||
die("%s: header is not valid\n", file);
|
|
Loading…
Reference in New Issue
Block a user