Update dtc to include libfdt_env.h (rhbz 969955)
This commit is contained in:
parent
59ddc0c5b2
commit
3eadff4fae
@ -1,65 +0,0 @@
|
|||||||
From jwboyer@linux.vnet.ibm.com Tue Jun 28 08:47:09 2011
|
|
||||||
Date: Tue, 28 Jun 2011 08:47:09 -0400
|
|
||||||
From: Josh Boyer <jwboyer@linux.vnet.ibm.com>
|
|
||||||
To: Jon Loeliger <jdl@jdl.com>
|
|
||||||
Cc: linuxppc-dev@lists.ozlabs.org
|
|
||||||
Subject: [PATCH] dtc: Remove unused check variable
|
|
||||||
Message-ID: <20110628124709.GC10237@zod.rchland.ibm.com>
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=us-ascii
|
|
||||||
Content-Disposition: inline
|
|
||||||
User-Agent: Mutt/1.5.21 (2010-09-15)
|
|
||||||
Status: RO
|
|
||||||
Content-Length: 1315
|
|
||||||
Lines: 49
|
|
||||||
|
|
||||||
Commit 376ab6f2 removed the old style check functionality from DTC,
|
|
||||||
however the check option and variable were not removed. This leads to
|
|
||||||
build failures when -Werror=unused-but-set-variable is specified:
|
|
||||||
|
|
||||||
dtc.c: In function 'main':
|
|
||||||
dtc.c:102:17: error: variable 'check' set but not used [-Werror=unused-but-set-variable]
|
|
||||||
cc1: all warnings being treated as errors
|
|
||||||
make: *** [dtc.o] Error 1
|
|
||||||
make: *** Waiting for unfinished jobs....
|
|
||||||
|
|
||||||
Remove the check variable.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@linux.vnet.ibm.com>
|
|
||||||
|
|
||||||
---
|
|
||||||
|
|
||||||
t a/dtc.c b/dtc.c
|
|
||||||
index cbc0193..15d2fc2 100644
|
|
||||||
--- a/dtc.c
|
|
||||||
+++ b/dtc.c
|
|
||||||
@@ -99,7 +99,7 @@ int main(int argc, char *argv[])
|
|
||||||
const char *inform = "dts";
|
|
||||||
const char *outform = "dts";
|
|
||||||
const char *outname = "-";
|
|
||||||
- int force = 0, check = 0, sort = 0;
|
|
||||||
+ int force = 0, sort = 0;
|
|
||||||
const char *arg;
|
|
||||||
int opt;
|
|
||||||
FILE *outf = NULL;
|
|
||||||
@@ -111,7 +111,7 @@ int main(int argc, char *argv[])
|
|
||||||
minsize = 0;
|
|
||||||
padsize = 0;
|
|
||||||
|
|
||||||
- while ((opt = getopt(argc, argv, "hI:O:o:V:R:S:p:fcqb:vH:s")) != EOF) {
|
|
||||||
+ while ((opt = getopt(argc, argv, "hI:O:o:V:R:S:p:fqb:vH:s")) != EOF) {
|
|
||||||
switch (opt) {
|
|
||||||
case 'I':
|
|
||||||
inform = optarg;
|
|
||||||
@@ -137,9 +137,6 @@ int main(int argc, char *argv[])
|
|
||||||
case 'f':
|
|
||||||
force = 1;
|
|
||||||
break;
|
|
||||||
- case 'c':
|
|
||||||
- check = 1;
|
|
||||||
- break;
|
|
||||||
case 'q':
|
|
||||||
quiet++;
|
|
||||||
break;
|
|
||||||
|
|
||||||
|
|
@ -1,52 +0,0 @@
|
|||||||
From jwboyer@linux.vnet.ibm.com Tue Jun 28 09:42:53 2011
|
|
||||||
Date: Tue, 28 Jun 2011 09:42:53 -0400
|
|
||||||
From: Josh Boyer <jwboyer@linux.vnet.ibm.com>
|
|
||||||
To: jdl@jdl.com, david@gibson.dropbear.id.au
|
|
||||||
Cc: linuxppc-dev@lists.ozlabs.org
|
|
||||||
Subject: [PATCH] dtc: Remove unused variable in flat_read_mem_reserve
|
|
||||||
Message-ID: <20110628134253.GD10237@zod.rchland.ibm.com>
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=us-ascii
|
|
||||||
Content-Disposition: inline
|
|
||||||
User-Agent: Mutt/1.5.21 (2010-09-15)
|
|
||||||
Status: RO
|
|
||||||
Content-Length: 1865
|
|
||||||
Lines: 68
|
|
||||||
|
|
||||||
The *p variable is declared and used to save inb->ptr, however p is
|
|
||||||
later never used. This has been the case since commit 6c0f3676 and can
|
|
||||||
lead to build failures with -Werror=unused-but-set-variable:
|
|
||||||
|
|
||||||
flattree.c: In function 'flat_read_mem_reserve':
|
|
||||||
flattree.c:700:14: error: variable 'p' set but not used [-Werror=unused-but-set-variable]
|
|
||||||
cc1: all warnings being treated as errors
|
|
||||||
make: *** [flattree.o] Error 1
|
|
||||||
|
|
||||||
Remove the variable.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@linux.vnet.ibm.com>
|
|
||||||
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/flattree.c b/flattree.c
|
|
||||||
index ead0332..28d0b23 100644
|
|
||||||
--- a/flattree.c
|
|
||||||
+++ b/flattree.c
|
|
||||||
@@ -697,7 +697,6 @@ static struct reserve_info *flat_read_mem_reserve(struct inbuf *inb)
|
|
||||||
{
|
|
||||||
struct reserve_info *reservelist = NULL;
|
|
||||||
struct reserve_info *new;
|
|
||||||
- const char *p;
|
|
||||||
struct fdt_reserve_entry re;
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -706,7 +705,6 @@ static struct reserve_info *flat_read_mem_reserve(struct inbuf *inb)
|
|
||||||
*
|
|
||||||
* First pass, count entries.
|
|
||||||
*/
|
|
||||||
- p = inb->ptr;
|
|
||||||
while (1) {
|
|
||||||
flat_read_chunk(inb, &re, sizeof(re));
|
|
||||||
re.address = fdt64_to_cpu(re.address);
|
|
||||||
|
|
||||||
|
|
14335
dtc-update.patch
Normal file
14335
dtc-update.patch
Normal file
File diff suppressed because it is too large
Load Diff
9
dtc.spec
9
dtc.spec
@ -1,13 +1,12 @@
|
|||||||
Name: dtc
|
Name: dtc
|
||||||
Version: 1.3.0
|
Version: 1.3.0
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
Summary: Device Tree Compiler
|
Summary: Device Tree Compiler
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://git.jdl.com/gitweb/?p=dtc.git;a=summary
|
URL: http://git.jdl.com/gitweb/?p=dtc.git;a=summary
|
||||||
Source: http://www.jdl.com/software/dtc-v%{version}.tgz
|
Source: http://www.jdl.com/software/dtc-v%{version}.tgz
|
||||||
Patch0: dtc-check.patch
|
Patch0: dtc-update.patch
|
||||||
Patch1: dtc-flattree.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: flex, bison
|
BuildRequires: flex, bison
|
||||||
@ -35,7 +34,6 @@ This package provides development files for libfdt
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n dtc-v%{version}
|
%setup -q -n dtc-v%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -75,6 +73,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 03 2013 Josh Boyer <jwboyer@redhat.com> - 1.3.0-7
|
||||||
|
- Update dtc to include libfdt_env.h (rhbz 969955)
|
||||||
|
|
||||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user