import drpm-0.3.0-14.el8
This commit is contained in:
commit
04ed6d596e
1
.drpm.metadata
Normal file
1
.drpm.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
5bba9e784193ba61ca76dc008c8e115628ca7f5b SOURCES/drpm-0.3.0.tar.bz2
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/drpm-0.3.0.tar.bz2
|
39
SOURCES/drpm-0.3.0-workaround-ppc64le-gcc.patch
Normal file
39
SOURCES/drpm-0.3.0-workaround-ppc64le-gcc.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
diff -up drpm-0.3.0/CMakeLists.txt.than drpm-0.3.0/CMakeLists.txt
|
||||||
|
diff -up drpm-0.3.0/src/CMakeLists.txt.than drpm-0.3.0/src/CMakeLists.txt
|
||||||
|
--- drpm-0.3.0/src/CMakeLists.txt.than 2017-03-23 13:32:42.043858861 -0400
|
||||||
|
+++ drpm-0.3.0/src/CMakeLists.txt 2017-03-23 13:33:07.444304342 -0400
|
||||||
|
@@ -16,7 +16,7 @@ configure_file(config.h.in ${CMAKE_BINAR
|
||||||
|
add_library(drpm SHARED ${DRPM_SOURCES})
|
||||||
|
|
||||||
|
set_source_files_properties(${DRPM_SOURCES} PROPERTIES
|
||||||
|
- COMPILE_FLAGS "-std=c99 -pedantic -Wall -Wextra -DHAVE_CONFIG_H -I${CMAKE_BINARY_DIR}"
|
||||||
|
+ COMPILE_FLAGS "-std=c99 -fno-builtin-strcmp -pedantic -Wall -Wextra -DHAVE_CONFIG_H -I${CMAKE_BINARY_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
target_link_libraries(drpm ${DRPM_LINK_LIBRARIES})
|
||||||
|
diff -up drpm-0.3.0/test/CMakeLists.txt.than drpm-0.3.0/test/CMakeLists.txt
|
||||||
|
--- drpm-0.3.0/test/CMakeLists.txt.than 2017-03-23 13:38:06.729554341 -0400
|
||||||
|
+++ drpm-0.3.0/test/CMakeLists.txt 2017-03-23 13:38:42.840187780 -0400
|
||||||
|
@@ -33,7 +33,7 @@ endif()
|
||||||
|
add_executable(drpm_api_tests ${DRPM_TEST_SOURCES})
|
||||||
|
|
||||||
|
set_source_files_properties(${DRPM_TEST_SOURCES} PROPERTIES
|
||||||
|
- COMPILE_FLAGS "-std=c99 -pedantic -Wall -Wextra -DHAVE_CONFIG_H -I${CMAKE_BINARY_DIR}"
|
||||||
|
+ COMPILE_FLAGS "-std=c99 -fno-builtin-strcmp -pedantic -Wall -Wextra -DHAVE_CONFIG_H -I${CMAKE_BINARY_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
target_link_libraries(drpm_api_tests ${DRPM_LINK_LIBRARIES} ${CMOCKA_LIBRARIES})
|
||||||
|
@@ -52,13 +52,3 @@ if (BASH_PROGRAM)
|
||||||
|
)
|
||||||
|
set_tests_properties(drpm_cmp_files PROPERTIES DEPENDS drpm_api_tests)
|
||||||
|
endif()
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-if (VALGRIND_PROGRAM)
|
||||||
|
- add_test(
|
||||||
|
- NAME drpm_memcheck
|
||||||
|
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
|
||||||
|
- COMMAND valgrind ${DRPM_TEST_ARGS_VALGRIND} ./drpm_api_tests
|
||||||
|
- )
|
||||||
|
-endif()
|
||||||
|
-
|
163
SPECS/drpm.spec
Normal file
163
SPECS/drpm.spec
Normal file
@ -0,0 +1,163 @@
|
|||||||
|
Name: drpm
|
||||||
|
Version: 0.3.0
|
||||||
|
Release: 14%{?dist}
|
||||||
|
Summary: A library for making, reading and applying deltarpm packages
|
||||||
|
|
||||||
|
# the entire source code is LGPLv3+, except src/drpm_diff.c and src/drpm_search.c which are BSD
|
||||||
|
License: LGPLv3+ and BSD
|
||||||
|
URL: https://fedorahosted.org/%{name}
|
||||||
|
Source: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
|
# add workaround for gcc7 on ppc64le temporary before it's fixed in gcc
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1420350
|
||||||
|
Patch1: drpm-0.3.0-workaround-ppc64le-gcc.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake >= 2.8
|
||||||
|
BuildRequires: gcc
|
||||||
|
|
||||||
|
BuildRequires: rpm-devel
|
||||||
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: bzip2-devel
|
||||||
|
BuildRequires: xz-devel
|
||||||
|
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: doxygen
|
||||||
|
|
||||||
|
BuildRequires: libcmocka-devel >= 1.0
|
||||||
|
%ifarch %{valgrind_arches}
|
||||||
|
BuildRequires: valgrind
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
The drpm package provides a library for making, reading and applying deltarpms,
|
||||||
|
compatible with the original deltarpm packages.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: C interface for the drpm library
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The drpm-devel package provides a C interface (drpm.h) for the drpm library.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
mkdir build
|
||||||
|
|
||||||
|
%build
|
||||||
|
pushd build
|
||||||
|
%cmake ..
|
||||||
|
%make_build
|
||||||
|
make doc
|
||||||
|
popd
|
||||||
|
|
||||||
|
%install
|
||||||
|
pushd build
|
||||||
|
%make_install
|
||||||
|
popd
|
||||||
|
|
||||||
|
%check
|
||||||
|
pushd build
|
||||||
|
ctest -VV
|
||||||
|
popd
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING COPYING.LESSER LICENSE.BSD
|
||||||
|
%{_libdir}/libdrpm.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc build/doc/html/
|
||||||
|
%{_libdir}/libdrpm.so
|
||||||
|
%{_includedir}/drpm.h
|
||||||
|
%{_libdir}/pkgconfig/drpm.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Aug 3 2018 Florian Weimer <fweimer@redhat.com> - 0.3.0-14
|
||||||
|
- Honor %%{valgrind_arches}
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-12
|
||||||
|
- Switch to %%ldconfig_scriptlets
|
||||||
|
|
||||||
|
* Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.3.0-11
|
||||||
|
- Rebuilt after RPM update (№ 3)
|
||||||
|
|
||||||
|
* Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.3.0-10
|
||||||
|
- Rebuilt for RPM soname bump
|
||||||
|
|
||||||
|
* Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.3.0-9
|
||||||
|
- Rebuilt for RPM soname bump
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 13 2017 Than Ngo <than@redhat.com> - 0.3.0-6
|
||||||
|
- updated workaround patch
|
||||||
|
|
||||||
|
* Tue Mar 28 2017 Than Ngo <than@redhat.com> - 0.3.0-5
|
||||||
|
- added workaround for gcc7 bug on ppc64le temporary
|
||||||
|
|
||||||
|
* Thu Sep 29 2016 Pete Walter <pwalter@fedoraproject.org> - 0.3.0-4
|
||||||
|
- Simplify spec file
|
||||||
|
|
||||||
|
* Tue May 3 2016 Matej Chalk <mchalk@redhat.com> 0.3.0-3
|
||||||
|
- Now contains makedeltarpm and applydeltarpm functionality
|
||||||
|
- Added lzlib-devel dependency for OpenSUSE
|
||||||
|
|
||||||
|
* Tue Apr 12 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.3.0-2
|
||||||
|
- Cleanup spec
|
||||||
|
- Make build out-of-tree
|
||||||
|
- Sync with valgrind arches
|
||||||
|
- Build documentation
|
||||||
|
|
||||||
|
* Thu Sep 3 2015 Matej Chalk <mchalk@redhat.com> 0.3.0-1
|
||||||
|
- Bumped minor version (deltarpm creation added)
|
||||||
|
|
||||||
|
* Tue Aug 4 2015 Matej Chalk <mchalk@redhat.com> 0.2.1-1
|
||||||
|
- Added openssl dependency
|
||||||
|
|
||||||
|
* Fri Jul 24 2015 Matej Chalk <mchalk@redhat.com> 0.2.0-2
|
||||||
|
- Fixed bug in test suite
|
||||||
|
|
||||||
|
* Tue Jun 23 2015 Matej Chalk <mchalk@redhat.com> 0.2.0-1
|
||||||
|
- Bumped minor version
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Matej Chalk <mchalk@redhat.com> 0.1.3-4
|
||||||
|
- Memory test only for architectures that have valgrind (#1232157)
|
||||||
|
|
||||||
|
* Wed Mar 11 2015 Matej Chalk <mchalk@redhat.com> 0.1.3-3
|
||||||
|
- Added cmocka and valgrind package dependencies
|
||||||
|
|
||||||
|
* Fri Mar 6 2015 Matej Chalk <mchalk@redhat.com> 0.1.3-2
|
||||||
|
- Added check section
|
||||||
|
|
||||||
|
* Fri Feb 13 2015 Matej Chalk <mchalk@redhat.com> 0.1.3-1
|
||||||
|
- Bumped version to 0.1.3
|
||||||
|
- Added CMake tool
|
||||||
|
|
||||||
|
* Fri Dec 19 2014 Matej Chalk <mchalk@redhat.com> 0.1.2-4
|
||||||
|
- Enabled hardened build
|
||||||
|
|
||||||
|
* Mon Dec 15 2014 Matej Chalk <mchalk@redhat.com> 0.1.2-3
|
||||||
|
- Added unversioned .so to package to enable linking with -ldrpm
|
||||||
|
|
||||||
|
* Thu Dec 11 2014 Matej Chalk <mchalk@redhat.com> 0.1.2-2
|
||||||
|
- Removed unversioned .so from package
|
||||||
|
- Included copies of both GPLv3 and LGPLv3
|
||||||
|
|
||||||
|
* Wed Dec 3 2014 Matej Chalk <mchalk@redhat.com> 0.1.2-1
|
||||||
|
- Bumped version to 0.1.2
|
||||||
|
- Added drpm.pc file for pkgconfig tool
|
||||||
|
|
||||||
|
* Thu Nov 6 2014 Matej Chalk <mchalk@redhat.com> 0.1.1-1
|
||||||
|
- Bumped version to 0.1.1
|
||||||
|
|
||||||
|
* Wed Nov 5 2014 Matej Chalk <mchalk@redhat.com> 0.1.0-1
|
||||||
|
- Initial RPM release
|
Loading…
Reference in New Issue
Block a user