adf00e139f
- fix initramfs creation on noexec tmpdir Resolves: rhbz#953426 - more options for lsinitrd - bash completion for lsinitrd - do not output debug information on initramfs creation, if rd.debug is on the kernel command line - drop requirement on 'file', lsinitrd can find the magic on its own
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
From 26ab7b07a6c7bff7b62a59ab880e735017076141 Mon Sep 17 00:00:00 2001
|
|
From: Harald Hoyer <harald@redhat.com>
|
|
Date: Mon, 15 Apr 2013 11:53:03 +0200
|
|
Subject: [PATCH] Makefile: fixup tarball Makefile
|
|
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 6bda766..d3798c6 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -158,7 +158,7 @@ dracut-$(VERSION).tar.bz2: doc
|
|
git archive --format=tar $(VERSION) --prefix=dracut-$(VERSION)/ > dracut-$(VERSION).tar
|
|
mkdir -p dracut-$(VERSION)
|
|
cp $(manpages) dracut.html dracut-$(VERSION)
|
|
- sed 's/^RELEASEDVERSION =.*/RELEASEDVERSION = $(VERSION)/' Makefile > dracut-$(VERSION)/Makefile
|
|
+ git show $(VERSION):Makefile | sed 's/^RELEASEDVERSION =.*/RELEASEDVERSION = $(VERSION)/' > dracut-$(VERSION)/Makefile
|
|
tar --owner=root --group=root -rf dracut-$(VERSION).tar dracut-$(VERSION)/*.[0-9] dracut-$(VERSION)/dracut.html dracut-$(VERSION)/Makefile
|
|
rm -fr dracut-$(VERSION).tar.bz2 dracut-$(VERSION)
|
|
bzip2 -9 dracut-$(VERSION).tar
|