bcb5fa941d
- version 036 - parse dns information on "ip=" command line arg - preserve ownership of files, if root creates the initramfs - parse ibft nameserver settings - do not run dhcp twice on an interface - try to not reload systemd
298 lines
10 KiB
Diff
298 lines
10 KiB
Diff
From f52759131bd8d0c118106de9c1f0ddb68bf16521 Mon Sep 17 00:00:00 2001
|
|
From: Harald Hoyer <harald@redhat.com>
|
|
Date: Tue, 4 Feb 2014 12:01:11 +0100
|
|
Subject: [PATCH] test: include the same Makefile.testdir
|
|
|
|
---
|
|
test/TEST-01-BASIC/Makefile | 11 +----------
|
|
test/TEST-02-SYSTEMD/Makefile | 11 +----------
|
|
test/TEST-03-USR-MOUNT/Makefile | 11 +----------
|
|
test/TEST-04-FULL-SYSTEMD/Makefile | 11 +----------
|
|
test/TEST-10-RAID/Makefile | 11 +----------
|
|
test/TEST-11-LVM/Makefile | 11 +----------
|
|
test/TEST-12-RAID-DEG/Makefile | 11 +----------
|
|
test/TEST-13-ENC-RAID-LVM/Makefile | 11 +----------
|
|
test/TEST-14-IMSM/Makefile | 11 +----------
|
|
test/TEST-15-BTRFSRAID/Makefile | 11 +----------
|
|
test/TEST-16-DMSQUASH/Makefile | 11 +----------
|
|
test/TEST-17-LVM-THIN/Makefile | 11 +----------
|
|
test/TEST-20-NFS/Makefile | 11 +----------
|
|
test/TEST-30-ISCSI/Makefile | 11 +----------
|
|
test/TEST-40-NBD/Makefile | 11 +----------
|
|
test/TEST-50-MULTINIC/Makefile | 11 +----------
|
|
test/TEST-99-RPM/Makefile | 11 +----------
|
|
17 files changed, 17 insertions(+), 170 deletions(-)
|
|
|
|
diff --git a/test/TEST-01-BASIC/Makefile b/test/TEST-01-BASIC/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-01-BASIC/Makefile
|
|
+++ b/test/TEST-01-BASIC/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-02-SYSTEMD/Makefile b/test/TEST-02-SYSTEMD/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-02-SYSTEMD/Makefile
|
|
+++ b/test/TEST-02-SYSTEMD/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-03-USR-MOUNT/Makefile b/test/TEST-03-USR-MOUNT/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-03-USR-MOUNT/Makefile
|
|
+++ b/test/TEST-03-USR-MOUNT/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-04-FULL-SYSTEMD/Makefile b/test/TEST-04-FULL-SYSTEMD/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-04-FULL-SYSTEMD/Makefile
|
|
+++ b/test/TEST-04-FULL-SYSTEMD/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-10-RAID/Makefile b/test/TEST-10-RAID/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-10-RAID/Makefile
|
|
+++ b/test/TEST-10-RAID/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-11-LVM/Makefile b/test/TEST-11-LVM/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-11-LVM/Makefile
|
|
+++ b/test/TEST-11-LVM/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-12-RAID-DEG/Makefile b/test/TEST-12-RAID-DEG/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-12-RAID-DEG/Makefile
|
|
+++ b/test/TEST-12-RAID-DEG/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-13-ENC-RAID-LVM/Makefile b/test/TEST-13-ENC-RAID-LVM/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-13-ENC-RAID-LVM/Makefile
|
|
+++ b/test/TEST-13-ENC-RAID-LVM/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-14-IMSM/Makefile b/test/TEST-14-IMSM/Makefile
|
|
index bc0ddb6..2dcab81 100644
|
|
--- a/test/TEST-14-IMSM/Makefile
|
|
+++ b/test/TEST-14-IMSM/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @make -s --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @make --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-15-BTRFSRAID/Makefile b/test/TEST-15-BTRFSRAID/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-15-BTRFSRAID/Makefile
|
|
+++ b/test/TEST-15-BTRFSRAID/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-16-DMSQUASH/Makefile b/test/TEST-16-DMSQUASH/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-16-DMSQUASH/Makefile
|
|
+++ b/test/TEST-16-DMSQUASH/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-17-LVM-THIN/Makefile b/test/TEST-17-LVM-THIN/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-17-LVM-THIN/Makefile
|
|
+++ b/test/TEST-17-LVM-THIN/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-20-NFS/Makefile b/test/TEST-20-NFS/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-20-NFS/Makefile
|
|
+++ b/test/TEST-20-NFS/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-30-ISCSI/Makefile b/test/TEST-30-ISCSI/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-30-ISCSI/Makefile
|
|
+++ b/test/TEST-30-ISCSI/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-40-NBD/Makefile b/test/TEST-40-NBD/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-40-NBD/Makefile
|
|
+++ b/test/TEST-40-NBD/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-50-MULTINIC/Makefile b/test/TEST-50-MULTINIC/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-50-MULTINIC/Makefile
|
|
+++ b/test/TEST-50-MULTINIC/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|
|
diff --git a/test/TEST-99-RPM/Makefile b/test/TEST-99-RPM/Makefile
|
|
index aad2705..2dcab81 100644
|
|
--- a/test/TEST-99-RPM/Makefile
|
|
+++ b/test/TEST-99-RPM/Makefile
|
|
@@ -1,10 +1 @@
|
|
-all:
|
|
- @$(MAKE) -s --no-print-directory -C ../.. all
|
|
- @V=$(V) basedir=../.. testdir=../ ./test.sh --all
|
|
-setup:
|
|
- @$(MAKE) --no-print-directory -C ../.. all
|
|
- @basedir=../.. testdir=../ ./test.sh --setup
|
|
-clean:
|
|
- @basedir=../.. testdir=../ ./test.sh --clean
|
|
-run:
|
|
- @basedir=../.. testdir=../ ./test.sh --run
|
|
+-include ../Makefile.testdir
|