35271e26a2
- new upstream version
23 lines
946 B
Diff
23 lines
946 B
Diff
From 53e3244dbafdd583a2487a56e02a2a0108245383 Mon Sep 17 00:00:00 2001
|
|
From: Harald Hoyer <harald@redhat.com>
|
|
Date: Thu, 10 May 2012 14:30:31 +0200
|
|
Subject: [PATCH] Makefile: call git2spec.pl with LANG=C
|
|
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 5ce1778..bf51b51 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -87,7 +87,7 @@ dracut-$(VERSION).tar.bz2: doc
|
|
rpm: dracut-$(VERSION).tar.bz2
|
|
rpmbuild=$$(mktemp -d -t rpmbuild-dracut.XXXXXX); src=$$(pwd); \
|
|
cp dracut-$(VERSION).tar.bz2 "$$rpmbuild"; \
|
|
- $$src/git2spec.pl $(VERSION) "$$rpmbuild" < dracut.spec > $$rpmbuild/dracut.spec; \
|
|
+ LANG=C $$src/git2spec.pl $(VERSION) "$$rpmbuild" < dracut.spec > $$rpmbuild/dracut.spec; \
|
|
(cd "$$rpmbuild"; rpmbuild --define "_topdir $$PWD" --define "_sourcedir $$PWD" \
|
|
--define "_specdir $$PWD" --define "_srcrpmdir $$PWD" \
|
|
--define "_rpmdir $$PWD" -ba dracut.spec; ) && \
|