25 lines
949 B
Diff
25 lines
949 B
Diff
From a2c631c0a3d3208069ebccefc39f591e0595a545 Mon Sep 17 00:00:00 2001
|
|
From: Harald Hoyer <harald@redhat.com>
|
|
Date: Thu, 16 Feb 2012 09:36:13 +0100
|
|
Subject: [PATCH] Makefile: also link dracut-shutdown.service to shutdown
|
|
target
|
|
|
|
---
|
|
Makefile | 2 ++
|
|
1 files changed, 2 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 321e923..6556c01 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -52,7 +52,9 @@ install: doc
|
|
mkdir -p $(DESTDIR)$(systemdsystemunitdir); \
|
|
install -m 0644 dracut-shutdown.service $(DESTDIR)$(systemdsystemunitdir); \
|
|
mkdir -p $(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants; \
|
|
+ mkdir -p $(DESTDIR)$(systemdsystemunitdir)/shutdown.target.wants; \
|
|
ln -s ../dracut-shutdown.service $(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants/dracut-shutdown.service; \
|
|
+ ln -s ../dracut-shutdown.service $(DESTDIR)$(systemdsystemunitdir)/shutdown.target.wants/dracut-shutdown.service; \
|
|
fi
|
|
|
|
clean:
|