dracut - 047-8
- git snapshot
This commit is contained in:
parent
6b7533a6e6
commit
ffd5ff4fbc
159
0001.patch
159
0001.patch
@ -1,145 +1,24 @@
|
||||
From 5e574046e76eae2af5563f48b3ab910b3553ba56 Mon Sep 17 00:00:00 2001
|
||||
From: Javier Martinez Canillas <javierm@redhat.com>
|
||||
Date: Wed, 28 Feb 2018 09:39:12 +0100
|
||||
Subject: [PATCH 1/1] 5?-dracut*.install: Allow scripts to install the
|
||||
initramfs in /boot dir
|
||||
From 7b3f374a82dd1846a2fcb06490cafd95177b3f59 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Mon, 19 Feb 2018 10:16:30 +0100
|
||||
Subject: [PATCH] dracut.spec: remove clean section
|
||||
|
||||
The GRUB 2 bootloaders expect the initrd to be installed in /boot instead
|
||||
of /boot/$MACHINE_ID/$KERNEL_VERSION/{linux,initrd}, so if that directory
|
||||
doesn't exists, install the initramfs images on the /boot directory.
|
||||
|
||||
Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
---
|
||||
50-dracut.install | 17 ++++++++++-----
|
||||
51-dracut-rescue.install | 55 ++++++++++++++++++++++++++++++++++--------------
|
||||
2 files changed, 51 insertions(+), 21 deletions(-)
|
||||
dracut.spec | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/50-dracut.install b/50-dracut.install
|
||||
index f1314d0222c8..64e3549f2992 100755
|
||||
--- a/50-dracut.install
|
||||
+++ b/50-dracut.install
|
||||
@@ -11,6 +11,13 @@ if ! [[ ${KERNEL_INSTALL_MACHINE_ID-x} ]]; then
|
||||
exit 0
|
||||
fi
|
||||
diff --git a/dracut.spec b/dracut.spec
|
||||
index 4b5f0146..f16e69f7 100644
|
||||
--- a/dracut.spec
|
||||
+++ b/dracut.spec
|
||||
@@ -336,9 +336,6 @@ echo 'dracut_rescue_image="yes"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/
|
||||
> $RPM_BUILD_ROOT/etc/system-fips
|
||||
%endif
|
||||
|
||||
+if [[ -d "$BOOT_DIR_ABS" ]]; then
|
||||
+ INITRD="initrd"
|
||||
+else
|
||||
+ BOOT_DIR_ABS="/boot"
|
||||
+ INITRD="initramfs-${KERNEL_VERSION}.img"
|
||||
+fi
|
||||
+
|
||||
ret=0
|
||||
case "$COMMAND" in
|
||||
add)
|
||||
@@ -18,9 +25,9 @@ case "$COMMAND" in
|
||||
if [[ -f ${INITRD_IMAGE_PREGENERATED} ]]; then
|
||||
# we found an initrd at the same place as the kernel
|
||||
# use this and don't generate a new one
|
||||
- cp --reflink=auto "$INITRD_IMAGE_PREGENERATED" "$BOOT_DIR_ABS/initrd" \
|
||||
- && chown root:root "$BOOT_DIR_ABS/initrd" \
|
||||
- && chmod 0600 "$BOOT_DIR_ABS/initrd" \
|
||||
+ cp --reflink=auto "$INITRD_IMAGE_PREGENERATED" "$BOOT_DIR_ABS/$INITRD" \
|
||||
+ && chown root:root "$BOOT_DIR_ABS/$INITRD" \
|
||||
+ && chmod 0600 "$BOOT_DIR_ABS/$INITRD" \
|
||||
&& exit 0
|
||||
fi
|
||||
|
||||
@@ -42,11 +49,11 @@ case "$COMMAND" in
|
||||
break
|
||||
fi
|
||||
done
|
||||
- dracut ${noimageifnotneeded:+--noimageifnotneeded} "$BOOT_DIR_ABS"/initrd "$KERNEL_VERSION"
|
||||
+ dracut ${noimageifnotneeded:+--noimageifnotneeded} "$BOOT_DIR_ABS/$INITRD" "$KERNEL_VERSION"
|
||||
ret=$?
|
||||
;;
|
||||
remove)
|
||||
- rm -f -- "$BOOT_DIR_ABS"/initrd
|
||||
+ rm -f -- "$BOOT_DIR_ABS/$INITRD"
|
||||
ret=$?
|
||||
;;
|
||||
esac
|
||||
diff --git a/51-dracut-rescue.install b/51-dracut-rescue.install
|
||||
index 7fbeac1d4ce6..3f07a698f2f9 100755
|
||||
--- a/51-dracut-rescue.install
|
||||
+++ b/51-dracut-rescue.install
|
||||
@@ -63,15 +63,30 @@ if ! [[ ${BOOT_OPTIONS[*]} ]]; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-BOOT_DIR="/${MACHINE_ID}/0-rescue"
|
||||
-BOOT_ROOT=${BOOT_DIR_ABS%$BOOT_DIR}
|
||||
-LOADER_ENTRY="$BOOT_ROOT/loader/entries/${MACHINE_ID}-0-rescue.conf"
|
||||
+if [[ -d "$BOOT_DIR_ABS" ]]; then
|
||||
+ BOOT_DIR="/${MACHINE_ID}/0-rescue"
|
||||
+ BOOT_ROOT=${BOOT_DIR_ABS%$BOOT_DIR}
|
||||
+ LOADER_ENTRY="$BOOT_ROOT/loader/entries/${MACHINE_ID}-0-rescue.conf"
|
||||
+ KERNEL="linux"
|
||||
+ INITRD="initrd"
|
||||
+else
|
||||
+ BLS_DIR="/boot/loader/entries"
|
||||
+ if [ -d /sys/firmware/efi ]; then
|
||||
+ BLS_DIR="/boot/efi/EFI/${ID}/loader/entries"
|
||||
+ fi
|
||||
+
|
||||
+ BOOT_DIR_ABS="/boot"
|
||||
+ LOADER_ENTRY="$BLS_DIR/${MACHINE_ID}-0-rescue.conf"
|
||||
+ KERNEL="vmlinuz-0-rescue-${MACHINE_ID}"
|
||||
+ INITRD="initramfs-0-rescue-${MACHINE_ID}.img"
|
||||
+fi
|
||||
|
||||
ret=0
|
||||
|
||||
case "$COMMAND" in
|
||||
add)
|
||||
- [[ -f "$LOADER_ENTRY" ]] && exit 0
|
||||
+ [[ -f "$LOADER_ENTRY" ]] && [[ -f "$BOOT_DIR_ABS/$KERNEL" ]] \
|
||||
+ && [[ -f "$BOOT_DIR_ABS/$INITRD" ]] && exit 0
|
||||
|
||||
# source our config dir
|
||||
for f in $(dropindirs_sort ".conf" "/etc/dracut.conf.d" "/usr/lib/dracut/dracut.conf.d"); do
|
||||
@@ -82,21 +97,29 @@ case "$COMMAND" in
|
||||
|
||||
[[ -d "$BOOT_DIR_ABS" ]] || mkdir -p "$BOOT_DIR_ABS"
|
||||
|
||||
- if ! cp --reflink=auto "$KERNEL_IMAGE" "$BOOT_DIR_ABS"/linux; then
|
||||
- echo "Can't copy '$KERNEL_IMAGE to '$BOOT_DIR_ABS/linux'!" >&2
|
||||
+ if ! cp --reflink=auto "$KERNEL_IMAGE" "$BOOT_DIR_ABS/$KERNEL"; then
|
||||
+ echo "Can't copy '$KERNEL_IMAGE to '$BOOT_DIR_ABS/$KERNEL'!" >&2
|
||||
fi
|
||||
|
||||
- dracut --no-hostonly -a "rescue" "$BOOT_DIR_ABS"/initrd "$KERNEL_VERSION"
|
||||
- ((ret+=$?))
|
||||
+ if [[ ! -f "$BOOT_DIR_ABS/$INITRD" ]]; then
|
||||
+ dracut --no-hostonly -a "rescue" "$BOOT_DIR_ABS/$INITRD" "$KERNEL_VERSION"
|
||||
+ ((ret+=$?))
|
||||
+ fi
|
||||
+
|
||||
+ if [[ -d "$BOOT_DIR" ]]; then
|
||||
+ {
|
||||
+ echo "title $PRETTY_NAME - Rescue Image"
|
||||
+ echo "version $KERNEL_VERSION"
|
||||
+ echo "machine-id $MACHINE_ID"
|
||||
+ echo "options ${BOOT_OPTIONS[@]} rd.auto=1"
|
||||
+ echo "linux $BOOT_DIR/linux"
|
||||
+ echo "initrd $BOOT_DIR/initrd"
|
||||
+ } > $LOADER_ENTRY
|
||||
+ else
|
||||
+ cp -aT "${KERNEL_IMAGE%/*}/bls.conf" $LOADER_ENTRY
|
||||
+ sed -i 's/'$KERNEL_VERSION'/0-rescue-'${MACHINE_ID}'/' $LOADER_ENTRY
|
||||
+ fi
|
||||
|
||||
- {
|
||||
- echo "title $PRETTY_NAME - Rescue Image"
|
||||
- echo "version $KERNEL_VERSION"
|
||||
- echo "machine-id $MACHINE_ID"
|
||||
- echo "options ${BOOT_OPTIONS[@]} rd.auto=1"
|
||||
- echo "linux $BOOT_DIR/linux"
|
||||
- echo "initrd $BOOT_DIR/initrd"
|
||||
- } > $LOADER_ENTRY
|
||||
((ret+=$?))
|
||||
;;
|
||||
|
||||
--
|
||||
2.14.3
|
||||
-%clean
|
||||
-rm -rf -- $RPM_BUILD_ROOT
|
||||
-
|
||||
%files
|
||||
%defattr(-,root,root,0755)
|
||||
%if %{with doc}
|
||||
|
||||
|
32
0002.patch
Normal file
32
0002.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 0a68b6a5181cf147b5706b52fd032901b347d5cb Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Mon, 19 Feb 2018 10:17:36 +0100
|
||||
Subject: [PATCH] dracut.spec: remove BuildRoot
|
||||
|
||||
---
|
||||
dracut.spec | 5 -----
|
||||
1 file changed, 5 deletions(-)
|
||||
|
||||
diff --git a/dracut.spec b/dracut.spec
|
||||
index f16e69f7..445d6adb 100644
|
||||
--- a/dracut.spec
|
||||
+++ b/dracut.spec
|
||||
@@ -45,17 +45,12 @@ BuildRequires: kmod-devel >= 23
|
||||
BuildRequires: gcc
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: pkgconfig
|
||||
%endif
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: bash-completion
|
||||
%endif
|
||||
|
||||
-%if 0%{?suse_version}
|
||||
-BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
||||
-%endif
|
||||
-
|
||||
%if %{with doc}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
BuildRequires: docbook-style-xsl docbook-dtds libxslt
|
||||
|
32
0003.patch
Normal file
32
0003.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 3ed33db54a34e5d398a063f578f0d15d834816db Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Mon, 26 Feb 2018 11:22:55 +0100
|
||||
Subject: [PATCH] Update %description a bit
|
||||
|
||||
---
|
||||
dracut.spec | 11 ++++++-----
|
||||
1 file changed, 6 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/dracut.spec b/dracut.spec
|
||||
index 445d6adb..725f89d6 100644
|
||||
--- a/dracut.spec
|
||||
+++ b/dracut.spec
|
||||
@@ -127,11 +127,12 @@ Requires: util-linux-ng >= 2.21
|
||||
Conflicts: mdadm < 3.2.6-14
|
||||
|
||||
%description
|
||||
-dracut contains tools to create a bootable initramfs for 2.6 Linux kernels.
|
||||
-Unlike existing implementations, dracut does hard-code as little as possible
|
||||
-into the initramfs. dracut contains various modules which are driven by the
|
||||
-event-based udev. Having root on MD, DM, LVM2, LUKS is supported as well as
|
||||
-NFS, iSCSI, NBD, FCoE with the dracut-network package.
|
||||
+dracut contains tools to create bootable initramfses for the Linux
|
||||
+kernel. Unlike previous implementations, dracut hard-codes as little
|
||||
+as possible into the initramfs. dracut contains various modules which
|
||||
+are driven by the event-based udev. Having root on MD, DM, LVM2, LUKS
|
||||
+is supported as well as NFS, iSCSI, NBD, FCoE with the dracut-network
|
||||
+package.
|
||||
|
||||
%package network
|
||||
Summary: dracut modules to build a dracut initramfs with network support
|
||||
|
26
0004.patch
Normal file
26
0004.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 48723f28aa4451b1793373c35527d3627b001b7e Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Molkentin <dmolkentin@suse.com>
|
||||
Date: Thu, 1 Mar 2018 10:24:29 +0100
|
||||
Subject: [PATCH] 90kernel-modules: Ensure PCI host modules are included
|
||||
|
||||
The includes modules like the Intel Volume Management Device driver,
|
||||
which is required to boot from disk on some systems.
|
||||
|
||||
Reference: boo#1079924
|
||||
---
|
||||
modules.d/90kernel-modules/module-setup.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
|
||||
index 076f1e8a..94592e6b 100755
|
||||
--- a/modules.d/90kernel-modules/module-setup.sh
|
||||
+++ b/modules.d/90kernel-modules/module-setup.sh
|
||||
@@ -17,6 +17,7 @@ installkernel() {
|
||||
"=drivers/input/serio" \
|
||||
"=drivers/input/keyboard" \
|
||||
"=drivers/usb/storage" \
|
||||
+ "=drivers/pci/host" \
|
||||
${NULL}
|
||||
|
||||
instmods \
|
||||
|
143
0005.patch
Normal file
143
0005.patch
Normal file
@ -0,0 +1,143 @@
|
||||
From b39b8452d23d098aa4f6898a2bdb8391aa45836e Mon Sep 17 00:00:00 2001
|
||||
From: Javier Martinez Canillas <javierm@redhat.com>
|
||||
Date: Wed, 28 Feb 2018 09:39:12 +0100
|
||||
Subject: [PATCH] 5?-dracut*.install: Allow scripts to install the initramfs in
|
||||
/boot dir
|
||||
|
||||
The GRUB 2 bootloaders expect the initrd to be installed in /boot instead
|
||||
of /boot/$MACHINE_ID/$KERNEL_VERSION/{linux,initrd}, so if that directory
|
||||
doesn't exists, install the initramfs images on the /boot directory.
|
||||
|
||||
Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
|
||||
---
|
||||
50-dracut.install | 17 ++++++++++-----
|
||||
51-dracut-rescue.install | 55 ++++++++++++++++++++++++++++++++++--------------
|
||||
2 files changed, 51 insertions(+), 21 deletions(-)
|
||||
|
||||
diff --git a/50-dracut.install b/50-dracut.install
|
||||
index f1314d02..64e3549f 100755
|
||||
--- a/50-dracut.install
|
||||
+++ b/50-dracut.install
|
||||
@@ -11,6 +11,13 @@ if ! [[ ${KERNEL_INSTALL_MACHINE_ID-x} ]]; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
+if [[ -d "$BOOT_DIR_ABS" ]]; then
|
||||
+ INITRD="initrd"
|
||||
+else
|
||||
+ BOOT_DIR_ABS="/boot"
|
||||
+ INITRD="initramfs-${KERNEL_VERSION}.img"
|
||||
+fi
|
||||
+
|
||||
ret=0
|
||||
case "$COMMAND" in
|
||||
add)
|
||||
@@ -18,9 +25,9 @@ case "$COMMAND" in
|
||||
if [[ -f ${INITRD_IMAGE_PREGENERATED} ]]; then
|
||||
# we found an initrd at the same place as the kernel
|
||||
# use this and don't generate a new one
|
||||
- cp --reflink=auto "$INITRD_IMAGE_PREGENERATED" "$BOOT_DIR_ABS/initrd" \
|
||||
- && chown root:root "$BOOT_DIR_ABS/initrd" \
|
||||
- && chmod 0600 "$BOOT_DIR_ABS/initrd" \
|
||||
+ cp --reflink=auto "$INITRD_IMAGE_PREGENERATED" "$BOOT_DIR_ABS/$INITRD" \
|
||||
+ && chown root:root "$BOOT_DIR_ABS/$INITRD" \
|
||||
+ && chmod 0600 "$BOOT_DIR_ABS/$INITRD" \
|
||||
&& exit 0
|
||||
fi
|
||||
|
||||
@@ -42,11 +49,11 @@ case "$COMMAND" in
|
||||
break
|
||||
fi
|
||||
done
|
||||
- dracut ${noimageifnotneeded:+--noimageifnotneeded} "$BOOT_DIR_ABS"/initrd "$KERNEL_VERSION"
|
||||
+ dracut ${noimageifnotneeded:+--noimageifnotneeded} "$BOOT_DIR_ABS/$INITRD" "$KERNEL_VERSION"
|
||||
ret=$?
|
||||
;;
|
||||
remove)
|
||||
- rm -f -- "$BOOT_DIR_ABS"/initrd
|
||||
+ rm -f -- "$BOOT_DIR_ABS/$INITRD"
|
||||
ret=$?
|
||||
;;
|
||||
esac
|
||||
diff --git a/51-dracut-rescue.install b/51-dracut-rescue.install
|
||||
index 7fbeac1d..3f07a698 100755
|
||||
--- a/51-dracut-rescue.install
|
||||
+++ b/51-dracut-rescue.install
|
||||
@@ -63,15 +63,30 @@ if ! [[ ${BOOT_OPTIONS[*]} ]]; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-BOOT_DIR="/${MACHINE_ID}/0-rescue"
|
||||
-BOOT_ROOT=${BOOT_DIR_ABS%$BOOT_DIR}
|
||||
-LOADER_ENTRY="$BOOT_ROOT/loader/entries/${MACHINE_ID}-0-rescue.conf"
|
||||
+if [[ -d "$BOOT_DIR_ABS" ]]; then
|
||||
+ BOOT_DIR="/${MACHINE_ID}/0-rescue"
|
||||
+ BOOT_ROOT=${BOOT_DIR_ABS%$BOOT_DIR}
|
||||
+ LOADER_ENTRY="$BOOT_ROOT/loader/entries/${MACHINE_ID}-0-rescue.conf"
|
||||
+ KERNEL="linux"
|
||||
+ INITRD="initrd"
|
||||
+else
|
||||
+ BLS_DIR="/boot/loader/entries"
|
||||
+ if [ -d /sys/firmware/efi ]; then
|
||||
+ BLS_DIR="/boot/efi/EFI/${ID}/loader/entries"
|
||||
+ fi
|
||||
+
|
||||
+ BOOT_DIR_ABS="/boot"
|
||||
+ LOADER_ENTRY="$BLS_DIR/${MACHINE_ID}-0-rescue.conf"
|
||||
+ KERNEL="vmlinuz-0-rescue-${MACHINE_ID}"
|
||||
+ INITRD="initramfs-0-rescue-${MACHINE_ID}.img"
|
||||
+fi
|
||||
|
||||
ret=0
|
||||
|
||||
case "$COMMAND" in
|
||||
add)
|
||||
- [[ -f "$LOADER_ENTRY" ]] && exit 0
|
||||
+ [[ -f "$LOADER_ENTRY" ]] && [[ -f "$BOOT_DIR_ABS/$KERNEL" ]] \
|
||||
+ && [[ -f "$BOOT_DIR_ABS/$INITRD" ]] && exit 0
|
||||
|
||||
# source our config dir
|
||||
for f in $(dropindirs_sort ".conf" "/etc/dracut.conf.d" "/usr/lib/dracut/dracut.conf.d"); do
|
||||
@@ -82,21 +97,29 @@ case "$COMMAND" in
|
||||
|
||||
[[ -d "$BOOT_DIR_ABS" ]] || mkdir -p "$BOOT_DIR_ABS"
|
||||
|
||||
- if ! cp --reflink=auto "$KERNEL_IMAGE" "$BOOT_DIR_ABS"/linux; then
|
||||
- echo "Can't copy '$KERNEL_IMAGE to '$BOOT_DIR_ABS/linux'!" >&2
|
||||
+ if ! cp --reflink=auto "$KERNEL_IMAGE" "$BOOT_DIR_ABS/$KERNEL"; then
|
||||
+ echo "Can't copy '$KERNEL_IMAGE to '$BOOT_DIR_ABS/$KERNEL'!" >&2
|
||||
fi
|
||||
|
||||
- dracut --no-hostonly -a "rescue" "$BOOT_DIR_ABS"/initrd "$KERNEL_VERSION"
|
||||
- ((ret+=$?))
|
||||
+ if [[ ! -f "$BOOT_DIR_ABS/$INITRD" ]]; then
|
||||
+ dracut --no-hostonly -a "rescue" "$BOOT_DIR_ABS/$INITRD" "$KERNEL_VERSION"
|
||||
+ ((ret+=$?))
|
||||
+ fi
|
||||
+
|
||||
+ if [[ -d "$BOOT_DIR" ]]; then
|
||||
+ {
|
||||
+ echo "title $PRETTY_NAME - Rescue Image"
|
||||
+ echo "version $KERNEL_VERSION"
|
||||
+ echo "machine-id $MACHINE_ID"
|
||||
+ echo "options ${BOOT_OPTIONS[@]} rd.auto=1"
|
||||
+ echo "linux $BOOT_DIR/linux"
|
||||
+ echo "initrd $BOOT_DIR/initrd"
|
||||
+ } > $LOADER_ENTRY
|
||||
+ else
|
||||
+ cp -aT "${KERNEL_IMAGE%/*}/bls.conf" $LOADER_ENTRY
|
||||
+ sed -i 's/'$KERNEL_VERSION'/0-rescue-'${MACHINE_ID}'/' $LOADER_ENTRY
|
||||
+ fi
|
||||
|
||||
- {
|
||||
- echo "title $PRETTY_NAME - Rescue Image"
|
||||
- echo "version $KERNEL_VERSION"
|
||||
- echo "machine-id $MACHINE_ID"
|
||||
- echo "options ${BOOT_OPTIONS[@]} rd.auto=1"
|
||||
- echo "linux $BOOT_DIR/linux"
|
||||
- echo "initrd $BOOT_DIR/initrd"
|
||||
- } > $LOADER_ENTRY
|
||||
((ret+=$?))
|
||||
;;
|
||||
|
||||
|
74
0006.patch
Normal file
74
0006.patch
Normal file
@ -0,0 +1,74 @@
|
||||
From 3aa37cafde734719f2377600a17459fad30edfbc Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Nykryn <lnykryn@redhat.com>
|
||||
Date: Fri, 2 Mar 2018 12:29:46 +0100
|
||||
Subject: [PATCH] all: fix issues found by shellcheck
|
||||
|
||||
Error: SHELLCHECK_WARNING:
|
||||
/usr/lib/dracut/dracut-init.sh:939:20: error: Argument to implicit -n is always true due to literal strings. [SC2157]
|
||||
937| dracut_kernel_post() {
|
||||
938| for _f in modules.builtin.bin modules.builtin modules.order; do
|
||||
939|-> [[ $srcmods/$_f ]] && inst_simple "$srcmods/$_f" "/lib/modules/$kernel/$_f"
|
||||
940| done
|
||||
941|
|
||||
|
||||
Error: SHELLCHECK_WARNING:
|
||||
/usr/lib/dracut/modules.d/98syslog/parse-syslog-opts.sh:18:12: error: This expression is constant. Did you forget a $ somewhere? [SC2078]
|
||||
16| elif [ -e /sbin/syslogd ]; then
|
||||
17| syslogtype="syslogd"
|
||||
18|-> elif [ /sbin/syslog-ng ]; then
|
||||
19| syslogtype="syslog-ng"
|
||||
20| else
|
||||
|
||||
Error: SHELLCHECK_WARNING:
|
||||
/usr/lib/dracut/modules.d/90crypt/crypt-lib.sh:15:29: error: Since you double quoted this, it will not word split, and the loop will only run once. [SC2066]
|
||||
13| strstr "$d" "${luks##luks-}" && return 0
|
||||
14| if [ -n "$dev" ]; then
|
||||
15|-> for _dev in "$(devnames $d)"; do
|
||||
16| [ "$dev" -ef "$_dev" ] && return 0
|
||||
17| done
|
||||
---
|
||||
dracut-init.sh | 2 +-
|
||||
modules.d/90crypt/crypt-lib.sh | 2 +-
|
||||
modules.d/98syslog/parse-syslog-opts.sh | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/dracut-init.sh b/dracut-init.sh
|
||||
index 53e6f13a..1278c638 100644
|
||||
--- a/dracut-init.sh
|
||||
+++ b/dracut-init.sh
|
||||
@@ -942,7 +942,7 @@ for_each_kmod_dep() {
|
||||
|
||||
dracut_kernel_post() {
|
||||
for _f in modules.builtin.bin modules.builtin modules.order; do
|
||||
- [[ $srcmods/$_f ]] && inst_simple "$srcmods/$_f" "/lib/modules/$kernel/$_f"
|
||||
+ [[ -e $srcmods/$_f ]] && inst_simple "$srcmods/$_f" "/lib/modules/$kernel/$_f"
|
||||
done
|
||||
|
||||
# generate module dependencies for the initrd
|
||||
diff --git a/modules.d/90crypt/crypt-lib.sh b/modules.d/90crypt/crypt-lib.sh
|
||||
index 532b9a71..bbf485e0 100755
|
||||
--- a/modules.d/90crypt/crypt-lib.sh
|
||||
+++ b/modules.d/90crypt/crypt-lib.sh
|
||||
@@ -12,7 +12,7 @@ crypttab_contains() {
|
||||
strstr "${l##luks-}" "${luks##luks-}" && return 0
|
||||
strstr "$d" "${luks##luks-}" && return 0
|
||||
if [ -n "$dev" ]; then
|
||||
- for _dev in "$(devnames $d)"; do
|
||||
+ for _dev in $(devnames $d); do
|
||||
[ "$dev" -ef "$_dev" ] && return 0
|
||||
done
|
||||
fi
|
||||
diff --git a/modules.d/98syslog/parse-syslog-opts.sh b/modules.d/98syslog/parse-syslog-opts.sh
|
||||
index 50ec2759..9ec6ad47 100755
|
||||
--- a/modules.d/98syslog/parse-syslog-opts.sh
|
||||
+++ b/modules.d/98syslog/parse-syslog-opts.sh
|
||||
@@ -15,7 +15,7 @@ detect_syslog() {
|
||||
syslogtype="rsyslogd"
|
||||
elif [ -e /sbin/syslogd ]; then
|
||||
syslogtype="syslogd"
|
||||
- elif [ /sbin/syslog-ng ]; then
|
||||
+ elif [ -e /sbin/syslog-ng ]; then
|
||||
syslogtype="syslog-ng"
|
||||
else
|
||||
warn "Could not find any syslog binary although the syslogmodule is selected to be installed. Please check."
|
||||
|
21
0007.patch
Normal file
21
0007.patch
Normal file
@ -0,0 +1,21 @@
|
||||
From f8e0c7cc6296909cff92f718ed360ff9ef1f7bae Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Mon, 5 Mar 2018 09:55:39 +0100
|
||||
Subject: [PATCH] kernel-modules: add mmc/core for arm
|
||||
|
||||
---
|
||||
modules.d/90kernel-modules/module-setup.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
|
||||
index 94592e6b..7de44735 100755
|
||||
--- a/modules.d/90kernel-modules/module-setup.sh
|
||||
+++ b/modules.d/90kernel-modules/module-setup.sh
|
||||
@@ -36,6 +36,7 @@ installkernel() {
|
||||
"=drivers/hwspinlock" \
|
||||
"=drivers/i2c/busses" \
|
||||
"=drivers/mfd" \
|
||||
+ "=drivers/mmc/core" \
|
||||
"=drivers/phy" \
|
||||
"=drivers/power" \
|
||||
"=drivers/regulator" \
|
15
dracut.spec
15
dracut.spec
@ -14,7 +14,7 @@
|
||||
%define with_nbd 0
|
||||
%endif
|
||||
|
||||
%define dist_free_release 2
|
||||
%define dist_free_release 8.git20180305
|
||||
|
||||
Name: dracut
|
||||
Version: 047
|
||||
@ -37,8 +37,13 @@ URL: https://dracut.wiki.kernel.org/
|
||||
# Source can be generated by
|
||||
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=%%{version};sf=tgz
|
||||
Source0: http://www.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001.patch
|
||||
Patch2: 0002.patch
|
||||
Patch3: 0003.patch
|
||||
Patch4: 0004.patch
|
||||
Patch5: 0005.patch
|
||||
Patch6: 0006.patch
|
||||
Patch7: 0007.patch
|
||||
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
|
||||
@ -54,9 +59,6 @@ BuildRequires: pkgconfig
|
||||
BuildRequires: bash-completion
|
||||
%endif
|
||||
|
||||
%if 0%{?suse_version}
|
||||
%endif
|
||||
|
||||
%if %{with doc}
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
BuildRequires: docbook-style-xsl docbook-dtds libxslt
|
||||
@ -539,6 +541,9 @@ echo 'dracut_rescue_image="yes"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Mar 05 2018 Harald Hoyer <harald@redhat.com> - 047-8
|
||||
- git snapshot
|
||||
|
||||
* Tue Feb 27 2018 Javier Martinez Canillas <javierm@redhat.com> - 047-2
|
||||
- Allow generating initramfs images on the /boot directory
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user