dracut - 046-36
- git snapshot
This commit is contained in:
parent
b3dfe76019
commit
d88ded4f5a
@ -62,3 +62,4 @@ index 62babb2b..7723f6fa 100755
|
||||
|
||||
inst_opt_decompress ${kbddir}/consolefonts/${DEFAULT_FONT}.*
|
||||
|
||||
|
||||
|
33
0035.patch
Normal file
33
0035.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From a13e97e5110121e38f9a6d9550b5ac07250a37af Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Thu, 30 Nov 2017 15:07:48 +0100
|
||||
Subject: [PATCH] dracut-install: remove double "//" in path names
|
||||
|
||||
makes relative symlinks shorter
|
||||
---
|
||||
install/dracut-install.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/install/dracut-install.c b/install/dracut-install.c
|
||||
index 82e882cc..90077226 100644
|
||||
--- a/install/dracut-install.c
|
||||
+++ b/install/dracut-install.c
|
||||
@@ -633,7 +633,7 @@ static int dracut_install(const char *src, const char *dst, bool isdir, bool res
|
||||
|
||||
hashmap_put(items, i, i);
|
||||
|
||||
- ret = asprintf(&fulldstpath, "%s/%s", destrootdir, dst);
|
||||
+ ret = asprintf(&fulldstpath, "%s/%s", destrootdir, (dst[0]=='/' ? (dst+1) : dst));
|
||||
if (ret < 0) {
|
||||
log_error("Out of memory!");
|
||||
exit(EXIT_FAILURE);
|
||||
@@ -720,7 +720,7 @@ static int dracut_install(const char *src, const char *dst, bool isdir, bool res
|
||||
if (lstat(fulldstpath, &sb) != 0) {
|
||||
_cleanup_free_ char *absdestpath = NULL;
|
||||
|
||||
- ret = asprintf(&absdestpath, "%s/%s", destrootdir, abspath);
|
||||
+ ret = asprintf(&absdestpath, "%s/%s", destrootdir, (abspath[0]=='/' ? (abspath+1) : abspath));
|
||||
if (ret < 0) {
|
||||
log_error("Out of memory!");
|
||||
exit(EXIT_FAILURE);
|
||||
|
32
0036.patch
Normal file
32
0036.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 96d69bbf34901e054d5f06f14224ae5094804103 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@hoyer.xyz>
|
||||
Date: Fri, 1 Dec 2017 09:13:53 +0100
|
||||
Subject: [PATCH] Merge pull request #309 from danimo/multipath_bin_error
|
||||
|
||||
Fix warning about multipath if not needed
|
||||
---
|
||||
modules.d/90multipath/module-setup.sh | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/modules.d/90multipath/module-setup.sh b/modules.d/90multipath/module-setup.sh
|
||||
index 28857ebc..0a680b17 100755
|
||||
--- a/modules.d/90multipath/module-setup.sh
|
||||
+++ b/modules.d/90multipath/module-setup.sh
|
||||
@@ -10,13 +10,14 @@ is_mpath() {
|
||||
# called by dracut
|
||||
check() {
|
||||
local _rootdev
|
||||
- # if there's no multipath binary, no go.
|
||||
- require_binaries multipath || return 1
|
||||
|
||||
[[ $hostonly ]] || [[ $mount_needs ]] && {
|
||||
for_each_host_dev_and_slaves is_mpath || return 255
|
||||
}
|
||||
|
||||
+ # if there's no multipath binary, no go.
|
||||
+ require_binaries multipath || return 1
|
||||
+
|
||||
return 0
|
||||
}
|
||||
|
||||
|
23
0037.patch
Normal file
23
0037.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 84fe3c1a20544fbc46d54854ffb516947d751adf Mon Sep 17 00:00:00 2001
|
||||
From: Robert Scheck <robert@fedoraproject.org>
|
||||
Date: Fri, 1 Dec 2017 14:18:18 +0100
|
||||
Subject: [PATCH] Add fuse/ntfs-3g run-time dependencies for -live subpackage
|
||||
|
||||
---
|
||||
dracut.spec | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/dracut.spec b/dracut.spec
|
||||
index 855adba6..03363fb2 100644
|
||||
--- a/dracut.spec
|
||||
+++ b/dracut.spec
|
||||
@@ -202,6 +202,9 @@ Requires: %{name} = %{version}-%{release}
|
||||
%endif
|
||||
Requires: %{name}-network = %{version}-%{release}
|
||||
Requires: tar gzip coreutils bash device-mapper curl
|
||||
+%if 0%{?fedora}
|
||||
+Requires: fuse ntfs-3g
|
||||
+%endif
|
||||
|
||||
%description live
|
||||
This package requires everything which is needed to build an
|
11
dracut.spec
11
dracut.spec
@ -14,7 +14,7 @@
|
||||
%define with_nbd 0
|
||||
%endif
|
||||
|
||||
%define dist_free_release 33.git20171127
|
||||
%define dist_free_release 36.git20171201
|
||||
|
||||
Name: dracut
|
||||
Version: 046
|
||||
@ -69,6 +69,9 @@ Patch29: 0031.patch
|
||||
Patch30: 0032.patch
|
||||
Patch31: 0033.patch
|
||||
Patch32: 0034.patch
|
||||
Patch33: 0035.patch
|
||||
Patch34: 0036.patch
|
||||
Patch35: 0037.patch
|
||||
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
|
||||
@ -235,6 +238,9 @@ Requires: %{name} = %{version}-%{release}
|
||||
%endif
|
||||
Requires: %{name}-network = %{version}-%{release}
|
||||
Requires: tar gzip coreutils bash device-mapper curl
|
||||
%if 0%{?fedora}
|
||||
Requires: fuse ntfs-3g
|
||||
%endif
|
||||
|
||||
%description live
|
||||
This package requires everything which is needed to build an
|
||||
@ -548,6 +554,9 @@ rm -rf -- $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 01 2017 Harald Hoyer <harald@redhat.com> - 046-36
|
||||
- git snapshot
|
||||
|
||||
* Wed Nov 29 2017 Harald Hoyer <harald@redhat.com> - 046-33
|
||||
- git snapshot
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user