- do not write dracut.log to /tmp under any circumstances
- touch /dev/.systemd/plymouth after plymouth started
This commit is contained in:
parent
e2db08adf3
commit
cc91be1122
@ -0,0 +1,23 @@
|
||||
From 52889453c13258b3fd036bbb7a8b37df132505e3 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Tue, 8 Feb 2011 17:59:48 +0100
|
||||
Subject: [PATCH] dracut-functions: write to $HOME/dracut.log instead of /tmp/dracut.log
|
||||
|
||||
---
|
||||
dracut-functions | 3 +--
|
||||
1 files changed, 1 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dracut-functions b/dracut-functions
|
||||
index e80a638..9ac0bba 100755
|
||||
--- a/dracut-functions
|
||||
+++ b/dracut-functions
|
||||
@@ -65,8 +65,7 @@ is_func() {
|
||||
if ! [[ $dracutlogfile ]]; then
|
||||
[[ $dracutbasedir = /usr/share/dracut ]] && \
|
||||
dracutlogfile=/var/log/dracut.log || \
|
||||
- dracutlogfile=/tmp/dracut.log
|
||||
-# [[ -w $dracutlogfile ]] || dracutlogfile=/tmp/dracut.log
|
||||
+ dracutlogfile=$HOME/dracut.log
|
||||
if [[ -w $dracutlogfile ]]; then
|
||||
>"$dracutlogfile"
|
||||
fi
|
22
0002-dracut.8.xml-corrected-typo.patch
Normal file
22
0002-dracut.8.xml-corrected-typo.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From c965ed2db4062044ba43e78b28376f572878e2bf Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Tue, 8 Feb 2011 18:06:25 +0100
|
||||
Subject: [PATCH] dracut.8.xml: corrected typo
|
||||
|
||||
---
|
||||
dracut.8.xml | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/dracut.8.xml b/dracut.8.xml
|
||||
index 34b3986..26e575b 100644
|
||||
--- a/dracut.8.xml
|
||||
+++ b/dracut.8.xml
|
||||
@@ -298,7 +298,7 @@ Default:
|
||||
<para>activates the local mode. dracut will use modules from the current working
|
||||
directory instead of the system-wide installed modules in
|
||||
<filename>/usr/share/dracut/modules.d</filename>.
|
||||
-Thsi is useful when running dracut from a git checkout.</para>
|
||||
+This is useful when running dracut from a git checkout.</para>
|
||||
</listitem>
|
||||
</varlistentry>
|
||||
<varlistentry>
|
24
0003-plymouth-touch-dev-.systemd-plymouth.patch
Normal file
24
0003-plymouth-touch-dev-.systemd-plymouth.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From 1cedde068192af7536479ff5fb159c75fc7d7ed6 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 9 Feb 2011 13:22:49 +0100
|
||||
Subject: [PATCH] plymouth: touch /dev/.systemd/plymouth
|
||||
|
||||
until plymouth does it itsself, touch /dev/.systemd/plymouth
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=676302
|
||||
---
|
||||
modules.d/50plymouth/plymouth-pretrigger.sh | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/modules.d/50plymouth/plymouth-pretrigger.sh b/modules.d/50plymouth/plymouth-pretrigger.sh
|
||||
index 0800dbc..c224875 100755
|
||||
--- a/modules.d/50plymouth/plymouth-pretrigger.sh
|
||||
+++ b/modules.d/50plymouth/plymouth-pretrigger.sh
|
||||
@@ -18,6 +18,8 @@ if getargbool 1 rd.plymouth -n rd_NO_PLYMOUTH; then
|
||||
|
||||
info "Starting plymouth daemon"
|
||||
[ -x /bin/plymouthd ] && /bin/plymouthd --attach-to-session
|
||||
+ mkdir -m 0755 /dev/.systemd >/dev/null 2>&1
|
||||
+ >/dev/.systemd/plymouth
|
||||
/lib/udev/console_init tty0
|
||||
/bin/plymouth --show-splash 2>&1 | vinfo
|
||||
fi
|
20
dracut.spec
20
dracut.spec
@ -6,17 +6,9 @@
|
||||
%define with_nbd 0
|
||||
%endif
|
||||
|
||||
%if %{defined gittag}
|
||||
%define rdist .git%{gittag}%{?dist}
|
||||
%define dashgittag -%{gittag}
|
||||
%else
|
||||
%define rdist %{?dist}
|
||||
%endif
|
||||
|
||||
Name: dracut
|
||||
Version: 008
|
||||
%define release_prefix 1%{?rdist}
|
||||
Release: %{release_prefix}.1
|
||||
Release: 2
|
||||
|
||||
Summary: Initramfs generator using udev
|
||||
%if 0%{?fedora}
|
||||
@ -90,6 +82,9 @@ Requires: plymouth >= 0.8.0-0.2009.29.09.19.1
|
||||
Requires: util-linux >= 2.16
|
||||
%endif
|
||||
|
||||
Patch1: 0001-dracut-functions-write-to-HOME-dracut.log-instead-of.patch
|
||||
Patch2: 0002-dracut.8.xml-corrected-typo.patch
|
||||
Patch3: 0003-plymouth-touch-dev-.systemd-plymouth.patch
|
||||
|
||||
%description
|
||||
Dracut contains tools to create a bootable initramfs for 2.6 Linux kernels.
|
||||
@ -153,6 +148,9 @@ This package contains tools to assemble the local initrd and host configuration.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?dashgittag}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
make WITH_SWITCH_ROOT=0%{?with_switch_root}
|
||||
@ -277,6 +275,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir /var/lib/dracut/overlay
|
||||
|
||||
%changelog
|
||||
* Wed Feb 09 2011 Harald Hoyer <harald@redhat.com> 008-2
|
||||
- do not write dracut.log to /tmp under any circumstances
|
||||
- touch /dev/.systemd/plymouth after plymouth started
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 008-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user