dracut-049-231.git20231115
Resolves: RHEL-11779,RHEL-12408,RHEL-16551
This commit is contained in:
parent
e5890b4d2d
commit
c3daab614d
33
0228.patch
Normal file
33
0228.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 9f4ce92bdf294cb69991c974ba440f286b43acd4 Mon Sep 17 00:00:00 2001
|
||||
From: Wenchao Hao <haowenchao@huawei.com>
|
||||
Date: Fri, 29 Apr 2022 14:09:02 +0800
|
||||
Subject: [PATCH] fix(iscsi): do not exit in handle_netroot() if discovery
|
||||
failed
|
||||
|
||||
User may specify multiple netroot in cmdline, failed to connect one netroot
|
||||
do not mean all netroot are not accessible. So if one netroot failed, do
|
||||
not exit the discovery and login flow.
|
||||
|
||||
Signed-off-by: Wenchao Hao <haowenchao@huawei.com>
|
||||
|
||||
(Cherry-picked commit: 319dc7fe10585a19d1a051f8ad1ba0190f86ff1f)
|
||||
|
||||
Resolves: RHEL-11779
|
||||
---
|
||||
modules.d/95iscsi/iscsiroot.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/modules.d/95iscsi/iscsiroot.sh b/modules.d/95iscsi/iscsiroot.sh
|
||||
index 6a12a108..029060e0 100755
|
||||
--- a/modules.d/95iscsi/iscsiroot.sh
|
||||
+++ b/modules.d/95iscsi/iscsiroot.sh
|
||||
@@ -211,7 +211,7 @@ handle_netroot()
|
||||
fi
|
||||
|
||||
targets=$(iscsiadm -m discovery -t st -p $iscsi_target_ip:${iscsi_target_port:+$iscsi_target_port} | sed 's/^.*iqn/iqn/')
|
||||
- [ -z "$targets" ] && echo "Target discovery to $iscsi_target_ip:${iscsi_target_port:+$iscsi_target_port} failed with status $?" && exit 1
|
||||
+ [ -z "$targets" ] && echo "Target discovery to $iscsi_target_ip:${iscsi_target_port:+$iscsi_target_port} failed with status $?" && return 1
|
||||
|
||||
found=
|
||||
for target in $targets; do
|
||||
|
28
0229.patch
Normal file
28
0229.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 243dcc41710cb8475ec4188b39fca98258baac99 Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
|
||||
Date: Thu, 1 Sep 2022 11:47:09 +0200
|
||||
Subject: [PATCH] feat(systemd): install systemd-sysroot-fstab-check
|
||||
|
||||
systemd-sysroot-fstab-check is a symlink to systemd-fstab-generator added in
|
||||
systemd commit https://github.com/systemd/systemd/commit/cd7ad0cb
|
||||
|
||||
(cherry picked from commit 23684e4a2bb024595ad63d9f49d83b4693537110)
|
||||
|
||||
Resolves: RHEL-12408
|
||||
---
|
||||
modules.d/00systemd/module-setup.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/00systemd/module-setup.sh b/modules.d/00systemd/module-setup.sh
|
||||
index 38c244a2..1e75afbc 100755
|
||||
--- a/modules.d/00systemd/module-setup.sh
|
||||
+++ b/modules.d/00systemd/module-setup.sh
|
||||
@@ -47,6 +47,7 @@ install() {
|
||||
$systemdutildir/systemd-sysctl \
|
||||
$systemdutildir/systemd-modules-load \
|
||||
$systemdutildir/systemd-vconsole-setup \
|
||||
+ $systemdutildir/systemd-sysroot-fstab-check \
|
||||
$systemdutildir/system-generators/systemd-fstab-generator \
|
||||
$systemdutildir/system-generators/systemd-gpt-auto-generator \
|
||||
\
|
||||
|
57
0230.patch
Normal file
57
0230.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From 81b6ee891bae6b2b0271f8449f7fd698e278c40a Mon Sep 17 00:00:00 2001
|
||||
From: Pavel Valena <pvalena@redhat.com>
|
||||
Date: Wed, 7 Jun 2023 22:12:45 +0200
|
||||
Subject: [PATCH] fix(fcoe-uefi): exit early on empty vlan
|
||||
|
||||
Exit early in case get_fcoe_boot_vlan exits with error or just an empty string,
|
||||
instead of producing invalid config entry.
|
||||
|
||||
(Cherry-picked commit: 45fc8df1cf3fdf9726efda4d26c7cccb9e6aedd2)
|
||||
|
||||
Resolves: RHEL-16551
|
||||
---
|
||||
modules.d/95fcoe-uefi/parse-uefifcoe.sh | 31 +++++++++++++++++--------------
|
||||
1 file changed, 17 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/modules.d/95fcoe-uefi/parse-uefifcoe.sh b/modules.d/95fcoe-uefi/parse-uefifcoe.sh
|
||||
index 87d49660..02fab138 100755
|
||||
--- a/modules.d/95fcoe-uefi/parse-uefifcoe.sh
|
||||
+++ b/modules.d/95fcoe-uefi/parse-uefifcoe.sh
|
||||
@@ -9,20 +9,23 @@ print_fcoe_uefi_conf()
|
||||
local mac dev vlan
|
||||
mac=$(get_fcoe_boot_mac "$1")
|
||||
[ -z "$mac" ] && return 1
|
||||
- dev=$(set_ifname fcoe $mac)
|
||||
- vlan=$(get_fcoe_boot_vlan "$1")
|
||||
- if [ "$vlan" -ne "0" ]; then
|
||||
- case "$vlan" in
|
||||
- [0-9]*)
|
||||
- printf "%s\n" "vlan=$dev.$vlan:$dev"
|
||||
- dev="$dev.$vlan"
|
||||
- ;;
|
||||
- *)
|
||||
- printf "%s\n" "vlan=$vlan:$dev"
|
||||
- dev="$vlan"
|
||||
- ;;
|
||||
- esac
|
||||
- fi
|
||||
+ dev=$(set_ifname fcoe "$mac")
|
||||
+ vlan=$(get_fcoe_boot_vlan "$1") || return 1
|
||||
+ case "$vlan" in
|
||||
+ "0") ;;
|
||||
+
|
||||
+ '')
|
||||
+ return 1
|
||||
+ ;;
|
||||
+ [0-9]*)
|
||||
+ printf "%s\n" "vlan=$dev.$vlan:$dev"
|
||||
+ dev="$dev.$vlan"
|
||||
+ ;;
|
||||
+ *)
|
||||
+ printf "%s\n" "vlan=$vlan:$dev"
|
||||
+ dev="$vlan"
|
||||
+ ;;
|
||||
+ esac
|
||||
# fcoe=eth0:nodcb
|
||||
printf "fcoe=%s\n" "$dev:nodcb"
|
||||
return 0
|
10
dracut.spec
10
dracut.spec
@ -5,7 +5,7 @@
|
||||
# strip the automatically generated dep here and instead co-own the
|
||||
# directory.
|
||||
%global __requires_exclude pkg-config
|
||||
%define dist_free_release 228.git20230802
|
||||
%define dist_free_release 231.git20231115
|
||||
|
||||
Name: dracut
|
||||
Version: 049
|
||||
@ -255,6 +255,9 @@ Patch224: 0224.patch
|
||||
Patch225: 0225.patch
|
||||
Patch226: 0226.patch
|
||||
Patch227: 0227.patch
|
||||
Patch228: 0228.patch
|
||||
Patch229: 0229.patch
|
||||
Patch230: 0230.patch
|
||||
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
|
||||
@ -710,6 +713,11 @@ echo '# Since rhel-8.3 dracut moved to use NetworkManager
|
||||
add_dracutmodules+=" network-legacy "' > /etc/dracut.conf.d/50-network-legacy.conf
|
||||
|
||||
%changelog
|
||||
* Thu Nov 16 2023 Pavel Valena <pvalena@redhat.com> - 049-231.git20231115
|
||||
- fix(iscsi): do not exit in handle_netroot() if discovery
|
||||
- feat(systemd): install systemd-sysroot-fstab-check
|
||||
- fix(fcoe-uefi): exit early on empty vlan
|
||||
|
||||
* Wed Aug 02 2023 Lukas Nykryn <lnykryn@redhat.com> - 049-228.git20230802
|
||||
- feat(qemu): include the virtio_mem kernel module
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user