- fixed missing grep for md
- reorder cleanup
This commit is contained in:
parent
c518b61785
commit
831665e53b
24
0005-mdraid-add-grep-for-convenience.patch
Normal file
24
0005-mdraid-add-grep-for-convenience.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From 429aa1a2c29dd42fbc91e956a8a77675773cc46d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Harald Hoyer <harald@redhat.com>
|
||||||
|
Date: Thu, 3 Sep 2009 17:11:03 +0200
|
||||||
|
Subject: [PATCH 5/6] mdraid: add grep for convenience
|
||||||
|
|
||||||
|
---
|
||||||
|
modules.d/90mdraid/install | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/modules.d/90mdraid/install b/modules.d/90mdraid/install
|
||||||
|
index 60f289a..497e5b0 100755
|
||||||
|
--- a/modules.d/90mdraid/install
|
||||||
|
+++ b/modules.d/90mdraid/install
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
-dracut_install mdadm partx
|
||||||
|
+dracut_install mdadm partx grep
|
||||||
|
|
||||||
|
|
||||||
|
# XXX: mdmon really needs to run as non-root?
|
||||||
|
--
|
||||||
|
1.6.2.5
|
||||||
|
|
@ -0,0 +1,58 @@
|
|||||||
|
From e4dec3d6b66ad6cc3c5b0646459c4ba2db1808b7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Harald Hoyer <harald@redhat.com>
|
||||||
|
Date: Thu, 3 Sep 2009 17:11:57 +0200
|
||||||
|
Subject: [PATCH 6/6] {crypt,dmraid,lvm,mdraid}: cleanup with pre-pivot 30 and 31
|
||||||
|
|
||||||
|
---
|
||||||
|
modules.d/90crypt/install | 2 +-
|
||||||
|
modules.d/90dmraid/install | 2 +-
|
||||||
|
modules.d/90lvm/install | 2 +-
|
||||||
|
modules.d/90mdraid/install | 2 +-
|
||||||
|
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/modules.d/90crypt/install b/modules.d/90crypt/install
|
||||||
|
index 5108fef..b15440c 100755
|
||||||
|
--- a/modules.d/90crypt/install
|
||||||
|
+++ b/modules.d/90crypt/install
|
||||||
|
@@ -4,4 +4,4 @@ inst_rules "$moddir/70-luks.rules"
|
||||||
|
inst "$moddir"/cryptroot-ask.sh /sbin/cryptroot-ask
|
||||||
|
inst_hook cmdline 30 "$moddir/parse-crypt.sh"
|
||||||
|
inst_hook pre-pivot 30 "$moddir/crypt-cleanup.sh"
|
||||||
|
-inst_hook pre-pivot 60 "$moddir/crypt-cleanup.sh"
|
||||||
|
+inst_hook pre-pivot 31 "$moddir/crypt-cleanup.sh"
|
||||||
|
diff --git a/modules.d/90dmraid/install b/modules.d/90dmraid/install
|
||||||
|
index 704728b..b66257c 100755
|
||||||
|
--- a/modules.d/90dmraid/install
|
||||||
|
+++ b/modules.d/90dmraid/install
|
||||||
|
@@ -4,4 +4,4 @@ inst "$moddir/dmraid.sh" /sbin/dmraid_scan
|
||||||
|
inst_rules 64-md-raid.rules
|
||||||
|
inst_rules "$moddir/61-dmraid-imsm.rules"
|
||||||
|
inst_hook pre-pivot 30 "$moddir/dmraid-cleanup.sh"
|
||||||
|
-inst_hook pre-pivot 60 "$moddir/dmraid-cleanup.sh"
|
||||||
|
+inst_hook pre-pivot 31 "$moddir/dmraid-cleanup.sh"
|
||||||
|
diff --git a/modules.d/90lvm/install b/modules.d/90lvm/install
|
||||||
|
index eb27159..ad4d2e2 100755
|
||||||
|
--- a/modules.d/90lvm/install
|
||||||
|
+++ b/modules.d/90lvm/install
|
||||||
|
@@ -13,4 +13,4 @@ fi
|
||||||
|
inst "$moddir/lvm_scan.sh" /sbin/lvm_scan
|
||||||
|
inst_hook cmdline 30 "$moddir/parse-lvm.sh"
|
||||||
|
inst_hook pre-pivot 30 "$moddir/lvm-cleanup.sh"
|
||||||
|
-inst_hook pre-pivot 60 "$moddir/lvm-cleanup.sh"
|
||||||
|
\ No newline at end of file
|
||||||
|
+inst_hook pre-pivot 31 "$moddir/lvm-cleanup.sh"
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/modules.d/90mdraid/install b/modules.d/90mdraid/install
|
||||||
|
index 497e5b0..71c313b 100755
|
||||||
|
--- a/modules.d/90mdraid/install
|
||||||
|
+++ b/modules.d/90mdraid/install
|
||||||
|
@@ -34,4 +34,4 @@ fi
|
||||||
|
inst "$moddir/mdraid_start.sh" /sbin/mdraid_start
|
||||||
|
inst_hook pre-trigger 30 "$moddir/parse-md.sh"
|
||||||
|
inst_hook pre-pivot 30 "$moddir/mdraid-cleanup.sh"
|
||||||
|
-inst_hook pre-pivot 60 "$moddir/mdraid-cleanup.sh"
|
||||||
|
\ No newline at end of file
|
||||||
|
+inst_hook pre-pivot 31 "$moddir/mdraid-cleanup.sh"
|
||||||
|
--
|
||||||
|
1.6.2.5
|
||||||
|
|
14
dracut.spec
14
dracut.spec
@ -13,12 +13,17 @@
|
|||||||
|
|
||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 001
|
Version: 001
|
||||||
Release: 1%{?rdist}
|
Release: 2%{?rdist}
|
||||||
Summary: Initramfs generator using udev
|
Summary: Initramfs generator using udev
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://apps.sourceforge.net/trac/dracut/wiki
|
URL: http://apps.sourceforge.net/trac/dracut/wiki
|
||||||
Source0: dracut-%{version}%{?dashgittag}.tar.bz2
|
Source0: dracut-%{version}%{?dashgittag}.tar.bz2
|
||||||
|
|
||||||
|
Patch1: 0005-mdraid-add-grep-for-convenience.patch
|
||||||
|
Patch2: 0006--crypt-dmraid-lvm-mdraid-cleanup-with-pre-pivot-30.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: udev
|
Requires: udev
|
||||||
Requires: util-linux-ng
|
Requires: util-linux-ng
|
||||||
@ -102,11 +107,12 @@ This package contains tools to assemble the local initrd and host configuration.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?dashgittag}
|
%setup -q -n %{name}-%{version}%{?dashgittag}
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make
|
make
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
|
make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
|
||||||
@ -179,6 +185,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir /var/lib/dracut/overlay
|
%dir /var/lib/dracut/overlay
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
|
||||||
|
- fixed missing grep for md
|
||||||
|
- reorder cleanup
|
||||||
|
|
||||||
* Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
|
* Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
|
||||||
- version 001
|
- version 001
|
||||||
- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
|
- see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
|
||||||
|
Loading…
Reference in New Issue
Block a user