dracut-031-24.git20130809
- fixed logging to journal - fixed lsinitrd
This commit is contained in:
parent
f8c4a0f4e5
commit
7b4bfbae93
23
0022-lsinitrd.sh-fixed-case.patch
Normal file
23
0022-lsinitrd.sh-fixed-case.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From d93fe0fa35d29762a21a44a9644ba37e352e8b7a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Harald Hoyer <harald@redhat.com>
|
||||||
|
Date: Fri, 9 Aug 2013 15:35:20 +0200
|
||||||
|
Subject: [PATCH] lsinitrd.sh: fixed case
|
||||||
|
|
||||||
|
---
|
||||||
|
lsinitrd.sh | 3 +--
|
||||||
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lsinitrd.sh b/lsinitrd.sh
|
||||||
|
index ef1c262..faad99a 100755
|
||||||
|
--- a/lsinitrd.sh
|
||||||
|
+++ b/lsinitrd.sh
|
||||||
|
@@ -109,8 +109,7 @@ case $bin in
|
||||||
|
CAT="zcat";;
|
||||||
|
BZh*)
|
||||||
|
CAT="bzcat";;
|
||||||
|
- $'\x71\xc7'*)
|
||||||
|
- 070701)
|
||||||
|
+ $'\x71\xc7'*|070701)
|
||||||
|
CAT="cat";;
|
||||||
|
*)
|
||||||
|
CAT="xzcat";
|
@ -0,0 +1,55 @@
|
|||||||
|
From 3e6c9011d0f42e19c1c5e2b04b41073100edcf14 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Harald Hoyer <harald@redhat.com>
|
||||||
|
Date: Fri, 9 Aug 2013 15:47:30 +0200
|
||||||
|
Subject: [PATCH] dracut-logger.sh: do not unset logging messages if sysloglvl
|
||||||
|
is set
|
||||||
|
|
||||||
|
---
|
||||||
|
dracut-logger.sh | 12 ++++++------
|
||||||
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/dracut-logger.sh b/dracut-logger.sh
|
||||||
|
index f4dcdb8..ff23301 100755
|
||||||
|
--- a/dracut-logger.sh
|
||||||
|
+++ b/dracut-logger.sh
|
||||||
|
@@ -173,34 +173,34 @@ dlog_init() {
|
||||||
|
export maxloglvl
|
||||||
|
|
||||||
|
|
||||||
|
- if (($stdloglvl < 6)) && (($kmsgloglvl < 6)) && (($fileloglvl < 6)); then
|
||||||
|
+ if (($stdloglvl < 6)) && (($kmsgloglvl < 6)) && (($fileloglvl < 6)) && (($sysloglvl < 6)); then
|
||||||
|
unset dtrace
|
||||||
|
dtrace() { :; };
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if (($stdloglvl < 5)) && (($kmsgloglvl < 5)) && (($fileloglvl < 5)); then
|
||||||
|
+ if (($stdloglvl < 5)) && (($kmsgloglvl < 5)) && (($fileloglvl < 5)) && (($sysloglvl < 5)); then
|
||||||
|
unset ddebug
|
||||||
|
ddebug() { :; };
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if (($stdloglvl < 4)) && (($kmsgloglvl < 4)) && (($fileloglvl < 4)); then
|
||||||
|
+ if (($stdloglvl < 4)) && (($kmsgloglvl < 4)) && (($fileloglvl < 4)) && (($sysloglvl < 4)); then
|
||||||
|
unset dinfo
|
||||||
|
dinfo() { :; };
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if (($stdloglvl < 3)) && (($kmsgloglvl < 3)) && (($fileloglvl < 3)); then
|
||||||
|
+ if (($stdloglvl < 3)) && (($kmsgloglvl < 3)) && (($fileloglvl < 3)) && (($sysloglvl < 3)); then
|
||||||
|
unset dwarn
|
||||||
|
dwarn() { :; };
|
||||||
|
unset dwarning
|
||||||
|
dwarning() { :; };
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if (($stdloglvl < 2)) && (($kmsgloglvl < 2)) && (($fileloglvl < 2)); then
|
||||||
|
+ if (($stdloglvl < 2)) && (($kmsgloglvl < 2)) && (($fileloglvl < 2)) && (($sysloglvl < 2)); then
|
||||||
|
unset derror
|
||||||
|
derror() { :; };
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if (($stdloglvl < 1)) && (($kmsgloglvl < 1)) && (($fileloglvl < 1)); then
|
||||||
|
+ if (($stdloglvl < 1)) && (($kmsgloglvl < 1)) && (($fileloglvl < 1)) && (($sysloglvl < 1)); then
|
||||||
|
unset dfatal
|
||||||
|
dfatal() { :; };
|
||||||
|
fi
|
10
dracut.spec
10
dracut.spec
@ -10,7 +10,7 @@
|
|||||||
|
|
||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 031
|
Version: 031
|
||||||
Release: 22.git20130809%{?dist}
|
Release: 24.git20130809%{?dist}
|
||||||
|
|
||||||
Summary: Initramfs generator using udev
|
Summary: Initramfs generator using udev
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
@ -50,6 +50,8 @@ Patch18: 0018-network-net-lib.sh-fix-ibft-interface-configuration.patch
|
|||||||
Patch19: 0019-iscsi-module-setup.sh-install-some-modules-regardles.patch
|
Patch19: 0019-iscsi-module-setup.sh-install-some-modules-regardles.patch
|
||||||
Patch20: 0020-multipath-need_shutdown-if-multipath-devices-exist.patch
|
Patch20: 0020-multipath-need_shutdown-if-multipath-devices-exist.patch
|
||||||
Patch21: 0021-omit-drivers-fix.patch
|
Patch21: 0021-omit-drivers-fix.patch
|
||||||
|
Patch22: 0022-lsinitrd.sh-fixed-case.patch
|
||||||
|
Patch23: 0023-dracut-logger.sh-do-not-unset-logging-messages-if-sy.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: bash git
|
BuildRequires: bash git
|
||||||
@ -465,6 +467,12 @@ rm -rf -- $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 09 2013 Harald Hoyer <harald@redhat.com> 031-24.git20130809
|
||||||
|
- fixed logging to journal
|
||||||
|
|
||||||
|
* Fri Aug 09 2013 Harald Hoyer <harald@redhat.com> 031-23.git20130809
|
||||||
|
- fixed lsinitrd
|
||||||
|
|
||||||
* Fri Aug 09 2013 Harald Hoyer <harald@redhat.com> 031-22.git20130809
|
* Fri Aug 09 2013 Harald Hoyer <harald@redhat.com> 031-22.git20130809
|
||||||
- lsinitrd.sh: add old cpio signature
|
- lsinitrd.sh: add old cpio signature
|
||||||
- dracut.sh: call find with -print0 and cpio with --null
|
- dracut.sh: call find with -print0 and cpio with --null
|
||||||
|
Loading…
Reference in New Issue
Block a user