import dracut-049-136.git20210426.el8

This commit is contained in:
CentOS Sources 2021-05-06 14:16:03 +00:00 committed by Andrew Lukoshko
parent 19b7cf2912
commit 65b87aac39
3 changed files with 121 additions and 2 deletions

View File

@ -40,3 +40,4 @@ index 8bb55c6e..86f4331e 100755
info "rd.nofcoe=0: skipping fcoe"
return 0
fi

115
SOURCES/0135.patch Normal file
View File

@ -0,0 +1,115 @@
From 2fe454f21b6b3890b02f52810a662530ec019968 Mon Sep 17 00:00:00 2001
From: mulhern <amulhern@redhat.com>
Date: Wed, 19 Aug 2020 11:11:14 -0400
Subject: [PATCH] Remove stratis module
It is obsolete. An approach which does not start the daemon is being worked
on.
Signed-off-by: mulhern <amulhern@redhat.com>
(cherry picked from commit fe761330e5db60f19f0ab2d937ea71a5b2438656)
Cherry-picked from: fe761330e5db60f19f0ab2d937ea71a5b2438656
Resolves: #1950572
---
dracut.spec | 1 -
modules.d/90stratis/module-setup.sh | 33 -------------------------------
modules.d/90stratis/stratisd-init.service | 15 --------------
modules.d/90stratis/stratisd-start.sh | 3 ---
modules.d/90stratis/stratisd-stop.sh | 6 ------
5 files changed, 58 deletions(-)
diff --git a/dracut.spec b/dracut.spec
index fa3e4b99..dcaafa61 100644
--- a/dracut.spec
+++ b/dracut.spec
@@ -365,7 +365,6 @@ install -m 0755 51-dracut-rescue-postinst.sh $RPM_BUILD_ROOT%{_sysconfdir}/kerne
%{dracutlibdir}/modules.d/90lvm
%{dracutlibdir}/modules.d/90mdraid
%{dracutlibdir}/modules.d/90multipath
-%{dracutlibdir}/modules.d/90stratis
%{dracutlibdir}/modules.d/90qemu
%{dracutlibdir}/modules.d/91crypt-gpg
%{dracutlibdir}/modules.d/91crypt-loop
diff --git a/modules.d/90stratis/module-setup.sh b/modules.d/90stratis/module-setup.sh
deleted file mode 100755
index 943f572e..00000000
--- a/modules.d/90stratis/module-setup.sh
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-
-# called by dracut
-check() {
- require_binaries stratisd-init thin_check thin_repair mkfs.xfs xfs_admin xfs_growfs || return 1
- return 255
-}
-
-# called by dracut
-depends() {
- echo dm
- return 0
-}
-
-# called by dracut
-installkernel() {
- instmods xfs
-}
-
-# called by dracut
-install() {
-
- inst_multiple stratisd-init thin_check thin_repair mkfs.xfs xfs_admin xfs_growfs
-
- if dracut_module_included "systemd"; then
- inst_simple "${moddir}/stratisd-init.service" "${systemdsystemunitdir}/stratisd-init.service"
- systemctl -q --root "$initdir" enable stratisd-init.service
- else
- inst_hook cmdline 25 "$moddir/stratisd-start.sh"
- inst_hook cleanup 25 "$moddir/stratisd-stop.sh"
- fi
-}
-
diff --git a/modules.d/90stratis/stratisd-init.service b/modules.d/90stratis/stratisd-init.service
deleted file mode 100644
index 318e8c27..00000000
--- a/modules.d/90stratis/stratisd-init.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=A daemon that manages a pool of block devices to create flexible file systems
-Documentation=man:stratisd(8)
-Before=local-fs-pre.target
-DefaultDependencies=no
-
-[Service]
-Type=simple
-ExecStart=/sbin/stratisd-init --debug
-KillSignal=SIGINT
-StandardOutput=syslog
-StandardError=syslog
-
-[Install]
-WantedBy=sysinit.target
diff --git a/modules.d/90stratis/stratisd-start.sh b/modules.d/90stratis/stratisd-start.sh
deleted file mode 100755
index afcd81fd..00000000
--- a/modules.d/90stratis/stratisd-start.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-stratisd-init --debug > /dev/kmsg 2>&1 &
\ No newline at end of file
diff --git a/modules.d/90stratis/stratisd-stop.sh b/modules.d/90stratis/stratisd-stop.sh
deleted file mode 100755
index f394a843..00000000
--- a/modules.d/90stratis/stratisd-stop.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-[ -f /lib/dracut-lib.sh ] && . /lib/dracut-lib.sh
-
-pid=$(pidof stratisd-init)
-[ -n "$pid" ] && kill ${pid}

View File

@ -5,7 +5,7 @@
# strip the automatically generated dep here and instead co-own the
# directory.
%global __requires_exclude pkg-config
%define dist_free_release 135.git20210121
%define dist_free_release 136.git20210426
Name: dracut
Version: 049
@ -162,6 +162,7 @@ Patch131: 0131.patch
Patch132: 0132.patch
Patch133: 0133.patch
Patch134: 0134.patch
Patch135: 0135.patch
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
@ -500,7 +501,6 @@ install -m 0755 51-dracut-rescue-postinst.sh $RPM_BUILD_ROOT%{_sysconfdir}/kerne
%{dracutlibdir}/modules.d/90lvm
%{dracutlibdir}/modules.d/90mdraid
%{dracutlibdir}/modules.d/90multipath
%{dracutlibdir}/modules.d/90stratis
%{dracutlibdir}/modules.d/90qemu
%{dracutlibdir}/modules.d/91crypt-gpg
%{dracutlibdir}/modules.d/91crypt-loop
@ -625,6 +625,9 @@ echo '# Since rhel-8.3 dracut moved to use NetworkManager
add_dracutmodules+=" network-legacy "' > /etc/dracut.conf.d/50-network-legacy.conf
%changelog
* Mon Apr 26 2021 Lukas Nykryn <lnykryn@redhat.com> - 049-136.git20210426
- Remove stratis module
* Thu Jan 21 2021 Lukas Nykryn <lnykryn@redhat.com> - 049-135.git20210121
- 95fcoe: default rd.nofcoe to false