Re-add patch Never-enable-the-bluetooth-module-by-default
Keep until this gets fixed properly in upstream. Resolves: #1964879
This commit is contained in:
parent
adc42dfa9f
commit
52e9ef90a6
33
1521-Never-enable-the-bluetooth-module-by-default.patch
Normal file
33
1521-Never-enable-the-bluetooth-module-by-default.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From ea8c9b1c4f39c52fc45788516dea19892cc275f7 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Williamson <awilliam@redhat.com>
|
||||
Date: Thu, 10 Jun 2021 08:41:30 -0700
|
||||
Subject: [PATCH] Never enable the bluetooth module by default (#1521)
|
||||
|
||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
||||
---
|
||||
modules.d/62bluetooth/module-setup.sh | 9 +--------
|
||||
1 file changed, 1 insertion(+), 8 deletions(-)
|
||||
|
||||
diff --git a/modules.d/62bluetooth/module-setup.sh b/modules.d/62bluetooth/module-setup.sh
|
||||
index b8270dd5..fd22670d 100755
|
||||
--- a/modules.d/62bluetooth/module-setup.sh
|
||||
+++ b/modules.d/62bluetooth/module-setup.sh
|
||||
@@ -6,14 +6,7 @@
|
||||
check() {
|
||||
# If the binary(s) requirements are not fulfilled the module can't be installed
|
||||
require_any_binary /usr/lib/bluetooth/bluetoothd /usr/libexec/bluetooth/bluetoothd || return 1
|
||||
-
|
||||
- if [[ $hostonly ]]; then
|
||||
- # Include by default if a Peripheral (0x500) is found of minor class:
|
||||
- # * Keyboard (0x40)
|
||||
- # * Keyboard/pointing (0xC0)
|
||||
- grep -qiE 'Class=0x[0-9a-f]{3}5[4c]0' /var/lib/bluetooth/*/*/info 2> /dev/null && return 0
|
||||
- fi
|
||||
-
|
||||
+ # disabled until https://github.com/dracutdevs/dracut/issues/1521 is resolved
|
||||
return 255
|
||||
}
|
||||
|
||||
--
|
||||
2.32.0.rc2
|
||||
|
10
dracut.spec
10
dracut.spec
@ -5,7 +5,7 @@
|
||||
# strip the automatically generated dep here and instead co-own the
|
||||
# directory.
|
||||
%global __requires_exclude pkg-config
|
||||
%define dist_free_release 2
|
||||
%define dist_free_release 3
|
||||
|
||||
Name: dracut
|
||||
Version: 057
|
||||
@ -30,6 +30,11 @@ Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
# https://github.com/dracutdevs/dracut/pull/1882
|
||||
Patch0: 1882-dmsquash-live-root-Run-checkisomd5-on-correct-device.patch
|
||||
|
||||
# Never auto-enable bluetooth module (but it can be manually included
|
||||
# for debugging) - workaround for RHBZ #1964879.
|
||||
# https://github.com/dracutdevs/dracut/pull/1521
|
||||
Patch1: 1521-Never-enable-the-bluetooth-module-by-default.patch
|
||||
|
||||
BuildRequires: bash
|
||||
BuildRequires: git-core
|
||||
BuildRequires: pkgconfig(libkmod) >= 23
|
||||
@ -427,6 +432,9 @@ echo 'dracut_rescue_image="yes"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/
|
||||
%{_prefix}/lib/kernel/install.d/51-dracut-rescue.install
|
||||
|
||||
%changelog
|
||||
* Thu Aug 25 2022 Pavel Valena <pvalena@redhat.com> - 057-3
|
||||
- Re-add patch Never-enable-the-bluetooth-module-by-default-1521
|
||||
|
||||
* Tue Aug 16 2022 Pavel Valena <pvalena@redhat.com> - 057-2
|
||||
- dmsquash-live-root: Run checkisomd5 on correct device
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user