dracut-044-117
- git snapshot
This commit is contained in:
parent
414eba6e75
commit
4f714a2ec2
@ -0,0 +1,33 @@
|
||||
From 242c03d6fb45f2a291f2b924dedcf2237ad183ba Mon Sep 17 00:00:00 2001
|
||||
From: Xunlei Pang <xpang@redhat.com>
|
||||
Date: Fri, 19 Aug 2016 13:39:37 +0200
|
||||
Subject: [PATCH] network: use require_any_binary instead of
|
||||
require_any_binaries
|
||||
|
||||
---
|
||||
modules.d/40network/module-setup.sh | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/modules.d/40network/module-setup.sh b/modules.d/40network/module-setup.sh
|
||||
index 0501ffe..4a10cf3 100755
|
||||
--- a/modules.d/40network/module-setup.sh
|
||||
+++ b/modules.d/40network/module-setup.sh
|
||||
@@ -5,7 +5,7 @@ check() {
|
||||
local _program
|
||||
|
||||
require_binaries ip dhclient || return 1
|
||||
- require_any_binaries arping arping2 || return 1
|
||||
+ require_any_binary arping arping2 || return 1
|
||||
|
||||
return 255
|
||||
}
|
||||
@@ -24,7 +24,8 @@ installkernel() {
|
||||
# called by dracut
|
||||
install() {
|
||||
local _arch _i _dir
|
||||
- inst_multiple ip arping arping2 dhclient sed awk
|
||||
+ inst_multiple ip dhclient sed awk
|
||||
+ inst_multiple -o arping arping2
|
||||
inst_multiple -o ping ping6
|
||||
inst_multiple -o brctl
|
||||
inst_multiple -o teamd teamdctl teamnl
|
391
0110-TEST-20-NFS-remove-stale-pid-file.patch
Normal file
391
0110-TEST-20-NFS-remove-stale-pid-file.patch
Normal file
@ -0,0 +1,391 @@
|
||||
From 1de836c76316ac2cbd752227ed1b4ab322420224 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Fri, 19 Aug 2016 15:33:59 +0200
|
||||
Subject: [PATCH] TEST-20-NFS: remove stale pid file
|
||||
|
||||
---
|
||||
test/TEST-20-NFS/dhcpd.conf | 340 ++++++++++++++++++++--------------------
|
||||
test/TEST-20-NFS/server-init.sh | 2 +
|
||||
test/TEST-20-NFS/test.sh | 2 +-
|
||||
3 files changed, 173 insertions(+), 171 deletions(-)
|
||||
|
||||
diff --git a/test/TEST-20-NFS/dhcpd.conf b/test/TEST-20-NFS/dhcpd.conf
|
||||
index a4f7fc1..4ba7301 100644
|
||||
--- a/test/TEST-20-NFS/dhcpd.conf
|
||||
+++ b/test/TEST-20-NFS/dhcpd.conf
|
||||
@@ -3,175 +3,175 @@ ddns-update-style none;
|
||||
use-host-decl-names true;
|
||||
|
||||
subnet 192.168.50.0 netmask 255.255.255.0 {
|
||||
- option subnet-mask 255.255.255.0;
|
||||
- option routers 192.168.50.1;
|
||||
- next-server 192.168.50.1;
|
||||
- server-identifier 192.168.50.1;
|
||||
- option domain-name-servers 192.168.50.1;
|
||||
- option domain-search "example.com";
|
||||
- option domain-name "other.com";
|
||||
-
|
||||
- # MAC numbering scheme:
|
||||
- # NFSv3: last octect starts at 0x00 and works up
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp or root={/dev/,}nfs, use server-id
|
||||
- option root-path "/nfs/client";
|
||||
-
|
||||
- host nfs3-1 {
|
||||
- hardware ethernet 52:54:00:12:34:00;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp or root={/dev/,}nfs, use given IP
|
||||
- option root-path "192.168.50.2:/nfs/client";
|
||||
-
|
||||
- host nfs3-2 {
|
||||
- hardware ethernet 52:54:00:12:34:01;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, use protocol from root-path
|
||||
- option root-path "nfs:192.168.50.3:/nfs/client";
|
||||
-
|
||||
- host nfs3-3 {
|
||||
- hardware ethernet 52:54:00:12:34:02;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, use protocol, options from root-path
|
||||
- option root-path "nfs:192.168.50.3:/nfs/client:wsize=4096";
|
||||
-
|
||||
- host nfs3-4 {
|
||||
- hardware ethernet 52:54:00:12:34:03;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, nfsroot=/path and nfsroot=IP:/path testing
|
||||
-
|
||||
- host nfs3-5 {
|
||||
- hardware ethernet 52:54:00:12:34:04;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, use path, comma-separated options
|
||||
- option root-path "/nfs/client,wsize=4096";
|
||||
-
|
||||
- host nfs3-6 {
|
||||
- hardware ethernet 52:54:00:12:34:05;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, use IP, path, comma-separated options
|
||||
- option root-path "192.168.50.2:/nfs/client,wsize=4096";
|
||||
-
|
||||
- host nfs3-7 {
|
||||
- hardware ethernet 52:54:00:12:34:06;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=dhcp, use proto, IP, path, comma-separated options
|
||||
- option root-path "nfs:192.168.50.3:/nfs/client,wsize=4096";
|
||||
-
|
||||
- host nfs3-8 {
|
||||
- hardware ethernet 52:54:00:12:34:07;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- # MAC numbering scheme:
|
||||
- # NFSv4: last octect starts at 0x80 and works up
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root={/dev/,}nfs4, use server-id
|
||||
- option root-path "/client";
|
||||
-
|
||||
- host nfs4-1 {
|
||||
- hardware ethernet 52:54:00:12:34:80;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root={/dev/,}nfs4, use given IP
|
||||
- option root-path "192.168.50.2:/client";
|
||||
-
|
||||
- host nfs4-2 {
|
||||
- hardware ethernet 52:54:00:12:34:81;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root=dhcp, use profocol from root-path
|
||||
- option root-path "nfs4:192.168.50.3:/client";
|
||||
-
|
||||
- host nfs4-3 {
|
||||
- hardware ethernet 52:54:00:12:34:82;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root=dhcp, use profocol, options from root-path
|
||||
- option root-path "nfs4:192.168.50.3:/client:wsize=4096";
|
||||
-
|
||||
- host nfs4-4 {
|
||||
- hardware ethernet 52:54:00:12:34:83;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv3 root=nfs4, nfsroot=/path and nfsroot=IP:/path testing
|
||||
- host nfs4-5 {
|
||||
- hardware ethernet 52:54:00:12:34:84;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root={/dev/,}nfs4, use server-id, comma-separated opts
|
||||
- option root-path "/client,wsize=4096";
|
||||
-
|
||||
- host nfs4-6 {
|
||||
- hardware ethernet 52:54:00:12:34:85;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root={/dev/,}nfs4, use given IP, comma-separated opts
|
||||
- option root-path "192.168.50.2:/client,wsize=4096";
|
||||
-
|
||||
- host nfs4-7 {
|
||||
- hardware ethernet 52:54:00:12:34:86;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- group {
|
||||
- # NFSv4 root=dhcp, use comma-separated opts
|
||||
- option root-path "nfs4:192.168.50.3:/client,wsize=4096";
|
||||
-
|
||||
- host nfs4-8 {
|
||||
- hardware ethernet 52:54:00:12:34:87;
|
||||
- fixed-address 192.168.50.101;
|
||||
- }
|
||||
- }
|
||||
+option subnet-mask 255.255.255.0;
|
||||
+option routers 192.168.50.1;
|
||||
+next-server 192.168.50.1;
|
||||
+server-identifier 192.168.50.1;
|
||||
+option domain-name-servers 192.168.50.1;
|
||||
+option domain-search "example.com";
|
||||
+option domain-name "other.com";
|
||||
+
|
||||
+# MAC numbering scheme:
|
||||
+# NFSv3: last octect starts at 0x00 and works up
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp or root={/dev/,}nfs, use server-id
|
||||
+ option root-path "/nfs/client";
|
||||
+
|
||||
+ host nfs3-1 {
|
||||
+ hardware ethernet 52:54:00:12:34:00;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp or root={/dev/,}nfs, use given IP
|
||||
+ option root-path "192.168.50.2:/nfs/client";
|
||||
+
|
||||
+ host nfs3-2 {
|
||||
+ hardware ethernet 52:54:00:12:34:01;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, use protocol from root-path
|
||||
+ option root-path "nfs:192.168.50.3:/nfs/client";
|
||||
+
|
||||
+ host nfs3-3 {
|
||||
+ hardware ethernet 52:54:00:12:34:02;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, use protocol, options from root-path
|
||||
+ option root-path "nfs:192.168.50.3:/nfs/client:wsize=4096";
|
||||
+
|
||||
+ host nfs3-4 {
|
||||
+ hardware ethernet 52:54:00:12:34:03;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, nfsroot=/path and nfsroot=IP:/path testing
|
||||
+
|
||||
+ host nfs3-5 {
|
||||
+ hardware ethernet 52:54:00:12:34:04;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, use path, comma-separated options
|
||||
+ option root-path "/nfs/client,wsize=4096";
|
||||
+
|
||||
+ host nfs3-6 {
|
||||
+ hardware ethernet 52:54:00:12:34:05;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, use IP, path, comma-separated options
|
||||
+ option root-path "192.168.50.2:/nfs/client,wsize=4096";
|
||||
+
|
||||
+ host nfs3-7 {
|
||||
+ hardware ethernet 52:54:00:12:34:06;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=dhcp, use proto, IP, path, comma-separated options
|
||||
+ option root-path "nfs:192.168.50.3:/nfs/client,wsize=4096";
|
||||
+
|
||||
+ host nfs3-8 {
|
||||
+ hardware ethernet 52:54:00:12:34:07;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ # MAC numbering scheme:
|
||||
+ # NFSv4: last octect starts at 0x80 and works up
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root={/dev/,}nfs4, use server-id
|
||||
+ option root-path "/client";
|
||||
+
|
||||
+ host nfs4-1 {
|
||||
+ hardware ethernet 52:54:00:12:34:80;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root={/dev/,}nfs4, use given IP
|
||||
+ option root-path "192.168.50.2:/client";
|
||||
+
|
||||
+ host nfs4-2 {
|
||||
+ hardware ethernet 52:54:00:12:34:81;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root=dhcp, use profocol from root-path
|
||||
+ option root-path "nfs4:192.168.50.3:/client";
|
||||
+
|
||||
+ host nfs4-3 {
|
||||
+ hardware ethernet 52:54:00:12:34:82;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root=dhcp, use profocol, options from root-path
|
||||
+ option root-path "nfs4:192.168.50.3:/client:wsize=4096";
|
||||
+
|
||||
+ host nfs4-4 {
|
||||
+ hardware ethernet 52:54:00:12:34:83;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv3 root=nfs4, nfsroot=/path and nfsroot=IP:/path testing
|
||||
+ host nfs4-5 {
|
||||
+ hardware ethernet 52:54:00:12:34:84;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root={/dev/,}nfs4, use server-id, comma-separated opts
|
||||
+ option root-path "/client,wsize=4096";
|
||||
+
|
||||
+ host nfs4-6 {
|
||||
+ hardware ethernet 52:54:00:12:34:85;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root={/dev/,}nfs4, use given IP, comma-separated opts
|
||||
+ option root-path "192.168.50.2:/client,wsize=4096";
|
||||
+
|
||||
+ host nfs4-7 {
|
||||
+ hardware ethernet 52:54:00:12:34:86;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ group {
|
||||
+ # NFSv4 root=dhcp, use comma-separated opts
|
||||
+ option root-path "nfs4:192.168.50.3:/client,wsize=4096";
|
||||
+
|
||||
+ host nfs4-8 {
|
||||
+ hardware ethernet 52:54:00:12:34:87;
|
||||
+ fixed-address 192.168.50.101;
|
||||
+ }
|
||||
+ }
|
||||
|
||||
}
|
||||
diff --git a/test/TEST-20-NFS/server-init.sh b/test/TEST-20-NFS/server-init.sh
|
||||
index 5b6f42f..aa8af53 100755
|
||||
--- a/test/TEST-20-NFS/server-init.sh
|
||||
+++ b/test/TEST-20-NFS/server-init.sh
|
||||
@@ -46,10 +46,12 @@ rpc.idmapd
|
||||
echo > /dev/watchdog
|
||||
exportfs -r
|
||||
echo > /dev/watchdog
|
||||
+mkdir -p /var/lib/dhcpd
|
||||
>/var/lib/dhcpd/dhcpd.leases
|
||||
echo > /dev/watchdog
|
||||
chmod 777 /var/lib/dhcpd/dhcpd.leases
|
||||
echo > /dev/watchdog
|
||||
+rm -f /var/run/dhcpd.pid
|
||||
dhcpd -d -cf /etc/dhcpd.conf -lf /var/lib/dhcpd/dhcpd.leases &
|
||||
echo "Serving NFS mounts"
|
||||
while :; do
|
||||
diff --git a/test/TEST-20-NFS/test.sh b/test/TEST-20-NFS/test.sh
|
||||
index 981cd82..039fb61 100755
|
||||
--- a/test/TEST-20-NFS/test.sh
|
||||
+++ b/test/TEST-20-NFS/test.sh
|
||||
@@ -237,7 +237,7 @@ test_setup() {
|
||||
inst_multiple sh ls shutdown poweroff stty cat ps ln ip \
|
||||
dmesg mkdir cp ping exportfs \
|
||||
modprobe rpc.nfsd rpc.mountd showmount tcpdump \
|
||||
- /etc/services sleep mount chmod
|
||||
+ /etc/services sleep mount chmod rm
|
||||
for _terminfodir in /lib/terminfo /etc/terminfo /usr/share/terminfo; do
|
||||
[ -f ${_terminfodir}/l/linux ] && break
|
||||
done
|
57
0111-dracut-functions.sh-catch-all-lvm-slaves.patch
Normal file
57
0111-dracut-functions.sh-catch-all-lvm-slaves.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From c7c8c4981ac3a0258ff053fdd02cfe17a11710da Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Tue, 9 Aug 2016 15:26:04 +0200
|
||||
Subject: [PATCH] dracut-functions.sh: catch all lvm slaves
|
||||
|
||||
add check_vol_slaves_all to be used in check_block_and_slaves_all
|
||||
|
||||
otherwise only the first lvm VG member would be processed
|
||||
|
||||
(cherry picked from commit 7a7b8c174023886b015bd484372839aecf63f324)
|
||||
---
|
||||
dracut-functions.sh | 25 ++++++++++++++++++++++++-
|
||||
1 file changed, 24 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dracut-functions.sh b/dracut-functions.sh
|
||||
index 4496bfe..249d8fb 100755
|
||||
--- a/dracut-functions.sh
|
||||
+++ b/dracut-functions.sh
|
||||
@@ -507,7 +507,7 @@ check_block_and_slaves_all() {
|
||||
if ! lvm_internal_dev $2 && "$1" $2; then
|
||||
_ret=0
|
||||
fi
|
||||
- check_vol_slaves "$@" && return 0
|
||||
+ check_vol_slaves_all "$@" && return 0
|
||||
if [[ -f /sys/dev/block/$2/../dev ]]; then
|
||||
check_block_and_slaves_all $1 $(<"/sys/dev/block/$2/../dev") && _ret=0
|
||||
fi
|
||||
@@ -580,6 +580,29 @@ check_vol_slaves() {
|
||||
return 1
|
||||
}
|
||||
|
||||
+check_vol_slaves_all() {
|
||||
+ local _lv _vg _pv
|
||||
+ for i in /dev/mapper/*; do
|
||||
+ [[ $i == /dev/mapper/control ]] && continue
|
||||
+ _lv=$(get_maj_min $i)
|
||||
+ if [[ $_lv = $2 ]]; then
|
||||
+ _vg=$(lvm lvs --noheadings -o vg_name $i 2>/dev/null)
|
||||
+ # strip space
|
||||
+ _vg="${_vg//[[:space:]]/}"
|
||||
+ if [[ $_vg ]]; then
|
||||
+ for _pv in $(lvm vgs --noheadings -o pv_name "$_vg" 2>/dev/null)
|
||||
+ do
|
||||
+ check_block_and_slaves_all $1 $(get_maj_min $_pv)
|
||||
+ done
|
||||
+ return 0
|
||||
+ fi
|
||||
+ fi
|
||||
+ done
|
||||
+ return 1
|
||||
+}
|
||||
+
|
||||
+
|
||||
+
|
||||
# fs_get_option <filesystem options> <search for option>
|
||||
# search for a specific option in a bunch of filesystem options
|
||||
# and return the value
|
44
0112-systemd-dracut-cmdline.sh-unset-UNSET-root.patch
Normal file
44
0112-systemd-dracut-cmdline.sh-unset-UNSET-root.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From e168eeef67a6680730e86ee389a383d9c1607c25 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Fri, 12 Aug 2016 11:24:47 +0200
|
||||
Subject: [PATCH] systemd/dracut-cmdline.sh: unset "UNSET" $root
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1365667
|
||||
caused by commit 9aa224cc
|
||||
|
||||
(cherry picked from commit fc77aca7ddbd33328066a943a4de09de34d25c4c)
|
||||
---
|
||||
modules.d/98dracut-systemd/dracut-cmdline.sh | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/modules.d/98dracut-systemd/dracut-cmdline.sh b/modules.d/98dracut-systemd/dracut-cmdline.sh
|
||||
index ccf24fb..6c6ee02 100755
|
||||
--- a/modules.d/98dracut-systemd/dracut-cmdline.sh
|
||||
+++ b/modules.d/98dracut-systemd/dracut-cmdline.sh
|
||||
@@ -25,7 +25,7 @@ source_conf /etc/conf.d
|
||||
# between the case where it was set to the empty string and the case where it
|
||||
# wasn't specified at all.
|
||||
if ! root="$(getarg root=)"; then
|
||||
- root='UNSET'
|
||||
+ root_unset='UNSET'
|
||||
fi
|
||||
|
||||
rflags="$(getarg rootflags=)"
|
||||
@@ -49,7 +49,7 @@ source_hook cmdline
|
||||
|
||||
[ -f /lib/dracut/parse-resume.sh ] && . /lib/dracut/parse-resume.sh
|
||||
|
||||
-case "$root" in
|
||||
+case "${root}${root_unset}" in
|
||||
block:LABEL=*|LABEL=*)
|
||||
root="${root#block:}"
|
||||
root="$(echo $root | sed 's,/,\\x2f,g')"
|
||||
@@ -75,7 +75,7 @@ case "$root" in
|
||||
rootok=1 ;;
|
||||
esac
|
||||
|
||||
-[ -z "$root" ] && die "Empty root= argument"
|
||||
+[ -z "${root}${root_unset}" ] && die "Empty root= argument"
|
||||
[ -z "$rootok" ] && die "Don't know how to handle 'root=$root'"
|
||||
|
||||
export root rflags fstype netroot NEWROOT
|
31
0113-url-lib-ca-bundle.crt-changed-to-a-symlink.patch
Normal file
31
0113-url-lib-ca-bundle.crt-changed-to-a-symlink.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From f47090f918be67ca3b9a33090088d3164db2e6a8 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 17 Aug 2016 16:41:21 +0200
|
||||
Subject: [PATCH] url-lib: ca-bundle.crt changed to a symlink
|
||||
|
||||
use inst() instead of inst_simple()
|
||||
|
||||
/etc/pki/tls/certs/ca-bundle.crt is a symlink to
|
||||
../../ca-trust/extracted/pem/tls-ca-bundle.pem
|
||||
|
||||
with inst() we install the original file also.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1341280
|
||||
(cherry picked from commit 1b23c6c65c39630cb62faa2503817759f83d880b)
|
||||
---
|
||||
modules.d/45url-lib/module-setup.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/modules.d/45url-lib/module-setup.sh b/modules.d/45url-lib/module-setup.sh
|
||||
index c87f718..1ece400 100755
|
||||
--- a/modules.d/45url-lib/module-setup.sh
|
||||
+++ b/modules.d/45url-lib/module-setup.sh
|
||||
@@ -32,7 +32,7 @@ install() {
|
||||
_crt=$(grep -F --binary-files=text -z .crt $_lib)
|
||||
[[ $_crt ]] || continue
|
||||
[[ $_crt == /*/* ]] || continue
|
||||
- if ! inst_simple "$_crt"; then
|
||||
+ if ! inst "$_crt"; then
|
||||
dwarn "Couldn't install '$_crt' SSL CA cert bundle; HTTPS might not work."
|
||||
continue
|
||||
fi
|
@ -0,0 +1,27 @@
|
||||
From f367b73852f60d196bd5856d818730e08ca14270 Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 17 Aug 2016 16:48:07 +0200
|
||||
Subject: [PATCH] dracut.sh: document --hostonly-i18n and --no-hostonly-i18n
|
||||
|
||||
show description in --help
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1266448
|
||||
(cherry picked from commit 91896ab68e26b9f9191f4742dc8ad9c5025eac7f)
|
||||
---
|
||||
dracut.sh | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/dracut.sh b/dracut.sh
|
||||
index 36607cf..40ca08f 100755
|
||||
--- a/dracut.sh
|
||||
+++ b/dracut.sh
|
||||
@@ -151,6 +151,9 @@ Creates initial ramdisk images for preloading modules
|
||||
in the initramfs
|
||||
--no-hostonly-cmdline Do not store kernel command line arguments needed
|
||||
in the initramfs
|
||||
+ --hostonly-i18n Install only needed keyboard and font files according
|
||||
+ to the host configuration (default).
|
||||
+ --no-hostonly-i18n Install all keyboard and font files available.
|
||||
--persistent-policy [POLICY]
|
||||
Use [POLICY] to address disks and partitions.
|
||||
POLICY can be any directory name found in /dev/disk.
|
@ -0,0 +1,24 @@
|
||||
From 5db79ae414ee5ac2d964348d5e9fd3e1b37a088c Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 17 Aug 2016 16:49:00 +0200
|
||||
Subject: [PATCH] dracut.cmdline.7.asc: document rd.shell=0 for rd.emergency
|
||||
|
||||
(cherry picked from commit 1d267fb82c1e12e06ef80de16f5232ef06c84240)
|
||||
---
|
||||
dracut.cmdline.7.asc | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dracut.cmdline.7.asc b/dracut.cmdline.7.asc
|
||||
index a2d1f95..0009ff2 100644
|
||||
--- a/dracut.cmdline.7.asc
|
||||
+++ b/dracut.cmdline.7.asc
|
||||
@@ -130,7 +130,8 @@ menuentry 'Live Fedora 20' --class fedora --class gnu-linux --class gnu --class
|
||||
Misc
|
||||
~~~~
|
||||
**rd.emergency=**__[reboot|poweroff|halt]__::
|
||||
- specify, what action to execute in case of a critical failure.
|
||||
+ specify, what action to execute in case of a critical failure. rd.shell=0 also
|
||||
+ be specified.
|
||||
|
||||
**rd.driver.blacklist=**__<drivername>__[,__<drivername>__,...]::
|
||||
do not load kernel module <drivername>. This parameter can be specified
|
29
0116-network-ibft-put-IPv6-IP-in-brackets.patch
Normal file
29
0116-network-ibft-put-IPv6-IP-in-brackets.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 1a7b71bb146b4355683bde5df8b1b5b7dc7e36ed Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 17 Aug 2016 16:25:09 +0200
|
||||
Subject: [PATCH] network:ibft put IPv6 IP in brackets
|
||||
|
||||
ip=2620:0052:0000:2220:0226:b9ff:fe81:cde4::[2620:0052:0000:2220:0000:0000:0000:03fe]:64::ibft0:none
|
||||
|
||||
should be
|
||||
|
||||
ip=[2620:0052:0000:2220:0226:b9ff:fe81:cde4]::[2620:0052:0000:2220:0000:0000:0000:03fe]:64::ibft0:none
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1322592#c19
|
||||
(cherry picked from commit b8e6c051c6ad6ae3ae93db8e74f37dbc82c22514)
|
||||
---
|
||||
modules.d/40network/net-lib.sh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/40network/net-lib.sh b/modules.d/40network/net-lib.sh
|
||||
index eb98f8e..69d96aa 100755
|
||||
--- a/modules.d/40network/net-lib.sh
|
||||
+++ b/modules.d/40network/net-lib.sh
|
||||
@@ -284,6 +284,7 @@ ibft_to_cmdline() {
|
||||
[ -e ${iface}/hostname ] && hostname=$(read a < ${iface}/hostname; echo $a)
|
||||
if [ "$family" = "ipv6" ] ; then
|
||||
if [ -n "$ip" ] ; then
|
||||
+ ip="[$ip]"
|
||||
[ -n "$prefix" ] || prefix=64
|
||||
ip="[${ip}/${prefix}]"
|
||||
mask=
|
13
dracut.spec
13
dracut.spec
@ -16,7 +16,7 @@
|
||||
|
||||
Name: dracut
|
||||
Version: 044
|
||||
Release: 109%{?dist}
|
||||
Release: 117%{?dist}
|
||||
|
||||
Summary: Initramfs generator using udev
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
@ -143,6 +143,14 @@ Patch105: 0105-add-rd.emergency-reboot-poweroff-halt.patch
|
||||
Patch106: 0106-fips-module-add-missing-space.patch
|
||||
Patch107: 0107-network-support-macaddr-in-brackets.patch
|
||||
Patch108: 0108-nfs-install-all-nfs-modules-non-hostonly.patch
|
||||
Patch109: 0109-network-use-require_any_binary-instead-of-require_an.patch
|
||||
Patch110: 0110-TEST-20-NFS-remove-stale-pid-file.patch
|
||||
Patch111: 0111-dracut-functions.sh-catch-all-lvm-slaves.patch
|
||||
Patch112: 0112-systemd-dracut-cmdline.sh-unset-UNSET-root.patch
|
||||
Patch113: 0113-url-lib-ca-bundle.crt-changed-to-a-symlink.patch
|
||||
Patch114: 0114-dracut.sh-document-hostonly-i18n-and-no-hostonly-i18.patch
|
||||
Patch115: 0115-dracut.cmdline.7.asc-document-rd.shell-0-for-rd.emer.patch
|
||||
Patch116: 0116-network-ibft-put-IPv6-IP-in-brackets.patch
|
||||
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
|
||||
@ -606,6 +614,9 @@ rm -rf -- $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 19 2016 Harald Hoyer <harald@redhat.com> - 044-117
|
||||
- git snapshot
|
||||
|
||||
* Thu Aug 18 2016 Harald Hoyer <harald@redhat.com> - 044-109
|
||||
- git snapshot
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user