Add upstream patches to fix a number of ARM devices with generic initrd
This commit is contained in:
parent
ce47f2e2c7
commit
4eece4100e
@ -0,0 +1,25 @@
|
|||||||
|
From f496af50b7c5ddf13154123186cee713f540c8db Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Robinson <pbrobinson@gmail.com>
|
||||||
|
Date: Fri, 4 Aug 2017 18:43:26 +0100
|
||||||
|
Subject: [PATCH 1/2] add options to pickup dw_mmc submodules to blockfuncs
|
||||||
|
|
||||||
|
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||||
|
---
|
||||||
|
modules.d/90kernel-modules/module-setup.sh | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
index 623af868..4478dfe6 100755
|
||||||
|
--- a/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
+++ b/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
@@ -27,6 +27,7 @@ installkernel() {
|
||||||
|
|
||||||
|
if [[ "$(uname -m)" == arm* || "$(uname -m)" == aarch64 ]]; then
|
||||||
|
# arm/aarch64 specific modules
|
||||||
|
+ _blockfuncs+='|dw_mc_probe|dw_mci_pltfm_register'
|
||||||
|
instmods \
|
||||||
|
"=drivers/clk" \
|
||||||
|
"=drivers/dma" \
|
||||||
|
--
|
||||||
|
2.13.4
|
||||||
|
|
@ -0,0 +1,33 @@
|
|||||||
|
From 39018c93c2bcf20a7f5f9ee509ad1c0448d598f7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Robinson <pbrobinson@gmail.com>
|
||||||
|
Date: Fri, 4 Aug 2017 19:51:25 +0100
|
||||||
|
Subject: [PATCH 2/2] arm: add soc/extcon/mfd as they're often needed for USB
|
||||||
|
and core memory/soc drivers
|
||||||
|
|
||||||
|
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||||
|
---
|
||||||
|
modules.d/90kernel-modules/module-setup.sh | 3 +++
|
||||||
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
index 4478dfe6..462b5417 100755
|
||||||
|
--- a/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
+++ b/modules.d/90kernel-modules/module-setup.sh
|
||||||
|
@@ -31,11 +31,14 @@ installkernel() {
|
||||||
|
instmods \
|
||||||
|
"=drivers/clk" \
|
||||||
|
"=drivers/dma" \
|
||||||
|
+ "=drivers/extcon" \
|
||||||
|
"=drivers/i2c/busses" \
|
||||||
|
+ "=drivers/mfd" \
|
||||||
|
"=drivers/phy" \
|
||||||
|
"=drivers/power" \
|
||||||
|
"=drivers/regulator" \
|
||||||
|
"=drivers/rtc" \
|
||||||
|
+ "=drivers/soc" \
|
||||||
|
"=drivers/usb/chipidea" \
|
||||||
|
"=drivers/usb/dwc2" \
|
||||||
|
"=drivers/usb/dwc3" \
|
||||||
|
--
|
||||||
|
2.13.4
|
||||||
|
|
11
dracut.spec
11
dracut.spec
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 045
|
Version: 045
|
||||||
Release: 20.git20170515%{?dist}
|
Release: 21.git20170515%{?dist}
|
||||||
|
|
||||||
Summary: Initramfs generator using udev
|
Summary: Initramfs generator using udev
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
@ -52,11 +52,13 @@ Patch14: 0014-TEST-50-MULTINIC-fix-bridge-test.patch
|
|||||||
Patch15: 0015-Check-the-proper-variable-for-a-custom-IMA-keys-dire.patch
|
Patch15: 0015-Check-the-proper-variable-for-a-custom-IMA-keys-dire.patch
|
||||||
Patch16: 0016-Handle-curl-using-libnssckbi-for-TLS-RHBZ-1447777.patch
|
Patch16: 0016-Handle-curl-using-libnssckbi-for-TLS-RHBZ-1447777.patch
|
||||||
Patch17: 0017-drm-Install-pwm-modules-on-all-architectures.patch
|
Patch17: 0017-drm-Install-pwm-modules-on-all-architectures.patch
|
||||||
|
Patch18: 0018-add-options-to-pickup-dw_mmc-submodules-to-blockfunc.patch
|
||||||
|
Patch19: 0019-arm-add-soc-extcon-mfd-as-they-re-often-needed-for-U.patch
|
||||||
|
|
||||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: bash git
|
BuildRequires: bash git-core
|
||||||
BuildRequires: kmod-devel >= 15
|
BuildRequires: kmod-devel >= 15
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
@ -321,8 +323,6 @@ echo 'dracut_rescue_image="yes"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/
|
|||||||
> $RPM_BUILD_ROOT/etc/system-fips
|
> $RPM_BUILD_ROOT/etc/system-fips
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf -- $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,0755)
|
%defattr(-,root,root,0755)
|
||||||
@ -516,6 +516,9 @@ rm -rf -- $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 7 2017 Peter Robinson <pbrobinson@fedoraproject.org> 045-21.git20170515
|
||||||
|
- Add upstream patches to fix a number of ARM devices with generic initrd
|
||||||
|
|
||||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 045-20.git20170515
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 045-20.git20170515
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user