don't specify "p" as a separator for dmraid (#966162)
This commit is contained in:
parent
e2c90d75b6
commit
3d3710b922
@ -0,0 +1,38 @@
|
|||||||
|
From 96dd416ac2ea8ea0f5bbbdce2abafbbce84f0ad6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Williamson <awilliam@redhat.com>
|
||||||
|
Date: Wed, 22 May 2013 13:56:58 -0700
|
||||||
|
Subject: [PATCH 45/45] don't specify "p" as a separator for dmraid arrays
|
||||||
|
(RHBZ #966162)
|
||||||
|
|
||||||
|
As per RHBZ #966162, parted stopped unconditionally using "p" as a
|
||||||
|
separator for dmraid device names in version 3.1, so other things need
|
||||||
|
to fall in line with that convention now.
|
||||||
|
---
|
||||||
|
modules.d/90dmraid/dmraid.sh | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/modules.d/90dmraid/dmraid.sh b/modules.d/90dmraid/dmraid.sh
|
||||||
|
index 68e0515..3753ddd 100755
|
||||||
|
--- a/modules.d/90dmraid/dmraid.sh
|
||||||
|
+++ b/modules.d/90dmraid/dmraid.sh
|
||||||
|
@@ -28,7 +28,7 @@ if [ -n "$DM_RAIDS" ] || getargbool 0 rd.auto; then
|
||||||
|
if [ "${s##$r}" != "$s" ]; then
|
||||||
|
info "Activating $s"
|
||||||
|
dmraid -ay -i -p --rm_partitions "$s" 2>&1 | vinfo
|
||||||
|
- [ -e "/dev/mapper/$s" ] && kpartx -a -p p "/dev/mapper/$s" 2>&1 | vinfo
|
||||||
|
+ [ -e "/dev/mapper/$s" ] && kpartx -a "/dev/mapper/$s" 2>&1 | vinfo
|
||||||
|
udevsettle
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
@@ -38,7 +38,7 @@ if [ -n "$DM_RAIDS" ] || getargbool 0 rd.auto; then
|
||||||
|
for s in $SETS; do
|
||||||
|
info "Activating $s"
|
||||||
|
dmraid -ay -i -p --rm_partitions "$s" 2>&1 | vinfo
|
||||||
|
- [ -e "/dev/mapper/$s" ] && kpartx -a -p p "/dev/mapper/$s" 2>&1 | vinfo
|
||||||
|
+ [ -e "/dev/mapper/$s" ] && kpartx -a "/dev/mapper/$s" 2>&1 | vinfo
|
||||||
|
done
|
||||||
|
fi
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.2.1
|
||||||
|
|
10
dracut.spec
10
dracut.spec
@ -10,7 +10,7 @@
|
|||||||
|
|
||||||
Name: dracut
|
Name: dracut
|
||||||
Version: 027
|
Version: 027
|
||||||
Release: 45.git20130430%{?dist}
|
Release: 46.git20130430%{?dist}
|
||||||
|
|
||||||
Summary: Initramfs generator using udev
|
Summary: Initramfs generator using udev
|
||||||
%if 0%{?fedora} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?rhel}
|
||||||
@ -73,6 +73,10 @@ Patch41: 0041-dracut-install-make-use-of-_cleanup_-macros.patch
|
|||||||
Patch42: 0042-_emergency_shell-Show-current-working-directory-corr.patch
|
Patch42: 0042-_emergency_shell-Show-current-working-directory-corr.patch
|
||||||
Patch43: 0043-test-use-grep-option-F-and-install-etc-os-release.patch
|
Patch43: 0043-test-use-grep-option-F-and-install-etc-os-release.patch
|
||||||
Patch44: 0044-zfcp-match-udev-rule-against-KERNEL-zfcp.patch
|
Patch44: 0044-zfcp-match-udev-rule-against-KERNEL-zfcp.patch
|
||||||
|
# Don't specify 'p' as a separator for dmraid; see #966162. Generated in
|
||||||
|
# sequence with the above patches against dracut HEAD of 2013-05-22, will
|
||||||
|
# send to harald. -adamw
|
||||||
|
Patch45: 0045-don-t-specify-p-as-a-separator-for-dmraid-arrays-RHB.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: dash bash git
|
BuildRequires: dash bash git
|
||||||
@ -481,6 +485,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{dracutlibdir}/dracut.conf.d/02-norescue.conf
|
%{dracutlibdir}/dracut.conf.d/02-norescue.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 22 2013 Adam Williamson <awilliam@redhat.com> 027-46.git20130430
|
||||||
|
- don't specify "p" as a separator for dmraid
|
||||||
|
Resolves: rhbz#966162
|
||||||
|
|
||||||
* Tue Apr 30 2013 Harald Hoyer <harald@redhat.com> 027-45.git20130430
|
* Tue Apr 30 2013 Harald Hoyer <harald@redhat.com> 027-45.git20130430
|
||||||
- fixed fips mode more
|
- fixed fips mode more
|
||||||
Resolves: rhbz#956521
|
Resolves: rhbz#956521
|
||||||
|
Loading…
Reference in New Issue
Block a user