dracut - 049-11.git20181024
- git snapshot
This commit is contained in:
parent
737328c260
commit
19aece0514
31
0004.patch
Normal file
31
0004.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 83cbc06ab91288e2d931b4f36935bfdb79a99b0e Mon Sep 17 00:00:00 2001
|
||||
From: Kairui Song <kasong@redhat.com>
|
||||
Date: Fri, 12 Oct 2018 13:07:13 +0800
|
||||
Subject: [PATCH] 40network: Don't include 40network by default
|
||||
|
||||
commit 7347391 ('network-legacy: split off from network module')
|
||||
splitted network function to network-legacy and removed check() function
|
||||
of 40network. This caused 40network to be included even if network is
|
||||
not needed.
|
||||
|
||||
Signed-off-by: Kairui Song <kasong@redhat.com>
|
||||
---
|
||||
modules.d/40network/module-setup.sh | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/modules.d/40network/module-setup.sh b/modules.d/40network/module-setup.sh
|
||||
index 57c0a45e..e8541636 100755
|
||||
--- a/modules.d/40network/module-setup.sh
|
||||
+++ b/modules.d/40network/module-setup.sh
|
||||
@@ -1,5 +1,10 @@
|
||||
#!/bin/bash
|
||||
|
||||
+# called by dracut
|
||||
+check() {
|
||||
+ return 255
|
||||
+}
|
||||
+
|
||||
# called by dracut
|
||||
depends() {
|
||||
echo -n "kernel-network-modules "
|
||||
|
31
0005.patch
Normal file
31
0005.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From b9af0fcdfb2364245b333a123cdb07523855079f Mon Sep 17 00:00:00 2001
|
||||
From: Kairui Song <kasong@redhat.com>
|
||||
Date: Thu, 18 Oct 2018 17:05:22 +0800
|
||||
Subject: [PATCH] 99squash: Don't clean up squahfs on isolate
|
||||
|
||||
The only time we need to cleanup squahfs manually is on switch root, to
|
||||
release resource and memory. We've covered that by setting
|
||||
"Conflicts=initrd-switch-root.target" for squash cleanup service.
|
||||
On shutdown systemd will take care of squahfs mounts. But for other
|
||||
isolate, files in initramfs are most likely still required, so don't
|
||||
clean up squahfs. For example, kdump's emergency handler will isolate
|
||||
into its own target, if squahfs is cleaned up it will fail.
|
||||
|
||||
Signed-off-by: Kairui Song <kasong@redhat.com>
|
||||
---
|
||||
modules.d/99squash/squash-mnt-clear.service | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/modules.d/99squash/squash-mnt-clear.service b/modules.d/99squash/squash-mnt-clear.service
|
||||
index 8dd17812..f8d5db46 100644
|
||||
--- a/modules.d/99squash/squash-mnt-clear.service
|
||||
+++ b/modules.d/99squash/squash-mnt-clear.service
|
||||
@@ -9,6 +9,7 @@ After=dracut-initqueue.service dracut-pre-pivot.service
|
||||
Before=initrd-cleanup.service
|
||||
ConditionPathExists=/squash/root
|
||||
Conflicts=initrd-switch-root.target
|
||||
+IgnoreOnIsolate=true
|
||||
|
||||
[Service]
|
||||
Type=oneshot
|
||||
|
28
0006.patch
Normal file
28
0006.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From e54ab383f7529f340d69536709624dffb30046a1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Renaud=20M=C3=A9trich?= <rmetrich@redhat.com>
|
||||
Date: Fri, 19 Oct 2018 13:21:37 +0200
|
||||
Subject: [PATCH] fips: check fips integrity just before mounting local
|
||||
filesystems in /sysroot
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Renaud Métrich <rmetrich@redhat.com>
|
||||
---
|
||||
modules.d/01fips/module-setup.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/modules.d/01fips/module-setup.sh b/modules.d/01fips/module-setup.sh
|
||||
index f3af4d90..808292af 100755
|
||||
--- a/modules.d/01fips/module-setup.sh
|
||||
+++ b/modules.d/01fips/module-setup.sh
|
||||
@@ -52,7 +52,7 @@ installkernel() {
|
||||
# called by dracut
|
||||
install() {
|
||||
local _dir
|
||||
- inst_hook pre-trigger 01 "$moddir/fips-boot.sh"
|
||||
+ inst_hook pre-mount 01 "$moddir/fips-boot.sh"
|
||||
inst_hook pre-pivot 01 "$moddir/fips-noboot.sh"
|
||||
inst_script "$moddir/fips.sh" /sbin/fips.sh
|
||||
|
||||
|
26
0007.patch
Normal file
26
0007.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 7117bf627028298970d8a6a5e153e1942f3430f3 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Molkentin <dmolkentin@suse.com>
|
||||
Date: Fri, 19 Oct 2018 14:30:36 +0200
|
||||
Subject: [PATCH] 99base: Allow files with backslashes in hostonly files
|
||||
|
||||
Files with blackslashes are routinely by systemd.
|
||||
|
||||
Reference: bsc#1090884
|
||||
---
|
||||
modules.d/99base/dracut-lib.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/modules.d/99base/dracut-lib.sh b/modules.d/99base/dracut-lib.sh
|
||||
index f71e757c..ab348855 100755
|
||||
--- a/modules.d/99base/dracut-lib.sh
|
||||
+++ b/modules.d/99base/dracut-lib.sh
|
||||
@@ -1327,7 +1327,7 @@ show_memstats()
|
||||
remove_hostonly_files() {
|
||||
rm -fr /etc/cmdline /etc/cmdline.d/*.conf "$hookdir/initqueue/finished"
|
||||
if [ -f /lib/dracut/hostonly-files ]; then
|
||||
- while read line || [ -n "$line" ]; do
|
||||
+ while read -r line || [ -n "$line" ]; do
|
||||
[ -e "$line" ] || [ -h "$line" ] || continue
|
||||
rm -f "$line"
|
||||
done < /lib/dracut/hostonly-files
|
||||
|
24
0008.patch
Normal file
24
0008.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From b38b7fef36333a59890233dccfbbb6d2c40ebe83 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Molkentin <dmolkentin@suse.com>
|
||||
Date: Fri, 19 Oct 2018 14:39:30 +0200
|
||||
Subject: [PATCH] 95dasd_rules: mark dasd rules host_only
|
||||
|
||||
Reference: bsc#1090884
|
||||
---
|
||||
modules.d/95dasd_rules/module-setup.sh | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/modules.d/95dasd_rules/module-setup.sh b/modules.d/95dasd_rules/module-setup.sh
|
||||
index 488400c3..124dbad9 100755
|
||||
--- a/modules.d/95dasd_rules/module-setup.sh
|
||||
+++ b/modules.d/95dasd_rules/module-setup.sh
|
||||
@@ -54,6 +54,8 @@ install() {
|
||||
if [[ $hostonly ]] ; then
|
||||
inst_rules_wildcard 51-dasd-*.rules
|
||||
inst_rules_wildcard 41-s390x-dasd-*.rules
|
||||
+ mark_hostonly /etc/udev/rules.d/51-dasd-*.rules
|
||||
+ mark_hostonly /etc/udev/rules.d/41-s390x-dasd-*.rules
|
||||
fi
|
||||
inst_rules 59-dasd.rules
|
||||
}
|
||||
|
37
0009.patch
Normal file
37
0009.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From 765b20333d9589e09b29dbe0d8304a56745623c6 Mon Sep 17 00:00:00 2001
|
||||
From: Dusty Mabe <dusty@dustymabe.com>
|
||||
Date: Mon, 22 Oct 2018 13:25:29 -0400
|
||||
Subject: [PATCH] 95iscsi: drop systemd dracut service dependencies for iscsid
|
||||
|
||||
These dependencies cause an odd issue where swap devices specified
|
||||
by resume= on the kernel command line will cause systemd device
|
||||
timeouts to occur on boot. According to @haraldh these lines aren't
|
||||
needed because the socket activiation will take care of it for us.
|
||||
Removing these lines now as it fixes the resume= device timeout issue.
|
||||
|
||||
Fixes #480
|
||||
Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1641268
|
||||
---
|
||||
modules.d/95iscsi/module-setup.sh | 8 --------
|
||||
1 file changed, 8 deletions(-)
|
||||
|
||||
diff --git a/modules.d/95iscsi/module-setup.sh b/modules.d/95iscsi/module-setup.sh
|
||||
index 5c2073bb..3c791001 100755
|
||||
--- a/modules.d/95iscsi/module-setup.sh
|
||||
+++ b/modules.d/95iscsi/module-setup.sh
|
||||
@@ -257,14 +257,6 @@ install() {
|
||||
; do
|
||||
ln_r "$systemdsystemunitdir/${i}" "$systemdsystemunitdir/basic.target.wants/${i}"
|
||||
done
|
||||
-
|
||||
- # Make sure iscsid is started after dracut-cmdline and ready for the initqueue
|
||||
- mkdir -p "${initdir}/$systemdsystemunitdir/iscsid.service.d"
|
||||
- (
|
||||
- echo "[Unit]"
|
||||
- echo "After=dracut-cmdline.service"
|
||||
- echo "Before=dracut-initqueue.service"
|
||||
- ) > "${initdir}/$systemdsystemunitdir/iscsid.service.d/dracut.conf"
|
||||
fi
|
||||
inst_dir /var/lib/iscsi
|
||||
dracut_need_initqueue
|
||||
|
40
0010.patch
Normal file
40
0010.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 0eef73ea43427cdb82fa031e09978d3cea6e188a Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Wed, 24 Oct 2018 15:14:03 +0200
|
||||
Subject: [PATCH] Makefile: add srpm target
|
||||
|
||||
---
|
||||
Makefile | 13 ++++++++++++-
|
||||
1 file changed, 12 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 80623437..503d069f 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -40,7 +40,7 @@ man8pages = dracut.8 \
|
||||
|
||||
manpages = $(man1pages) $(man5pages) $(man7pages) $(man8pages)
|
||||
|
||||
-.PHONY: install clean archive rpm testimage test all check AUTHORS doc dracut-version.sh
|
||||
+.PHONY: install clean archive rpm srpm testimage test all check AUTHORS doc dracut-version.sh
|
||||
|
||||
all: dracut-version.sh dracut.pc dracut-install skipcpio/skipcpio
|
||||
|
||||
@@ -216,6 +216,17 @@ rpm: dracut-$(VERSION).tar.xz syncheck
|
||||
--define "_rpmdir $$PWD" -ba dracut.spec; ) && \
|
||||
( mv "$$rpmbuild"/{,$$(arch)/}*.rpm $(DESTDIR).; rm -fr -- "$$rpmbuild"; ls $(DESTDIR)*.rpm )
|
||||
|
||||
+srpm: dracut-$(VERSION).tar.xz syncheck
|
||||
+ rpmbuild=$$(mktemp -d -t rpmbuild-dracut.XXXXXX); src=$$(pwd); \
|
||||
+ cp dracut-$(VERSION).tar.xz "$$rpmbuild"; \
|
||||
+ LC_MESSAGES=C $$src/git2spec.pl $(VERSION) "$$rpmbuild" < dracut.spec > $$rpmbuild/dracut.spec; \
|
||||
+ (cd "$$rpmbuild"; \
|
||||
+ [ -f $$src/lgpl-2.1.txt ] && cp $$src/lgpl-2.1.txt . || wget https://www.gnu.org/licenses/lgpl-2.1.txt; \
|
||||
+ rpmbuild --define "_topdir $$PWD" --define "_sourcedir $$PWD" \
|
||||
+ --define "_specdir $$PWD" --define "_srcrpmdir $$PWD" \
|
||||
+ --define "_rpmdir $$PWD" -bs dracut.spec; ) && \
|
||||
+ ( mv "$$rpmbuild"/*.src.rpm $(DESTDIR).; rm -fr -- "$$rpmbuild"; ls $(DESTDIR)*.rpm )
|
||||
+
|
||||
syncheck:
|
||||
@ret=0;for i in dracut-initramfs-restore.sh modules.d/*/*.sh; do \
|
||||
[ "$${i##*/}" = "module-setup.sh" ] && continue; \
|
12
dracut.spec
12
dracut.spec
@ -5,7 +5,7 @@
|
||||
# strip the automatically generated dep here and instead co-own the
|
||||
# directory.
|
||||
%global __requires_exclude pkg-config
|
||||
%define dist_free_release 4.git20181010
|
||||
%define dist_free_release 11.git20181024
|
||||
|
||||
Name: dracut
|
||||
Version: 049
|
||||
@ -31,6 +31,13 @@ Source0: http://www.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version}.tar
|
||||
Patch1: 0001.patch
|
||||
Patch2: 0002.patch
|
||||
Patch3: 0003.patch
|
||||
Patch4: 0004.patch
|
||||
Patch5: 0005.patch
|
||||
Patch6: 0006.patch
|
||||
Patch7: 0007.patch
|
||||
Patch8: 0008.patch
|
||||
Patch9: 0009.patch
|
||||
Patch10: 0010.patch
|
||||
|
||||
Source1: https://www.gnu.org/licenses/lgpl-2.1.txt
|
||||
|
||||
@ -476,6 +483,9 @@ install -m 0755 51-dracut-rescue-postinst.sh $RPM_BUILD_ROOT%{_sysconfdir}/kerne
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 24 2018 Harald Hoyer <harald@redhat.com> - 049-11.git20181024
|
||||
- git snapshot
|
||||
|
||||
* Wed Oct 10 2018 Harald Hoyer <harald@redhat.com> - 049-4.git20181010
|
||||
- fixed spec file
|
||||
- git snapshot
|
||||
|
Loading…
Reference in New Issue
Block a user