dracut-034-1
- version 034 - add option to turn on/off prelinking --prelink, --noprelink do_prelink=[yes|no] - add ACPI table overriding - do not log to syslog/kmsg/journal for UID != 0 - lvm/mdraid: Fix LVM on MD activation - bcache module removed (now in bcache-tools upstream) - mdadm: also install configs from /etc/mdadm.conf.d - fixes for mdadm-3.2.6+ - fcoe: add FCoE UEFI boot device support - rootfs-block: add support for the rootfallback= kernel cmdline option
This commit is contained in:
parent
d559f4679c
commit
0142f0711e
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@
|
||||
/dracut-031.tar.bz2
|
||||
/dracut-032.tar.bz2
|
||||
/dracut-033.tar.bz2
|
||||
/dracut-034.tar.bz2
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 57f90974f9d7c11e06c2b3f2b7e4b47801f380cc Mon Sep 17 00:00:00 2001
|
||||
From: Harald Hoyer <harald@redhat.com>
|
||||
Date: Fri, 13 Sep 2013 16:33:01 +0200
|
||||
Subject: [PATCH] dracut.sh: harden host_modalias reading
|
||||
|
||||
Some weird PPC driver make their modulias unreadable
|
||||
|
||||
$ cat /sys/devices/vio/4000/modalias
|
||||
cat: /sys/devices/vio/4000/modalias: No such device
|
||||
---
|
||||
dracut.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dracut.sh b/dracut.sh
|
||||
index bd905e3..fd27846 100755
|
||||
--- a/dracut.sh
|
||||
+++ b/dracut.sh
|
||||
@@ -921,7 +921,7 @@ if [[ $hostonly ]]; then
|
||||
declare -A host_modalias
|
||||
find /sys/devices/ -name modalias -print > "$initdir/.modalias"
|
||||
while read m; do
|
||||
- host_modalias["$(<"$m")"]=1
|
||||
+ modalias="$(<"$m")" && [[ $modalias ]] && host_modalias["$modalias"]=1
|
||||
done < "$initdir/.modalias"
|
||||
rm -f -- "$initdir/.modalias"
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 63f3bcd85245901515f4f45238301e030468cdc5 Mon Sep 17 00:00:00 2001
|
||||
From: WANG Chao <chaowang@redhat.com>
|
||||
Date: Fri, 13 Sep 2013 22:28:44 +0800
|
||||
Subject: [PATCH] ifup: do not dhcp on network interface of secondary stack
|
||||
|
||||
Configure cmdline to:
|
||||
ip=br0:dhcp bridge=br0:bond0 bond=bond0:eth0
|
||||
|
||||
By default ifup bond0 will run dhcp on bond0, which is wrong. bond0
|
||||
isn't the top interface. we should really run dhcp on br0.
|
||||
|
||||
So if we ifup an network interface on secondary stack, we should not
|
||||
dhcp. Fix this issue with this patch.
|
||||
---
|
||||
modules.d/40network/ifup.sh | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/modules.d/40network/ifup.sh b/modules.d/40network/ifup.sh
|
||||
index 3261647..9f6f449 100755
|
||||
--- a/modules.d/40network/ifup.sh
|
||||
+++ b/modules.d/40network/ifup.sh
|
||||
@@ -336,6 +336,13 @@ for p in $(getargs ip=); do
|
||||
exit 0
|
||||
done
|
||||
|
||||
+# netif isn't the top stack? Then we should exit here.
|
||||
+# eg. netif is bond0. br0 is on top of it. dhcp br0 is correct but dhcp
|
||||
+# bond0 doesn't make sense.
|
||||
+if [ -n "$DO_BOND_SETUP" -o -n "$DO_TEAM_SETUP" -o -n "$DO_VLAN_SETUP" ]; then
|
||||
+ exit 0
|
||||
+fi
|
||||
+
|
||||
# no ip option directed at our interface?
|
||||
if [ ! -e /tmp/setup_net_${netif}.ok ]; then
|
||||
do_dhcp -4
|
34
dracut.spec
34
dracut.spec
@ -9,8 +9,8 @@
|
||||
%endif
|
||||
|
||||
Name: dracut
|
||||
Version: 033
|
||||
Release: 3.git20130913%{?dist}
|
||||
Version: 034
|
||||
Release: 1%{?dist}
|
||||
|
||||
Summary: Initramfs generator using udev
|
||||
%if 0%{?fedora} || 0%{?rhel}
|
||||
@ -29,8 +29,6 @@ URL: https://dracut.wiki.kernel.org/
|
||||
# Source can be generated by
|
||||
# http://git.kernel.org/?p=boot/dracut/dracut.git;a=snapshot;h=%{version};sf=tgz
|
||||
Source0: http://www.kernel.org/pub/linux/utils/boot/dracut/dracut-%{version}.tar.bz2
|
||||
Patch1: 0001-dracut.sh-harden-host_modalias-reading.patch
|
||||
Patch2: 0002-ifup-do-not-dhcp-on-network-interface-of-secondary-s.patch
|
||||
|
||||
|
||||
BuildRequires: bash git
|
||||
@ -100,16 +98,14 @@ Requires: util-linux >= 2.21
|
||||
Requires: systemd >= 199
|
||||
Requires: procps-ng
|
||||
Conflicts: grubby < 8.23
|
||||
Conflicts: initscripts < 8.63-1
|
||||
Conflicts: plymouth < 0.8.0-0.2009.29.09.19.1
|
||||
Conflicts: bcache-tools < 0-0.14.20130909git
|
||||
%else
|
||||
Requires: udev > 166
|
||||
Requires: util-linux-ng >= 2.21
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 6
|
||||
Conflicts: initscripts < 8.63-1
|
||||
Conflicts: plymouth < 0.8.0-0.2009.29.09.19.1
|
||||
%endif
|
||||
|
||||
Conflicts: mdadm < 3.2.6-14
|
||||
|
||||
%description
|
||||
@ -274,6 +270,10 @@ echo 'hostonly="no"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/02-generic-i
|
||||
echo 'dracut_rescue_image="yes"' > $RPM_BUILD_ROOT%{dracutlibdir}/dracut.conf.d/02-rescue.conf
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} || 0%{?suse_version}
|
||||
> $RPM_BUILD_ROOT/etc/system-fips
|
||||
%endif
|
||||
|
||||
# create compat symlink
|
||||
mkdir -p $RPM_BUILD_ROOT/sbin
|
||||
ln -s /usr/bin/dracut $RPM_BUILD_ROOT/sbin/dracut
|
||||
@ -333,7 +333,6 @@ rm -rf -- $RPM_BUILD_ROOT
|
||||
%{dracutlibdir}/modules.d/50drm
|
||||
%{dracutlibdir}/modules.d/50plymouth
|
||||
%{dracutlibdir}/modules.d/80cms
|
||||
%{dracutlibdir}/modules.d/90bcache
|
||||
%{dracutlibdir}/modules.d/90btrfs
|
||||
%{dracutlibdir}/modules.d/90crypt
|
||||
%{dracutlibdir}/modules.d/90dm
|
||||
@ -416,6 +415,7 @@ rm -rf -- $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root,0755)
|
||||
%{dracutlibdir}/modules.d/01fips
|
||||
%{dracutlibdir}/dracut.conf.d/40-fips.conf
|
||||
%config(missingok) /etc/system-fips
|
||||
%endif
|
||||
|
||||
%files fips-aesni
|
||||
@ -448,6 +448,20 @@ rm -rf -- $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 08 2013 Harald Hoyer <harald@redhat.com> 034-1
|
||||
- version 034
|
||||
- add option to turn on/off prelinking
|
||||
--prelink, --noprelink
|
||||
do_prelink=[yes|no]
|
||||
- add ACPI table overriding
|
||||
- do not log to syslog/kmsg/journal for UID != 0
|
||||
- lvm/mdraid: Fix LVM on MD activation
|
||||
- bcache module removed (now in bcache-tools upstream)
|
||||
- mdadm: also install configs from /etc/mdadm.conf.d
|
||||
- fixes for mdadm-3.2.6+
|
||||
- fcoe: add FCoE UEFI boot device support
|
||||
- rootfs-block: add support for the rootfallback= kernel cmdline option
|
||||
|
||||
* Fri Sep 13 2013 Harald Hoyer <harald@redhat.com> 033-3.git20130913
|
||||
- do not dhcp members of team, bond, etc.
|
||||
- harden against weird ppc kernel driver
|
||||
|
Loading…
Reference in New Issue
Block a user