8f01de6aa6
The dpdk-tools and dpdk packages copy the same files into %{_bindir}, which should be avoided. To fix this, setup an exclude. Additionally, there's an odd requirement imposed by using dpdk because of libraries not being linked in properly against the shared objects generated. To fix this, introduce the dt-needed patch. A version of this has been accepted upstream for some PMDs, but we will do this for all. Signed-off-by: Aaron Conole <aconole@redhat.com>
25 lines
1015 B
Diff
25 lines
1015 B
Diff
diff -up dpdk-2.0.0/lib/librte_eal/linuxapp/eal/Makefile.dtneeded dpdk-2.0.0/lib/librte_eal/linuxapp/eal/Makefile
|
|
--- dpdk-2.0.0/lib/librte_eal/linuxapp/eal/Makefile.dtneeded 2015-04-03 17:13:45.000000000 +0300
|
|
+++ dpdk-2.0.0/lib/librte_eal/linuxapp/eal/Makefile 2015-04-17 15:23:38.267984467 +0300
|
|
@@ -53,6 +53,8 @@ CFLAGS += -I$(RTE_SDK)/drivers/net/af_packet
|
|
CFLAGS += -I$(RTE_SDK)/lib/librte_ivshmem
|
|
CFLAGS += $(WERROR_FLAGS) -O3
|
|
|
|
+LDLIBS += -ldl -lpthread
|
|
+
|
|
# specific to linuxapp exec-env
|
|
SRCS-$(CONFIG_RTE_LIBRTE_EAL_LINUXAPP) := eal.c
|
|
SRCS-$(CONFIG_RTE_LIBRTE_EAL_LINUXAPP) += eal_hugepage_info.c
|
|
diff -up dpdk-2.1.0/drivers/net/pcap/Makefile.dtneeded dpdk-2.0.0/lib/librte_pmd_pcap/Makefile
|
|
--- dpdk-2.1.0/drivers/net/pcap/Makefile.dtneeded 2015-04-03 17:13:45.000000000 +0300
|
|
+++ dpdk-2.1.0/drivers/net/pcap/Makefile 2015-04-17 15:23:38.267984467 +0300
|
|
@@ -37,6 +37,8 @@ include $(RTE_SDK)/mk/rte.vars.mk
|
|
#
|
|
LIB = librte_pmd_pcap.a
|
|
|
|
+LDLIBS += -lpcap
|
|
+
|
|
CFLAGS += -O3
|
|
CFLAGS += $(WERROR_FLAGS)
|
|
|