dpdk/dpdk-dtneeded-2.2-accepted.patch
Aaron Conole 8f01de6aa6 dpdk.spec: linkage and file overlap
The dpdk-tools and dpdk packages copy the same files into %{_bindir}, which
should be avoided. To fix this, setup an exclude.

Additionally, there's an odd requirement imposed by using dpdk because of
libraries not being linked in properly against the shared objects generated.
To fix this, introduce the dt-needed patch. A version of this has been
accepted upstream for some PMDs, but we will do this for all.

Signed-off-by: Aaron Conole <aconole@redhat.com>
2015-11-13 17:29:13 -05:00

12 lines
423 B
Diff

diff -up dpdk-2.0.0/lib/librte_vhost/Makefile.dtneeded dpdk-2.0.0/lib/librte_vhost/Makefile
--- dpdk-2.0.0/lib/librte_vhost/Makefile.dtneeded 2015-04-03 17:13:45.000000000 +0300
+++ dpdk-2.0.0/lib/librte_vhost/Makefile 2015-04-17 15:24:37.593834737 +0300
@@ -44,6 +44,7 @@ CFLAGS += -I vhost_user
else
CFLAGS += -I vhost_cuse -lfuse
LDFLAGS += -lfuse
+LDLIBS += -lfuse
endif
ifeq ($(CONFIG_RTE_LIBRTE_VHOST_NUMA),y)