parent
b71f31ec34
commit
b7a03b924c
2
.gitignore
vendored
2
.gitignore
vendored
@ -16,3 +16,5 @@
|
||||
/dpdk-18.11.tar.xz
|
||||
/dpdk-18.11.2.tar.xz
|
||||
/dpdk-18.11.6.tar.xz
|
||||
/dpdk-19.11.tar.xz
|
||||
/dpdk-19.11.1.tar.xz
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff -up ./lib/librte_net/rte_ether.h.align ./lib/librte_net/rte_ether.h
|
||||
--- ./lib/librte_net/rte_ether.h.align 2018-04-19 10:09:22.000000000 -0400
|
||||
+++ ./lib/librte_net/rte_ether.h 2019-02-12 14:15:57.719572582 -0500
|
||||
@@ -175,10 +175,9 @@ static inline int is_multicast_ether_add
|
||||
*/
|
||||
static inline int is_broadcast_ether_addr(const struct ether_addr *ea)
|
||||
{
|
||||
- const unaligned_uint16_t *ea_words = (const unaligned_uint16_t *)ea;
|
||||
-
|
||||
- return (ea_words[0] == 0xFFFF && ea_words[1] == 0xFFFF &&
|
||||
- ea_words[2] == 0xFFFF);
|
||||
+ return (ea->addr_bytes[0] == 0xFF && ea->addr_bytes[1] == 0xFF &&
|
||||
+ ea->addr_bytes[2] == 0xFF && ea->addr_bytes[3] == 0xFF &&
|
||||
+ ea->addr_bytes[4] == 0xFF && ea->addr_bytes[5] == 0xFF);
|
||||
}
|
||||
|
||||
/**
|
35
dpdk.spec
35
dpdk.spec
@ -8,7 +8,7 @@
|
||||
%bcond_with pdfdoc
|
||||
|
||||
Name: dpdk
|
||||
Version: 18.11.6
|
||||
Version: 19.11
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
URL: http://dpdk.org
|
||||
@ -16,7 +16,6 @@ Source: https://fast.dpdk.org/rel/dpdk-%{version}.tar.xz
|
||||
|
||||
Patch0: app-pie.patch
|
||||
Patch1: fcf-protection.patch
|
||||
Patch2: dpdk-rte-ether-align.patch
|
||||
# fixed multilib issue with doxygen
|
||||
Patch3: dpdk-stable-18.11.2-doxygen-multilib.patch
|
||||
|
||||
@ -123,13 +122,35 @@ as L2 and L3 forwarding.
|
||||
%define incdir %{_includedir}/%{name}
|
||||
%define pmddir %{_libdir}/%{name}-pmds
|
||||
|
||||
%pretrans -p <lua>
|
||||
-- This is to clean up directories before links created
|
||||
-- See https://fedoraproject.org/wiki/Packaging:Directory_Replacement
|
||||
|
||||
directories = {
|
||||
"/usr/share/dpdk/mk/exec-env/bsdapp",
|
||||
"/usr/share/dpdk/mk/exec-env/linuxapp"
|
||||
}
|
||||
for i,path in ipairs(directories) do
|
||||
st = posix.stat(path)
|
||||
if st and st.type == "directory" then
|
||||
status = os.rename(path, path .. ".rpmmoved")
|
||||
if not status then
|
||||
suffix = 0
|
||||
while not status do
|
||||
suffix = suffix + 1
|
||||
status = os.rename(path .. ".rpmmoved", path .. ".rpmmoved." .. suffix)
|
||||
end
|
||||
os.rename(path, path .. ".rpmmoved")
|
||||
end
|
||||
end
|
||||
end
|
||||
|
||||
%prep
|
||||
%setup -q -n dpdk-stable-%{version}
|
||||
%patch0 -p1
|
||||
%setup -q -n dpdk-%{version}
|
||||
%patch0 -p1
|
||||
%ifarch x86_64 i686
|
||||
%patch1 -p1
|
||||
%endif
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
@ -289,6 +310,8 @@ sed -i -e 's:-%{machine_tmpl}-:-%{machine}-:g' %{buildroot}/%{_sysconfdir}/profi
|
||||
#BSD
|
||||
%{incdir}/
|
||||
%{sdkdir}
|
||||
%ghost %{sdkdir}/mk/exec-env/bsdapp
|
||||
%ghost %{sdkdir}/mk/exec-env/linuxapp
|
||||
%if %{with tools}
|
||||
%exclude %{sdkdir}/usertools/
|
||||
%endif
|
||||
@ -309,7 +332,9 @@ sed -i -e 's:-%{machine_tmpl}-:-%{machine}-:g' %{buildroot}/%{_sysconfdir}/profi
|
||||
%{_bindir}/dpdk-pdump
|
||||
%{_bindir}/dpdk-pmdinfo
|
||||
%{_bindir}/dpdk-test-bbdev
|
||||
%{_bindir}/dpdk-test-compress-perf
|
||||
%{_bindir}/dpdk-test-crypto-perf
|
||||
%{_bindir}/testsad
|
||||
%endif
|
||||
|
||||
%if %{with examples}
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dpdk-18.11.6.tar.xz) = 72b413a6f2d1b6e8ecbecf84b0e97cf59315843a128f83b1d1ed0740cf7f6b838a49937197574d7889235e213e595ddb9cd8a122a3e297f56959ef52cd7c52e3
|
||||
SHA512 (dpdk-19.11.1.tar.xz) = 3079240c34c0270dc47f530214fb0915399c7346a3885516cb2ea146950f3795894d90574dd89a4e3da2e5731151867f8e9467cbeb75086e9d1e0f09a43d97f3
|
||||
|
Loading…
Reference in New Issue
Block a user