Resolves: bz 1256137
This commit is contained in:
parent
7c2b8051e3
commit
b41f5f17db
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/dpdk-1.7.0-20140603git5ebbb1728.tgz
|
||||
/dpdk-1.7.0.tar.gz
|
||||
/dpdk-2.0.0.tar.gz
|
||||
/dpdk-2.1.0.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxapp
|
||||
--- dpdk-2.0.0/config/common_linuxapp.orig 2015-04-03 10:13:45.000000000 -0400
|
||||
+++ dpdk-2.0.0/config/common_linuxapp 2015-04-06 10:52:14.073329962 -0400
|
||||
diff -up ./dpdk-2.1.0/config/common_linuxapp.config ./dpdk-2.1.0/config/common_linuxapp
|
||||
--- ./dpdk-2.1.0/config/common_linuxapp.config 2015-08-27 09:51:50.192529771 -0400
|
||||
+++ ./dpdk-2.1.0/config/common_linuxapp 2015-08-27 09:52:48.342213540 -0400
|
||||
@@ -52,7 +52,7 @@ CONFIG_RTE_EXEC_ENV_LINUXAPP=y
|
||||
## Note: if your compiler does not support the relevant -march options,
|
||||
## it will be compiled with whatever latest processor the compiler supports!
|
||||
@ -10,16 +10,25 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
#
|
||||
##
|
||||
## define the architecture we compile for.
|
||||
@@ -98,7 +98,7 @@ CONFIG_RTE_LOG_HISTORY=256
|
||||
@@ -91,7 +91,7 @@ CONFIG_RTE_BUILD_COMBINE_LIBS=n
|
||||
#
|
||||
# Use newest code breaking previous ABI
|
||||
#
|
||||
-CONFIG_RTE_NEXT_ABI=y
|
||||
+CONFIG_RTE_NEXT_ABI=n
|
||||
|
||||
#
|
||||
# Compile Environment Abstraction Layer
|
||||
@@ -107,7 +107,7 @@ CONFIG_RTE_LOG_HISTORY=256
|
||||
CONFIG_RTE_LIBEAL_USE_HPET=n
|
||||
CONFIG_RTE_EAL_ALLOW_INV_SOCKET_ID=n
|
||||
CONFIG_RTE_EAL_ALWAYS_PANIC_ON_ERROR=n
|
||||
-CONFIG_RTE_EAL_IGB_UIO=y
|
||||
+CONFIG_RTE_EAL_IGB_UIO=n
|
||||
CONFIG_RTE_EAL_VFIO=y
|
||||
CONFIG_RTE_MALLOC_DEBUG=n
|
||||
|
||||
#
|
||||
@@ -147,8 +147,8 @@ CONFIG_RTE_NIC_BYPASS=n
|
||||
@@ -152,8 +152,8 @@ CONFIG_RTE_NIC_BYPASS=n
|
||||
#
|
||||
# Compile burst-oriented IGB & EM PMD drivers
|
||||
#
|
||||
@ -30,7 +39,7 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
CONFIG_RTE_LIBRTE_E1000_DEBUG_INIT=n
|
||||
CONFIG_RTE_LIBRTE_E1000_DEBUG_RX=n
|
||||
CONFIG_RTE_LIBRTE_E1000_DEBUG_TX=n
|
||||
@@ -159,7 +159,7 @@ CONFIG_RTE_LIBRTE_E1000_PF_DISABLE_STRIP
|
||||
@@ -164,7 +164,7 @@ CONFIG_RTE_LIBRTE_E1000_PF_DISABLE_STRIP
|
||||
#
|
||||
# Compile burst-oriented IXGBE PMD driver
|
||||
#
|
||||
@ -39,7 +48,7 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
CONFIG_RTE_LIBRTE_IXGBE_DEBUG_INIT=n
|
||||
CONFIG_RTE_LIBRTE_IXGBE_DEBUG_RX=n
|
||||
CONFIG_RTE_LIBRTE_IXGBE_DEBUG_TX=n
|
||||
@@ -173,7 +173,7 @@ CONFIG_RTE_IXGBE_RX_OLFLAGS_ENABLE=y
|
||||
@@ -177,7 +177,7 @@ CONFIG_RTE_IXGBE_RX_OLFLAGS_ENABLE=y
|
||||
#
|
||||
# Compile burst-oriented I40E PMD driver
|
||||
#
|
||||
@ -48,7 +57,7 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
CONFIG_RTE_LIBRTE_I40E_DEBUG_INIT=n
|
||||
CONFIG_RTE_LIBRTE_I40E_DEBUG_RX=n
|
||||
CONFIG_RTE_LIBRTE_I40E_DEBUG_TX=n
|
||||
@@ -242,7 +242,7 @@ CONFIG_RTE_PMD_RING_MAX_TX_RINGS=16
|
||||
@@ -267,7 +267,7 @@ CONFIG_RTE_PMD_RING_MAX_TX_RINGS=16
|
||||
#
|
||||
# Compile software PMD backed by PCAP files
|
||||
#
|
||||
@ -57,7 +66,7 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
|
||||
#
|
||||
# Compile link bonding PMD library
|
||||
@@ -338,7 +338,7 @@ CONFIG_RTE_LIBRTE_LPM_DEBUG=n
|
||||
@@ -356,7 +356,7 @@ CONFIG_RTE_LIBRTE_LPM_DEBUG=n
|
||||
#
|
||||
# Compile librte_acl
|
||||
#
|
||||
@ -66,20 +75,22 @@ diff -up dpdk-2.0.0/config/common_linuxapp.orig dpdk-2.0.0/config/common_linuxap
|
||||
CONFIG_RTE_LIBRTE_ACL_DEBUG=n
|
||||
|
||||
#
|
||||
@@ -403,8 +403,8 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
|
||||
@@ -424,9 +424,9 @@ CONFIG_RTE_PIPELINE_STATS_COLLECT=n
|
||||
#
|
||||
# Compile librte_kni
|
||||
#
|
||||
-CONFIG_RTE_LIBRTE_KNI=y
|
||||
-CONFIG_RTE_KNI_KMOD=y
|
||||
-CONFIG_RTE_KNI_PREEMPT_DEFAULT=y
|
||||
+CONFIG_RTE_LIBRTE_KNI=n
|
||||
+CONFIG_RTE_KNI_KMOD=n
|
||||
+CONFIG_RTE_KNI_PREEMPT_DEFAULT=n
|
||||
CONFIG_RTE_KNI_KO_DEBUG=n
|
||||
CONFIG_RTE_KNI_VHOST=n
|
||||
CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
|
||||
diff -up dpdk-2.0.0/config/defconfig_x86_64-native-linuxapp-gcc.orig dpdk-2.0.0/config/defconfig_x86_64-native-linuxapp-gcc
|
||||
--- dpdk-2.0.0/config/defconfig_x86_64-native-linuxapp-gcc.orig 2015-04-03 10:13:45.000000000 -0400
|
||||
+++ dpdk-2.0.0/config/defconfig_x86_64-native-linuxapp-gcc 2015-04-06 10:53:01.495666675 -0400
|
||||
diff -up ./dpdk-2.1.0/config/defconfig_x86_64-native-linuxapp-gcc.config ./dpdk-2.1.0/config/defconfig_x86_64-native-linuxapp-gcc
|
||||
--- ./dpdk-2.1.0/config/defconfig_x86_64-native-linuxapp-gcc.config 2015-08-17 13:35:37.000000000 -0400
|
||||
+++ ./dpdk-2.1.0/config/defconfig_x86_64-native-linuxapp-gcc 2015-08-27 09:52:29.304662294 -0400
|
||||
@@ -31,8 +31,10 @@
|
||||
#
|
||||
|
||||
|
21
dpdk.spec
21
dpdk.spec
@ -4,8 +4,8 @@
|
||||
%bcond_without shared
|
||||
|
||||
Name: dpdk
|
||||
Version: 2.0.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
URL: http://dpdk.org
|
||||
Source: http://dpdk.org/browse/dpdk/snapshot/dpdk-%{version}.tar.gz
|
||||
|
||||
@ -36,7 +36,13 @@ ExclusiveArch: x86_64
|
||||
|
||||
|
||||
BuildRequires: kernel-headers, libpcap-devel, doxygen, texlive-dejavu
|
||||
BuildRequires: python-sphinx inkscape
|
||||
BuildRequires: python-sphinx inkscape texlive-latex-bin-bin
|
||||
BuildRequires: texlive-kpathsea-bin texlive-metafont-bin texlive-cm
|
||||
BuildRequires: texlive-cmap texlive-ec texlive-babel-english
|
||||
BuildRequires: texlive-fancyhdr texlive-fancybox texlive-titlesec
|
||||
BuildRequires: texlive-framed texlive-threeparttable texlive-mdwtools
|
||||
BuildRequires: texlive-wrapfig texlive-parskip texlive-upquote texlive-multirow
|
||||
BuildRequires: texlive-helvetic texlive-times texlive-dvips
|
||||
|
||||
%description
|
||||
The Data Plane Development Kit is a set of libraries and drivers for
|
||||
@ -65,9 +71,9 @@ API programming documentation for the Data Plane Development Kit.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -z .config
|
||||
%patch2 -p1 -z .enic
|
||||
%patch3 -p1 -z .null
|
||||
%patch1 -p2 -z .config
|
||||
%patch2 -p2 -z .enic
|
||||
%patch3 -p2 -z .null
|
||||
|
||||
%if %{with shared}
|
||||
sed -i 's:^CONFIG_RTE_BUILD_SHARED_LIB=n$:CONFIG_RTE_BUILD_SHARED_LIB=y:g' config/common_linuxapp
|
||||
@ -180,6 +186,9 @@ install -m 644 ${comblib} %{buildroot}/%{_libdir}/%{name}-%{version}/${comblib}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 26 2015 Neil Horman <nhorman@redhat.com> - 2.1.0-1
|
||||
- Update to latest version
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
@ -1,8 +1,7 @@
|
||||
diff -up dpdk-2.0.0/build/.config.orig dpdk-2.0.0/build/.config
|
||||
diff -up dpdk-2.0.0/lib/librte_pmd_enic/enic_ethdev.c.orig dpdk-2.0.0/lib/librte_pmd_enic/enic_ethdev.c
|
||||
--- dpdk-2.0.0/lib/librte_pmd_enic/enic_ethdev.c.orig 2015-04-06 14:01:57.388519083 -0400
|
||||
+++ dpdk-2.0.0/lib/librte_pmd_enic/enic_ethdev.c 2015-04-06 14:05:50.939207323 -0400
|
||||
@@ -313,13 +313,15 @@ static void enicpmd_dev_stop(struct rte_
|
||||
diff -up ./dpdk-2.1.0/drivers/net/enic/enic_ethdev.c.enic ./dpdk-2.1.0/drivers/net/enic/enic_ethdev.c
|
||||
--- ./dpdk-2.1.0/drivers/net/enic/enic_ethdev.c.enic 2015-08-17 13:35:37.000000000 -0400
|
||||
+++ ./dpdk-2.1.0/drivers/net/enic/enic_ethdev.c 2015-08-26 10:33:17.953104878 -0400
|
||||
@@ -348,13 +348,15 @@ static void enicpmd_dev_stop(struct rte_
|
||||
{
|
||||
struct rte_eth_link link;
|
||||
struct enic *enic = pmd_priv(eth_dev);
|
||||
@ -21,4 +20,3 @@ diff -up dpdk-2.0.0/lib/librte_pmd_enic/enic_ethdev.c.orig dpdk-2.0.0/lib/librte
|
||||
}
|
||||
|
||||
/*
|
||||
diff -up dpdk-2.0.0/test/.config.orig dpdk-2.0.0/test/.config
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up dpdk-2.0.0/lib/librte_pmd_null/rte_eth_null.c.orig dpdk-2.0.0/lib/librte_pmd_null/rte_eth_null.c
|
||||
--- dpdk-2.0.0/lib/librte_pmd_null/rte_eth_null.c.orig 2015-04-07 15:54:49.437739442 -0400
|
||||
+++ dpdk-2.0.0/lib/librte_pmd_null/rte_eth_null.c 2015-04-07 15:55:48.880447043 -0400
|
||||
diff -up ./dpdk-2.1.0/drivers/net/null/rte_eth_null.c.null ./dpdk-2.1.0/drivers/net/null/rte_eth_null.c
|
||||
--- ./dpdk-2.1.0/drivers/net/null/rte_eth_null.c.null 2015-08-17 13:35:37.000000000 -0400
|
||||
+++ ./dpdk-2.1.0/drivers/net/null/rte_eth_null.c 2015-08-26 10:34:03.060418807 -0400
|
||||
@@ -71,8 +71,13 @@ struct pmd_internals {
|
||||
unsigned nb_rx_queues;
|
||||
unsigned nb_tx_queues;
|
||||
|
Loading…
Reference in New Issue
Block a user