Resolves: bz 142285
This commit is contained in:
parent
45f496a7f3
commit
8af87f94d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/dpdk-16.04.tar.gz
|
||||
/dpdk-16.07.tar.xz
|
||||
/dpdk-16.11.tar.xz
|
||||
/dpdk-17.02.tar.xz
|
||||
|
26
dpdk.spec
26
dpdk.spec
@ -8,11 +8,12 @@
|
||||
%bcond_with pdfdoc
|
||||
|
||||
Name: dpdk
|
||||
Version: 16.11
|
||||
Release: 2%{?dist}
|
||||
Version: 17.02
|
||||
Release: 1%{?dist}
|
||||
URL: http://dpdk.org
|
||||
Source: http://dpdk.org/browse/dpdk/snapshot/dpdk-%{version}.tar.xz
|
||||
Patch0: test-app-libfix.patch
|
||||
Patch1: lengthfix.patch
|
||||
Patch2: makefix.patch
|
||||
|
||||
Summary: Set of libraries and drivers for fast packet processing
|
||||
|
||||
@ -118,7 +119,8 @@ as L2 and L3 forwarding.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1 -b .lengthfix
|
||||
%patch2 -p1 -b .makefix
|
||||
|
||||
%build
|
||||
# set up a method for modifying the resulting .config file
|
||||
@ -149,7 +151,6 @@ make V=1 O=%{target} T=%{target} %{?_smp_mflags} config
|
||||
setconf CONFIG_RTE_MACHINE '"%{machine}"'
|
||||
# Disable experimental features
|
||||
setconf CONFIG_RTE_NEXT_ABI n
|
||||
setconf CONFIG_RTE_LIBRTE_CRYPTODEV n
|
||||
setconf CONFIG_RTE_LIBRTE_MBUF_OFFLOAD n
|
||||
# Disable unmaintained features
|
||||
setconf CONFIG_RTE_LIBRTE_POWER n
|
||||
@ -170,7 +171,7 @@ setconf CONFIG_RTE_KNI_PREEMPT_DEFAULT n
|
||||
setconf CONFIG_RTE_BUILD_SHARED_LIB y
|
||||
%endif
|
||||
|
||||
make V=1 O=%{target} %{?_smp_mflags}
|
||||
make V=1 O=%{target} %{?_smp_mflags} -Wimplicit-fallthrough=0
|
||||
make V=1 O=%{target} %{?_smp_mflags} doc-api-html doc-guides-html %{?with_pdfdoc: guides-pdf}
|
||||
|
||||
%if %{with examples}
|
||||
@ -184,10 +185,11 @@ unset RTE_SDK RTE_INCLUDE RTE_TARGET
|
||||
%make_install O=%{target} prefix=%{_usr} libdir=%{_libdir}
|
||||
|
||||
%if ! %{with tools}
|
||||
rm -rf %{buildroot}%{sdkdir}/tools
|
||||
rm -rf %{buildroot}%{sdkdir}/devtools
|
||||
rm -rf %{buildroot}%{_sbindir}/dpdk_nic_bind
|
||||
rm -rf %{buildroot}%{_bindir}/dpdk-test-crypto-perf
|
||||
%endif
|
||||
rm -f %{buildroot}%{sdkdir}/tools/setup.sh
|
||||
rm -f %{buildroot}%{sdkdir}/devtools/setup.sh
|
||||
|
||||
%if %{with examples}
|
||||
find %{target}/examples/ -name "*.map" | xargs rm -f
|
||||
@ -243,7 +245,7 @@ sed -i -e 's:-%{machine_tmpl}-:-%{machine}-:g' %{buildroot}/%{_sysconfdir}/profi
|
||||
%{incdir}/
|
||||
%{sdkdir}
|
||||
%if %{with tools}
|
||||
%exclude %{sdkdir}/tools/
|
||||
%exclude %{sdkdir}/devtools/
|
||||
%endif
|
||||
%if %{with examples}
|
||||
%exclude %{sdkdir}/examples/
|
||||
@ -257,10 +259,11 @@ sed -i -e 's:-%{machine_tmpl}-:-%{machine}-:g' %{buildroot}/%{_sysconfdir}/profi
|
||||
|
||||
%if %{with tools}
|
||||
%files tools
|
||||
%{sdkdir}/tools/
|
||||
#%{sdkdir}/devtools/
|
||||
%{_sbindir}/dpdk-devbind
|
||||
%{_bindir}/dpdk-pdump
|
||||
%{_bindir}/dpdk-pmdinfo
|
||||
%{_bindir}/dpdk-test-crypto-perf
|
||||
%endif
|
||||
|
||||
%if %{with examples}
|
||||
@ -270,6 +273,9 @@ sed -i -e 's:-%{machine_tmpl}-:-%{machine}-:g' %{buildroot}/%{_sysconfdir}/profi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 15 2017 Fedora Release Monitoring <release-monitoring@fedoraproject.org> - 17.02-1
|
||||
- Update to 17.02 (#1422285)
|
||||
|
||||
* Mon Feb 06 2017 Yaakov Selkowitz <yselkowi@redhat.com> - 16.11-2
|
||||
- Enable aarch64, ppc64le (#1419731)
|
||||
|
||||
|
59
lengthfix.patch
Normal file
59
lengthfix.patch
Normal file
@ -0,0 +1,59 @@
|
||||
diff -up ./examples/ip_pipeline/cpu_core_map.c.lengthfix ./examples/ip_pipeline/cpu_core_map.c
|
||||
--- ./examples/ip_pipeline/cpu_core_map.c.lengthfix 2017-02-14 16:17:45.000000000 -0500
|
||||
+++ ./examples/ip_pipeline/cpu_core_map.c 2017-02-21 10:23:38.982228068 -0500
|
||||
@@ -311,7 +311,7 @@ cpu_core_map_get_core_id_linux(int lcore
|
||||
static int
|
||||
cpu_core_map_get_socket_id_linux(int lcore_id)
|
||||
{
|
||||
- char buffer[64];
|
||||
+ char buffer[128];
|
||||
FILE *fd;
|
||||
int socket_id;
|
||||
|
||||
diff -up ./examples/multi_process/client_server_mp/mp_server/main.c.lengthfix ./examples/multi_process/client_server_mp/mp_server/main.c
|
||||
--- ./examples/multi_process/client_server_mp/mp_server/main.c.lengthfix 2017-02-14 16:17:45.000000000 -0500
|
||||
+++ ./examples/multi_process/client_server_mp/mp_server/main.c 2017-02-21 11:17:15.946342832 -0500
|
||||
@@ -93,14 +93,14 @@ static const char *
|
||||
get_printable_mac_addr(uint8_t port)
|
||||
{
|
||||
static const char err_address[] = "00:00:00:00:00:00";
|
||||
- static char addresses[RTE_MAX_ETHPORTS][sizeof(err_address)];
|
||||
+ static char addresses[RTE_MAX_ETHPORTS][sizeof(err_address)+2];
|
||||
|
||||
if (unlikely(port >= RTE_MAX_ETHPORTS))
|
||||
return err_address;
|
||||
if (unlikely(addresses[port][0]=='\0')){
|
||||
struct ether_addr mac;
|
||||
rte_eth_macaddr_get(port, &mac);
|
||||
- snprintf(addresses[port], sizeof(addresses[port]),
|
||||
+ snprintf(addresses[port], sizeof(addresses[port])+2,
|
||||
"%02x:%02x:%02x:%02x:%02x:%02x\n",
|
||||
mac.addr_bytes[0], mac.addr_bytes[1], mac.addr_bytes[2],
|
||||
mac.addr_bytes[3], mac.addr_bytes[4], mac.addr_bytes[5]);
|
||||
diff -up ./examples/server_node_efd/server/main.c.lengthfix ./examples/server_node_efd/server/main.c
|
||||
--- ./examples/server_node_efd/server/main.c.lengthfix 2017-02-21 10:59:27.769936326 -0500
|
||||
+++ ./examples/server_node_efd/server/main.c 2017-02-21 10:59:43.719823270 -0500
|
||||
@@ -100,7 +100,7 @@ static const char *
|
||||
get_printable_mac_addr(uint8_t port)
|
||||
{
|
||||
static const char err_address[] = "00:00:00:00:00:00";
|
||||
- static char addresses[RTE_MAX_ETHPORTS][sizeof(err_address)];
|
||||
+ static char addresses[RTE_MAX_ETHPORTS][sizeof(err_address)+2];
|
||||
struct ether_addr mac;
|
||||
|
||||
if (unlikely(port >= RTE_MAX_ETHPORTS))
|
||||
diff -up ./examples/server_node_efd/shared/common.h.lengthfix ./examples/server_node_efd/shared/common.h
|
||||
--- ./examples/server_node_efd/shared/common.h.lengthfix 2017-02-21 10:48:32.788582926 -0500
|
||||
+++ ./examples/server_node_efd/shared/common.h 2017-02-21 10:48:07.540762374 -0500
|
||||
@@ -86,9 +86,9 @@ get_rx_queue_name(unsigned int id)
|
||||
{
|
||||
/*
|
||||
* Buffer for return value. Size calculated by %u being replaced
|
||||
- * by maximum 3 digits (plus an extra byte for safety)
|
||||
+ * by maximum 10 digits (plus an extra byte for safety)
|
||||
*/
|
||||
- static char buffer[sizeof(MP_NODE_RXQ_NAME) + 2];
|
||||
+ static char buffer[sizeof(MP_NODE_RXQ_NAME) + 12];
|
||||
|
||||
snprintf(buffer, sizeof(buffer) - 1, MP_NODE_RXQ_NAME, id);
|
||||
return buffer;
|
13
makefix.patch
Normal file
13
makefix.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up ./examples/ethtool/ethtool-app/Makefile.makefix ./examples/ethtool/ethtool-app/Makefile
|
||||
--- ./examples/ethtool/ethtool-app/Makefile.makefix 2017-02-22 07:08:22.873372009 -0500
|
||||
+++ ./examples/ethtool/ethtool-app/Makefile 2017-02-22 07:09:10.138033792 -0500
|
||||
@@ -49,6 +49,8 @@ CFLAGS += $(WERROR_FLAGS)
|
||||
|
||||
LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib
|
||||
LDLIBS += -lrte_ethtool
|
||||
-
|
||||
+ifeq ($(CONFIG_RTE_LIBRTE_IXGBE_PMD),y)
|
||||
+LDLIBS += -lrte_pmd_ixgbe
|
||||
+endif
|
||||
|
||||
include $(RTE_SDK)/mk/rte.extapp.mk
|
Loading…
Reference in New Issue
Block a user