Rebase to 24.11.1
Resolves: RHEL-71284 Signed-off-by: David Marchand <david.marchand@redhat.com>
This commit is contained in:
parent
ef0efe16b3
commit
1ec9aaa0c8
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
|||||||
/dpdk-21.11.2.tar.xz
|
/dpdk-21.11.2.tar.xz
|
||||||
/dpdk-22.11.tar.xz
|
/dpdk-22.11.tar.xz
|
||||||
/dpdk-23.11.tar.xz
|
/dpdk-23.11.tar.xz
|
||||||
|
/dpdk-24.11.1.tar.xz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From 606fd08b1bfce6d81c9532a9ecbbbe88aa266793 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Olivier Matz <olivier.matz@6wind.com>
|
|
||||||
Date: Thu, 28 Nov 2024 12:09:56 +0100
|
|
||||||
Subject: [PATCH] net/virtio: fix Rx checksum calculation
|
|
||||||
|
|
||||||
If hdr->csum_start is larger than packet length, the len argument passed
|
|
||||||
to rte_raw_cksum_mbuf() overflows and causes a segmentation fault.
|
|
||||||
|
|
||||||
Ignore checksum computation in this case.
|
|
||||||
|
|
||||||
CVE-2024-11614
|
|
||||||
|
|
||||||
Fixes: ca7036b4af3a ("vhost: fix offload flags in Rx path")
|
|
||||||
Signed-off-by: Maxime Gouin <maxime.gouin@6wind.com>
|
|
||||||
Signed-off-by: Olivier Matz <olivier.matz@6wind.com>
|
|
||||||
Reviewed-by: Maxime Coquelin <maxime.coquelin@redhat.com>
|
|
||||||
---
|
|
||||||
lib/vhost/virtio_net.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/lib/vhost/virtio_net.c b/lib/vhost/virtio_net.c
|
|
||||||
index 6d53ff932d..e42aabf126 100644
|
|
||||||
--- a/lib/vhost/virtio_net.c
|
|
||||||
+++ b/lib/vhost/virtio_net.c
|
|
||||||
@@ -2831,6 +2831,9 @@ vhost_dequeue_offload(struct virtio_net *dev, struct virtio_net_hdr *hdr,
|
|
||||||
*/
|
|
||||||
uint16_t csum = 0, off;
|
|
||||||
|
|
||||||
+ if (hdr->csum_start >= rte_pktmbuf_pkt_len(m))
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
if (rte_raw_cksum_mbuf(m, hdr->csum_start,
|
|
||||||
rte_pktmbuf_pkt_len(m) - hdr->csum_start, &csum) < 0)
|
|
||||||
return;
|
|
||||||
--
|
|
||||||
2.47.0
|
|
||||||
|
|
12
dpdk.spec
12
dpdk.spec
@ -8,8 +8,8 @@
|
|||||||
#% define date 20191128
|
#% define date 20191128
|
||||||
#% define shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
#% define shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||||
|
|
||||||
%define ver 23.11
|
%define ver 24.11.1
|
||||||
%define rel 2
|
%define rel 1
|
||||||
|
|
||||||
%define srcname dpdk%(awk -F. '{ if (NF > 2) print "-stable" }' <<<%{version})
|
%define srcname dpdk%(awk -F. '{ if (NF > 2) print "-stable" }' <<<%{version})
|
||||||
|
|
||||||
@ -17,7 +17,7 @@
|
|||||||
|
|
||||||
Name: dpdk
|
Name: dpdk
|
||||||
Version: %{ver}
|
Version: %{ver}
|
||||||
Release: %{rel}%{?commit0:.%{date}git%{shortcommit0}}%{?dist}.2
|
Release: %{rel}%{?commit0:.%{date}git%{shortcommit0}}%{?dist}
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 8
|
%if 0%{?fedora} || 0%{?rhel} > 8
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
%endif
|
%endif
|
||||||
@ -31,9 +31,6 @@ Source: https://fast.dpdk.org/rel/dpdk-%{ver}.tar.xz
|
|||||||
# Only needed for creating snapshot tarballs, not used in build itself
|
# Only needed for creating snapshot tarballs, not used in build itself
|
||||||
Source100: dpdk-snapshot.sh
|
Source100: dpdk-snapshot.sh
|
||||||
|
|
||||||
# CVE-2024-11614
|
|
||||||
Patch1: 0001-net-virtio-fix-Rx-checksum-calculation.patch
|
|
||||||
|
|
||||||
Summary: Set of libraries and drivers for fast packet processing
|
Summary: Set of libraries and drivers for fast packet processing
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -288,6 +285,9 @@ find %{buildroot}%{_datadir}/man/ -type f -a ! -iname "*rte_*" -exec rm {} \;
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 18 2024 David Marchand <david.marchand@redhat.com> - 24.11.1-1
|
||||||
|
- Rebase to 24.11.1 (RHEL-71284)
|
||||||
|
|
||||||
* Tue Dec 17 2024 Kevin Traynor <ktraynor@redhat.com> - 23.11-2
|
* Tue Dec 17 2024 Kevin Traynor <ktraynor@redhat.com> - 23.11-2
|
||||||
- Backport fixes for CVE-2024-11614 (RHEL-68662)
|
- Backport fixes for CVE-2024-11614 (RHEL-68662)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (dpdk-23.11.tar.xz) = e5177d658fca8df55090a92ea1a8932aac5847314fed7c686b8a36e709f34b14c05e68d6c4c433ff5371b67a39c4324b4eefab8c138f417468f57092bf269b4c
|
SHA512 (dpdk-24.11.1.tar.xz) = ad6a3b8a4dc2e89de685917679c23e73c6f8b29a544b517a9036fa257c65e49a5a68c8db81119bfa4aabca393f1cd9cd5eda9aa1700d017b2fbbe7e9a50cff73
|
||||||
SHA512 (pyelftools-0.27.tar.gz) = bb0a00e5500016e3d4f64be0a728e190f84b11a805f78d668b5a74716a30400e6794946f198ef4a3f3b8f64a63deb1b5a96180b09e56b7357b988b28e25fad0a
|
SHA512 (pyelftools-0.27.tar.gz) = bb0a00e5500016e3d4f64be0a728e190f84b11a805f78d668b5a74716a30400e6794946f198ef4a3f3b8f64a63deb1b5a96180b09e56b7357b988b28e25fad0a
|
||||||
|
Loading…
Reference in New Issue
Block a user