1.8.6
This commit is contained in:
parent
d416892d2e
commit
f4a9c566b3
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@ doxygen-1.7.1.src.tar.gz
|
|||||||
/doxygen-1.8.3.1.src.tar.gz
|
/doxygen-1.8.3.1.src.tar.gz
|
||||||
/doxygen-1.8.4.src.tar.gz
|
/doxygen-1.8.4.src.tar.gz
|
||||||
/doxygen-1.8.5.src.tar.gz
|
/doxygen-1.8.5.src.tar.gz
|
||||||
|
/doxygen-1.8.6.src.tar.gz
|
||||||
|
@ -1,19 +1,18 @@
|
|||||||
diff -up doxygen-1.8.4/addon/doxywizard/Makefile.in.config doxygen-1.8.4/addon/doxywizard/Makefile.in
|
diff -up doxygen-1.8.6/addon/doxywizard/Makefile.in.config doxygen-1.8.6/addon/doxywizard/Makefile.in
|
||||||
--- doxygen-1.8.4/addon/doxywizard/Makefile.in.config 2013-01-05 16:35:52.000000000 +0100
|
--- doxygen-1.8.6/addon/doxywizard/Makefile.in.config 2013-12-26 12:17:57.281368574 -0700
|
||||||
+++ doxygen-1.8.4/addon/doxywizard/Makefile.in 2013-05-21 12:22:49.689166894 +0200
|
+++ doxygen-1.8.6/addon/doxywizard/Makefile.in 2013-12-26 12:20:44.673513404 -0700
|
||||||
@@ -10,8 +10,6 @@
|
@@ -10,7 +10,6 @@
|
||||||
# See the GNU General Public License for more details.
|
# See the GNU General Public License for more details.
|
||||||
#
|
#
|
||||||
|
|
||||||
-QMAKE=qmake $(MKSPECS)
|
-QMAKE=$(QTDIR)/bin/qmake $(MKSPECS)
|
||||||
-
|
INCBUFSIZE=$(PYTHON) ../../src/increasebuffer.py
|
||||||
all: Makefile.doxywizard
|
|
||||||
$(MAKE) -f Makefile.doxywizard
|
|
||||||
|
|
||||||
diff -up doxygen-1.8.4/configure.config doxygen-1.8.4/configure
|
all: Makefile.doxywizard
|
||||||
--- doxygen-1.8.4/configure.config 2013-05-19 12:05:39.000000000 +0200
|
diff -up doxygen-1.8.6/configure.config doxygen-1.8.6/configure
|
||||||
+++ doxygen-1.8.4/configure 2013-05-21 12:25:43.570743493 +0200
|
--- doxygen-1.8.6/configure.config 2013-12-24 09:14:46.000000000 -0700
|
||||||
@@ -296,9 +296,10 @@ if test "$f_wizard" = YES; then
|
+++ doxygen-1.8.6/configure 2013-12-26 12:20:20.542636493 -0700
|
||||||
|
@@ -326,9 +326,10 @@ if test "$f_wizard" = YES; then
|
||||||
if test -z "$QTDIR"; then
|
if test -z "$QTDIR"; then
|
||||||
echo " QTDIR environment variable not set!"
|
echo " QTDIR environment variable not set!"
|
||||||
printf " Checking for Qt..."
|
printf " Checking for Qt..."
|
||||||
@ -22,10 +21,10 @@ diff -up doxygen-1.8.4/configure.config doxygen-1.8.4/configure
|
|||||||
if test -x "$d/bin/qmake"; then
|
if test -x "$d/bin/qmake"; then
|
||||||
QTDIR=$d
|
QTDIR=$d
|
||||||
+ QMAKE=$d/bin/qmake
|
+ QMAKE=$d/bin/qmake
|
||||||
|
break 2
|
||||||
fi
|
fi
|
||||||
done
|
done
|
||||||
else
|
@@ -704,6 +705,8 @@ INSTTOOL = $f_insttool
|
||||||
@@ -606,6 +607,8 @@ INSTTOOL = $f_insttool
|
|
||||||
DOXYDOCS = ..
|
DOXYDOCS = ..
|
||||||
DOCDIR = $f_docdir
|
DOCDIR = $f_docdir
|
||||||
QTDIR = $QTDIR
|
QTDIR = $QTDIR
|
||||||
@ -34,23 +33,23 @@ diff -up doxygen-1.8.4/configure.config doxygen-1.8.4/configure
|
|||||||
EOF
|
EOF
|
||||||
|
|
||||||
if test "$f_dot" != NO; then
|
if test "$f_dot" != NO; then
|
||||||
diff -up doxygen-1.8.4/Makefile.in.config doxygen-1.8.4/Makefile.in
|
diff -up doxygen-1.8.6/Makefile.in.config doxygen-1.8.6/Makefile.in
|
||||||
--- doxygen-1.8.4/Makefile.in.config 2013-04-25 21:38:39.000000000 +0200
|
--- doxygen-1.8.6/Makefile.in.config 2013-12-26 12:17:57.283368564 -0700
|
||||||
+++ doxygen-1.8.4/Makefile.in 2013-05-21 12:22:49.689166894 +0200
|
+++ doxygen-1.8.6/Makefile.in 2013-12-26 12:19:17.796956667 -0700
|
||||||
@@ -53,8 +53,6 @@ distclean: clean
|
@@ -78,8 +78,6 @@ realclean: clean
|
||||||
|
|
||||||
DATE=$(shell date "+%B %Y")
|
DATE=$(shell date "+%B %Y")
|
||||||
|
|
||||||
-MAN1DIR = man/man1
|
-MAN1DIR = man/man1
|
||||||
-
|
-
|
||||||
install: doxywizard_install doxysearch_install
|
install: doxywizard_install doxysearch_install
|
||||||
$(INSTTOOL) -d $(DESTDIR)/$(INSTALL)/bin
|
$(INSTTOOL) -d $(DESTDIR)$(INSTALL)/bin
|
||||||
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)/$(INSTALL)/bin
|
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)$(INSTALL)/bin
|
||||||
diff -up doxygen-1.8.4/tmake/lib/linux-g++/tmake.conf.config doxygen-1.8.4/tmake/lib/linux-g++/tmake.conf
|
diff -up doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf.config doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf
|
||||||
--- doxygen-1.8.4/tmake/lib/linux-g++/tmake.conf.config 2012-12-22 19:49:04.000000000 +0100
|
--- doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf.config 2013-11-02 08:18:53.000000000 -0600
|
||||||
+++ doxygen-1.8.4/tmake/lib/linux-g++/tmake.conf 2013-05-21 12:22:49.689166894 +0200
|
+++ doxygen-1.8.6/tmake/lib/linux-g++/tmake.conf 2013-12-26 12:18:38.268158455 -0700
|
||||||
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
||||||
TMAKE_CFLAGS = -pipe
|
TMAKE_CFLAGS = -pipe -fsigned-char
|
||||||
TMAKE_CFLAGS_WARN_ON = -Wall -W
|
TMAKE_CFLAGS_WARN_ON = -Wall -W
|
||||||
TMAKE_CFLAGS_WARN_OFF =
|
TMAKE_CFLAGS_WARN_OFF =
|
||||||
-TMAKE_CFLAGS_RELEASE = -O2
|
-TMAKE_CFLAGS_RELEASE = -O2
|
@ -1,8 +1,8 @@
|
|||||||
Summary: A documentation system for C/C++
|
Summary: A documentation system for C/C++
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.8.5
|
Version: 1.8.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# No version is specified.
|
# No version is specified.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
@ -12,7 +12,7 @@ Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
|||||||
Source1: doxywizard.png
|
Source1: doxywizard.png
|
||||||
Source2: doxywizard.desktop
|
Source2: doxywizard.desktop
|
||||||
|
|
||||||
Patch1: doxygen-1.8.5-config.patch
|
Patch1: doxygen-1.8.6-config.patch
|
||||||
Patch2: doxygen-1.8.5-html_timestamp_default_false.patch
|
Patch2: doxygen-1.8.5-html_timestamp_default_false.patch
|
||||||
Patch3: doxygen-1.8.3-multilib.patch
|
Patch3: doxygen-1.8.3-multilib.patch
|
||||||
|
|
||||||
@ -120,6 +120,9 @@ desktop-file-install \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 26 2013 Orion Poplawski <orion@cora.nwra.com> - 1:1.8.6-1
|
||||||
|
- 1.8.6
|
||||||
|
|
||||||
* Tue Oct 08 2013 Than Ngo <than@redhat.com> - 1:1.8.5-2
|
* Tue Oct 08 2013 Than Ngo <than@redhat.com> - 1:1.8.5-2
|
||||||
- add exlive-epstopdf-bin in requirement
|
- add exlive-epstopdf-bin in requirement
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user