Fixed #2113876, Failed to build LaTex output
This commit is contained in:
parent
cd11c2f98d
commit
eaf38ac359
@ -0,0 +1,19 @@
|
|||||||
|
commit 6f6b3be36c51a0e7436538d8b99a7e3350a6c3a4
|
||||||
|
Author: František Dvořák <valtri@civ.zcu.cz>
|
||||||
|
Date: Mon Jul 25 21:40:19 2022 +0200
|
||||||
|
|
||||||
|
Fix typo in generated Makefile for LaTex
|
||||||
|
|
||||||
|
diff --git a/src/latexgen.cpp b/src/latexgen.cpp
|
||||||
|
index d3ad3bd3..c5f436ce 100644
|
||||||
|
--- a/src/latexgen.cpp
|
||||||
|
+++ b/src/latexgen.cpp
|
||||||
|
@@ -337,7 +337,7 @@ static void writeLatexMakefile()
|
||||||
|
}
|
||||||
|
t << "\techo \"Rerunning latex....\"\n"
|
||||||
|
<< "\t$(LATEX_CMD) $(MANUAL_FILE).tex\n"
|
||||||
|
- << "\tlatex_count=%(LATEX_COUNT) ; \\\n"
|
||||||
|
+ << "\tlatex_count=$(LATEX_COUNT) ; \\\n"
|
||||||
|
<< "\twhile egrep -s 'Rerun (LaTeX|to get cross-references right|to get bibliographical references right)' $(MANUAL_FILE).log && [ $$latex_count -gt 0 ] ;\\\n"
|
||||||
|
<< "\t do \\\n"
|
||||||
|
<< "\t echo \"Rerunning latex....\" ;\\\n"
|
16
doxygen.spec
16
doxygen.spec
@ -9,7 +9,7 @@
|
|||||||
%global stable 1
|
%global stable 1
|
||||||
|
|
||||||
%if 0%{?stable}
|
%if 0%{?stable}
|
||||||
%global irelease 1
|
%global irelease 2
|
||||||
%else
|
%else
|
||||||
%global commit e18f715eb55121a4219d00bc4d824cebf1fb504b
|
%global commit e18f715eb55121a4219d00bc4d824cebf1fb504b
|
||||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
@ -21,8 +21,14 @@ Summary: A documentation system for C/C++
|
|||||||
Name: doxygen
|
Name: doxygen
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 1.9.4
|
Version: 1.9.4
|
||||||
Release: %{irelease}%{?dist}.1
|
%if 0%{?stable}
|
||||||
|
Release: 2%{?dist}
|
||||||
|
%else
|
||||||
|
%global commit e18f715eb55121a4219d00bc4d824cebf1fb504b
|
||||||
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
%global date 20220217
|
||||||
|
Release: 0.%{date}git%{shortcommit}
|
||||||
|
%endif
|
||||||
# No version is specified.
|
# No version is specified.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
Url: https://github.com/doxygen
|
Url: https://github.com/doxygen
|
||||||
@ -37,6 +43,7 @@ Source1: doxywizard.desktop
|
|||||||
Source2: doxywizard-icons.tar.xz
|
Source2: doxywizard-icons.tar.xz
|
||||||
# upstream patches
|
# upstream patches
|
||||||
Patch0: doxygen-1.9.4-gcc12.1.patch
|
Patch0: doxygen-1.9.4-gcc12.1.patch
|
||||||
|
Patch1: doxygen-6f6b3be36c51a0e7436538d8b99a7e3350a6c3a4-typo_in_generated_Makefile_for_LaTex.patch
|
||||||
|
|
||||||
BuildRequires: %{_bindir}/python3
|
BuildRequires: %{_bindir}/python3
|
||||||
BuildRequires: gcc-c++ gcc
|
BuildRequires: gcc-c++ gcc
|
||||||
@ -314,6 +321,9 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 04 2022 Than Ngo <than@redhat.com> - 2:1.9.4-2
|
||||||
|
- Fixed #2113876, Failed to build LaTex output
|
||||||
|
|
||||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.4-1.1
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.9.4-1.1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user