apply patch to not break partial include paths, thanks to Tim Niemueller
This commit is contained in:
parent
87c2563426
commit
e725b76908
12
doxygen-1.5.5-brokenpaths.patch
Normal file
12
doxygen-1.5.5-brokenpaths.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -urN doxygen-1.5.5/src/util.cpp doxygen-1.5.5.brokenpaths/src/util.cpp
|
||||||
|
--- doxygen-1.5.5/src/util.cpp 2008-01-19 16:54:27.000000000 +0100
|
||||||
|
+++ doxygen-1.5.5.brokenpaths/src/util.cpp 2008-03-14 16:45:47.000000000 +0100
|
||||||
|
@@ -4468,7 +4468,7 @@
|
||||||
|
QCString pathStripped = stripFromIncludePath(path);
|
||||||
|
for (fni.toFirst();(fd=fni.current());++fni)
|
||||||
|
{
|
||||||
|
- QCString fdStripPath = stripFromIncludePath(fd->getPath());
|
||||||
|
+ QCString fdStripPath = stripFromIncludePath(fd->getPath().right(path.length()));
|
||||||
|
if (path.isEmpty() || fdStripPath==pathStripped)
|
||||||
|
{
|
||||||
|
count++;
|
11
doxygen.spec
11
doxygen.spec
@ -4,7 +4,7 @@
|
|||||||
Summary: A documentation system for C/C++.
|
Summary: A documentation system for C/C++.
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Version: 1.5.5
|
Version: 1.5.5
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||||
|
|
||||||
@ -13,6 +13,9 @@ Patch2: doxygen-1.2.18-libdir.patch
|
|||||||
Patch3: doxygen-1.2.18-libdir64.patch
|
Patch3: doxygen-1.2.18-libdir64.patch
|
||||||
Patch4: doxygen-1.5.5-system-png.patch
|
Patch4: doxygen-1.5.5-system-png.patch
|
||||||
|
|
||||||
|
# upstream patches
|
||||||
|
Patch100: doxygen-1.5.5-brokenpaths.patch
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPL
|
License: GPL
|
||||||
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
||||||
@ -58,6 +61,9 @@ are used by doxygen.
|
|||||||
%endif
|
%endif
|
||||||
%patch4 -p1 -b .system-png
|
%patch4 -p1 -b .system-png
|
||||||
|
|
||||||
|
# upstream patches
|
||||||
|
%patch100 -p1 -b .brokenpaths
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with_qt}
|
%if %{with_qt}
|
||||||
QTDIR="" && . /etc/profile.d/qt.sh
|
QTDIR="" && . /etc/profile.d/qt.sh
|
||||||
@ -104,6 +110,9 @@ rm -rf %{buildroot}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 14 2008 Than Ngo <than@redhat.com> 1.5.5-3
|
||||||
|
- apply patch to not break partial include paths, thanks to Tim Niemueller
|
||||||
|
|
||||||
* Wed Feb 20 2008 Than Ngo <than@redhat.com> 1.5.5-2
|
* Wed Feb 20 2008 Than Ngo <than@redhat.com> 1.5.5-2
|
||||||
- apply patch to make doxygen using system libpng/zlib
|
- apply patch to make doxygen using system libpng/zlib
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user