Merge branch 'master' into f25
This commit is contained in:
commit
9691646b80
43
doxygen-771310.patch
Normal file
43
doxygen-771310.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
commit b5e1e195bc207c7bb93df4e51253f9f3a1026a3d
|
||||||
|
Author: Dimitri van Heesch <dimitri@stack.nl>
|
||||||
|
Date: Wed Sep 21 20:24:15 2016 +0200
|
||||||
|
|
||||||
|
Bug 771310 - French description for "Namespace Members" is wrong and causes fatal javascript error
|
||||||
|
|
||||||
|
diff --git a/src/index.cpp b/src/index.cpp
|
||||||
|
index 96909c7..41e3318 100644
|
||||||
|
--- a/src/index.cpp
|
||||||
|
+++ b/src/index.cpp
|
||||||
|
@@ -4327,8 +4327,8 @@ void renderMemberIndicesAsJs(FTextStream &t,
|
||||||
|
t << "children:[";
|
||||||
|
firstMember=FALSE;
|
||||||
|
}
|
||||||
|
- t << endl << "{text:'" << convertToJSString(getInfo(i)->title) << "',url:'"
|
||||||
|
- << convertToJSString(getInfo(i)->fname+Doxygen::htmlFileExtension) << "'";
|
||||||
|
+ t << endl << "{text:\"" << convertToJSString(getInfo(i)->title) << "\",url:\""
|
||||||
|
+ << convertToJSString(getInfo(i)->fname+Doxygen::htmlFileExtension) << "\"";
|
||||||
|
|
||||||
|
// Check if we have many members, then add sub entries per letter...
|
||||||
|
// quick alphabetical index
|
||||||
|
@@ -4357,8 +4357,8 @@ void renderMemberIndicesAsJs(FTextStream &t,
|
||||||
|
anchor=fullName+extension+"#index_";
|
||||||
|
else // other pages of multi page index
|
||||||
|
anchor=fullName+"_"+is+extension+"#index_";
|
||||||
|
- t << "{text:'" << convertToJSString(ci) << "',url:'"
|
||||||
|
- << convertToJSString(anchor+is) << "'}";
|
||||||
|
+ t << "{text:\"" << convertToJSString(ci) << "\",url:\""
|
||||||
|
+ << convertToJSString(anchor+is) << "\"}";
|
||||||
|
firstLetter=FALSE;
|
||||||
|
}
|
||||||
|
t << "]";
|
||||||
|
@@ -4393,8 +4393,8 @@ static bool renderQuickLinksAsJs(FTextStream &t,LayoutNavEntry *root,bool first)
|
||||||
|
if (!firstChild) t << "," << endl;
|
||||||
|
firstChild=FALSE;
|
||||||
|
QCString url = entry->url();
|
||||||
|
- t << "{text:'" << convertToJSString(entry->title()) << "',url:'"
|
||||||
|
- << convertToJSString(url) << "'";
|
||||||
|
+ t << "{text:\"" << convertToJSString(entry->title()) << "\",url:\""
|
||||||
|
+ << convertToJSString(url) << "\"";
|
||||||
|
bool hasChildren=FALSE;
|
||||||
|
if (entry->kind()==LayoutNavEntry::NamespaceMembers)
|
||||||
|
{
|
23
doxygen-771344.patch
Normal file
23
doxygen-771344.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
commit b93dbcdab6dfc5681ec49f1d567698b7c4dc6846
|
||||||
|
Author: albert-github <albert.tests@gmail.com>
|
||||||
|
Date: Sun Sep 18 17:58:30 2016 +0200
|
||||||
|
|
||||||
|
Bug 771344 - Class name 'internal' breaks class hierarchy in C++
|
||||||
|
|
||||||
|
Analogous to the rule for:
|
||||||
|
<FindMembers>{B}*"internal"{BN}*":"{BN}*
|
||||||
|
reject the "internal" keyword in case not in Cli
|
||||||
|
|
||||||
|
diff --git a/src/scanner.l b/src/scanner.l
|
||||||
|
index 6c69224..68eb8fc 100644
|
||||||
|
--- a/src/scanner.l
|
||||||
|
+++ b/src/scanner.l
|
||||||
|
@@ -5771,7 +5771,7 @@ OPERATOR "operator"{B}*({ARITHOP}|{ASSIGNOP}|{LOGICOP}|{BITOP})
|
||||||
|
<BasesProt>"virtual"{BN}+ { lineCount(); baseVirt = Virtual; }
|
||||||
|
<BasesProt>"public"{BN}+ { lineCount(); baseProt = Public; }
|
||||||
|
<BasesProt>"protected"{BN}+ { lineCount(); baseProt = Protected; }
|
||||||
|
-<BasesProt>"internal"{BN}+ { lineCount(); baseProt = Package; }
|
||||||
|
+<BasesProt>"internal"{BN}+ { if (!insideCli) REJECT ; lineCount(); baseProt = Package; }
|
||||||
|
<BasesProt>"private"{BN}+ { lineCount(); baseProt = Private; }
|
||||||
|
<BasesProt>{BN} { lineCount(); }
|
||||||
|
<BasesProt>. { unput(*yytext); BEGIN(Bases); }
|
34
doxygen.spec
34
doxygen.spec
@ -2,7 +2,7 @@ Summary: A documentation system for C/C++
|
|||||||
Name: doxygen
|
Name: doxygen
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.8.12
|
Version: 1.8.12
|
||||||
Release: 1%{?dist}
|
Release: 3%{?dist}
|
||||||
|
|
||||||
# No version is specified.
|
# No version is specified.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
@ -13,6 +13,8 @@ Source1: doxywizard.png
|
|||||||
Source2: doxywizard.desktop
|
Source2: doxywizard.desktop
|
||||||
|
|
||||||
# upstream fixes
|
# upstream fixes
|
||||||
|
Patch1: doxygen-771310.patch
|
||||||
|
Patch2: doxygen-771344.patch
|
||||||
|
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
BuildRequires: tex(dvips)
|
BuildRequires: tex(dvips)
|
||||||
@ -21,6 +23,9 @@ BuildRequires: tex(multirow.sty)
|
|||||||
BuildRequires: tex(sectsty.sty)
|
BuildRequires: tex(sectsty.sty)
|
||||||
BuildRequires: tex(tocloft.sty)
|
BuildRequires: tex(tocloft.sty)
|
||||||
BuildRequires: tex(xtab.sty)
|
BuildRequires: tex(xtab.sty)
|
||||||
|
BuildRequires: tex(import.sty)
|
||||||
|
BuildRequires: tex(tabu.sty)
|
||||||
|
BuildRequires: tex(appendix.sty)
|
||||||
BuildRequires: /usr/bin/epstopdf
|
BuildRequires: /usr/bin/epstopdf
|
||||||
BuildRequires: texlive-epstopdf
|
BuildRequires: texlive-epstopdf
|
||||||
BuildRequires: ghostscript
|
BuildRequires: ghostscript
|
||||||
@ -63,7 +68,7 @@ Requires: texlive-epstopdf-bin
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
# convert into utf-8
|
# convert into utf-8
|
||||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||||
@ -76,7 +81,7 @@ mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
|||||||
mkdir -p %{_target_platform}
|
mkdir -p %{_target_platform}
|
||||||
pushd %{_target_platform}
|
pushd %{_target_platform}
|
||||||
%cmake \
|
%cmake \
|
||||||
-Dbuild_doc=OFF \
|
-Dbuild_doc=ON \
|
||||||
-Dbuild_wizard=ON \
|
-Dbuild_wizard=ON \
|
||||||
-Dbuild_xmlparser=ON \
|
-Dbuild_xmlparser=ON \
|
||||||
-Dbuild_search=ON \
|
-Dbuild_search=ON \
|
||||||
@ -86,12 +91,11 @@ pushd %{_target_platform}
|
|||||||
..
|
..
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
make docs %{?_smp_mflags} -C %{_target_platform}
|
||||||
make %{?_smp_mflags} -C %{_target_platform}
|
make %{?_smp_mflags} -C %{_target_platform}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install \
|
make install DESTDIR=%{buildroot} -C %{_target_platform}
|
||||||
DESTDIR=%{buildroot} \
|
|
||||||
-C %{_target_platform}
|
|
||||||
|
|
||||||
install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
||||||
|
|
||||||
@ -99,11 +103,15 @@ install -m644 -p -D %{SOURCE1} %{buildroot}%{_datadir}/pixmaps/doxywizard.png
|
|||||||
mkdir -p %{buildroot}/%{_mandir}/man1
|
mkdir -p %{buildroot}/%{_mandir}/man1
|
||||||
cp doc/*.1 %{buildroot}/%{_mandir}/man1/
|
cp doc/*.1 %{buildroot}/%{_mandir}/man1/
|
||||||
|
|
||||||
desktop-file-install \
|
# remove duplicate
|
||||||
--dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
rm -rf %{buildroot}/%{_docdir}/packages
|
||||||
|
|
||||||
|
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc LANGUAGE.HOWTO README.md
|
%doc LANGUAGE.HOWTO README.md
|
||||||
|
%doc %{_target_platform}/latex/doxygen_manual.pdf
|
||||||
|
%doc %{_target_platform}/html
|
||||||
%{_bindir}/doxygen
|
%{_bindir}/doxygen
|
||||||
%{_bindir}/doxyindexer
|
%{_bindir}/doxyindexer
|
||||||
%{_bindir}/doxysearch*
|
%{_bindir}/doxysearch*
|
||||||
@ -120,8 +128,16 @@ desktop-file-install \
|
|||||||
%files latex
|
%files latex
|
||||||
# intentionally left blank
|
# intentionally left blank
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 15 2016 Than Ngo <than@redhat.com> - 1:1.8.12-3
|
||||||
|
- bz#1394456, add missing docs
|
||||||
|
- fix build issue when build_doc=ON
|
||||||
|
|
||||||
|
* Thu Oct 20 2016 Than Ngo <than@redhat.com> - 1:1.8.12-2
|
||||||
|
- backport upstream fixes
|
||||||
|
Bug 771310 - French description for "Namespace Members" is wrong and causes fatal javascript error
|
||||||
|
Bug 771344 - Class name 'internal' breaks class hierarchy in C++
|
||||||
|
|
||||||
* Tue Sep 06 2016 Than Ngo <than@redhat.com> - 1:1.8.12-1
|
* Tue Sep 06 2016 Than Ngo <than@redhat.com> - 1:1.8.12-1
|
||||||
- 1.8.12
|
- 1.8.12
|
||||||
- fixed bz#1373167 - doxygen ships bogus man pages
|
- fixed bz#1373167 - doxygen ships bogus man pages
|
||||||
|
Loading…
Reference in New Issue
Block a user