drop QT_ARCH_X86_64 hardcoded definition
Change was needed to get doxygen built on aarch64. (it built by pure luck on other architectures)
This commit is contained in:
parent
7593fe1a8c
commit
63a1e09bad
35
doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch
Normal file
35
doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 031780293d2838da2643b46878061598ebb56822 Mon Sep 17 00:00:00 2001
|
||||
From: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
|
||||
Date: Thu, 8 Oct 2015 10:24:36 +0200
|
||||
Subject: [PATCH] DO NOT hardcode x86-64 architecture.
|
||||
|
||||
doxygen built on most of architectures by pure luck and order of Qt5
|
||||
qatomics_arch.h header where check for QT_ARCH_X86_64 was *after* most
|
||||
of other architectures.
|
||||
|
||||
But not after AArch64 where it failed due to attempt of using x86-64
|
||||
atomics code.
|
||||
|
||||
https://github.com/doxygen/doxygen/pull/402
|
||||
|
||||
Signed-off-by: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
|
||||
---
|
||||
addon/doxywizard/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
|
||||
index eb97388..9971679 100644
|
||||
--- a/addon/doxywizard/CMakeLists.txt
|
||||
+++ b/addon/doxywizard/CMakeLists.txt
|
||||
@@ -45,7 +45,7 @@ include_directories(
|
||||
set(GENERATED_SRC_WIZARD ${GENERATED_SRC}/doxywizard)
|
||||
file(MAKE_DIRECTORY ${GENERATED_SRC_WIZARD})
|
||||
|
||||
-add_definitions(-DQT_ARCH_X86_64 -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
|
||||
+add_definitions(-DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
|
||||
if (NOT Qt5Core_FOUND)
|
||||
include(${QT_USE_FILE})
|
||||
endif()
|
||||
--
|
||||
2.6.0
|
||||
|
@ -2,7 +2,7 @@ Summary: A documentation system for C/C++
|
||||
Name: doxygen
|
||||
Epoch: 1
|
||||
Version: 1.8.10
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
# No version is specified.
|
||||
License: GPL+
|
||||
@ -12,6 +12,7 @@ Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||
Source1: doxywizard.png
|
||||
Source2: doxywizard.desktop
|
||||
Patch1: doxygen-1.8.10-install.patch
|
||||
Patch2: doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch
|
||||
|
||||
BuildRequires: perl
|
||||
BuildRequires: tex(dvips)
|
||||
@ -63,6 +64,7 @@ Requires: texlive-epstopdf-bin
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .config
|
||||
%patch2 -p1
|
||||
|
||||
# convert into utf-8
|
||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||
@ -117,6 +119,10 @@ desktop-file-install \
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 08 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 1:1.8.10-3
|
||||
- drop QT_ARCH_X86_64 hardcoded definition to get doxygen built on aarch64
|
||||
(it built by pure luck on other architectures)
|
||||
|
||||
* Wed Sep 23 2015 Than Ngo <than@redhat.com> - 1.8.10-2
|
||||
- fix broken deps
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user