1.5.6
This commit is contained in:
parent
6279fecdfd
commit
617a39cb3c
@ -12,3 +12,4 @@ doxygen-1.5.2.src.tar.gz
|
|||||||
doxygen-1.5.3.src.tar.gz
|
doxygen-1.5.3.src.tar.gz
|
||||||
doxygen-1.5.4.src.tar.gz
|
doxygen-1.5.4.src.tar.gz
|
||||||
doxygen-1.5.5.src.tar.gz
|
doxygen-1.5.5.src.tar.gz
|
||||||
|
doxygen-1.5.6.src.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
--- doxygen-1.4.3/Makefile.in.redhat 2005-03-28 22:52:12.000000000 +0200
|
|
||||||
+++ doxygen-1.4.3/Makefile.in 2005-06-14 14:26:10.000000000 +0200
|
|
||||||
@@ -46,7 +46,7 @@
|
|
||||||
|
|
||||||
DATE=$(shell date "+%B %Y")
|
|
||||||
|
|
||||||
-MAN1DIR = man/man1
|
|
||||||
+MAN1DIR = share/man/man1
|
|
||||||
|
|
||||||
install: doxywizard_install
|
|
||||||
$(INSTTOOL) -d $(INSTALL)/bin
|
|
||||||
--- doxygen-1.4.3/tmake/lib/linux-g++/tmake.conf.redhat 2005-04-20 20:23:26.000000000 +0200
|
|
||||||
+++ doxygen-1.4.3/tmake/lib/linux-g++/tmake.conf 2005-06-14 14:19:25.000000000 +0200
|
|
||||||
@@ -11,7 +11,7 @@
|
|
||||||
TMAKE_CFLAGS = -pipe
|
|
||||||
TMAKE_CFLAGS_WARN_ON = -Wall -W -fno-exceptions
|
|
||||||
TMAKE_CFLAGS_WARN_OFF =
|
|
||||||
-TMAKE_CFLAGS_RELEASE = -O2
|
|
||||||
+TMAKE_CFLAGS_RELEASE = $(RPM_OPT_FLAGS)
|
|
||||||
TMAKE_CFLAGS_DEBUG = -g
|
|
||||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
|
||||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
|
||||||
@@ -50,7 +50,7 @@
|
|
||||||
TMAKE_LIBS_QT_OPENGL = -lqgl
|
|
||||||
TMAKE_LIBS_OPENGL = -lMesaGL -lMesaGLU -lXmu
|
|
||||||
|
|
||||||
-TMAKE_MOC = moc
|
|
||||||
+TMAKE_MOC = $(QTDIR)/bin/moc
|
|
||||||
|
|
||||||
TMAKE_AR = ar cqs
|
|
||||||
TMAKE_RANLIB =
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -urN doxygen-1.5.5/src/util.cpp doxygen-1.5.5.brokenpaths/src/util.cpp
|
|
||||||
--- doxygen-1.5.5/src/util.cpp 2008-01-19 16:54:27.000000000 +0100
|
|
||||||
+++ doxygen-1.5.5.brokenpaths/src/util.cpp 2008-03-14 16:45:47.000000000 +0100
|
|
||||||
@@ -4468,7 +4468,7 @@
|
|
||||||
QCString pathStripped = stripFromIncludePath(path);
|
|
||||||
for (fni.toFirst();(fd=fni.current());++fni)
|
|
||||||
{
|
|
||||||
- QCString fdStripPath = stripFromIncludePath(fd->getPath());
|
|
||||||
+ QCString fdStripPath = stripFromIncludePath(fd->getPath().right(path.length()));
|
|
||||||
if (path.isEmpty() || fdStripPath==pathStripped)
|
|
||||||
{
|
|
||||||
count++;
|
|
45
doxygen-1.5.6-config.patch
Normal file
45
doxygen-1.5.6-config.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
diff -up doxygen-1.5.6/addon/doxywizard/Makefile.in.redhat doxygen-1.5.6/addon/doxywizard/Makefile.in
|
||||||
|
--- doxygen-1.5.6/addon/doxywizard/Makefile.in.redhat 2008-05-19 11:28:20.000000000 +0200
|
||||||
|
+++ doxygen-1.5.6/addon/doxywizard/Makefile.in 2008-05-19 11:28:42.000000000 +0200
|
||||||
|
@@ -41,7 +41,7 @@ clean: Makefile.doxywizard
|
||||||
|
distclean: clean
|
||||||
|
$(RM) Makefile.doxywizard version.cpp config.l config.h portable.h portable.cpp
|
||||||
|
|
||||||
|
-MAN1DIR = man/man1
|
||||||
|
+MAN1DIR = share/man/man1
|
||||||
|
|
||||||
|
install:
|
||||||
|
$(INSTTOOL) -d $(INSTALL)/bin
|
||||||
|
diff -up doxygen-1.5.6/Makefile.in.redhat doxygen-1.5.6/Makefile.in
|
||||||
|
--- doxygen-1.5.6/Makefile.in.redhat 2008-04-20 09:59:24.000000000 +0200
|
||||||
|
+++ doxygen-1.5.6/Makefile.in 2008-05-19 11:18:09.000000000 +0200
|
||||||
|
@@ -50,7 +47,7 @@ distclean: clean
|
||||||
|
|
||||||
|
DATE=$(shell date "+%B %Y")
|
||||||
|
|
||||||
|
-MAN1DIR = man/man1
|
||||||
|
+MAN1DIR = share/man/man1
|
||||||
|
|
||||||
|
install: doxywizard_install
|
||||||
|
$(INSTTOOL) -d $(INSTALL)/bin
|
||||||
|
diff -up doxygen-1.5.6/tmake/lib/linux-g++/tmake.conf.redhat doxygen-1.5.6/tmake/lib/linux-g++/tmake.conf
|
||||||
|
--- doxygen-1.5.6/tmake/lib/linux-g++/tmake.conf.redhat 2006-07-21 21:54:13.000000000 +0200
|
||||||
|
+++ doxygen-1.5.6/tmake/lib/linux-g++/tmake.conf 2008-05-19 11:18:09.000000000 +0200
|
||||||
|
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
||||||
|
TMAKE_CFLAGS = -pipe
|
||||||
|
TMAKE_CFLAGS_WARN_ON = -Wall -W -fno-exceptions
|
||||||
|
TMAKE_CFLAGS_WARN_OFF =
|
||||||
|
-TMAKE_CFLAGS_RELEASE = -O2
|
||||||
|
+TMAKE_CFLAGS_RELEASE = $(RPM_OPT_FLAGS)
|
||||||
|
TMAKE_CFLAGS_DEBUG = -g
|
||||||
|
TMAKE_CFLAGS_SHLIB = -fPIC
|
||||||
|
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
||||||
|
@@ -50,7 +50,7 @@ TMAKE_LIBS_QT_MT = -lqt-mt
|
||||||
|
TMAKE_LIBS_QT_OPENGL = -lqgl
|
||||||
|
TMAKE_LIBS_OPENGL = -lMesaGL -lMesaGLU -lXmu
|
||||||
|
|
||||||
|
-TMAKE_MOC = moc
|
||||||
|
+TMAKE_MOC = $(QTDIR)/bin/moc
|
||||||
|
|
||||||
|
TMAKE_AR = ar cqs
|
||||||
|
TMAKE_RANLIB =
|
17
doxygen.spec
17
doxygen.spec
@ -3,19 +3,16 @@
|
|||||||
|
|
||||||
Summary: A documentation system for C/C++.
|
Summary: A documentation system for C/C++.
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Version: 1.5.5
|
Version: 1.5.6
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||||
|
|
||||||
Patch0: doxygen-1.4.3-config.patch
|
Patch0: doxygen-1.5.6-config.patch
|
||||||
Patch2: doxygen-1.2.18-libdir.patch
|
Patch2: doxygen-1.2.18-libdir.patch
|
||||||
Patch3: doxygen-1.2.18-libdir64.patch
|
Patch3: doxygen-1.2.18-libdir64.patch
|
||||||
Patch4: doxygen-1.5.5-system-png.patch
|
Patch4: doxygen-1.5.5-system-png.patch
|
||||||
|
|
||||||
# upstream patches
|
|
||||||
Patch100: doxygen-1.5.5-brokenpaths.patch
|
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: GPL
|
License: GPL
|
||||||
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
||||||
@ -52,7 +49,7 @@ are used by doxygen.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .redhat
|
%patch0 -p1 -b .config
|
||||||
|
|
||||||
%if "%{_lib}" != "lib"
|
%if "%{_lib}" != "lib"
|
||||||
%patch3 -p1 -b .libdir
|
%patch3 -p1 -b .libdir
|
||||||
@ -61,9 +58,6 @@ are used by doxygen.
|
|||||||
%endif
|
%endif
|
||||||
%patch4 -p1 -b .system-png
|
%patch4 -p1 -b .system-png
|
||||||
|
|
||||||
# upstream patches
|
|
||||||
%patch100 -p1 -b .brokenpaths
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with_qt}
|
%if %{with_qt}
|
||||||
QTDIR="" && . /etc/profile.d/qt.sh
|
QTDIR="" && . /etc/profile.d/qt.sh
|
||||||
@ -110,6 +104,9 @@ rm -rf %{buildroot}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 19 2008 Than Ngo <than@redhat.com> 1.5.6-1
|
||||||
|
- 1.5.6
|
||||||
|
|
||||||
* Fri Mar 14 2008 Than Ngo <than@redhat.com> 1.5.5-3
|
* Fri Mar 14 2008 Than Ngo <than@redhat.com> 1.5.5-3
|
||||||
- apply patch to not break partial include paths, thanks to Tim Niemueller
|
- apply patch to not break partial include paths, thanks to Tim Niemueller
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user