1.7.5
This commit is contained in:
parent
ac3c905653
commit
4542525c21
@ -1,54 +0,0 @@
|
|||||||
--- doxygen-1.7.3.orig/src/memberdef.cpp 2011-01-02 14:17:45.000000000 +0100
|
|
||||||
+++ doxygen-1.7.3.orig/src/memberdef.cpp 2011-03-23 16:47:58.490450171 +0100
|
|
||||||
@@ -101,6 +101,7 @@
|
|
||||||
//ol.disableAllBut(OutputGenerator::Html);
|
|
||||||
bool htmlOn = ol.isEnabled(OutputGenerator::Html);
|
|
||||||
bool latexOn = ol.isEnabled(OutputGenerator::Latex);
|
|
||||||
+ bool manOn = ol.isEnabled(OutputGenerator::Man);
|
|
||||||
{
|
|
||||||
// html and latex
|
|
||||||
if (htmlOn) ol.enable(OutputGenerator::Html);
|
|
||||||
@@ -108,7 +109,8 @@
|
|
||||||
ol.endMemberDocName();
|
|
||||||
ol.startParameterList(!md->isObjCMethod());
|
|
||||||
}
|
|
||||||
- ol.enableAll();
|
|
||||||
+ ol.popGeneratorState();
|
|
||||||
+ ol.pushGeneratorState();
|
|
||||||
ol.disable(OutputGenerator::Html);
|
|
||||||
ol.disable(OutputGenerator::Latex);
|
|
||||||
{
|
|
||||||
@@ -210,13 +212,13 @@
|
|
||||||
ol.disable(OutputGenerator::Man);
|
|
||||||
ol.disable(OutputGenerator::Latex);
|
|
||||||
ol.startEmphasis();
|
|
||||||
- ol.enable(OutputGenerator::Man);
|
|
||||||
+ if (manOn) ol.enable(OutputGenerator::Man);
|
|
||||||
if (latexOn) ol.enable(OutputGenerator::Latex);
|
|
||||||
if (a->name.isEmpty()) ol.docify(a->type); else ol.docify(a->name);
|
|
||||||
ol.disable(OutputGenerator::Man);
|
|
||||||
ol.disable(OutputGenerator::Latex);
|
|
||||||
ol.endEmphasis();
|
|
||||||
- ol.enable(OutputGenerator::Man);
|
|
||||||
+ if (manOn) ol.enable(OutputGenerator::Man);
|
|
||||||
if (latexOn) ol.enable(OutputGenerator::Latex);
|
|
||||||
}
|
|
||||||
if (!a->array.isEmpty())
|
|
||||||
@@ -273,7 +275,6 @@
|
|
||||||
ol.disable(OutputGenerator::Html);
|
|
||||||
ol.disable(OutputGenerator::Latex);
|
|
||||||
if (!md->isObjCMethod()) ol.docify(")"); // end argument list
|
|
||||||
- ol.enableAll();
|
|
||||||
if (htmlOn) ol.enable(OutputGenerator::Html);
|
|
||||||
if (latexOn) ol.enable(OutputGenerator::Latex);
|
|
||||||
if (first) ol.startParameterName(defArgList->count()<2);
|
|
||||||
--- doxygen-1.7.3.orig/src/outputgen.cpp 2010-05-09 14:49:09.000000000 +0200
|
|
||||||
+++ doxygen-1.7.3.orig/src/outputgen.cpp 2011-03-23 15:53:44.768583075 +0100
|
|
||||||
@@ -58,6 +58,7 @@
|
|
||||||
|
|
||||||
void OutputGenerator::endPlainFile()
|
|
||||||
{
|
|
||||||
+ t.unsetDevice();
|
|
||||||
delete file;
|
|
||||||
file=0;
|
|
||||||
fileName.resize(0);
|
|
21
doxygen.spec
21
doxygen.spec
@ -1,17 +1,16 @@
|
|||||||
Summary: A documentation system for C/C++
|
Summary: A documentation system for C/C++
|
||||||
Name: doxygen
|
Name: doxygen
|
||||||
Version: 1.7.4
|
Version: 1.7.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
|
||||||
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
|
||||||
Patch1: doxygen-1.7.1-config.patch
|
|
||||||
Patch2: doxygen-1.7.3-timestamp.patch
|
|
||||||
Patch3: doxygen-1.7.3-bz#688684.patch
|
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
# No version is specified.
|
# No version is specified.
|
||||||
License: GPL+
|
License: GPL+
|
||||||
|
Url: http://www.stack.nl/~dimitri/doxygen/index.html
|
||||||
|
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
Patch1: doxygen-1.7.1-config.patch
|
||||||
|
Patch2: doxygen-1.7.5-timestamp.patch
|
||||||
|
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
BuildRequires: texlive-dvips
|
BuildRequires: texlive-dvips
|
||||||
@ -22,8 +21,6 @@ BuildRequires: gettext
|
|||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Doxygen can generate an online class browser (in HTML) and/or a
|
Doxygen can generate an online class browser (in HTML) and/or a
|
||||||
reference manual (in LaTeX) from a set of documented source files. The
|
reference manual (in LaTeX) from a set of documented source files. The
|
||||||
@ -46,7 +43,6 @@ are used by doxygen.
|
|||||||
|
|
||||||
%patch1 -p1 -b .config
|
%patch1 -p1 -b .config
|
||||||
%patch2 -p1 -b .timestamp
|
%patch2 -p1 -b .timestamp
|
||||||
%patch3 -p1 -b .bz#688684
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
unset QTDIR
|
unset QTDIR
|
||||||
@ -99,6 +95,9 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man1/doxywizard*
|
%{_mandir}/man1/doxywizard*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 23 2011 Than Ngo <than@redhat.com> - 1:1.7.5-1
|
||||||
|
- 1.7.5
|
||||||
|
|
||||||
* Mon Jun 27 2011 Than Ngo <than@redhat.com> - 1:1.7.4-2
|
* Mon Jun 27 2011 Than Ngo <than@redhat.com> - 1:1.7.4-2
|
||||||
- bz#688684, apply patch to fix crash when not generating man format
|
- bz#688684, apply patch to fix crash when not generating man format
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user