- backport upstream patch to fix
Bug 707266 - C++/CLI indexed property not documented Bug 774949 - Unknown reference in manual Bug 775245 - referencing Python files via tagfile broken
This commit is contained in:
parent
dfc5f33cc2
commit
44085665ca
26
doxygen-707266.patch
Normal file
26
doxygen-707266.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff --git a/src/scanner.l b/src/scanner.l
|
||||
index 1fe5667..14bf3fc 100644
|
||||
--- a/src/scanner.l
|
||||
+++ b/src/scanner.l
|
||||
@@ -1014,7 +1014,7 @@ OPERATOR "operator"{B}*({ARITHOP}|{ASSIGNOP}|{LOGICOP}|{BITOP})
|
||||
current->name = yytext;
|
||||
}
|
||||
<CliPropertyType>"[" { // C++/CLI indexed property
|
||||
- current->name += yytext;
|
||||
+ current->args = "[";
|
||||
BEGIN( CliPropertyIndex );
|
||||
}
|
||||
<CliPropertyType>"{" {
|
||||
@@ -1037,10 +1037,10 @@ OPERATOR "operator"{B}*({ARITHOP}|{ASSIGNOP}|{LOGICOP}|{BITOP})
|
||||
}
|
||||
<CliPropertyIndex>"]" {
|
||||
BEGIN( CliPropertyType );
|
||||
- current->name+=yytext;
|
||||
+ current->args+=yytext;
|
||||
}
|
||||
<CliPropertyIndex>. {
|
||||
- current->name+=yytext;
|
||||
+ current->args+=yytext;
|
||||
}
|
||||
/*
|
||||
<FindMembers>{B}*"property"{BN}+ {
|
13
doxygen-774949.patch
Normal file
13
doxygen-774949.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/doc/faq.doc b/doc/faq.doc
|
||||
index d1845e0..5af3db8 100644
|
||||
--- a/doc/faq.doc
|
||||
+++ b/doc/faq.doc
|
||||
@@ -247,7 +247,7 @@ option \ref cfg_builtin_stl_support "BUILTIN_STL_SUPPORT" is turned on.
|
||||
|
||||
\section faq_search I have problems getting the search engine to work with PHP5 and/or windows
|
||||
|
||||
-Please read <a href="searchengine.html">this</a> for hints on where to look.
|
||||
+Please read <a href="http://www.doxygen.org/searchengine.html">this</a> for hints on where to look.
|
||||
|
||||
\section faq_cmdline Can I configure doxygen from the command line?
|
||||
|
36
doxygen-775245.patch
Normal file
36
doxygen-775245.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff --git a/src/filedef.cpp b/src/filedef.cpp
|
||||
index 3fa896a..2cfe37a 100644
|
||||
--- a/src/filedef.cpp
|
||||
+++ b/src/filedef.cpp
|
||||
@@ -82,8 +82,8 @@ FileDef::FileDef(const char *p,const char *nm,
|
||||
m_path=p;
|
||||
m_filePath=m_path+nm;
|
||||
m_fileName=nm;
|
||||
- setDiskName(dn?dn:nm);
|
||||
setReference(lref);
|
||||
+ setDiskName(dn?dn:nm);
|
||||
m_classSDict = 0;
|
||||
m_includeList = 0;
|
||||
m_includeDict = 0;
|
||||
@@ -126,9 +126,18 @@ FileDef::~FileDef()
|
||||
|
||||
void FileDef::setDiskName(const QCString &name)
|
||||
{
|
||||
- m_outputDiskName = convertNameToFile(name);
|
||||
- m_inclDepFileName = convertNameToFile(name+"_incl");
|
||||
- m_inclByDepFileName = convertNameToFile(name+"_dep_incl");
|
||||
+ if (isReference())
|
||||
+ {
|
||||
+ m_outputDiskName = name;
|
||||
+ m_inclDepFileName = name+"_incl";
|
||||
+ m_inclByDepFileName = name+"_dep_incl";
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ m_outputDiskName = convertNameToFile(name);
|
||||
+ m_inclDepFileName = convertNameToFile(name+"_incl");
|
||||
+ m_inclByDepFileName = convertNameToFile(name+"_dep_incl");
|
||||
+ }
|
||||
}
|
||||
|
||||
/*! Compute the HTML anchor names for all members in the class */
|
11
doxygen.spec
11
doxygen.spec
@ -2,7 +2,7 @@ Summary: A documentation system for C/C++
|
||||
Name: doxygen
|
||||
Epoch: 1
|
||||
Version: 1.8.12
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
# No version is specified.
|
||||
License: GPL+
|
||||
@ -17,6 +17,9 @@ Patch1: doxygen-771310.patch
|
||||
Patch2: doxygen-771344.patch
|
||||
Patch3: doxygen-774273.patch
|
||||
Patch4: doxygen-774138.patch
|
||||
Patch5: doxygen-707266.patch
|
||||
Patch6: doxygen-774949.patch
|
||||
Patch7: doxygen-775245.patch
|
||||
|
||||
BuildRequires: perl
|
||||
BuildRequires: tex(dvips)
|
||||
@ -136,6 +139,12 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||
# intentionally left blank
|
||||
|
||||
%changelog
|
||||
* Mon Dec 12 2016 Than Ngo <than@redhat.com> - 1:1.8.12-6
|
||||
- backport upstream patch to fix
|
||||
Bug 707266 - C++/CLI indexed property not documented
|
||||
Bug 774949 - Unknown reference in manual
|
||||
Bug 775245 - referencing Python files via tagfile broken
|
||||
|
||||
* Thu Dec 08 2016 Than Ngo <than@redhat.com> - 1:1.8.12-5
|
||||
- fixed bz#1402043 - runtime dependency on perl
|
||||
- backport upstream patch to fix Bug 774138 . add HTML classes to "Definition at..." & "Referenced by..." for CSS
|
||||
|
Loading…
Reference in New Issue
Block a user